Skip to main content

Closing the RTP Payload Format Media Types IANA Registry
draft-ietf-avtcore-rtp-payload-registry-05

Yes

(Zaheduzzaman Sarker)

No Objection

Jim Guichard
(Erik Kline)
(Francesca Palombini)
(John Scudder)

Note: This ballot was opened for revision 04 and is now closed.

Deb Cooley
No Objection
Comment (2024-10-14 for -04) Not sent
No additional comments, outside those that have already been highlighted...
Éric Vyncke
No Objection
Comment (2024-10-10 for -04) Sent
Thanks for the work done in this document, let's indeed close a redundant registry (this is always dangerous to have duplicate/redundant pieces of information).

Like Gunter, I think that "informational" would have been enough pending an expert review, but I do not mind too much as the origin of this IANA registry is rather unclear indeed.

Strong suggestion to use the OLD / NEW format in section 3 (if only to be consistent with the end of section 4).

Please remove section 2 as no uppercase terms of BCP14 appears to be used in the I-D.
Gunter Van de Velde
(was Discuss) No Objection
Comment (2024-10-29) Sent
# Gunter Van de Velde, RTG AD, comments for draft-ietf-avtcore-rtp-payload-registry-05

Thank you for taking the comments and discuss into consideration
Jim Guichard
No Objection
Mahesh Jethanandani
No Objection
Comment (2024-10-09 for -04) Sent
This document does not use RFC2119 keywords, but contains the RFC8174
boilerplate.

The IANA review of this document seems to not have concluded yet.

-------------------------------------------------------------------------------
NIT
-------------------------------------------------------------------------------

All comments below are about very minor potential issues that you may choose to
address in some way - or ignore - as you see fit. Some were flagged by
automated tools (via https://github.com/larseggert/ietf-reviewtool), so there
will likely be some false positives. There is no need to let me know what you
did with these suggestions.

"Abstract", paragraph 1
>    It has been observed that specifications of new Real-time Transport
>    Protocol (RTP) payload formats often forget to specify registration
>    of the format's media type in the IANA registry "RTP Payload Formats
>    Media Types" as recommended by RFC 8088.  In practice this has no
>    real impact.  One reason is that the Media Types registry is the
>    crucial registry to register any Media Type to establish the media
>    type used to identified the format in various signaling usage.

s/to identified/to identify/

These URLs in the document can probably be converted to HTTPS:

 * http://www.iana.org/assignments/rtp-parameters

Section 4, paragraph 5
> er motivation see (RFC-TBD1)." In addition it is requested that the existing 
>                                   ^^^^^^^^
A comma may be missing after the conjunctive/linking adverb "addition".
Roman Danyliw
No Objection
Comment (2024-10-13 for -04) Not sent
Thank you to Elwyn Davies for the GENART review.
Orie Steele Former IESG member
Yes
Yes (2024-10-14 for -04) Sent
I support Gunter's discuss and agree with Éric's comments.

It seems the document need not be a proposed standard to update an informational document and close a registry.
Zaheduzzaman Sarker Former IESG member
Yes
Yes (for -04) Unknown

                            
Erik Kline Former IESG member
No Objection
No Objection (for -04) Not sent

                            
Francesca Palombini Former IESG member
No Objection
No Objection (for -04) Not sent

                            
John Scudder Former IESG member
No Objection
No Objection (for -04) Not sent

                            
Murray Kucherawy Former IESG member
No Objection
No Objection (2024-10-16 for -04) Not sent
I support Gunter's DISCUSS position, and support Eric's and Orie's comments.
Paul Wouters Former IESG member
No Objection
No Objection (2024-10-15 for -04) Not sent
no further comments than the ones raised.
Warren Kumari Former IESG member
No Objection
No Objection (2024-10-09 for -04) Not sent
Thank you for the document, as well as the information in the Shepherd Writeup.