Skip to main content

Definitions of Managed Objects for Bridges with Rapid Spanning Tree Protocol
draft-ietf-bridge-rstpmib-09

Revision differences

Document history

Date Rev. By Action
2012-08-22
09 (System) post-migration administrative database adjustment to the Yes position for Bert Wijnen
2005-09-08
09 Amy Vezza State Changes to RFC Ed Queue from Approved-announcement sent by Amy Vezza
2005-08-30
09 Amy Vezza IESG state changed to Approved-announcement sent
2005-08-30
09 Amy Vezza IESG has approved the document
2005-08-30
09 Amy Vezza Closed "Approve" ballot
2005-08-30
09 Bert Wijnen State Changes to Approved-announcement to be sent from IESG Evaluation::AD Followup by Bert Wijnen
2005-08-30
09 Bert Wijnen Status date has been changed to 2005-08-30 from 2005-08-24
2005-08-30
09 Bert Wijnen [Ballot Position Update] Position for Bert Wijnen has been changed to Yes from Discuss by Bert Wijnen
2005-08-25
09 (System) Sub state has been changed to AD Follow up from New Id Needed
2005-08-25
09 (System) New version available: draft-ietf-bridge-rstpmib-09.txt
2005-08-25
09 Allison Mankin [Ballot comment]
My earlier comment was based on misreading the RFC Editor Queue - the bis
Bridge MIB will not block this MIB.
2005-08-24
09 Bert Wijnen Status date has been changed to 2005-08-24 from 2005-08-11
2005-08-24
09 Bert Wijnen Note field has been cleared by Bert Wijnen
2005-08-22
09 Amy Vezza State Changes to IESG Evaluation::Revised ID Needed from Waiting for AD Go-Ahead by Amy Vezza
2005-08-19
09 (System) State has been changed to Waiting for AD Go-Ahead from In Last Call by system
2005-08-18
09 Sam Hartman [Ballot Position Update] New position, No Objection, has been recorded for Sam Hartman by Sam Hartman
2005-08-18
09 Bill Fenner [Ballot Position Update] New position, No Objection, has been recorded for Bill Fenner by Bill Fenner
2005-08-18
09 Allison Mankin [Ballot Position Update] Position for Allison Mankin has been changed to No Objection from Undefined by Allison Mankin
2005-08-18
09 Allison Mankin [Ballot comment]
How long will this wait in the RFC Editor queue for the bis
Bridge MIB?
2005-08-18
09 Allison Mankin [Ballot Position Update] New position, Undefined, has been recorded for Allison Mankin by Allison Mankin
2005-08-18
09 Alex Zinin [Ballot Position Update] New position, No Objection, has been recorded for Alex Zinin by Alex Zinin
2005-08-17
09 Jon Peterson [Ballot Position Update] New position, No Objection, has been recorded for Jon Peterson by Jon Peterson
2005-08-17
09 David Kessens [Ballot Position Update] New position, No Objection, has been recorded for David Kessens by David Kessens
2005-08-17
09 Michelle Cotton
IANA Last Call Comments:
Upon approval of this document the IANA will register a mib-2 number in the following registry:
http://www.iana.org/assignments/smi-numbers
We understand this to …
IANA Last Call Comments:
Upon approval of this document the IANA will register a mib-2 number in the following registry:
http://www.iana.org/assignments/smi-numbers
We understand this to be the only IANA Action.
2005-08-17
09 Mark Townsley [Ballot Position Update] New position, No Objection, has been recorded for Mark Townsley by Mark Townsley
2005-08-17
09 Russ Housley [Ballot Position Update] New position, No Objection, has been recorded for Russ Housley by Russ Housley
2005-08-16
09 Ted Hardie [Ballot Position Update] Position for Ted Hardie has been changed to No Objection from Undefined by Ted Hardie
2005-08-16
09 Ted Hardie [Ballot Position Update] New position, Undefined, has been recorded for Ted Hardie by Ted Hardie
2005-08-15
09 Scott Hollenbeck [Ballot Position Update] New position, No Objection, has been recorded for Scott Hollenbeck by Scott Hollenbeck
2005-08-15
09 Brian Carpenter
[Ballot comment]
Long Gen-ART comment from Harald, preceded by response from author. Non blocking but probably needs revision.

-----

Hi,

The references issue went through …
[Ballot comment]
Long Gen-ART comment from Harald, preceded by response from author. Non blocking but probably needs revision.

-----

Hi,

The references issue went through a long discussion in the Bridge WG,
with input from members of the IEEE 802.1 WG. The document represents
WG consensus for how to handle a difficult situation.

I agree the documentation can be confusing and am willing to modify it
for clarity.
I suggest that the document be changed by moving the 802.1D-2004
reference into "Informative References", and modifying the sentence
"Following are the references for the above objects in 802.1D-2004
[802.1D-2004]."
Suggested text:
"Following are the references for the above objects in 802.1D-2004
[802.1D-2004]. The 802.1t and 802.1w references are normative; the
802.1D-2004 references are only informative."

Would that be satisfactory?

David Harrington
dbharrington@comcast.net



>> -----Original Message-----
>> From: Harald Tveit Alvestrand [mailto:harald@alvestrand.no]
>> Sent: Monday, August 08, 2005 7:07 AM
>> To: gen-art@alvestrand.no; les_bell@3com.com;
>> vivian_ngai@acm.org; Dan Romascanu; David Harrington
>> Cc: Wijnen, Bert (Bert)
>> Subject: Gen-ART review of draft-ietf-bridge-rstpmib-08 (Last
>> Call review)
>>
>> Background for those who may be unaware of GenART:
>>
>> GenART is the Area Review Team for the General Area of the IETF.
>> We advise the General Area Director (i.e. the IETF/IESG chair) by
>> providing more in depth reviews than he could do himself of

documents

>> that come up for final decision in IESG telechat.  I was selected
>> as the GenART member to review this document.  Below is my review,
>> which was written specifically with an eye to the GenART process,

but

>> since I believe that it will be useful to have these comments more
>> widely distributed, others outside the GenART group are included.
>>
>> This review was done as part of IETF Last Call.
>>
>> Review criteria for WG submissions: "Is this document a reasonable
>> contribution to the area of Internet engineering which it covers? If
>> not, what changes would make it so?"
>>
>> Summary: This document seems ready to go technically, but has
>> nits that
>> should be fixed before publication - in particular, it may need
>> clarification of its references to other documents.
>>
>> Details:
>>
>> This is a relatively small MIB, and it focuses on management, not
>> monitoring; it is basically a set of "switches" to flip the value of


>> various per-port parameters that are used in RSTP and "lamps"
>> that allow
>> you to monitor these parameters' states.
>>
>> Where I get confused is in the technology it builds on.
>>
>> It claims to refer to IEEE 802.1D-1998 as amended by P802.1t
>> and P802.1w,
>> adopted in 2001 according to the reference list, but also
>> claims to refer
>> to IEEE 802.1D-2004. It extends the RFC 1493 MIB, but also
>> refers to the
>> 1493bis MIB, which is in the RFC Editor's queue.
>>
>> All of these documents (2 standards, 2 amendments, 1 RFC and
>> 1 draft) are
>> in the "normative references" section.
>>
>> It's possible that IEEE 802.1D-2004 failed to incorporate the
>> amendments,
>> but this seems unlikely, since section 3 gives mapppings of
>> the variables
>> to 802.1D-2004 section numbers; it's also possible that
>> people are so used
>> to referring to P802.1t and P802.1w that those references are
>> valuable and
>> should be retained. But it's confusing to me, and may be to others.
>>
>> Suggested fix:
>>
>> Move IEEE 802.1D-1998, P802.1t, P802.1w and RFC 1493 to the
>> "Informative
>> references" section.
>> Change section 3 to read:
>>
>>    This document defines managed object for the Rapid Spanning Tree
>>    Protocol defined by the IEEE 802.1D-2004 standard.
>>
>>    Following are the references for the above objects in 802.1D-2004
>>    [802.1D-2004].
>>
>>    RSTP-MIB Name                      IEEE 802.1D-2004 Reference
>>
>>    dot1dStp
>>      dot1dStpVersion                  17.13.4  ForceVersion
>>      dot1dStpTxHoldCount              17.13.12 TxHoldCount
>>      dot1dStpExtPortTable
>>        dot1dStpPortProtocolMigration  17.19.13 mcheck
>>        dot1dStpPortAdminEdgePort      17.13.1  adminEdgePort
>>        dot1dStpPortOperEdgePort        17.19.17 operEdgePort
>>        dot1dStpPortAdminPointToPoint  6.4.3    adminPointToPointMAC
>>        dot1dStpPortOperPointToPoint    6.4.3    operPointToPointMAC
>>        dot1dStpPortAdminPathCost      17.13.11 Path Cost
>>
>>    This extension was initially defined in P802.1t[] and P802.1w[].
>>    For reference, here are the section numbers in those documents:
>>
>>    RSTP-MIB Name                      IEEE 802.1 Reference
>>
>>    dot1dStp
>>      dot1dStpVersion                  (w) 17.16.1  ForceVersion
>>      dot1dStpTxHoldCount              (w) 17.16.6  TxHoldCount
>>      dot1dStpExtPortTable
>>        dot1dStpPortProtocolMigration  (w) 17.18.10 mcheck
>>        dot1dStpPortAdminEdgePort      (t) 18.3.3  adminEdgePort
>>        dot1dStpPortOperEdgePort        (t) 18.3.4  operEdgePort
>>        dot1dStpPortAdminPointToPoint  (w) 6.4.3   
>> adminPointToPointMAC
>>        dot1dStpPortOperPointToPoint    (w) 6.4.3   
>> operPointToPointMAC
>>        dot1dStpPortAdminPathCost      (D) 8.5.5.3  Path Cost
>>
>> Modify the document to consistently refer to IEEE 802.1D-2004
>> and 1493bis
>> as the documents it builds on. RFC 1493 and the older 802.1D
>> version may
>> need to be mentioned as background material.
>>
>> I think section 4 would be clearer if the sentence
>>
>>    The objects in the RSTP-MIB supplement those defined in the

Bridge

>>    MIB [RFC1493bis].
>>
>> started the section, rather than following the description of the
>> relationship between 1493 and 1493bis.
>>
>> Apart from this, I see no issues.
>> No nits found!
2005-08-15
09 Brian Carpenter [Ballot Position Update] New position, No Objection, has been recorded for Brian Carpenter by Brian Carpenter
2005-08-14
09 Margaret Cullen [Ballot Position Update] New position, No Objection, has been recorded for Margaret Wasserman by Margaret Wasserman
2005-08-11
09 Bert Wijnen
[Ballot discuss]
IETF Last Call expires on Aug 19th (one day after IESG telechat)
so I (Bert) will hold a DISCUSS to ensure we evaluate …
[Ballot discuss]
IETF Last Call expires on Aug 19th (one day after IESG telechat)
so I (Bert) will hold a DISCUSS to ensure we evaluate all IETF
LC comments that may come in up to and including the 19th.
2005-08-11
09 Bert Wijnen
[Ballot discuss]
IETF Last Call expires on Aug 19th (one day after IESG telechat)
so I (Bert) will hold a DISCUSS to ensure we evaluate …
[Ballot discuss]
IETF Last Call expires on Aug 19th (one day after IESG telechat)
so I (Bert) will hold a DISCUSS to ensure we evaluate all IETF
LC comments that may come in up to and including the 19th.
2005-08-11
09 Bert Wijnen [Ballot Position Update] Position for Bert Wijnen has been changed to Discuss from Yes by Bert Wijnen
2005-08-11
09 Bert Wijnen State Change Notice email list have been change to dromasca@avaya.com, dbharrington@comcast.net; dlevi@nortel.com from dromasca@avaya.com, dbharrington@comcast.net
2005-08-11
09 Bert Wijnen Telechat date was changed to 2005-08-18 from  by Bert Wijnen
2005-08-11
09 Bert Wijnen Status date has been changed to 2005-08-11 from 2005-07-21
2005-08-11
09 Bert Wijnen [Ballot Position Update] New position, Yes, has been recorded for Bert Wijnen
2005-08-11
09 Bert Wijnen Ballot has been issued by Bert Wijnen
2005-08-11
09 Bert Wijnen Created "Approve" ballot
2005-08-11
09 Bert Wijnen Placed on agenda for telechat - 2005-08-18 by Bert Wijnen
2005-08-11
09 Bert Wijnen
[Note]: 'IETF Last Call expires on Aug 19th (one day after IESG telechat)
so I (Bert) will hold a DISCUSS to ensure we evaluate all …
[Note]: 'IETF Last Call expires on Aug 19th (one day after IESG telechat)
so I (Bert) will hold a DISCUSS to ensure we evaluate all IETF
LC comments that may come in up to and including the 19th.' added by Bert Wijnen
2005-08-11
09 Bert Wijnen Status date has been changed to 2005-08-11 from 2005-07-21
2005-08-05
09 Amy Vezza Last call sent
2005-08-05
09 Amy Vezza State Changes to In Last Call from Last Call Requested by Amy Vezza
2005-08-05
09 Bert Wijnen State Changes to Last Call Requested from AD Evaluation::AD Followup by Bert Wijnen
2005-08-05
09 Bert Wijnen Last Call was requested by Bert Wijnen
2005-08-05
09 (System) Ballot writeup text was added
2005-08-05
09 (System) Last call text was added
2005-08-05
09 (System) Ballot approval text was added
2005-08-01
09 (System) Sub state has been changed to AD Follow up from New Id Needed
2005-08-01
08 (System) New version available: draft-ietf-bridge-rstpmib-08.txt
2005-07-21
09 Bert Wijnen State Changes to AD Evaluation::Revised ID Needed from AD Evaluation by Bert Wijnen
2005-07-21
09 Bert Wijnen New ID expected as promised by WG chair
2005-07-21
09 Bert Wijnen Status date has been changed to 2005-07-21 from 2005-06-10
2005-06-16
07 (System) New version available: draft-ietf-bridge-rstpmib-07.txt
2005-06-10
09 Bert Wijnen
AD review posted to WG mailing list.
Could do IETF Last Call and consider this as initial last call
comments. Possibly better to a quick …
AD review posted to WG mailing list.
Could do IETF Last Call and consider this as initial last call
comments. Possibly better to a quick rev first.
Checking with WG chairs.

-----Original Message-----
From: bridge-mib-bounces@ietf.org [mailto:bridge-mib-bounces@ietf.org]On
Behalf Of Wijnen, Bert (Bert)
Sent: Friday, June 10, 2005 13:56
To: 'dbharrington@comcast.net'; 'Dan Romascanu (E-mail)';
vivian_ngai@acm.org; Les_Bell@3Com.com
Cc: Bridge-Mib (E-mail)
Subject: [Bridge-mib] AD review: draft-ietf-bridge-rstpmib-06.txt


Serious issues:

- SMICng tells me:

  C:\bwijnen\smicng\work>smicng rstp.inc
  E: f(rstp.mi2), (32,11) Leading sub-Id "mib-2" is not known in current module
  W: f(rstp.mi2), (14,5) "dot1dBridge" imported but not used

  Seems those can be easily fixed.

- I wonder how we control that assignments under dot1dStp will not cause
  conflicts. This MIB module starts to asiign at { dot1dStp 16 } which is the
  next available number according to RFC1493. But how will we keep track?

- I see not text that indicates the persistency behaviour of the read-write
  objects.

NITs and little things:

- I see:
    dot1dStpVersion OBJECT-TYPE
      SYNTAX      INTEGER {
                    stpCompatible(0),
                    rstp(2)
                }
  We normally do not use the zero value in enumerations.
  And why is there not an enum for value 1?
  These are things that people wonder when reading I guess.
  Maybe add some explanation?

- For objects with SYNTAX TruthValue I see (in DESCRIPTION clauses)
  things like TRUE(1) and FALSE(2). WOuld probably be better to
  use lower case.

- dot1dStpPortAdminPointToPoint OBJECT-TYPE
    SYNTAX      INTEGER {
                    forceTrue(0),
                    forceFalse(1),
                    auto(2)
                }
    MAX-ACCESS  read-write
  Enumerations should not start with 0.
  I guess it is because of an underlying protocol reason.
  Might be good to explain that if it is indeed the case.
  I guess the persitency here is mandated by the entry it augemtns
  in the base table. Might be good to state so in the Table or
  Enrty DESCRIPTION clause.

Not sure if you want to do a new rev before I do IETF Last Call
or if you rather consider this as initial IETF Last Call comments.
I can live with that, so that I can start IETF Last Call today so
it will be finished a week before I get back from
vacation, during which week you can address all comments
and spin a new rev.

Whenever you do do a new rev, pls keep this in mind:

$ idnits draft-ietf-bridge-rstpmib-06.txt
idnits 1.72 (17 May 2005)

draft-ietf-bridge-rstpmib-06.txt:

  Checking nits according to http://www.ietf.org/ID-Checklist.html :

    Checking conformance with RFC 3978/3979 boilerplate...
  * The document seems to lack an RFC 3978 Section 5.1 IPR Disclosure Acknowledgement  --
    however, there's a paragraph with a matching beginning. Boilerplate error?
  * The document seems to lack an RFC 3978 Section 5.4 Copyright Line -- however, there's a
    paragraph with a matching beginning. Boilerplate error?
  * The document seems to lack an RFC 3978 Section 5.4 Reference to BCP 78.
    (The document uses RFC 3667 boilerplate or RFC 3978-like boilerplate instead of verbatim
    RFC 3978 boilerplate.  After 6 May 2005, submission of drafts without verbatim RFC 3978
    boilerplate is not accepted.)

  Checking nits according to http://www.ietf.org/ietf/1id-guidelines.txt :

    Nothing found here (but these checks does not cover all of 1id-guidelines.txt yet).

  Miscellaneous warnings:

    None.

    Run idnits with the --verbose option for more detailed information.

That is, there is new boilerplate.
RFC3668 was replaced/obsoleted by RFC3978.
latest xml2rfc generates proper boilerplate need to specify
 
 

Let me know if you need a copy of the boilerplate.

Further, checking citations and refrences I find:

!! Missing citation for Normative reference:
  P013 L034: [802.1D-2004]    IEEE Project 802 Local and Metropolitan  Area

!! Missing citation for Normative reference:
  P013 L021: [RFC2674]    Bell, E., Smith, A., Langille, P., Rijhsinghani, A. and

!! Missing Reference for citation: [USM]
  P012 L013:    of the User-based Security Model [USM] and the View-based Access

!! Missing Reference for citation: [VACM]
  P012 L014:    Control Model [VACM] is recommended.

Bert
2005-06-10
09 Bert Wijnen Status date has been changed to 2005-06-10 from 2005-05-18
2005-05-18
09 Bert Wijnen State Changes to AD Evaluation from Publication Requested by Bert Wijnen
2005-05-18
09 Bert Wijnen Status date has been changed to 2005-05-18 from
2005-04-11
09 Dinara Suleymanova Draft Added by Dinara Suleymanova in state Publication Requested
2005-04-07
06 (System) New version available: draft-ietf-bridge-rstpmib-06.txt
2004-09-21
05 (System) New version available: draft-ietf-bridge-rstpmib-05.txt
2004-03-25
04 (System) New version available: draft-ietf-bridge-rstpmib-04.txt
2002-06-18
03 (System) New version available: draft-ietf-bridge-rstpmib-03.txt
2002-03-25
02 (System) New version available: draft-ietf-bridge-rstpmib-02.txt
2001-11-26
01 (System) New version available: draft-ietf-bridge-rstpmib-01.txt
2001-07-19
00 (System) New version available: draft-ietf-bridge-rstpmib-00.txt