JSCalendar: Converting from and to iCalendar
draft-ietf-calext-jscalendar-icalendar-28
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-06
|
28 | (System) | Changed action holders to Robert Stepanek (IESG state changed) |
|
2026-10-06
|
28 | Andy Newton | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2026-10-06
|
28 | Andy Newton | IESG state changed to AD Evaluation from Publication Requested::AD Followup |
|
2026-10-02
|
28 | Daniel Migault | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? I see it as strong consensus within the group. The group is small but active. In addition, discussions were also held in other fora such as Calconnect 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There were no controversies. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? Yes. It is implemented by Fastmail. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. The main group that could be related is Calconnect, but it has already been sollicited. So I do not think there is any need for further reviews. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. N/A. The document is focused on translating format between JSCal and iCalendar formats. There is no as per say definition of new format. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? N/A 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. N/A ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? This document is need to ensure that JSCalendar and iCalendar do not exists as silos, but are able to interact between each others. The document is clearly written. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? These issues were addressed respectively in the JSCalendar and iCalendar definitions. So here such considerations do not apply. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The initial intention was to publish this document as informational as the conversion was supposed to be a documentation. However, conversion back and forth impact interoperability and as such the conversion was beleive to better fit a Standard Trck in order to enforce interoperability. See the following email: https://mailarchive.ietf.org/arch/msg/calsify/tK-4Q3F8Oah0z_knxPv_X3Hl99A/ 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. yes. https://mailarchive.ietf.org/arch/msg/calsify/EQfCtnn6gD5B-9DGY5sm6Gzh6So/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. https://mailarchive.ietf.org/arch/msg/calsify/EQfCtnn6gD5B-9DGY5sm6Gzh6So/ 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. -- Possible downref: Non-RFC (?) normative reference: ref. 'TZDB' It makes sense that the IANA TZ database is explicitly mentioned as a normative reference. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? N/A 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). There is no IANA section. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-10-02
|
28 | Bron Gondwana | Changed consensus to Yes from Unknown |
|
2026-10-02
|
28 | Bron Gondwana | This was agreed that it should be Proposed Standard in April 2022 in message: https://mailarchive.ietf.org/arch/msg/calsify/6nm-qXyHvg2wd4YSmFSeejP01WQ It was my mistake not to fix this. -- Bron |
|
2026-10-02
|
28 | Bron Gondwana | Intended Status changed to Proposed Standard from Informational |
|
2026-09-30
|
28 | Andy Newton | IESG state changed to Publication Requested::AD Followup from Publication Requested |
|
2026-09-30
|
28 | Andy Newton | Clarifications on shepherds write-up sent to mailing list. |
|
2026-09-16
|
28 | Daniel Migault | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? Yes. Discussions were held both at the IETF as well as other fora such as Calconnect 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? Yes. It is implemented by Fastmail. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Yes. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. N/A. The document is focused on translating format between JSCal and iCalendar formats. There is no as per say definition of new format. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? N/A 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. N/A ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? This document is need to ensure that JSCalendar and iCalendar do not exists as silos, but are able to interact between each others. The document is clearly written. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? These issues were addressed respectively in the JSCalendar and iCalendar definitions. So here such considerations do not apply. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The RFC is expected to be an Informational RFC. The main reason for such choice is that it documents a usage rather than a new protocol. More precisely, th eusage is how a calendar object in one format can be translated into the other format. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. yes. https://mailarchive.ietf.org/arch/msg/calsify/EQfCtnn6gD5B-9DGY5sm6Gzh6So/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. https://mailarchive.ietf.org/arch/msg/calsify/EQfCtnn6gD5B-9DGY5sm6Gzh6So/ 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. -- Possible downref: Non-RFC (?) normative reference: ref. 'TZDB' It makes sense that the IANA TZ database is explicitly mentioned as a normative reference. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? N/A 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). There is no IANA section. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-09-16
|
28 | Daniel Migault | IETF WG state changed to Submitted to IESG for Publication from In WG Last Call |
|
2026-09-16
|
28 | Daniel Migault | IESG state changed to Publication Requested from I-D Exists |
|
2026-09-16
|
28 | (System) | Changed action holders to Andy Newton (IESG state changed) |
|
2026-09-16
|
28 | Daniel Migault | Responsible AD changed to Andy Newton |
|
2026-09-16
|
28 | Daniel Migault | Document is now in IESG state Publication Requested |
|
2026-09-16
|
28 | Daniel Migault | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? Yes. Discussions were held both at the IETF as well as other fora such as Calconnect 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? Yes. It is implemented by Fastmail. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Yes. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. N/A. The document is focused on translating format between JSCal and iCalendar formats. There is no as per say definition of new format. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? N/A 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. N/A ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? This document is need to ensure that JSCalendar and iCalendar do not exists as silos, but are able to interact between each others. The document is clearly written. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? These issues were addressed respectively in the JSCalendar and iCalendar definitions. So here such considerations do not apply. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The RFC is expected to be an Informational RFC. The main reason for such choice is that it documents a usage rather than a new protocol. More precisely, th eusage is how a calendar object in one format can be translated into the other format. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. yes. https://mailarchive.ietf.org/arch/msg/calsify/EQfCtnn6gD5B-9DGY5sm6Gzh6So/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. https://mailarchive.ietf.org/arch/msg/calsify/EQfCtnn6gD5B-9DGY5sm6Gzh6So/ 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. -- Possible downref: Non-RFC (?) normative reference: ref. 'TZDB' It makes sense that the IANA TZ database is explicitly mentioned as a normative reference. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? N/A 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). There is no IANA section. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-09-16
|
28 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-28.txt |
|
2026-09-16
|
28 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2026-09-16
|
28 | Robert Stepanek | Uploaded new revision |
|
2026-09-15
|
27 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-27.txt |
|
2026-09-15
|
27 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2026-09-15
|
27 | Robert Stepanek | Uploaded new revision |
|
2026-09-02
|
26 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-26.txt |
|
2026-09-02
|
26 | (System) | New version approved |
|
2026-09-02
|
26 | (System) | Request for posting confirmation emailed to previous authors: Robert Stepanek |
|
2026-09-02
|
26 | Robert Stepanek | Uploaded new revision |
|
2026-07-31
|
25 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-25.txt |
|
2026-07-31
|
25 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2026-07-31
|
25 | Robert Stepanek | Uploaded new revision |
|
2026-07-06
|
24 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-24.txt |
|
2026-07-06
|
24 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2026-07-06
|
24 | Robert Stepanek | Uploaded new revision |
|
2026-06-01
|
23 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-23.txt |
|
2026-06-01
|
23 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2026-06-01
|
23 | Robert Stepanek | Uploaded new revision |
|
2026-01-22
|
22 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-22.txt |
|
2026-01-22
|
22 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2026-01-22
|
22 | Robert Stepanek | Uploaded new revision |
|
2026-01-07
|
21 | Daniel Migault | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? Yes. Discussions were held both at the IETF as well as other fora such as Calconnect 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? Yes. It is implemented by Fastmail. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Yes. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. N/A. The document is focused on translating format between JSCal and iCalendar formats. There is no as per say definition of new format. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? N/A 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. N/A ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? This document is need to ensure that JSCalendar and iCalendar do not exists as silos, but are able to interact between each others. The document is clearly written. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? These issues were addressed respectively in the JSCalendar and iCalendar definitions. So here such considerations do not apply. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The RFC is expected to be an Informational RFC. The main reason for such choice is that it documents a usage rather than a new protocol. More precisely, th eusage is how a calendar object in one format can be translated into the other format. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. -- Possible downref: Non-RFC (?) normative reference: ref. 'TZDB' It makes sense that the IANA TZ database is explicitly mentioned as a normative reference. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? N/A 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. No. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). There is no IANA section. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-01-07
|
21 | Daniel Migault | Notification list changed to daniel.migault@ericsson.com because the document shepherd was set |
|
2026-01-07
|
21 | Daniel Migault | Document shepherd changed to Daniel Migault |
|
2025-11-21
|
21 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-21.txt |
|
2025-11-21
|
21 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-11-21
|
21 | Robert Stepanek | Uploaded new revision |
|
2025-11-05
|
20 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-20.txt |
|
2025-11-05
|
20 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-11-05
|
20 | Robert Stepanek | Uploaded new revision |
|
2025-10-24
|
19 | Bron Gondwana | Added to session: IETF-124: jmap Tue-1630 |
|
2025-10-16
|
19 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-19.txt |
|
2025-10-16
|
19 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-10-16
|
19 | Robert Stepanek | Uploaded new revision |
|
2025-10-02
|
18 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-18.txt |
|
2025-10-02
|
18 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-10-02
|
18 | Robert Stepanek | Uploaded new revision |
|
2025-08-28
|
17 | Daniel Migault | IETF WG state changed to In WG Last Call from WG Document |
|
2025-08-28
|
17 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-17.txt |
|
2025-08-28
|
17 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-08-28
|
17 | Robert Stepanek | Uploaded new revision |
|
2025-08-13
|
16 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-16.txt |
|
2025-08-13
|
16 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-08-13
|
16 | Robert Stepanek | Uploaded new revision |
|
2025-07-21
|
15 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-15.txt |
|
2025-07-21
|
15 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-07-21
|
15 | Robert Stepanek | Uploaded new revision |
|
2025-06-23
|
14 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-14.txt |
|
2025-06-23
|
14 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-06-23
|
14 | Robert Stepanek | Uploaded new revision |
|
2025-05-21
|
13 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-13.txt |
|
2025-05-21
|
13 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-05-21
|
13 | Robert Stepanek | Uploaded new revision |
|
2025-04-17
|
12 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-12.txt |
|
2025-04-17
|
12 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-04-17
|
12 | Robert Stepanek | Uploaded new revision |
|
2025-03-19
|
11 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-11.txt |
|
2025-03-19
|
11 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-03-19
|
11 | Robert Stepanek | Uploaded new revision |
|
2025-02-26
|
10 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-10.txt |
|
2025-02-26
|
10 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2025-02-26
|
10 | Robert Stepanek | Uploaded new revision |
|
2024-11-12
|
09 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-09.txt |
|
2024-11-12
|
09 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2024-11-12
|
09 | Robert Stepanek | Uploaded new revision |
|
2024-11-04
|
08 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-08.txt |
|
2024-11-04
|
08 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2024-11-04
|
08 | Robert Stepanek | Uploaded new revision |
|
2023-01-12
|
07 | (System) | Document has expired |
|
2022-11-08
|
07 | Bron Gondwana | Added to session: IETF-115: calext Tue-1630 |
|
2022-07-11
|
07 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-07.txt |
|
2022-07-11
|
07 | Robert Stepanek | New version accepted (logged-in submitter: Robert Stepanek) |
|
2022-07-11
|
07 | Robert Stepanek | Uploaded new revision |
|
2022-01-13
|
06 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-06.txt |
|
2022-01-13
|
06 | (System) | New version accepted (logged-in submitter: Robert Stepanek) |
|
2022-01-13
|
06 | Robert Stepanek | Uploaded new revision |
|
2022-01-09
|
05 | (System) | Document has expired |
|
2021-07-08
|
05 | Michael Douglass | New version available: draft-ietf-calext-jscalendar-icalendar-05.txt |
|
2021-07-08
|
05 | (System) | New version approved |
|
2021-07-08
|
05 | (System) | Request for posting confirmation emailed to previous authors: Michael Douglass , Neil Jenkins , Robert Stepanek |
|
2021-07-08
|
05 | Michael Douglass | Uploaded new revision |
|
2021-04-14
|
04 | Bron Gondwana | Added to session: interim-2021-calext-01 |
|
2021-04-14
|
04 | Bron Gondwana | Added to session: interim-2021-jmap-01 |
|
2021-03-01
|
04 | Bron Gondwana | Added to session: IETF-110: calext Wed-1530 |
|
2021-02-20
|
04 | Michael Douglass | New version available: draft-ietf-calext-jscalendar-icalendar-04.txt |
|
2021-02-20
|
04 | (System) | New version approved |
|
2021-02-20
|
04 | (System) | Request for posting confirmation emailed to previous authors: Michael Douglass , Neil Jenkins , Robert Stepanek |
|
2021-02-20
|
04 | Michael Douglass | Uploaded new revision |
|
2021-01-25
|
03 | Michael Douglass | New version available: draft-ietf-calext-jscalendar-icalendar-03.txt |
|
2021-01-25
|
03 | (System) | New version approved |
|
2021-01-25
|
03 | (System) | Request for posting confirmation emailed to previous authors: Michael Douglass , Neil Jenkins , Robert Stepanek |
|
2021-01-25
|
03 | Michael Douglass | Uploaded new revision |
|
2020-07-29
|
02 | Michael Douglass | New version available: draft-ietf-calext-jscalendar-icalendar-02.txt |
|
2020-07-29
|
02 | (System) | New version approved |
|
2020-07-29
|
02 | (System) | Request for posting confirmation emailed to previous authors: calext-chairs@ietf.org, Neil Jenkins , Robert Stepanek |
|
2020-07-29
|
02 | Michael Douglass | Uploaded new revision |
|
2019-12-31
|
01 | (System) | Document has expired |
|
2019-06-29
|
01 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-01.txt |
|
2019-06-29
|
01 | (System) | New version approved |
|
2019-06-29
|
01 | (System) | Request for posting confirmation emailed to previous authors: Robert Stepanek , Neil Jenkins |
|
2019-06-29
|
01 | Robert Stepanek | Uploaded new revision |
|
2019-05-02
|
00 | Bron Gondwana | Intended Status changed to Informational from None |
|
2019-05-02
|
00 | Robert Stepanek | New version available: draft-ietf-calext-jscalendar-icalendar-00.txt |
|
2019-05-02
|
00 | (System) | WG -00 approved |
|
2019-05-02
|
00 | Robert Stepanek | Set submitter to "Robert Stepanek ", replaces to (none) and sent approval email to group chairs: calext-chairs@ietf.org |
|
2019-05-02
|
00 | Robert Stepanek | Uploaded new revision |