Skip to main content

An Attribute for Statement of Possession of a Private Key
draft-ietf-lamps-private-key-stmt-attr-09

Revision differences

Document history

Date Rev. By Action
2025-10-12
(System)
Received changes through RFC Editor sync (changed state to RFC, created became rfc relationship between draft-ietf-lamps-private-key-stmt-attr and RFC 9883, changed IESG state to RFC …
Received changes through RFC Editor sync (changed state to RFC, created became rfc relationship between draft-ietf-lamps-private-key-stmt-attr and RFC 9883, changed IESG state to RFC Published)
2025-10-10
09 (System) RFC Editor state changed to AUTH48-DONE from AUTH48
2025-10-10
09 (System) RFC Editor state changed to AUTH48
2025-06-30
09 (System) IANA Action state changed to RFC-Ed-Ack from Waiting on RFC Editor
2025-06-30
09 (System) IANA Action state changed to Waiting on RFC Editor from In Progress
2025-06-30
09 (System) IANA Action state changed to In Progress from Waiting on Authors
2025-06-30
09 (System) RFC Editor state changed to EDIT
2025-06-30
09 (System) IESG state changed to RFC Ed Queue from Approved-announcement sent
2025-06-30
09 (System) Announcement was received by RFC Editor
2025-06-27
09 (System) IANA Action state changed to Waiting on Authors from In Progress
2025-06-26
09 (System) IANA Action state changed to In Progress
2025-06-26
09 (System) Removed all action holders (IESG state changed)
2025-06-26
09 Morgan Condie IESG state changed to Approved-announcement sent from Approved-announcement to be sent
2025-06-26
09 Morgan Condie IESG has approved the document
2025-06-26
09 Morgan Condie Closed "Approve" ballot
2025-06-26
09 Morgan Condie Ballot approval text was generated
2025-06-26
09 Morgan Condie Ballot writeup was changed
2025-06-26
09 Deb Cooley IESG state changed to Approved-announcement to be sent from Approved-announcement to be sent::AD Followup
2025-06-26
09 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-09.txt
2025-06-26
09 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-06-26
09 Russ Housley Uploaded new revision
2025-06-26
08 Cindy Morgan IESG state changed to Approved-announcement to be sent::AD Followup from IESG Evaluation
2025-06-26
08 Mike Bishop
[Ballot comment]
I note some cases where lowercase non-2119 words are used that surprised me. For example, [in Section 6](https://www.ietf.org/archive/id/draft-ietf-lamps-private-key-stmt-attr-08.html#section-6-5), if you "Likewise... …
[Ballot comment]
I note some cases where lowercase non-2119 words are used that surprised me. For example, [in Section 6](https://www.ietf.org/archive/id/draft-ietf-lamps-private-key-stmt-attr-08.html#section-6-5), if you "Likewise... MUST", I would expect the first clause to also be a MUST.

Similarly, [in Section 3](https://www.ietf.org/archive/id/draft-ietf-lamps-private-key-stmt-attr-08.html#section-3-7), I was surprised that the diagnostic responses are not SHOULDs (though I can see a plausible rationale there, that such an action occurs after the protocol exchange has failed and therefore has no bearing on interoperability of the protocol).
2025-06-26
08 Mike Bishop [Ballot Position Update] New position, No Objection, has been recorded for Mike Bishop
2025-06-25
08 Orie Steele [Ballot Position Update] New position, No Objection, has been recorded for Orie Steele
2025-06-25
08 Amanda Baber IANA Review state changed to IANA OK - Actions Needed from IANA - Not OK
2025-06-25
08 Amanda Baber IANA Experts State changed to Expert Reviews OK from Reviews assigned
2025-06-25
08 Paul Wouters
[Ballot comment]
Thanks for this document. I have a few non-blocking questions.


        If the CA revokes a compromised signature certificate, then …
[Ballot comment]
Thanks for this document. I have a few non-blocking questions.


        If the CA revokes a compromised signature certificate, then the
        CA SHOULD also revoke all key establishment certificates that
        were obtained with privateKeyPossessionStatement attributes
        signed by that compromised signature certificate.

Why not MUST ?


Section 6 does not mention anything about timing. Is there an expectation
that a key establishment key is submitted around the same time as the
signature key was presented to the CA, possible bounf by some security token?
If not, is it valid on the last day of the signature key validity to use it
to let the A create a key establishment key with a 1 year validity ? Perhaps
Section 6 can give some clarity on this on (lack of) expectations around this?


Is an PoP statement transferable? Eg provided CA1 <-> CA2 is secured, is
it valid for CA1 to relay (eg sign?) a POP statement to CA2 so that CA2
can sign a key agreement certificate?
2025-06-25
08 Paul Wouters [Ballot Position Update] New position, Yes, has been recorded for Paul Wouters
2025-06-25
08 (System) IANA Review state changed to IANA - Not OK from Version Changed - Review Needed
2025-06-25
08 Roman Danyliw [Ballot comment]
Thank you to Roni Even for the GENART review.
2025-06-25
08 Roman Danyliw [Ballot Position Update] New position, No Objection, has been recorded for Roman Danyliw
2025-06-24
08 Gunter Van de Velde [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde
2025-06-23
08 Éric Vyncke
[Ballot comment]
# Éric Vyncke, INT AD, comments for draft-ietf-lamps-private-key-stmt-attr-08
CC @evyncke

Thank you for the work put into this document.

Please find below some …
[Ballot comment]
# Éric Vyncke, INT AD, comments for draft-ietf-lamps-private-key-stmt-attr-08
CC @evyncke

Thank you for the work put into this document.

Please find below some non-blocking COMMENT points/nits (replies would be appreciated even if only for my own education).

Special thanks to Tim Hollebeek for the shepherd's write-up including the WG consensus *but it lacks* the justification of the intended status.

I hope that this review helps to improve the document,

Regards,

-éric

### ACME

Does this document impact ACME ?

### Not-valid-after relationship

Should there be a relationship on the expiration dates of the 2 certs ? E.g., the expiration date of the cert #2 <= expiration date of the cert #1

### Section 2

Can 2 different CA be used ? Should the text be clear on whether it is allowed or not ?

Can the signature key pair be used to sign multiple CSR for multiple key negotiation keys ?

### Section 6

Why not a MUST in `If the CA revokes a compromised signature certificate, then the CA SHOULD also revoke all key establishment certificates` ?
2025-06-23
08 Éric Vyncke [Ballot Position Update] New position, No Objection, has been recorded for Éric Vyncke
2025-06-20
08 Ketan Talaulikar [Ballot Position Update] New position, No Objection, has been recorded for Ketan Talaulikar
2025-06-20
08 Jim Guichard [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard
2025-06-15
08 Erik Kline [Ballot Position Update] New position, No Objection, has been recorded for Erik Kline
2025-06-15
08 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-08.txt
2025-06-15
08 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-06-15
08 Russ Housley Uploaded new revision
2025-06-14
07 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-07.txt
2025-06-14
07 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-06-14
07 Russ Housley Uploaded new revision
2025-06-13
06 Bron Gondwana Request for IETF Last Call review by ARTART Completed: Ready. Reviewer: Bron Gondwana. Sent review to list.
2025-06-13
06 Mahesh Jethanandani [Ballot Position Update] New position, No Objection, has been recorded for Mahesh Jethanandani
2025-06-12
06 Andy Newton [Ballot Position Update] New position, No Objection, has been recorded for Andy Newton
2025-06-08
06 Adrian Farrel Request for IETF Last Call review by OPSDIR Completed: Ready. Reviewer: Adrian Farrel. Review has been revised by Adrian Farrel.
2025-06-08
06 Mohamed Boucadair
[Ballot comment]
Hi Russ,

Thank you for the effort put into this document.

Thanks to Adrian Farrel for the OPSDIR review and Russ for promptly …
[Ballot comment]
Hi Russ,

Thank you for the effort put into this document.

Thanks to Adrian Farrel for the OPSDIR review and Russ for promptly addressing the review:

* I like the new text added, but would prefer if that text was put in a separate section (grouped with other ops matters) in a specific section.

* Thanks also for expanding the terms as suggested by Adrian. However, please use a consistent approach for expanding these as we have currently two forms:

CURRENT:
  Certification Authority (CA) ….
  ..

  For example, ..
  a ML-DSA (Module-Lattice-Based Digital Signature Algorithm) .. a ML-KEM
  (Module-Lattice-Based Key-Encapsulation Mechanism) public key.  For
  … ECDSA (Elliptic Curve Digital Signature Algorithm) … ECDH
  (Elliptic Curve Diffie-Hellman) public key.
  ..
  2.  … Certificate Signing Request (CSR)
 
Please find below some comments:

# Meta comment

I trust the responsible AD/WG validated the examples and the ASN module.

Are there readily available online tools that one can use for these checks?

# Introduction:

## Missing Reference

CURRENT:
  A statement of possession may be used in lieu of the usual proof of
  possession mechanisms. 

Do we have a reference for these “usual” mechanisms?

## Redundant normative behavior

CURRENT:
  possession of the same certificate subject.  If the Certificate
  Policy [RFC3647] allows, the CA MAY accept this statement in lieu of
  proof that the requestor has possession of the private key.

* I guess a word is missing for “policy..allows”. Allows what?

* I guess this should be s/MAY/may as we do have the normative behavior in the body of the draft.

## nits

OLD:
  3.  The subject sends the CSR to the CA, and it gets back a signature
      certificate.  The signature certificate includes a key usage of
      digitalSignature, nonRepudiation, or both Section 4.2.1.3 of
      [RFC5280].

  6.  The subject sends the CSR to the CA, and it gets back a key
      establishment certificate.  The key establishment certificate
      includes a key usage of keyEncipherment or keyAgreement
      Section 4.2.1.3 of [RFC5280].


NEW:
  3.  The subject sends the CSR to the CA, and it gets back a signature
      certificate.  The signature certificate includes a key usage of
      digitalSignature, nonRepudiation, or both (Section 4.2.1.3 of
      [RFC5280]).

  6.  The subject sends the CSR to the CA, and it gets back a key
      establishment certificate.  The key establishment certificate
      includes a key usage of keyEncipherment or keyAgreement
      (Section 4.2.1.3 of [RFC5280]).

# Section 2

## Quote source of the citation

CURRENT:
      "The subject of the signature certificate that is used to validate
      the signature on this certificate request states, without
      providing proof, that it has possession of the private key that
      corresponds to the public key in the certificate request."

## Redundant behavior with 5280

CURRENT:
  The CA MUST perform certification path validation for the signature
  certificate as specified in Section 6 of [RFC5280].  If the
  certification path is not valid, then the CA MUST reject the
  certificate request.

Doe we need the second MUST? Isn’t that covered by the validation in rfc5280#section-6.1.6?

Please update accordingly. Thanks.

## Internal redundant behaviors

This section says:

CURRENT:
  If they are different, the
  certificate policy MUST describe how the CA can determine that the
  two subject names identify the same entity.

Section 5 has also:

CURRENT:
  If a CA allows subject in the key establishment certificate to be
  different than the subject name in the signature certificate, then
  certificate policy MUST describe how to determine that the two
  subject names identify the same entity. 

Please keep one MUST as these are covering the same aspect. I guess the first one should be kept but s/MUST/must in the sec cons section.

## Subject alternative names

Any reason why a different approach is followed for certificate policy when discussing subject alternative names vs subject names.

CURRENT:

  The subject in the signature certificate SHOULD be the same as the
  subject name in the certificate request.  If they are different, the
                                            ^^^^^^^^^^^^^^^^^^^^^^^^^^
  certificate policy MUST describe how the CA can determine that the
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  two subject names identify the same entity.  If the CA is unable to
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  determine that the two subject names identify the same entity, then
  the CA MUST reject the certificate request.

  If subject alternative names are present in the certificate request,
  they SHOULD match subject alternative names in the signature
  certificate.  If the CA is unable to determine that each of subject
  alternative names identifies the same entity as is named in the
  signature certificate, then the CA MUST reject the certificate
  request.

and Section 5:

  If a CA allows subject in the key establishment certificate to be
  different than the subject name in the signature certificate, then
  certificate policy MUST describe how to determine that the two
  subject names identify the same entity.  Likewise, if a CA allows
  subject alternative names in the key establishment certificate that
  are not present in the signature certificate, then certificate policy
                                                ^^^^^^^^^^^^^^^^^^^^^^
  MUST describe how to determine that the subject alternative names
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  identify the same entity as is named in the signature certificate.
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

## When is this possible?

CURRENT:
  If the CA is unable to
  determine that the two subject names identify the same entity, then
  the CA MUST reject the certificate request.

Given the MUST in the previous sentence, when this case occurs? It seems to me that a clarification is needed here.

# Section 4

## (nit) s/establisment/establishment
## (nit) s/signture/signature

# Fix IANA action

I guess the following change should be made to be consistent with the ASN module:

CURRENT:
  For the ASN.1 Module in the Appendix A of this document, IANA is
  requested to assign an object identifier (OID) for the module
  identifier (TBD0) with a Description of "d-mod-private-key-
                                            ^^^^^^^^^^^^^^^^
  possession-stmt-2025".  The OID for the module should be allocated in
  the "SMI Security for PKIX Module Identifier" registry
  (1.3.6.1.5.5.7.0).

NEW:
  For the ASN.1 Module in the Appendix A of this document, IANA is
  requested to assign an object identifier (OID) for the module
  identifier (TBD0) with a Description of "id-mod-private-key- 
  possession-stmt-2025".  The OID for the module should be allocated in
  the "SMI Security for PKIX Module Identifier" registry
  (1.3.6.1.5.5.7.0).

Cheers,
Med
2025-06-08
06 Mohamed Boucadair [Ballot Position Update] New position, No Objection, has been recorded for Mohamed Boucadair
2025-06-06
06 Morgan Condie Placed on agenda for telechat - 2025-06-26
2025-06-06
06 Deb Cooley Ballot has been issued
2025-06-06
06 Deb Cooley [Ballot Position Update] New position, Yes, has been recorded for Deb Cooley
2025-06-06
06 Deb Cooley Created "Approve" ballot
2025-06-06
06 Deb Cooley IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead
2025-06-06
06 (System) IANA Review state changed to Version Changed - Review Needed from IANA - Not OK
2025-06-06
06 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-06.txt
2025-06-06
06 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-06-06
06 Russ Housley Uploaded new revision
2025-06-02
05 Alexey Melnikov Request for IETF Last Call review by SECDIR Completed: Ready. Reviewer: Alexey Melnikov. Sent review to list.
2025-06-02
05 Roni Even Request for IETF Last Call review by GENART Completed: Ready. Reviewer: Roni Even. Sent review to list.
2025-06-02
05 (System) IESG state changed to Waiting for AD Go-Ahead from In Last Call
2025-05-29
05 David Dong
IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-lamps-private-key-stmt-attr-05. If any part of this review is inaccurate, please let us know.

IANA understands that, upon …
IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-lamps-private-key-stmt-attr-05. If any part of this review is inaccurate, please let us know.

IANA understands that, upon approval of this document, there is a single action which we must complete.

In the SMI Security for PKIX Module Identifier registry in the Structure of Management Information (SMI) Numbers (MIB Module Registrations) registry group located at:

https://www.iana.org/assignments/smi-numbers/

a single new registration is to be made as follows:

Decimal: [ TBD-at-Registration ]
Description: d-mod-private-key-possession-stmt-2025
Reference: [ RFC-to-be ]

As this document requests a registration in an Expert Review or Specification Required (see RFC 8126) registry, we have initiated the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK."

We understand that this is the only action required to be completed upon approval of this document.

NOTE: The action requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the action that will be performed.

For definitions of IANA review states, please see:

https://datatracker.ietf.org/help/state/draft/iana-review

Thank you,

David Dong
IANA Services Sr. Specialist
2025-05-29
05 (System) IANA Review state changed to IANA - Not OK from IANA - Review Needed
2025-05-24
05 Adrian Farrel Request for IETF Last Call review by OPSDIR Completed: Has Nits. Reviewer: Adrian Farrel. Sent review to list.
2025-05-23
05 Jean Mahoney Request for IETF Last Call review by GENART is assigned to Roni Even
2025-05-22
05 Tero Kivinen Request for IETF Last Call review by SECDIR is assigned to Alexey Melnikov
2025-05-21
05 Barry Leiba Request for IETF Last Call review by ARTART is assigned to Bron Gondwana
2025-05-21
05 Bo Wu Request for IETF Last Call review by OPSDIR is assigned to Adrian Farrel
2025-05-20
05 Mohamed Boucadair Requested IETF Last Call review by OPSDIR
2025-05-19
05 David Dong IANA Experts State changed to Reviews assigned
2025-05-19
05 Liz Flynn IANA Review state changed to IANA - Review Needed
2025-05-19
05 Liz Flynn
The following Last Call announcement was sent out (ends 2025-06-02):

From: The IESG
To: IETF-Announce
CC: debcooley1@gmail.com, draft-ietf-lamps-private-key-stmt-attr@ietf.org, lamps-chairs@ietf.org, spasm@ietf.org, tim.hollebeek@digicert.com …
The following Last Call announcement was sent out (ends 2025-06-02):

From: The IESG
To: IETF-Announce
CC: debcooley1@gmail.com, draft-ietf-lamps-private-key-stmt-attr@ietf.org, lamps-chairs@ietf.org, spasm@ietf.org, tim.hollebeek@digicert.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  (An Attribute for Statement of Possession of a Private Key) to Proposed Standard


The IESG has received a request from the Limited Additional Mechanisms for
PKIX and SMIME WG (lamps) to consider the following document: - 'An Attribute
for Statement of Possession of a Private Key'
  as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
last-call@ietf.org mailing lists by 2025-06-02. Exceptionally, comments may
be sent to iesg@ietf.org instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract


  This document specifies an attribute for a statement of possession of
  a private key by a certificate subject.  As part of X.509 certificate
  enrollment, a Certification Authority (CA) typically demands proof
  that the subject possesses the private key that corresponds to the
  to-be-certified public key.  In some cases, a CA might accept a
  signed statement from the certificate subject.  For example, when a
  certificate subject needs separate certificates for signature and key
  establishment, a statement that can be validated with the previously
  issued signature certificate for the same subject might be adequate
  for subsequent issuance of the key establishment certificate.




The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-lamps-private-key-stmt-attr/



No IPR declarations have been submitted directly on this I-D.




2025-05-19
05 Liz Flynn IESG state changed to In Last Call from Last Call Requested
2025-05-19
05 Liz Flynn Last call announcement was generated
2025-05-19
05 Deb Cooley Last call was requested
2025-05-19
05 Deb Cooley Last call announcement was generated
2025-05-19
05 Deb Cooley Ballot approval text was generated
2025-05-19
05 Deb Cooley IESG state changed to Last Call Requested from AD Evaluation::AD Followup
2025-05-19
05 (System) Changed action holders to Deb Cooley (IESG state changed)
2025-05-19
05 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2025-05-19
05 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-05.txt
2025-05-19
05 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-05-19
05 Russ Housley Uploaded new revision
2025-05-15
04 Deb Cooley comments are here:  https://mailarchive.ietf.org/arch/msg/spasm/-VZNo2e3baLgf71-8-mUrcox6VU/
2025-05-15
04 (System) Changed action holders to Russ Housley (IESG state changed)
2025-05-15
04 Deb Cooley IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation
2025-05-15
04 Deb Cooley IESG state changed to AD Evaluation from Publication Requested
2025-05-15
04 Deb Cooley Ballot writeup was changed
2025-05-02
04 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-04.txt
2025-05-02
04 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-05-02
04 Russ Housley Uploaded new revision
2025-05-01
03 Tim Hollebeek
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.

Note that some numbered items contain multiple related questions; please be sure
to answer all of them.

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

The document reached broad agreement.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

This document specifies an attribute for a protocol that already exists.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

No such formal review criteria.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

No YANG module.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

WARNING: This document contains ASN.1. Do not read without eye protection or
specialized expertise.

The ASN.1 in the text was examined by eye, and the ASN.1 module in Appendix A
was compiled.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is clearly written and ready.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

The SEC AD checklist was reviewed.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed Standard, which is correct. Datatracker was fixed while writing this
writeup and is now correct.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

The sole author has stated he is unaware of any relevant IP.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes, the sole author is willing.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

FIXME: RFC 6268 is referenced in a ASN.1 comment, but not included in references.
It is suggested the author add it to the references.

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

References look good.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

The references are all RFCs and the ITU-T ASN.1 standards, which are widely
available.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

It was confirmed that the downrefs are already in the downrefs registry.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

No such references.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

The IANA considerations only ask for one OID for the ASN.1 module, and the
request is properly formatted and contains the appropriate information.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No new registries.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2025-05-01
03 Tim Hollebeek IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up
2025-05-01
03 Tim Hollebeek IESG state changed to Publication Requested from I-D Exists
2025-05-01
03 (System) Changed action holders to Deb Cooley (IESG state changed)
2025-05-01
03 Tim Hollebeek Responsible AD changed to Deb Cooley
2025-05-01
03 Tim Hollebeek Document is now in IESG state Publication Requested
2025-05-01
03 Tim Hollebeek
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.

Note that some numbered items contain multiple related questions; please be sure
to answer all of them.

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

The document reached broad agreement.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

This document specifies an attribute for a protocol that already exists.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

No such formal review criteria.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

No YANG module.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

WARNING: This document contains ASN.1. Do not read without eye protection or
specialized expertise.

The ASN.1 in the text was examined by eye, and the ASN.1 module in Appendix A
was compiled.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is clearly written and ready.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

The SEC AD checklist was reviewed.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed Standard, which is correct. Datatracker was fixed while writing this
writeup and is now correct.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

The sole author has stated he is unaware of any relevant IP.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes, the sole author is willing.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

FIXME: RFC 6268 is referenced in a ASN.1 comment, but not included in references.
It is suggested the author add it to the references.

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

References look good.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

The references are all RFCs and the ITU-T ASN.1 standards, which are widely
available.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

It was confirmed that the downrefs are already in the downrefs registry.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

No such references.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

The IANA considerations only ask for one OID for the ASN.1 module, and the
request is properly formatted and contains the appropriate information.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No new registries.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2025-05-01
03 Tim Hollebeek Changed consensus to Yes from Unknown
2025-05-01
03 Tim Hollebeek Intended Status changed to Proposed Standard from None
2025-04-29
03 Tim Hollebeek Notification list changed to tim.hollebeek@digicert.com because the document shepherd was set
2025-04-29
03 Tim Hollebeek Document shepherd changed to Tim Hollebeek
2025-04-29
03 Tim Hollebeek IETF WG state changed to WG Consensus: Waiting for Write-Up from WG Document
2025-04-21
03 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-03.txt
2025-04-21
03 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-04-21
03 Russ Housley Uploaded new revision
2025-03-24
02 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-02.txt
2025-03-24
02 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-03-24
02 Russ Housley Uploaded new revision
2025-03-21
01 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-01.txt
2025-03-21
01 Russ Housley New version accepted (logged-in submitter: Russ Housley)
2025-03-21
01 Russ Housley Uploaded new revision
2025-02-15
00 Russ Housley This document now replaces draft-housley-lamps-private-key-attest-attr instead of None
2025-02-15
00 Russ Housley New version available: draft-ietf-lamps-private-key-stmt-attr-00.txt
2025-02-15
00 Russ Housley WG -00 approved
2025-02-15
00 Russ Housley Set submitter to "Russ Housley ", replaces to draft-housley-lamps-private-key-attest-attr and sent approval email to group chairs: lamps-chairs@ietf.org
2025-02-15
00 Russ Housley Uploaded new revision