Skip to main content

SIMAP: Concept, Requirements, and Use Cases
draft-ietf-nmop-simap-concept-14

Revision differences

Document history

Date Rev. By Action
2026-10-02
14 Morgan Condie Placed on agenda for telechat - 2026-10-22
2026-10-02
14 Mahesh Jethanandani Ballot has been issued
2026-10-02
14 Mahesh Jethanandani [Ballot Position Update] New position, Yes, has been recorded for Mahesh Jethanandani
2026-10-02
14 Mahesh Jethanandani Created "Approve" ballot
2026-10-02
14 Mahesh Jethanandani IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead::AD Followup
2026-10-02
14 Mahesh Jethanandani Ballot writeup was changed
2026-10-02
14 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-10-02
14 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-10-02
14 (System) IANA Review state changed to Version Changed - Review Needed from IANA OK - No Actions Needed
2026-10-02
14 Benoît Claise New version available: draft-ietf-nmop-simap-concept-14.txt
2026-10-02
14 Benoît Claise New version accepted (logged-in submitter: Benoît Claise)
2026-10-02
14 Benoît Claise Uploaded new revision
2026-09-30
13 Mahesh Jethanandani
Authors, I see that you have addressed all the expert review comments you have received. Once you post the updated draft, this document should be …
Authors, I see that you have addressed all the expert review comments you have received. Once you post the updated draft, this document should be ready for IESG review. Thanks for your work on this document.
2026-09-30
13 (System) Changed action holders to Olga Havel, Benoît Claise, Oscar de Dios, Thomas Graf (IESG state changed)
2026-09-30
13 Mahesh Jethanandani IESG state changed to Waiting for AD Go-Ahead::Revised I-D Needed from Waiting for AD Go-Ahead
2026-09-27
13 Michael Tüxen Request for IETF Last Call review by TSVART Completed: Ready with Nits. Reviewer: Michael Tüxen. Review has been revised by Michael Tüxen.
2026-09-27
13 Michael Tüxen Request for IETF Last Call review by TSVART Completed: Ready with Nits. Reviewer: Michael Tüxen. Sent review to list.
2026-09-26
13 (System) IESG state changed to Waiting for AD Go-Ahead from In Last Call
2026-09-25
13 (System) IANA Review state changed to IANA OK - No Actions Needed from IANA - Review Needed
2026-09-25
13 Barry Leiba Request for IETF Last Call review by ARTART is assigned to Shuping Peng
2026-09-14
13 Magnus Westerlund Request for IETF Last Call review by TSVART is assigned to Michael Tüxen
2026-09-12
13 Cindy Morgan IANA Review state changed to IANA - Review Needed
2026-09-12
13 Cindy Morgan
The following Last Call announcement was sent out (ends 2026-09-26):

From: The IESG
To: IETF-Announce
CC: draft-ietf-nmop-simap-concept@ietf.org, mjethanandani@gmail.com, mohamed.boucadair@orange.com, nmop-chairs@ietf.org, nmop@ietf.org …
The following Last Call announcement was sent out (ends 2026-09-26):

From: The IESG
To: IETF-Announce
CC: draft-ietf-nmop-simap-concept@ietf.org, mjethanandani@gmail.com, mohamed.boucadair@orange.com, nmop-chairs@ietf.org, nmop@ietf.org, reshad@yahoo.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  (SIMAP: Concept, Requirements, and Use Cases) to Informational RFC


The IESG has received a request from the Network Management Operations WG
(nmop) to consider the following document: - 'SIMAP: Concept, Requirements,
and Use Cases'
  as Informational RFC

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
last-call@ietf.org mailing lists by 2026-09-26. Exceptionally, comments may
be sent to iesg@ietf.org instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract


  This document defines the concept of Service & Infrastructure Maps
  (SIMAP) and identifies a set of SIMAP requirements and use cases.
  The SIMAP was previously known as Digital Map. SIMAP evolves the
  earlier 'Digital Map' concept by making explicit the ties between
  service and infrastructure layers, clarifying expected outcomes for
  operations and automation, and addressing ambiguity associated with
  the term 'digital.'

  The document intends to be used as a reference for the assessment of
  the various topology modules to meet SIMAP requirements.




The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-nmop-simap-concept/



No IPR declarations have been submitted directly on this I-D.




2026-09-12
13 Cindy Morgan IESG state changed to In Last Call from Last Call Requested
2026-09-12
13 Mahesh Jethanandani Last call was requested
2026-09-12
13 Mahesh Jethanandani Last call announcement was generated
2026-09-12
13 Mahesh Jethanandani Ballot approval text was generated
2026-09-12
13 Mahesh Jethanandani Ballot writeup was generated
2026-09-12
13 Mahesh Jethanandani IESG state changed to Last Call Requested from Expert Review::AD Followup
2026-09-04
13 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-09-04
13 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-09-04
13 Olga Havel New version available: draft-ietf-nmop-simap-concept-13.txt
2026-09-04
13 (System) New version approved
2026-09-04
13 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2026-09-04
13 Olga Havel Uploaded new revision
2026-09-04
12 Mališa Vučinić Request for IETF Last Call review by SECDIR Completed: Ready. Reviewer: Mališa Vučinić. Sent review to list.
2026-08-06
12 Mahesh Jethanandani Please address the OPSDIR review comments provided by Jen (thanks, Jen) and the GENART review comments provided by Stewart (thanks, Stewart).
2026-08-06
12 (System) Changed action holders to Olga Havel, Benoît Claise, Oscar de Dios, Thomas Graf (IESG state changed)
2026-08-06
12 Mahesh Jethanandani IESG state changed to Expert Review::Revised I-D Needed from Expert Review
2026-07-25
12 Stewart Bryant Request for IETF Last Call review by GENART Completed: Ready. Reviewer: Stewart Bryant. Sent review to list.
2026-07-07
12 Jen Linkova Request for IETF Last Call review by OPSDIR Completed: Has Nits. Reviewer: Jen Linkova. Sent review to list.
2026-06-30
12 Tero Kivinen Request for IETF Last Call review by SECDIR is assigned to Mališa Vučinić
2026-06-27
12 Bo Wu Request for IETF Last Call review by OPSDIR is assigned to Jen Linkova
2026-06-25
12 Peter Yee Request for IETF Last Call review by GENART is assigned to Stewart Bryant
2026-06-24
12 Mahesh Jethanandani IESG state changed to Expert Review from AD Evaluation::AD Followup
2026-06-24
12 Mahesh Jethanandani Requested IETF Last Call review by OPSDIR
2026-06-24
12 Mahesh Jethanandani Requested IETF Last Call review by GENART
2026-06-24
12 Mahesh Jethanandani Requested IETF Last Call review by SECDIR
2026-06-19
12 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-06-19
12 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-06-19
12 Benoît Claise New version available: draft-ietf-nmop-simap-concept-12.txt
2026-06-19
12 (System) New version approved
2026-06-19
12 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2026-06-19
12 Benoît Claise Uploaded new revision
2026-06-15
11 Mahesh Jethanandani Please see updated AD comments at https://mailarchive.ietf.org/arch/msg/nmop/O5xGcaLvXY2KrsjLt0Mj3wEWYas/
2026-06-04
11 Mahesh Jethanandani Please see follow-up email at https://mailarchive.ietf.org/arch/msg/nmop/K3iR-sfJGMa897TUSa9W9K-FbyA/
2026-06-04
11 (System) Changed action holders to Benoît Claise, Oscar de Dios, Olga Havel, Thomas Graf (IESG state changed)
2026-06-04
11 Mahesh Jethanandani IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation::AD Followup
2026-06-03
11 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-06-03
11 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-06-03
11 Olga Havel New version available: draft-ietf-nmop-simap-concept-11.txt
2026-06-03
11 (System) New version approved
2026-06-03
11 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2026-06-03
11 Olga Havel Uploaded new revision
2026-05-03
10 Mahesh Jethanandani Please see AD review at https://mailarchive.ietf.org/arch/msg/nmop/UUprYa5FrrlqzLpRb6aYIrXFG50/
2026-05-03
10 (System) Changed action holders to Mahesh Jethanandani, Olga Havel, Benoît Claise, Oscar de Dios, Thomas Graf (IESG state changed)
2026-05-03
10 Mahesh Jethanandani IESG state changed to AD Evaluation::Revised I-D Needed from Publication Requested
2026-03-31
10 Reshad Rahman
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

There was strong consensus in the WG.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No controversy. There was a lot of feedback/suggestions especially during WGLC.
Issues were captured @ https://github.com/ietf-wg-nmop/draft-ietf-nmop-digital-map-concept/issues?q=is%3Aissue%20state%3Aclosed and all discussions can be seen on the email archive.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No threat of appeal. All issues were closed "amicably".

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

N/A

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

N/A.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

N/A.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

N/A.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is needed, well written and is the result of WG consensus. yes it's ready to be handed off to the AD.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

No other review is needed.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

The intended status is Informational, due to the document defining the concept of SIMAP and discussing usecases. The status is clearly indicated in Datatracker and in the document.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

Yes, IPR polls were run. Here are the replies:
Olga: https://mailarchive.ietf.org/arch/msg/nmop/4CFONUeFQnv1oQAYLHq1YAzDu5U/
Benoît: https://mailarchive.ietf.org/arch/msg/nmop/U5SV2XQgjdHERqPyGBtLt5cxY4k/
Oscar: https://mailarchive.ietf.org/arch/msg/nmop/aJyDeNstMtAXB4fT3rELEozbLkU/
Thomas: https://mailarchive.ietf.org/arch/msg/nmop/bM-tdMEaBg_f_zIJzZwDenuJKuI/
Ahmed: https://mailarchive.ietf.org/arch/msg/nmop/0qutYe2KIXJcQBLifgLTDy9ajc0/

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

No nits in draft-ietf-nmop-simap-concept-10

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

No concerns with the references.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

N/A.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

N/A.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

N/A.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

No IANA actions.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No IANA registry.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2026-03-31
10 Reshad Rahman IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up
2026-03-31
10 Reshad Rahman IESG state changed to Publication Requested from I-D Exists
2026-03-31
10 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-03-31
10 Reshad Rahman Responsible AD changed to Mahesh Jethanandani
2026-03-31
10 Reshad Rahman Document is now in IESG state Publication Requested
2026-03-31
10 Reshad Rahman Tag Doc Shepherd Follow-up Underway cleared.
2026-03-31
10 Reshad Rahman
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

There was strong consensus in the WG.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No controversy. There was a lot of feedback/suggestions especially during WGLC.
Issues were captured @ https://github.com/ietf-wg-nmop/draft-ietf-nmop-digital-map-concept/issues?q=is%3Aissue%20state%3Aclosed and all discussions can be seen on the email archive.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No threat of appeal. All issues were closed "amicably".

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

N/A

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

N/A.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

N/A.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

N/A.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is needed, well written and is the result of WG consensus. yes it's ready to be handed off to the AD.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

No other review is needed.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

The intended status is Informational, due to the document defining the concept of SIMAP and discussing usecases. The status is clearly indicated in Datatracker and in the document.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

Yes, IPR polls were run. Here are the replies:
Olga: https://mailarchive.ietf.org/arch/msg/nmop/4CFONUeFQnv1oQAYLHq1YAzDu5U/
Benoît: https://mailarchive.ietf.org/arch/msg/nmop/U5SV2XQgjdHERqPyGBtLt5cxY4k/
Oscar: https://mailarchive.ietf.org/arch/msg/nmop/aJyDeNstMtAXB4fT3rELEozbLkU/
Thomas: https://mailarchive.ietf.org/arch/msg/nmop/bM-tdMEaBg_f_zIJzZwDenuJKuI/
Ahmed: https://mailarchive.ietf.org/arch/msg/nmop/0qutYe2KIXJcQBLifgLTDy9ajc0/

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

No nits in draft-ietf-nmop-simap-concept-10

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

No concerns with the references.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

N/A.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

N/A.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

N/A.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

No IANA actions.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No IANA registry.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2026-03-31
10 Olga Havel New version available: draft-ietf-nmop-simap-concept-10.txt
2026-03-31
10 Olga Havel New version approved
2026-03-31
10 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2026-03-31
10 Olga Havel Uploaded new revision
2026-03-29
09 Reshad Rahman
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

There was strong consensus in the WG.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No controversy. There was a lot of feedback/suggestions especially during WGLC.
Issues were captured @ https://github.com/ietf-wg-nmop/draft-ietf-nmop-digital-map-concept/issues?q=is%3Aissue%20state%3Aclosed and all discussions can be seen on the email archive.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No threat of appeal. All issues were closed "amicably".

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

N/A

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

N/A.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

N/A.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

N/A.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is needed, well written and is the result of WG consensus. yes it's ready to be handed off to the AD.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

No other review is needed.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

The intended status is Informational, due to the document defining the concept of SIMAP and discussing usecases. The status is clearly indicated in Datatracker and in the document.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

Yes, IPR polls were run. Here are the replies:
Olga: https://mailarchive.ietf.org/arch/msg/nmop/4CFONUeFQnv1oQAYLHq1YAzDu5U/
Benoît: https://mailarchive.ietf.org/arch/msg/nmop/U5SV2XQgjdHERqPyGBtLt5cxY4k/
Oscar: https://mailarchive.ietf.org/arch/msg/nmop/aJyDeNstMtAXB4fT3rELEozbLkU/
Thomas: https://mailarchive.ietf.org/arch/msg/nmop/bM-tdMEaBg_f_zIJzZwDenuJKuI/
Ahmed: https://mailarchive.ietf.org/arch/msg/nmop/0qutYe2KIXJcQBLifgLTDy9ajc0/

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

Yes there are some nits in -09 as per https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-nmop-simap-concept-09.txt

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

No concerns with the references.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

N/A.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

N/A.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

N/A.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

No IANA actions.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No IANA registry.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2026-03-18
09 Olga Havel New version available: draft-ietf-nmop-simap-concept-09.txt
2026-03-18
09 Olga Havel New version approved
2026-03-18
09 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2026-03-18
09 Olga Havel Uploaded new revision
2026-03-03
08 Reshad Rahman
WGLC conclusion email:

This concludes the WGLC, thanks for the authors for the updated document below and many thanks to the WG contributors for the …
WGLC conclusion email:

This concludes the WGLC, thanks for the authors for the updated document below and many thanks to the WG contributors for the multiple lively discussions!
https://datatracker.ietf.org/doc/draft-ietf-nmop-simap-concept/08/

Special thanks to Olga for tracking all the issues (https://github.com/ietf-wg-nmop/draft-ietf-nmop-digital-map-concept/issues), comments and driving them to closure.
2026-02-27
08 Reshad Rahman Tag Doc Shepherd Follow-up Underway set.
2026-02-27
08 Reshad Rahman IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call
2026-02-23
08 Olga Havel New version available: draft-ietf-nmop-simap-concept-08.txt
2026-02-23
08 (System) New version approved
2026-02-23
08 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2026-02-23
08 Olga Havel Uploaded new revision
2025-11-17
07 Reshad Rahman As discussed/mentioned @ IETF124.
2025-11-17
07 Reshad Rahman IETF WG state changed to In WG Last Call from WG Document
2025-10-18
07 Olga Havel New version available: draft-ietf-nmop-simap-concept-07.txt
2025-10-18
07 Olga Havel New version approved
2025-10-17
07 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-10-17
07 Olga Havel Uploaded new revision
2025-09-26
06 Olga Havel New version available: draft-ietf-nmop-simap-concept-06.txt
2025-09-26
06 Reshad Rahman New version approved
2025-09-26
06 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf , nmop-chairs@ietf.org
2025-09-26
06 Olga Havel Uploaded new revision
2025-09-23
05 Benoît Claise Changed consensus to Yes from Unknown
2025-07-07
05 Olga Havel New version available: draft-ietf-nmop-simap-concept-05.txt
2025-07-07
05 Olga Havel New version approved
2025-07-07
05 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-07-07
05 Olga Havel Uploaded new revision
2025-07-07
05 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-07-07
05 Olga Havel Uploaded new revision
2025-06-28
04 Olga Havel New version available: draft-ietf-nmop-simap-concept-04.txt
2025-06-28
04 Olga Havel New version approved
2025-06-27
04 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-06-27
04 Olga Havel Uploaded new revision
2025-03-04
03 Mohamed Boucadair Added to session: IETF-122: nmop  Tue-0830
2025-03-04
03 Mohamed Boucadair Added to session: IETF-122: nmop  Mon-0230
2025-03-03
03 Olga Havel New version available: draft-ietf-nmop-simap-concept-03.txt
2025-03-03
03 (System) New version approved
2025-03-03
03 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-03-03
03 Olga Havel Uploaded new revision
2025-03-03
02 Mohamed Boucadair Notification list changed to mohamed.boucadair@orange.com, reshad@yahoo.com from mohamed.boucadair@orange.com because the document shepherd was set
2025-03-03
02 Mohamed Boucadair Document shepherd changed to Reshad Rahman
2025-02-14
02 Olga Havel New version available: draft-ietf-nmop-simap-concept-02.txt
2025-02-14
02 Olga Havel New version approved
2025-02-14
02 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-02-14
02 Olga Havel Uploaded new revision
2025-02-14
02 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-02-14
02 Benoît Claise Uploaded new revision
2025-02-13
01 Olga Havel New version available: draft-ietf-nmop-simap-concept-01.txt
2025-02-13
01 Olga Havel New version approved
2025-02-13
01 (System) Request for posting confirmation emailed to previous authors: Benoit Claise , Olga Havel , Oscar de Dios , Thomas Graf
2025-02-13
01 Olga Havel Uploaded new revision
2024-11-29
00 Mohamed Boucadair Intended Status changed to Informational from None
2024-11-29
00 Mohamed Boucadair Rename per the outcome of IETF#121: https://datatracker.ietf.org/doc/minutes-121-nmop-202411050930/
2024-11-29
00 Mohamed Boucadair Changed document external resources from: None to:

github_repo https://github.com/ietf-wg-nmop/draft-ietf-nmop-digital-map-concept
2024-11-29
00 Mohamed Boucadair Notification list changed to mohamed.boucadair@orange.com because the document shepherd was set
2024-11-29
00 Mohamed Boucadair Document shepherd changed to Mohamed Boucadair
2024-11-29
00 Mohamed Boucadair This document now replaces draft-ietf-nmop-digital-map-concept instead of None
2024-11-29
00 Olga Havel New version available: draft-ietf-nmop-simap-concept-00.txt
2024-11-29
00 Olga Havel New version approved
2024-11-29
00 Olga Havel Request for posting confirmation emailed  to submitter and authors: =?utf-8?q?Beno=C3=AEt_Claise?= , Olga Havel , Oscar de Dios , Thomas Graf
2024-11-29
00 Olga Havel Uploaded new revision