Skip to main content

Network News Transfer Protocol (NNTP) Extension for Authentication
draft-ietf-nntpext-authinfo-10

Revision differences

Document history

Date Rev. By Action
2012-08-22
10 (System) post-migration administrative database adjustment to the No Objection position for Sam Hartman
2006-11-17
10 (System) This was part of a ballot set with: draft-ietf-nntpext-tls-nntp
2005-10-03
10 Amy Vezza State Changes to RFC Ed Queue from Approved-announcement sent by Amy Vezza
2005-09-27
10 Amy Vezza IESG state changed to Approved-announcement sent
2005-09-27
10 Amy Vezza IESG has approved the document
2005-09-27
10 Amy Vezza Closed "Approve" ballot
2005-09-27
10 Scott Hollenbeck State Changes to Approved-announcement to be sent from IESG Evaluation::Revised ID Needed by Scott Hollenbeck
2005-09-22
10 Scott Hollenbeck State Changes to IESG Evaluation::Revised ID Needed from IESG Evaluation::AD Followup by Scott Hollenbeck
2005-09-21
10 Sam Hartman [Ballot Position Update] Position for Sam Hartman has been changed to No Objection from Discuss by Sam Hartman
2005-08-10
10 Scott Hollenbeck State Changes to IESG Evaluation::AD Followup from IESG Evaluation::Point Raised - writeup needed by Scott Hollenbeck
2005-08-09
10 (System) New version available: draft-ietf-nntpext-authinfo-10.txt
2005-07-22
10 (System) Removed from agenda for telechat - 2005-07-21
2005-07-21
10 Amy Vezza State Changes to IESG Evaluation::Point Raised - writeup needed from IESG Evaluation by Amy Vezza
2005-07-21
10 (System) [Ballot Position Update] New position, No Objection, has been recorded for Allison Mankin by IESG Secretary
2005-07-21
10 Brian Carpenter
[Ballot comment]
From review by Lakshminath Dondeti

RFC 2222 is in normative and informative references' sections in the authinfo I-D.  Is that intended?

Page 9, …
[Ballot comment]
From review by Lakshminath Dondeti

RFC 2222 is in normative and informative references' sections in the authinfo I-D.  Is that intended?

Page 9, third paragraph from the bottom, last sentence of the -tls- I-D: "Furthermore, just because an NNTP server can authenticate ..." is not clear, and may be incorrect: articles *from* the NNTP client ... when the client *received* them.  Please correct/clarify that sentence.

  Please insert a "to" after the word "extension" in the abstract of -authinfo- ID. 
2005-07-21
10 Brian Carpenter [Ballot Position Update] New position, No Objection, has been recorded for Brian Carpenter by Brian Carpenter
2005-07-21
10 Jon Peterson [Ballot Position Update] New position, No Objection, has been recorded for Jon Peterson by Jon Peterson
2005-07-21
10 Alex Zinin [Ballot Position Update] New position, No Objection, has been recorded for Alex Zinin by Alex Zinin
2005-07-21
10 David Kessens [Ballot Position Update] New position, No Objection, has been recorded for David Kessens by David Kessens
2005-07-20
10 Bill Fenner [Ballot Position Update] New position, No Objection, has been recorded for Bill Fenner by Bill Fenner
2005-07-20
10 Mark Townsley [Ballot Position Update] New position, No Objection, has been recorded for Mark Townsley by Mark Townsley
2005-07-20
10 Sam Hartman
[Ballot discuss]
The authinfo draft needs to discuss internationalization of the
strings for the authinfo user and authinfo pass commands.  They are
listed as UTF8 …
[Ballot discuss]
The authinfo draft needs to discuss internationalization of the
strings for the authinfo user and authinfo pass commands.  They are
listed as UTF8 but no issues like normalization are discussed.
Personally I'd recommend that the server should use saslprep on the
strings.  Regardless of what decision the WG comes to the issue needs
discussion and consideration.  There is somewhat of a discussion of
the complexities in the sasl plain draft.


The authinfo draft needs to discuss what happens if both a SASL
security layer and TLS are negotiated.  I'd recommend that the SASL
security layer be applied first, although double check against
existing implementations.  I would explicitly recommend against the
option of forbidding both security layers and TLS at the same time
although the WG certainly can make that decision if it chooses.

In the TLS draft, please check the text about resuming after TLS
failures with the TLS community.  It is my understanding that most
implementations make this difficult or impossible.  I don't need to
review any text changes in response to this item.  I'm simply
requesting that you double check with the TLS community and make an
informed decision.

The TLS document discusses certificate matching but does not discuss
certificate verification.  I'd recommend using the certificate
verification specified in RFC 3280.  You certainly need to say
something about verification.


Shouldn't the change controller for these extensions be the IESG not
the authors?
2005-07-20
10 Sam Hartman [Ballot Position Update] New position, Discuss, has been recorded for Sam Hartman by Sam Hartman
2005-07-20
10 Bert Wijnen [Ballot Position Update] New position, No Objection, has been recorded for Bert Wijnen by Bert Wijnen
2005-07-19
10 Margaret Cullen [Ballot Position Update] New position, No Objection, has been recorded for Margaret Wasserman by Margaret Wasserman
2005-07-19
10 Ted Hardie [Ballot Position Update] New position, No Objection, has been recorded for Ted Hardie by Ted Hardie
2005-07-12
10 Scott Hollenbeck [Ballot Position Update] New position, Yes, has been recorded for Scott Hollenbeck
2005-07-12
10 Scott Hollenbeck Ballot has been issued by Scott Hollenbeck
2005-07-12
10 Scott Hollenbeck Created "Approve" ballot
2005-07-12
10 Scott Hollenbeck State Changes to IESG Evaluation from Waiting for AD Go-Ahead::AD Followup by Scott Hollenbeck
2005-07-12
10 Scott Hollenbeck Placed on agenda for telechat - 2005-07-21 by Scott Hollenbeck
2005-06-10
10 (System) Sub state has been changed to AD Follow up from New Id Needed
2005-06-10
09 (System) New version available: draft-ietf-nntpext-authinfo-09.txt
2005-06-09
10 Scott Hollenbeck State Changes to Waiting for AD Go-Ahead::Revised ID Needed from Waiting for AD Go-Ahead by Scott Hollenbeck
2005-06-07
10 (System) State has been changed to Waiting for AD Go-Ahead from In Last Call by system
2005-06-06
10 Michelle Cotton
IANA Last Call Comments:
Upon approval of this document the IANA will register the SASL/GSSAPI service name "nntp" at the following location:
http://www.iana.org/assignments/gssapi-service-names.  The …
IANA Last Call Comments:
Upon approval of this document the IANA will register the SASL/GSSAPI service name "nntp" at the following location:
http://www.iana.org/assignments/gssapi-service-names.  The IANA will also register the NNTP extension AUTHINFO in the registry created by
draft-ietf-nntpext-base.
2005-05-24
10 Amy Vezza Last call sent
2005-05-24
10 Amy Vezza State Changes to In Last Call from Last Call Requested by Amy Vezza
2005-05-24
10 Scott Hollenbeck State Changes to Last Call Requested from AD Evaluation by Scott Hollenbeck
2005-05-24
10 Scott Hollenbeck Last Call was requested by Scott Hollenbeck
2005-05-24
10 (System) Ballot writeup text was added
2005-05-24
10 (System) Last call text was added
2005-05-24
10 (System) Ballot approval text was added
2005-05-24
10 Scott Hollenbeck
Updated AD evaluation comments:

draft-ietf-nntpext-authinfo
Abstract: an abstract must be able to stand in isolation from the rest of the spec, so references shouldn't be …
Updated AD evaluation comments:

draft-ietf-nntpext-authinfo
Abstract: an abstract must be able to stand in isolation from the rest of the spec, so references shouldn't be included.  Please replace [NNTP] with "(NNTP)", [NNTP-COMMON] with "RFC 2980", and [SASL] with "(SASL)".

Section 8.2: The UTF-8 reference should be normative.  It's cited as a MUST in section 2.3.2.

draft-ietf-nntpext-tls-nntp
Abstract: an abstract must be able to stand in isolation from the rest of the spec, so references shouldn't be included.  Please replace [NNTP] with "(NNTP)" and [TLS] with "(TLS)".

Both documents:
Please consider updating the [ABNF] reference to use draft-crocker-abnf-rfc2234bis instead of RFC 2234.  The IESG recently approved draft-crocker-abnf-rfc2234bis to obsolete 2234.  It's in the RFC Editor queue.

None of these are significant.  I will start the last call.  Please consider these in the same context as any other comments received during the last call process.
2005-05-24
10 Scott Hollenbeck
AD evaluation comments:

draft-ietf-nntpext-authinfo
Abstract: an abstract must be able to stand in isolation from the rest of the spec, so references shouldn't be included.  …
AD evaluation comments:

draft-ietf-nntpext-authinfo
Abstract: an abstract must be able to stand in isolation from the rest of the spec, so references shouldn't be included.  Please replace [NNTP] with "(NNTP)", [NNTP-COMMON] with "RFC 2980", and [SASL] with "(SASL)".

Section 8.2: The UTF-8 reference should be normative.  It's cited as a MUST in section 2.3.2.

draft-ietf-nntpext-tls-nntp
Abstract: an abstract must be able to stand in isolation from the rest of the spec, so references shouldn't be included.  Please replace [NNTP] with "(NNTP)" and [TLS] with "(TLS)".
2005-05-23
10 Scott Hollenbeck [Note]: 'Document shepherd: Russ Allbery ' added by Scott Hollenbeck
2005-05-23
08 (System) New version available: draft-ietf-nntpext-authinfo-08.txt
2005-05-23
10 Scott Hollenbeck State Changes to AD Evaluation from Publication Requested by Scott Hollenbeck
2005-05-23
10 Scott Hollenbeck State Changes to Publication Requested from AD is watching by Scott Hollenbeck
2005-03-16
07 (System) New version available: draft-ietf-nntpext-authinfo-07.txt
2005-01-17
06 (System) New version available: draft-ietf-nntpext-authinfo-06.txt
2004-11-04
10 Scott Hollenbeck Intended Status has been changed to Proposed Standard from None
2004-10-05
05 (System) New version available: draft-ietf-nntpext-authinfo-05.txt
2004-09-29
04 (System) New version available: draft-ietf-nntpext-authinfo-04.txt
2004-09-07
03 (System) New version available: draft-ietf-nntpext-authinfo-03.txt
2004-07-12
02 (System) New version available: draft-ietf-nntpext-authinfo-02.txt
2004-06-17
01 (System) New version available: draft-ietf-nntpext-authinfo-01.txt
2004-06-08
10 Scott Hollenbeck State Changes to AD is watching from Publication Requested by Scott Hollenbeck
2004-06-08
10 Scott Hollenbeck Draft Added by Scott Hollenbeck
2004-04-30
00 (System) New version available: draft-ietf-nntpext-authinfo-00.txt