Secure Asset Transfer Protocol (SATP) Core
draft-ietf-satp-core-17
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-09
|
17 | (System) | IESG state changed to Waiting for AD Go-Ahead from In Last Call |
|
2026-10-08
|
17 | David Dong | IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-satp-core-17. If any part of this review is inaccurate, please let us know. IANA has a question … IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-satp-core-17. If any part of this review is inaccurate, please let us know. IANA has a question about one of the actions requested in the IANA Considerations section of this document. IANA understands that, upon approval of this document, there are two actions that we must complete. First, in section 13.1 of the current draft, the document requests the registration of a URN. IANA Question --> Could the authors specify in which IANA URN registry they would like the registration to be made? Second, in the applications namespace of the Media Types registry located at: https://www.iana.org/assignments/media-types a single registration is to be made as follows: Name: satp+json Template: [ TBD-at-registration ] Reference: [ RFC-to-be ] We understand that these are the only actions required to be completed upon approval of this document. NOTE: The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed. For definitions of IANA review states, please see: https://datatracker.ietf.org/help/state/draft/iana-review Thank you, David Dong IANA Services Sr. Specialist |
|
2026-10-08
|
17 | (System) | IANA Review state changed to IANA - Not OK from IANA - Review Needed |
|
2026-10-08
|
17 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Ionuț Mihalcea |
|
2026-10-05
|
17 | Joel Halpern | Request for IETF Last Call review by GENART Completed: On the Right Track. Reviewer: Joel Halpern. Sent review to list. |
|
2026-10-04
|
17 | Kyle Rose | Request for IETF Last Call review by TSVART Completed: Not Ready. Reviewer: Kyle Rose. Sent review to list. |
|
2026-10-03
|
17 | Peter Yee | Request for IETF Last Call review by GENART is assigned to Joel Halpern |
|
2026-09-28
|
17 | Magnus Westerlund | Request for IETF Last Call review by TSVART is assigned to Kyle Rose |
|
2026-09-27
|
17 | Barry Leiba | Request for IETF Last Call review by ARTART is assigned to Henry Thompson |
|
2026-09-25
|
17 | Morgan Condie | IANA Review state changed to IANA - Review Needed |
|
2026-09-25
|
17 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-10-09): From: The IESG To: IETF-Announce CC: andy@hxr.us, draft-ietf-satp-core@ietf.org, liuchunchi@huawei.com, sat@ietf.org, satp-chairs@ietf.org … The following Last Call announcement was sent out (ends 2026-10-09): From: The IESG To: IETF-Announce CC: andy@hxr.us, draft-ietf-satp-core@ietf.org, liuchunchi@huawei.com, sat@ietf.org, satp-chairs@ietf.org Reply-To: last-call@ietf.org, sat@ietf.org Sender: Subject: Last Call: (Secure Asset Transfer Protocol (SATP) Core) to Proposed Standard The IESG has received a request from the Secure Asset Transfer Protocol WG (satp) to consider the following document: 'Secure Asset Transfer Protocol (SATP) Core' as Proposed Standard The IESG plans to make a decision on this document in the coming weeks, and solicits last-call comments. Please send substantive comments to the last-call@ietf.org mailing list, with sat@ietf.org copied, no later than 2026-10-09. Please retain the beginning of the Subject line to facilitate automated sorting. Abstract This memo describes the Secure Asset Transfer Protocol (SATP) for digital assets. SATP is a protocol operating between two gateways that conducts the transfer of a digital asset from one gateway to another, each representing their corresponding digital asset networks. The protocol establishes a secure channel between the endpoints and implements a 2-phase commit (2PC) to ensure the properties of transfer atomicity, consistency, isolation and durability. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-satp-core/ No IPR declarations have been submitted directly on this I-D. |
|
2026-09-25
|
17 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-09-25
|
17 | Andy Newton | Last call was requested |
|
2026-09-25
|
17 | Andy Newton | Last call announcement was generated |
|
2026-09-25
|
17 | Andy Newton | Ballot approval text was generated |
|
2026-09-25
|
17 | Andy Newton | Ballot writeup was generated |
|
2026-09-25
|
17 | Andy Newton | IESG state changed to Last Call Requested from AD Evaluation |
|
2026-09-25
|
17 | Rafael Belchior | New version available: draft-ietf-satp-core-17.txt |
|
2026-09-25
|
17 | (System) | New version approved |
|
2026-09-25
|
17 | (System) | Request for posting confirmation emailed to previous authors: Alexandru Chiriac , Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2026-09-25
|
17 | Rafael Belchior | Uploaded new revision |
|
2026-09-15
|
16 | Andy Newton | Message sent to the list on 15 September 2026 by Andy Newton regarding the error codes registry, IANA considerations, and definition of a media-type. |
|
2026-09-02
|
16 | Peter Liu | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. By the time of IETF 125, Orie Steele as Area Director provided AD Reviews. The authors updated accordingly. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. As of IETF 125, the authors need to clarify the public key structure (canonicalization, JCS for example) they use, cite properly. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). One of the other instance is the Quant Network. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. At June, Andy provided several JSON related comments: https://mailarchive.ietf.org/arch/msg/sat/n41kUnJcCa94wnlvfkxJY6Zpu_E/ ...I think the JSON needs to be specified in more concrete terms. There are examples (some have formatting issues), but either use something like JSON Schema (there is a new working group on this topic) or specify the JSON more clearly in prose, such as "foo" is a JSON object with a "bar" string, etc... Do you mean a JSON string? See https://datatracker.ietf.org/doc/html/rfc8259 870 The format of the identity fields in this message, unless otherwise 871 stated, is a JSON text. Does these examples (Line 1001 to 1077) have the word "json" prepended? Additionally, there are other JSON examples that appear to have stray backslash characters. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. According to Andy's review at June, there appear to have a lot to fix: https://mailarchive.ietf.org/arch/msg/sat/n41kUnJcCa94wnlvfkxJY6Zpu_E/ 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. BUT, the document boilerplate has typo: Intended status: Informational. Please fix this. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. Update: From 2026 July 14 to July 29, Thomas called for IPR disclosure on all three documents. No IPR is claimed for all three. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Summary: 1 error (**), 0 flaws (~~), 10 warnings (==), 0 comment (--). The noteable error is listed as follows: ** Obsolete undefined reference: RFC 2616 (Obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235) It is recommended to clear the warnings as well. Link to the nits page: [nits](https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-12.txt) You can also find the latest nits page at the "Nits" button in the document page. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. RFC5939 should be normative. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. (It is removed in -12, and this issue is cleared.) 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors added IANA registration of URN name, message types, error codes, messages, etc. Andy mentioned A reference to this IANA registry is required. 977 * gatewayDefaultSignatureAlgorithm REQUIRED: The default digital 978 signature algorithm (algorithm-id) from the IANA "JSON Web 979 Signature and Encryption Algorithms" registry used by a gateway to 980 sign claims. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. None provided. |
|
2026-09-02
|
16 | Wes Hardaker | Tag AD Followup cleared. |
|
2026-09-02
|
16 | Wes Hardaker | IETF WG state changed to Waiting for WG Chair Go-Ahead from In WG Last Call |
|
2026-08-13
|
16 | Wes Hardaker | IETF WG state changed to In WG Last Call from Submitted to IESG for Publication |
|
2026-08-13
|
16 | Rafael Belchior | New version available: draft-ietf-satp-core-16.txt |
|
2026-08-13
|
16 | (System) | New version approved |
|
2026-08-13
|
16 | (System) | Request for posting confirmation emailed to previous authors: Alexandru Chiriac , Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2026-08-13
|
16 | Rafael Belchior | Uploaded new revision |
|
2026-07-28
|
15 | Rafael Belchior | New version available: draft-ietf-satp-core-15.txt |
|
2026-07-28
|
15 | (System) | New version approved |
|
2026-07-28
|
15 | (System) | Request for posting confirmation emailed to previous authors: Alexandru Chiriac , Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2026-07-28
|
15 | Rafael Belchior | Uploaded new revision |
|
2026-07-19
|
14 | (System) | Changed action holders to Andy Newton (IESG state changed) |
|
2026-07-19
|
14 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-07-19
|
14 | Thomas Hardjono | New version available: draft-ietf-satp-core-14.txt |
|
2026-07-19
|
14 | Thomas Hardjono | New version accepted (logged-in submitter: Thomas Hardjono) |
|
2026-07-19
|
14 | Thomas Hardjono | Uploaded new revision |
|
2026-06-09
|
13 | Andy Newton | Ad Evaluation sent on 9 June 2026 |
|
2026-06-09
|
13 | (System) | Changed action holders to Martin Hargreaves, Thomas Hardjono, Rafael Belchior, Venkatraman Ramakrishna, Alexandru Chiriac (IESG state changed) |
|
2026-06-09
|
13 | Andy Newton | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation::AD Followup |
|
2026-03-26
|
13 | Andy Newton | Changed action holders to Andy Newton |
|
2026-03-20
|
13 | Peter Liu | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. By the time of IETF 125, Orie Steele as Area Director provided AD Reviews. The authors updated accordingly. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. As of IETF 125, the authors need to clarify the public key structure (canonicalization, JCS for example) they use, cite properly. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). One of the other instance is the Quant Network. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. BUT, the document boilerplate has typo: Intended status: Informational. Please fix this. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No. The shepherd searched the email archive with keywords like "IPR", "disclosure", "patent", none came out. It seems the chairs didn't call for IPR disclosure. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Summary: 1 error (**), 0 flaws (~~), 10 warnings (==), 0 comment (--). The noteable error is listed as follows: ** Obsolete undefined reference: RFC 2616 (Obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235) It is recommended to clear the warnings as well. Link to the nits page: [nits](https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-12.txt) You can also find the latest nits page at the "Nits" button in the document page. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. RFC5939 should be normative. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. (It is removed in -12, and this issue is cleared.) 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors added IANA registration of URN name, message types, error codes, messages, etc. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. None provided. |
|
2026-03-18
|
13 | Morgan Condie | Shepherding AD changed to Andy Newton |
|
2026-03-16
|
13 | (System) | Changed action holders to Orie Steele (IESG state changed) |
|
2026-03-16
|
13 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-03-16
|
13 | Thomas Hardjono | New version available: draft-ietf-satp-core-13.txt |
|
2026-03-16
|
13 | (System) | New version approved |
|
2026-03-16
|
13 | (System) | Request for posting confirmation emailed to previous authors: Alexandru Chiriac , Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2026-03-16
|
13 | Thomas Hardjono | Uploaded new revision |
|
2026-02-24
|
12 | Orie Steele | # Orie Steele, ART AD, comments for draft-ietf-satp-core-12 CC @OR13 * line numbers: - https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-12.txt&submitcheck=True * comment syntax: - https://github.com/mnot/ietf-comments/blob/main/format.md ## Discuss ### … # Orie Steele, ART AD, comments for draft-ietf-satp-core-12 CC @OR13 * line numbers: - https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-12.txt&submitcheck=True * comment syntax: - https://github.com/mnot/ietf-comments/blob/main/format.md ## Discuss ### References There are lots of broken or unused references in this document. ### TSL 1.2 ``` 215 All messages exchanged between gateways are assumed to run over 216 TLS1.2 or higher, and the endpoints at the respective gateways are ``` Why is TLS 1.2 mandatory? Why not TLS 1.3? Some elaboration on this seems warranted. ## Comments ### 2PC vs 3PC ``` 23 networks. The protocol establishes a secure channel between the 24 endpoints and implements a 2-phase commit (2PC) to ensure the 25 properties of transfer atomicity, consistency, isolation and 26 durability. ``` IMO, if core never describes 3PC, the architecture should either say that, or not introduce 3PC. ### Legal Owner in Cert ``` 216 TLS1.2 or higher, and the endpoints at the respective gateways are 217 associated with a certificate indicating the legal owner (or 218 operator) of the gateway. HTTPS/S must be used intead of plain HTTP. ``` How? Does this mean that ACME / Let's Encrypt is not allowed? ### Claims Instead of: ``` 254 * Claim: An assertion made by an Entity [JWT]. 256 * Claim Type: Syntax used for representing a Claim Value [JWT]. ``` Readers might find something like: ``` The terms Claim, Claim Name and Claim Value are as defined in RFC 7519. ``` However, "Claim Type" is not defined in RFC 7519. ### All Signatures and Keys? ``` 377 SATP gateways SHOULD support the algorithms defined in the JSON Web 378 Algorithms (JWA) specification [RFC7518] and key types defined in the 379 JSON Web Key (JWK) specification [RFC7517]. The choice of signature ``` The implication here is that all SHOULD be supported. Its good enough that you have a MTI, I don't think you need to encourage the use of all algorithms and key types. ### Base64 JSON ``` 476 The default format of the digital asset Identifier is JSON, with 477 base64 encoding. ``` You mean that the identifier is an encoded JSON object? Or that the identifier is a base64 string, which can be found in the JSON messages? A small example would be helpful. ### JSON Block for TLS Schemes ``` 591 basic scheme (AES-128 in GCM mode with SHA-256), then the client may 592 may choose to send a JSON block containing information regarding the 593 client's supported TLS schemes. ``` Is there a reference for this? Has this been reviewed by the TLS list? ### SAT vs SATP ``` 598 identifier MUST be uniquely bound to its SAT endpoint (e.g. via X.509 599 certificates). ``` I noticed this in a few other places, are both SAT and SATP used? It seems better to use SATP consistently. ### Message Payload ``` 612 This is the hash of the current message payload. ``` How is message payload related to the messages in 5.3.2? ### Repeated MTI ``` 622 All implementations MUST support a common default of "ES256", which 623 is the ECDSA signature algorithm with the P-256 curve and the SHA-256 624 hash function. ``` Perhaps keep this one, and us a forward reference for the first statement on MTI signature algorithms. ### References for lock types? ``` 643 Currently, the most common type of mechanisms (NetworkLockType) to 644 temporarily lock an asset in a network are (i) TIME_LOCK, (ii) 645 HASH_LOCK, (iii) HASH_TIME_LOCK. ``` Are there any networks that implement these lock types? Perhaps provide at least one reference for each lock type. ### Nonces are not shown Not sure why this note occurs. Are these SATP Nonces? ### JSON string ``` 838 stated, is a JSON string that contains a [X.500] Distinguished Name. ``` I think you mean JSON text, as described in https://datatracker.ietf.org/doc/html/rfc7159#section-2 ### Default format ``` 843 for the digital asset located in the origin network. The default 844 format is JSON, with base64 encoding. ``` Not sure why this is repeated here. ### Format of Pubkey ``` 867 * originatorPubkey REQUIRED: This is the public key of the asset 868 owner (originator) in the origin network or system. ``` Is this a JWK? Can it be other formats?... looks like its hex... what is the format of these keys? Please provide references for undertanding the hex strings.... or use JWK. ``` receiverGatewaySignaturePublicKey ``` why both "Pubkey" and "PublicKey"? ### Some pre-negotiated ``` 933 the peer gateways. Some of these parameters must be previously 934 agreed to during the Stage-0 negotiations, which is outside the scope 935 of this document. ``` Which ones are part of Stage 0? ### hashTransferInitClaim ``` 1079 * hashTransferInitClaim REQUIRED: Hash of the Transfer 1080 Initialization Claim received in the Transfer Proposal Message. ``` How is this hash computed? in the claim set normalized before being hashed? No default algorithm is mentioned (I suggest you address default hashing algorithms once, along with any normalization requirements). Same question for: ``` 1118 * hashPrevMessage REQUIRED: The cryptographic hash of the last 1119 message that caused the rejection to occur. The default hash 1120 algorothm is SHA256. ``` ### Unrecognized claims must be ignored This is a common pattern in JSON based protocols. It was not clear to me if this protocol takes the same approach. ### Rollback ``` 1646 The mechanism to perform recovery and resumption in SATP will be 1647 defined in a separate specification. ``` Its weird to see this after describing a mechanism. Is session recovery and resumption mandatory in the protocol? ### resuting & why not MUST? ``` 1695 Connection errors resuting in the time-out of the session SHOULD 1696 result in the termination of the transfer session. ``` Won't leaving sessions open lead to resource exhaustion? ### Applicability ``` 1739 In general, the termination of sessions or aborts occurring before 1740 the sender gateway G1 disables (burns) the asset in NW1 (in flow 3.4 1741 in Figure 2) will incur a minimal cost in terms of computing 1742 resources or fees on the part of both gateways G1 and G2. ``` The use of "will" here, speaks to applicability of the protocol. I assume there are some networks where the "fees" are not "minimal". I would not assert anything about costs, other than to note that they are expected to be non zero for aborted sessions, and that reputation monitoring might be useful as an operational consideration. ### Gateway election ``` 1756 the SATP layer), and for new attempts to be conducted. If the 1757 gateway selection mechanisms are utilized by networks NW1 and NW2, 1758 such attacks may incur more delays because new gateways may have 1759 to be elected at either network. ``` Is this the first time gateway election is mentioned? How are election conducted? (consider removing this detail, if it does not generalize well) ### Names without references ``` 1795 uniqueness and reachability. Existing identification mechanisms 1796 such a X509 certificates and Verifiable Credentials (VC) and 1797 Selective Disclosure CBOR Web Tokens (SD-CWT) may be applied for 1798 gateway identification. ``` I would recommend adding references for these, and only including mechanisms that have a very high probability of being used, or where there are already 2 implementations which support the mechanism. ### err_1.1.11 invalid digitalAssetId ... I don't understand how this code would arise from the current protocol, would this not require the receiving network to understand asset ids from the sending network? Similar questions for the other error codes regarding identifiers. How would an implementation know if an id is invalid? based on the current text, the requirement for uniqueness is the only clear requirement I can see. ## Nits ### Support ``` 573 Gateways must suport TLS1.2 or higher [RFC8448]. ``` ### received ``` 1097 rejection of the the previous message receuved from the client. This ``` ### extra be ``` 1617 primary-backup strategy or self-healing paradigm. The first strategy 1618 pertains to the crashed gateway being eventually be replaced by a 1619 functioning one,while the second strategy focuses on the gateway ``` ### maybe? ``` 1710 Note that a session-abort message by be lost and never be received by 1711 the peer gateway. Gateways can crash prior to receiving an abort 1712 message. ``` |
|
2026-02-24
|
12 | (System) | Changed action holders to Martin Hargreaves, Thomas Hardjono, Rafael Belchior, Venkatraman Ramakrishna, Alexandru Chiriac (IESG state changed) |
|
2026-02-24
|
12 | Orie Steele | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2026-02-14
|
12 | Orie Steele | IESG state changed to AD Evaluation from Publication Requested |
|
2026-02-06
|
12 | Wes Hardaker | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). One of the other instance is the Quant Network. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. BUT, the document boilerplate has typo: Intended status: Informational. Please fix this. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No. The shepherd searched the email archive with keywords like "IPR", "disclosure", "patent", none came out. It seems the chairs didn't call for IPR disclosure. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Summary: 1 error (**), 0 flaws (~~), 10 warnings (==), 0 comment (--). The noteable error is listed as follows: ** Obsolete undefined reference: RFC 2616 (Obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235) It is recommended to clear the warnings as well. Link to the nits page: [nits](https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-12.txt) You can also find the latest nits page at the "Nits" button in the document page. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. RFC5939 should be normative. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. (It is removed in -12, and this issue is cleared.) 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors added IANA registration of URN name, message types, error codes, messages, etc. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. None provided. |
|
2026-02-06
|
12 | Wes Hardaker | IETF WG state changed to Submitted to IESG for Publication from In WG Last Call |
|
2026-02-06
|
12 | Wes Hardaker | IESG state changed to Publication Requested from I-D Exists |
|
2026-02-06
|
12 | (System) | Changed action holders to Orie Steele (IESG state changed) |
|
2026-02-06
|
12 | Wes Hardaker | Responsible AD changed to Orie Steele |
|
2026-02-06
|
12 | Wes Hardaker | Document is now in IESG state Publication Requested |
|
2025-11-03
|
12 | Peter Liu | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). One of the other instance is the Quant Network. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. BUT, the document boilerplate has typo: Intended status: Informational. Please fix this. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No. The shepherd searched the email archive with keywords like "IPR", "disclosure", "patent", none came out. It seems the chairs didn't call for IPR disclosure. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Summary: 1 error (**), 0 flaws (~~), 10 warnings (==), 0 comment (--). The noteable error is listed as follows: ** Obsolete undefined reference: RFC 2616 (Obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235) It is recommended to clear the warnings as well. Link to the nits page: [nits](https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-12.txt) You can also find the latest nits page at the "Nits" button in the document page. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. RFC5939 should be normative. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. (It is removed in -12, and this issue is cleared.) 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors added IANA registration of URN name, message types, error codes, messages, etc. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. None provided. |
|
2025-11-02
|
12 | Thomas Hardjono | New version available: draft-ietf-satp-core-12.txt |
|
2025-11-02
|
12 | (System) | New version approved |
|
2025-11-02
|
12 | (System) | Request for posting confirmation emailed to previous authors: Alexandru Chiriac , Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2025-11-02
|
12 | Thomas Hardjono | Uploaded new revision |
|
2025-08-07
|
11 | Peter Liu | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No. The shepherd searched the email archive with keywords like "IPR", "disclosure", "patent", none came out. It seems the chairs didn't call for IPR disclosure. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Summary: 1 error (**), 0 flaws (~~), 10 warnings (==), 1 comment (--). The noteable error is listed as follows: ** Obsolete undefined reference: RFC 2616 (Obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235) It is recommended to clear the warnings as well. Link to the nits page: [nits](https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-10.txt) You can also find the latest nits page at the "Nits" button in the document page. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. None. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors added IANA registration of URN name, message types, error messages, etc. at ver. -11. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. None provided. |
|
2025-08-07
|
11 | Thomas Hardjono | New version available: draft-ietf-satp-core-11.txt |
|
2025-08-07
|
11 | (System) | New version approved |
|
2025-08-07
|
11 | (System) | Request for posting confirmation emailed to previous authors: Alexandru Chiriac , Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2025-08-07
|
11 | Thomas Hardjono | Uploaded new revision |
|
2025-08-05
|
10 | Peter Liu | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No. The shepherd searched the email archive with keywords like "IPR", "disclosure", "patent", none came out. It seems the chairs didn't call for IPR disclosure. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Summary: 1 error (**), 0 flaws (~~), 10 warnings (==), 1 comment (--). The noteable error is listed as follows: ** Obsolete undefined reference: RFC 2616 (Obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235) It is recommended to clear the warnings as well. Link to the nits page: https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-satp-core-10.txt You can also find the latest nits page at the "Nits" button in the document page. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. None. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors left IANA considerations section as TBD. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. |
|
2025-07-22
|
10 | Claire | # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of … # SATP-core Shepherd Write-Up As required by [RFC 4858](https://www.rfc-editor.org/rfc/rfc4858.txt) and requested by the SATP WG, this is the shepherd write-up of SATP-core document using the most current template I found at [here](https://datatracker.ietf.org/doc/shepherdwriteup-template/individual). ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document has been discussed in nearly all SATP sessions at past IETF meetings. On February 4, 2025, the chairs called on the working group to review the document and submit feedback. For the SATP-core document, the following responses were received: * 2 reviews with suggested changes (Hadarker and Willman) * 23 reviews with explicit support. Before that, there are [20](https://github.com/ietf-satp/draft-ietf-satp-core/pulls?q=is%3Apr+is%3Aclosed) closed PRs related to reviews and fixes; about 6~7ish people are involved. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No. As of May 30, some points are under discussion, but not blockers: * SATP-core document need minimum MUST requirements for better interoperability. Specifically, the JSON message should be mandatorily signed using JWS mechanisms? A MUST-implement curve/ciphersuite? The tendency of consensus is yes-- use JWS with ECDSA over P256 curve with SHA-256 as the signing algorithm. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None noticed. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? One of the main editor's affiliation -- IBM, has a [Hyperledger Cacti implementation](https://hyperledger-cacti.github.io/cacti/). ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Since the document defines an application-layer SATP core message exchanged between two gateways, this document would benefit from a HTTP directorate review. A HTTP directorate early review is requested, and the [result](https://datatracker.ietf.org/doc/review-ietf-satp-core-00-httpdir-early-pardue-2023-04-28/) is NOT READY. He explicitly mentioned a few problems: * The document has left important interoperability questions answered (might refer to section 5, SATP core message format). If the document is developed based on external documentations of some existing projects, the document should reference it. Otherwise some clarification on the specification is needed. The WG is currently discussing this issue. * The document has some duplication with SATP-architecture. He recommend to reduce redundancy to make "the protocol specification clearer to review." * The reviewer thinks the JSON messages defined in this document should be just message payloads, but it appears some messages also include HTTP semantics. This problem is especially obvious for Type-1 API. Is this supposed to define a new/custom HTTP encapsulation? If so, it "needs deeper discussion and engagement". * Other ambiguity or editorial nits. There are no known reviews from other WGs. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. At April 15, Wes provided a [review](https://mailarchive.ietf.org/arch/msg/sat/myjl2gZ1emR4JuGObSJKHE6IswE/). He mentioned: The document "need the enumeration of possible values for restricted protocol components that really need an exact value agreed to by both sides", which could help disambiguate future implementation process using this proposed RFC. The shepherd infer that this reflects the similar ambiguity issues raised by the HTTP Directorate reivew above. Some other editorial nits are mentioned. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? The document does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The shepherd does not find related automated checks in the document homepage, as they usually being provided in the "additional resources" in the document homepage. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? According to the HTTP early review, there are certain specification ambiguity issues that need some fixes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because it defines the core SATP message format to be exchanged between two gateways. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No. The shepherd searched the email archive with keywords like "IPR", "disclosure", "patent", none came out. It seems the chairs didn't call for IPR disclosure. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. No issue discovered. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) == There are 3 instances of lines with non-ascii characters in the document. == The page length should not exceed 58 lines per page, but there was 3 longer pages, the longest (page 12) being 71 lines 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. None. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None discovered. 17. Are there any normative downward references (see RFC 3967 and BCP 1) that are not already listed in the DOWNREF registry? If so, list them. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? draft-belchior-satp-gateway-recovery-02 is referenced. Plan for completion is unknown. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). The authors left IANA considerations section as TBD. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. |
|
2025-07-22
|
10 | Claire | Notification list changed to liuchunchi@huawei.com because the document shepherd was set |
|
2025-07-22
|
10 | Claire | Document shepherd changed to Peter Chunchi Liu |
|
2025-07-04
|
10 | Thomas Hardjono | New version available: draft-ietf-satp-core-10.txt |
|
2025-07-04
|
10 | Thomas Hardjono | New version accepted (logged-in submitter: Thomas Hardjono) |
|
2025-07-04
|
10 | Thomas Hardjono | Uploaded new revision |
|
2025-06-06
|
09 | Thomas Hardjono | New version available: draft-ietf-satp-core-09.txt |
|
2025-06-06
|
09 | (System) | New version approved |
|
2025-06-06
|
09 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna , satp-chairs@ietf.org |
|
2025-06-06
|
09 | Thomas Hardjono | Uploaded new revision |
|
2025-02-19
|
08 | Wes Hardaker | Restarting a second last call for more feedback |
|
2025-01-14
|
08 | Wes Hardaker | IETF WG state changed to In WG Last Call from WG Document |
|
2025-01-10
|
08 | Thomas Hardjono | New version available: draft-ietf-satp-core-08.txt |
|
2025-01-10
|
08 | Thomas Hardjono | New version accepted (logged-in submitter: Thomas Hardjono) |
|
2025-01-10
|
08 | Thomas Hardjono | Uploaded new revision |
|
2024-10-15
|
07 | Thomas Hardjono | New version available: draft-ietf-satp-core-07.txt |
|
2024-10-15
|
07 | (System) | New version approved |
|
2024-10-15
|
07 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Rafael Belchior , Thomas Hardjono , Venkatraman Ramakrishna |
|
2024-10-15
|
07 | Thomas Hardjono | Uploaded new revision |
|
2024-10-04
|
06 | Martin Hargreaves | New version available: draft-ietf-satp-core-06.txt |
|
2024-10-04
|
06 | (System) | New version approved |
|
2024-10-04
|
06 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Thomas Hardjono , Venkatraman Ramakrishna , satp-chairs@ietf.org |
|
2024-10-04
|
06 | Martin Hargreaves | Uploaded new revision |
|
2024-09-11
|
05 | Thomas Hardjono | New version available: draft-ietf-satp-core-05.txt |
|
2024-09-11
|
05 | (System) | New version approved |
|
2024-09-11
|
05 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Rafael Belchior , Thomas Hardjono , satp-chairs@ietf.org |
|
2024-09-11
|
05 | Thomas Hardjono | Uploaded new revision |
|
2024-08-30
|
04 | Claire | Changed consensus to Yes from Unknown |
|
2024-08-30
|
04 | Claire | Intended Status changed to Proposed Standard from None |
|
2024-04-05
|
04 | Thomas Hardjono | New version available: draft-ietf-satp-core-04.txt |
|
2024-04-05
|
04 | (System) | New version approved |
|
2024-04-05
|
04 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Rafael Belchior , Thomas Hardjono |
|
2024-04-05
|
04 | Thomas Hardjono | Uploaded new revision |
|
2024-03-20
|
03 | Thomas Hardjono | New version available: draft-ietf-satp-core-03.txt |
|
2024-03-20
|
03 | (System) | New version approved |
|
2024-03-20
|
03 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Rafael Belchior , Thomas Hardjono |
|
2024-03-20
|
03 | Thomas Hardjono | Uploaded new revision |
|
2024-02-19
|
02 | Mark Nottingham | Assignment of request for Early review by HTTPDIR to Mark Nottingham was withdrawn |
|
2024-02-19
|
02 | Mark Nottingham | Request for Early review by HTTPDIR is assigned to Mark Nottingham |
|
2024-01-09
|
02 | (System) | Document has expired |
|
2023-10-07
|
02 | Mark Nottingham | Requested Early review by HTTPDIR |
|
2023-07-08
|
02 | Thomas Hardjono | New version available: draft-ietf-satp-core-02.txt |
|
2023-07-08
|
02 | (System) | New version approved |
|
2023-07-08
|
02 | (System) | Request for posting confirmation emailed to previous authors: Martin Hargreaves , Rafael Belchior , Thomas Hardjono |
|
2023-07-08
|
02 | Thomas Hardjono | Uploaded new revision |
|
2023-06-12
|
01 | Thomas Hardjono | New version available: draft-ietf-satp-core-01.txt |
|
2023-06-12
|
01 | Thomas Hardjono | New version accepted (logged-in submitter: Thomas Hardjono) |
|
2023-06-12
|
01 | Thomas Hardjono | Uploaded new revision |
|
2023-04-28
|
00 | Lucas Pardue | Request for Early review by HTTPDIR Completed: Not Ready. Reviewer: Lucas Pardue. Sent review to list. |
|
2023-04-27
|
00 | Mark Nottingham | Request for Early review by HTTPDIR is assigned to Lucas Pardue |
|
2023-04-27
|
00 | Mark Nottingham | Requested Early review by HTTPDIR |
|
2023-04-27
|
00 | Wes Hardaker | This document now replaces draft-hargreaves-sat-core instead of None |
|
2023-04-27
|
00 | Thomas Hardjono | New version available: draft-ietf-satp-core-00.txt |
|
2023-04-27
|
00 | Claire | WG -00 approved |
|
2023-04-27
|
00 | Thomas Hardjono | Set submitter to "Thomas Hardjono ", replaces to (none) and sent approval email to group chairs: satp-chairs@ietf.org |
|
2023-04-27
|
00 | Thomas Hardjono | Uploaded new revision |