Automatically Connecting Stub Networks to Unmanaged Infrastructure
draft-ietf-snac-simple-12
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-09-29
|
12 | David Lou | https://mailarchive.ietf.org/arch/browse/snac/ |
|
2026-09-29
|
12 | David Lou | Tag Revised I-D Needed - Issue raised by WGLC set. |
|
2026-09-29
|
12 | David Lou | IETF WG state changed to Waiting for WG Chair Go-Ahead from In WG Last Call |
|
2026-09-03
|
12 | David Lou | IETF WG state changed to In WG Last Call from WG Document |
|
2026-09-03
|
12 | Éric Vyncke | Sending it back to the SNAC WG as the changes after the AD review were quite substantial. The AD decided that another WG last call … Sending it back to the SNAC WG as the changes after the AD review were quite substantial. The AD decided that another WG last call is required. More details at: https://mailarchive.ietf.org/arch/msg/snac/FkGruURZi13Ry73YPIxmjz4NTvE/ |
|
2026-09-03
|
12 | Éric Vyncke | Tag Doc Shepherd Follow-up Underway cleared. |
|
2026-09-03
|
12 | Éric Vyncke | IETF WG state changed to WG Document from Submitted to IESG for Publication |
|
2026-09-03
|
12 | Éric Vyncke | Sending it back to the SNAC WG as the changes after the AD review were quite substantial. The AD decided that another WG last call … Sending it back to the SNAC WG as the changes after the AD review were quite substantial. The AD decided that another WG last call is required. More details at: https://mailarchive.ietf.org/arch/msg/snac/FkGruURZi13Ry73YPIxmjz4NTvE/ |
|
2026-09-03
|
12 | Éric Vyncke | IESG state changed to I-D Exists from AD Evaluation::AD Followup |
|
2026-08-30
|
12 | Esko Dijk | New version available: draft-ietf-snac-simple-12.txt |
|
2026-08-30
|
12 | (System) | New version approved |
|
2026-08-30
|
12 | (System) | Request for posting confirmation emailed to previous authors: Esko Dijk , Jonathan Hui , Ted Lemon |
|
2026-08-30
|
12 | Esko Dijk | Uploaded new revision |
|
2026-08-30
|
11 | (System) | Changed action holders to Éric Vyncke (IESG state changed) |
|
2026-08-30
|
11 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-08-30
|
11 | Esko Dijk | New version available: draft-ietf-snac-simple-11.txt |
|
2026-08-30
|
11 | (System) | New version approved |
|
2026-08-30
|
11 | (System) | Request for posting confirmation emailed to previous authors: Esko Dijk , Jonathan Hui , Ted Lemon |
|
2026-08-30
|
11 | Esko Dijk | Uploaded new revision |
|
2026-06-15
|
10 | Éric Vyncke | A revised I-D is needed to address the AD review at https://mailarchive.ietf.org/arch/msg/snac/tx_jkO0aR8kg6Ih8jBAUF4FLSxI/ |
|
2026-06-15
|
10 | (System) | Changed action holders to Ted Lemon, Jonathan Hui, Esko Dijk (IESG state changed) |
|
2026-06-15
|
10 | Éric Vyncke | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2026-06-13
|
10 | Éric Vyncke | IESG state changed to AD Evaluation from Publication Requested |
|
2026-06-13
|
10 | David Lou | This version is dated 4 July 2022. Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this … This version is dated 4 July 2022. Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group (IESG) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in RFC 4858. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document is the primary output of the snac working group, so it reached broad agreement within the working group, with comments from working group members who aren’t the authors. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was little controversy, with good discussion among the working group members. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) There seems to be no extreme discontent, so I would not expect an appeal. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? The authors indicated that OpenThread (https://github.com/openthread/openthread), Apple tvOS, and Thread Border Routers (https://threadgroup.org/Certified-Products) all implement this document. Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document was reviewed by IPv6 experts in the 6MAN and v6ops working groups. Additionally, the Thread Group reviewed it based on the authors' responses. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. There were no additional required reviews. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? N/A 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. N/A Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? As document shepherd, I reviewed this document to ensure that it is following the WG consensus and discussions and is of good quality. In my opinion, the document is ready for publication. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? SNAC is part of the Internet Area working group and had the appropriate amount of review. 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The RFC requested is Proposed Standard and is correctly attributed in the Datatracker. This is appropriate for this document as it describes how to implement and connect IPv6 stub networks to adjacent unmanaged IPv6 networks. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. I reached out to the authors about IPR and they responded they aren’t aware of any. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, all the authors have expressed willingness to be listed. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) I was not able to find any additional nits. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. No, every reference I reviewed is correctly classified as Normative or Informative. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative References? All references are publicly available. 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. RFC 7084 and RFC 9663 are both Informational at present, so they are downrefs, and neither is listed in the DOWNREF registry. RFC 7084 is moving to BCP via 7084-bis; if that were used, it wouldn't be a downref. I believe these downrefs are appropriate for this document. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? There are two drafts listed as normative references. ietf-6man-snac-router-ra-flag has been submitted to IESG for publication. ietf-dnssd-advertising-proxy appears to have expired in 2024. This either needs to be removed or work needs to be done to complete this for the draft to move forward. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No, this document is stand alone. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). A new entry in the service.arpa subdomain is requested, and the name and request seem reasonable. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No new registries are needed. |
|
2026-06-13
|
10 | David Lou | IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up |
|
2026-06-13
|
10 | David Lou | IESG state changed to Publication Requested from I-D Exists |
|
2026-06-13
|
10 | (System) | Changed action holders to Éric Vyncke (IESG state changed) |
|
2026-06-13
|
10 | David Lou | Responsible AD changed to Éric Vyncke |
|
2026-06-13
|
10 | David Lou | Document is now in IESG state Publication Requested |
|
2026-06-12
|
10 | Timothy Winters | This version is dated 4 July 2022. Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this … This version is dated 4 July 2022. Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group (IESG) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in RFC 4858. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document is the primary output of the snac working group, so it reached broad agreement within the working group, with comments from working group members who aren’t the authors. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was little controversy, with good discussion among the working group members. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) There seems to be no extreme discontent, so I would not expect an appeal. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? The authors indicated that OpenThread (https://github.com/openthread/openthread), Apple tvOS, and Thread Border Routers (https://threadgroup.org/Certified-Products) all implement this document. Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document was reviewed by IPv6 experts in the 6MAN and v6ops working groups. Additionally, the Thread Group reviewed it based on the authors' responses. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. There were no additional required reviews. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? N/A 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. N/A Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? As document shepherd, I reviewed this document to ensure that it is following the WG consensus and discussions and is of good quality. In my opinion, the document is ready for publication. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? SNAC is part of the Internet Area working group and had the appropriate amount of review. 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The RFC requested is Proposed Standard and is correctly attributed in the Datatracker. This is appropriate for this document as it describes how to implement and connect IPv6 stub networks to adjacent unmanaged IPv6 networks. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. I reached out to the authors about IPR and they responded they aren’t aware of any. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, all the authors have expressed willingness to be listed. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) I was not able to find any additional nits. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. No, every reference I reviewed is correctly classified as Normative or Informative. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative References? All references are publicly available. 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. RFC 7084 and RFC 9663 are both Informational at present, so they are downrefs, and neither is listed in the DOWNREF registry. RFC 7084 is moving to BCP via 7084-bis; if that were used, it wouldn't be a downref. I believe these downrefs are appropriate for this document. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? There are two drafts listed as normative references. ietf-6man-snac-router-ra-flag has been submitted to IESG for publication. ietf-dnssd-advertising-proxy appears to have expired in 2024. This either needs to be removed or work needs to be done to complete this for the draft to move forward. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No, this document is stand alone. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). A new entry in the service.arpa subdomain is requested, and the name and request seem reasonable. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No new registries are needed. |
|
2026-06-08
|
10 | Darren Dukes | The WG Last Call has completed and the shepherd, Timothy Winters, is completing the writeup. |
|
2026-06-08
|
10 | Darren Dukes | Tag Doc Shepherd Follow-up Underway set. |
|
2026-06-08
|
10 | Darren Dukes | IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call |
|
2026-05-06
|
10 | Esko Dijk | New version available: draft-ietf-snac-simple-10.txt |
|
2026-05-06
|
10 | Esko Dijk | New version accepted (logged-in submitter: Esko Dijk) |
|
2026-05-06
|
10 | Esko Dijk | Uploaded new revision |
|
2026-04-25
|
09 | Darren Dukes | IETF WG state changed to In WG Last Call from WG Document |
|
2026-04-20
|
09 | Esko Dijk | New version available: draft-ietf-snac-simple-09.txt |
|
2026-04-20
|
09 | Darren Dukes | New version approved |
|
2026-04-20
|
09 | (System) | Request for posting confirmation emailed to previous authors: Jonathan Hui , Ted Lemon , snac-chairs@ietf.org |
|
2026-04-20
|
09 | Esko Dijk | Uploaded new revision |
|
2026-04-13
|
08 | (System) | Document has expired |
|
2025-10-10
|
08 | Jonathan Hui | New version available: draft-ietf-snac-simple-08.txt |
|
2025-10-10
|
08 | Jonathan Hui | New version accepted (logged-in submitter: Jonathan Hui) |
|
2025-10-10
|
08 | Jonathan Hui | Uploaded new revision |
|
2025-07-25
|
07 | Éric Vyncke | Changed document external resources from: None to: github_repo https://github.com/ietf-wg-snac/draft-ietf-snac-simple |
|
2025-07-07
|
07 | Jonathan Hui | New version available: draft-ietf-snac-simple-07.txt |
|
2025-07-07
|
07 | Jonathan Hui | New version accepted (logged-in submitter: Jonathan Hui) |
|
2025-07-07
|
07 | Jonathan Hui | Uploaded new revision |
|
2025-05-08
|
06 | (System) | Document has expired |
|
2025-03-19
|
06 | Darren Dukes | Notification list changed to tim@qacafe.com because the document shepherd was set |
|
2025-03-19
|
06 | Darren Dukes | Document shepherd changed to Timothy Winters |
|
2024-12-03
|
06 | David Lou | Changed consensus to Yes from Unknown |
|
2024-12-03
|
06 | David Lou | Intended Status changed to Proposed Standard from None |
|
2024-11-04
|
06 | Jonathan Hui | New version available: draft-ietf-snac-simple-06.txt |
|
2024-11-04
|
06 | Jonathan Hui | New version accepted (logged-in submitter: Jonathan Hui) |
|
2024-11-04
|
06 | Jonathan Hui | Uploaded new revision |
|
2024-11-03
|
05 | Darren Dukes | Added to session: IETF-121: snac Mon-1300 |
|
2024-07-08
|
05 | Ted Lemon | New version available: draft-ietf-snac-simple-05.txt |
|
2024-07-08
|
05 | Ted Lemon | New version accepted (logged-in submitter: Ted Lemon) |
|
2024-07-08
|
05 | Ted Lemon | Uploaded new revision |
|
2024-03-04
|
04 | Jonathan Hui | New version available: draft-ietf-snac-simple-04.txt |
|
2024-03-04
|
04 | (System) | New version approved |
|
2024-03-04
|
04 | (System) | Request for posting confirmation emailed to previous authors: Jonathan Hui , Ted Lemon |
|
2024-03-04
|
04 | Jonathan Hui | Uploaded new revision |
|
2024-01-30
|
03 | Jonathan Hui | New version available: draft-ietf-snac-simple-03.txt |
|
2024-01-30
|
03 | Jonathan Hui | New version accepted (logged-in submitter: Jonathan Hui) |
|
2024-01-30
|
03 | Jonathan Hui | Uploaded new revision |
|
2024-01-29
|
02 | (System) | Document has expired |
|
2023-07-28
|
02 | Ted Lemon | New version available: draft-ietf-snac-simple-02.txt |
|
2023-07-28
|
02 | Ted Lemon | New version accepted (logged-in submitter: Ted Lemon) |
|
2023-07-28
|
02 | Ted Lemon | Uploaded new revision |
|
2023-03-08
|
01 | Jonathan Hui | New version available: draft-ietf-snac-simple-01.txt |
|
2023-03-08
|
01 | Ted Lemon | New version accepted (logged-in submitter: Ted Lemon) |
|
2023-03-08
|
01 | Ted Lemon | Uploaded new revision |
|
2023-02-13
|
00 | Marc Blanchet | This document now replaces draft-lemon-stub-networks instead of None |
|
2023-02-13
|
00 | Ted Lemon | New version available: draft-ietf-snac-simple-00.txt |
|
2023-02-13
|
00 | Marc Blanchet | WG -00 approved |
|
2023-02-13
|
00 | Ted Lemon | Set submitter to "Ted Lemon ", replaces to draft-lemon-stub-networks and sent approval email to group chairs: snac-chairs@ietf.org |
|
2023-02-13
|
00 | Ted Lemon | Uploaded new revision |