Skip to main content

Shepherd writeup
draft-ietf-taps-interface

# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.

Note that some numbered items contain multiple related questions; please be sure
to answer all of them.

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
   few individuals, with others being silent, or did it reach broad agreement?

This document reached broad agreement, with contributions from most active WG
members.

2. Was there controversy about particular points, or were there decisions where
   the consensus was particularly rough?

No.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
   so, please summarize the areas of conflict in separate email messages to the
   responsible Area Director. (It should be in a separate email because this
   questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
   the document? Have a significant number of potential implementers indicated
   plans to implement? Are any existing implementations reported somewhere,
   either in the document itself (as [RFC 7942][3] recommends) or elsewhere
   (where)?

This document specifies and abstract API for the Transport Services reference
architecture described in the -arch draft; the proposed API is based on
experience gained in one widely deployed production implementation and two open
implementations deployed for research purposes, as listed in Appendix C of the
-implementation draft.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
   IETF working groups or external organizations, and would it therefore benefit
   from their review? Have those reviews occurred? If yes, describe which
   reviews took place.

This draft has benefited from broad TSV area review within the WG itself, and
has had secdir and artart early review.

6. Describe how the document meets any required formal expert review criteria,
   such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

No formal review necessary as no MIB models, YANG models, media types, or URI
types etc. are used in the document.

7. If the document contains a YANG module, has the final version of the module
   been checked with any of the [recommended validation tools][4] for syntax and
   formatting validation? If there are any resulting errors or warnings, what is
   the justification for not fixing them at this time? Does the YANG module
   comply with the Network Management Datastore Architecture (NMDA) as specified
   in [RFC 8342][5]?

It does not contain a YANG module.

8. Describe reviews and automated checks performed to validate sections of the
   final version of the document written in a formal language, such as XML code,
   BNF rules, MIB definitions, CBOR's CDDL, etc.

No sections of the document are written in a formal language.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
   document is needed, clearly written, complete, correctly designed, and ready
   to be handed off to the responsible Area Director?

Yes.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

The document has undergone both artart and secdir early review and has seen
broad review overall to also receive comments for many of the int area topics
(esp. v6). All identified issues have been resolved.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed standard. The requested type is consistent with the milestones for the
working group and correctly reflected in the Intended RFC status field in the
Datatracker. It is the proper type as the abstract API is based on experience
from multiple implementations and intended to be used by multiple applications
over different realizations of the API.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

Yes; no IPR issues are known.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes, the authors have all shown their willingness to be listed as such.

The draft has 8 authors and editors. The wg believes there is a well-argued
case for an exception to the 5 author rule.

First: The TAPS work on the core API draft has been a 7-year journey. It forms
the first IETF transport API, something not previously published by the IETF.
An integrated team-based approach was recognized as important from early in the
document development and was discussed a number of times. The resulting team
drew from several previous projects, important initial contributions from two
EU projects (NEAT,MAMI), independent work at TU Berlin and Glasgow and
independent work at Apple, and a small number of others. Each author continues
to play a key part in shaping the way the final document is structured, while
bringing necessarily expertise across a wide area of topics (see github
activity) to draw expertise on a wide range of subjects. Things have evolved
many times, but this was essentially a team effort - not an editorial process
to draw together contributions.

Second, the topics span a very wide set of expertise - even for the IETF, and
rather than make many documents, the wg purposely focused on three closely
linked documents to cover: Understanding of applications use of transport;
Architectural design; Privacy, Security and Policy in the stack; Trends in
modern API and variations between programming languages, and use of callback,
events, etc.; Detailed understanding of differences between the IETF
transports; Understanding of STUN/ICE and Rendezvous; Understanding of NAT,
details of using of IPv4 and IPv6, etc. The author lists for the other two core
documents have been trimmed down to 5 authors, leaving a larger number of
authors only for the API draft.

Third, as the document passes through IETF review, IESG review and RFC-Ed the
present authors have a commitment and style of working that is effective and
ensures that details are not overlooked. This close working may not be typical
of the IETF process, and likely is because of the nature of these specific
specifications, motivating a longer author list.

Overall, the draft represents a major investment by the entire author team.
Normally the underpinning research contribution can be published in Journals,
etc. However, in this case, people have been actively working on refining the
spec for several years after their research to bring a consistent and new type
of API to the IETF, and the final outcome is this spec. For the academic
contributors, this contribution is only recognized by their Universities when
they are authors.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

There are 2 instances of lines with non-ascii characters and a few lines that
are too long and may need editing.

The document has a "Security and Privacy Considerations" Section. According to
the idnits tool these should be two separate sections. The authors decided to
leave this as it is for now and let the ADs decide about this matter.

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

No.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

No non-IETF normative references.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

No.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

No, the companion drafts will be submitted and published together.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

This document has no actions for IANA, which is appropriate.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No new IANA registries.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://trac.ietf.org/trac/ops/wiki/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://trac.ietf.org/trac/iesg/wiki/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]:
https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
Back