Early Review of draft-ietf-avtcore-rtp-payload-registry-02
review-ietf-avtcore-rtp-payload-registry-02-genart-early-davies-2024-09-19-00
| Request | Review of | draft-ietf-avtcore-rtp-payload-registry |
|---|---|---|
| Requested revision | No specific revision (document currently at 05) | |
| Type | Early Review | |
| Team | General Area Review Team (Gen-ART) (genart) | |
| Deadline | 2024-09-30 | |
| Requested | 2024-08-27 | |
| Requested by | Dr. Bernard D. Aboba | |
| Authors | Magnus Westerlund | |
| I-D last updated | 2025-03-18 (Latest revision 2024-10-18) | |
| Completed reviews |
Genart Early review of -02
by Elwyn B. Davies
(diff)
Secdir IETF Last Call review of -03 by Wes Hardaker (diff) |
|
| Comments |
Document is straightforward and non-technical, so don't need review by technical directorates. |
|
| Assignment | Reviewer | Elwyn B. Davies |
| State | Completed | |
| Request | Early review on draft-ietf-avtcore-rtp-payload-registry by General Area Review Team (Gen-ART) Assigned | |
| Posted at | https://mailarchive.ietf.org/arch/msg/gen-art/oor5NLltTMqdGCbLuB-G5raIs_o | |
| Reviewed revision | 02 (document currently at 05) | |
| Result | Ready w/nits | |
| Completed | 2024-09-19 |
review-ietf-avtcore-rtp-payload-registry-02-genart-early-davies-2024-09-19-00
Early review requested from the General Area Review team ======================================================== Summary: The document covers the situation (cock up!) appropriately. It is essentially ready. I have suggested that some additional modification of the note in the IANA registry being shut down would be helpful. There are also half a dozen editorial nits. Minor Suggestion The IANA Registry affected by this document (RTP Payload Format Media Types) references RFC 4855 and claims that it contains registration procedures and a registration template. This document correctly asserts that this is untrue. Perhaps this document should additionally ask IANA to modify the reference to [RFC4855], [RFC-TBD1] and replace the second para of the note as follows: OLD: Registration procedures and a registration template can be found in [RFC4855]. NEW: It was previously stated that registration procedures and a registration template can be found in [RFC4855]. This is not actually the case and [RFC4855] has been updated by [RFC-TBD1]. END This would be followed by the the text in this document starting "This registry has been closed..." Editorial Nits Abstract, s1: Specifications not being sentient beings (probably).... s/to register themselves/ to specify registration of the format/ Abstract: s/"RTP Payload Formats Media Types"./"RTP Payload Formats Media Types" created by RFC 8088./ (which will suppress IDNITS complaints about not seeing RFC 8988 in the abstract/) s1, para 1: s/RTP payload formats/RTP payload formats created according to [RFC8088]/ s1, para 2: s/various signalling usage/its various signalling usages/ s3, para 1: s/mandates/mandates in its IANA Considerations (Section 7.4)/ s4, para 2 (just after Table 1): s/add the following to the note to the registry:/add the following note to the registry:/