Last Call Review of draft-ietf-fecframe-ldpc-02

Request Review of draft-ietf-fecframe-ldpc
Requested rev. no specific revision (document currently at 04)
Type Last Call Review
Team General Area Review Team (Gen-ART) (genart)
Deadline 2012-10-01
Requested 2012-09-20
Authors Vincent Roca, Mathieu Cunche, Jerome Lacan
Draft last updated 2012-10-01
Completed reviews Genart Last Call review of -02 by Meral Shirazipour (diff)
Genart Telechat review of -04 by Meral Shirazipour
Secdir Last Call review of -?? by Brian Weis
Assignment Reviewer Meral Shirazipour 
State Completed
Review review-ietf-fecframe-ldpc-02-genart-lc-shirazipour-2012-10-01
Reviewed rev. 02 (document currently at 04)
Review result Ready with Nits
Review completed: 2012-10-01


I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <> .

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-fecframe-ldpc-02
Reviewer: Meral Shirazipour
Review Date: 2012-10-01
IETF LC End Date: 2012-10-01
IESG Telechat date: NA

This draft is almost ready for publication as a standard track RFC, but I have some comments.

Nits/editorial comments:
[Page 3], Section 1, "ALC [RFC5775]", please spell out ALC: "Asynchronous Layered Coding (ALC)"

[Page 3], Section 1, "NORM [RFC5740]", please spell out NORM: "NACK-Oriented Reliable Multicast (NORM)"

[Page 4], line 3, ALU is first used, please spell out: "Application Data Unit (ADU)", or move section "3.3 Abbreviations" to the beginning.

[Page 4], Section "3.1.  Definitions", after the ":" for all definitions, please start with capital letters or with lower case (for consistency please choose one)

[Page 5], for "ADU Block", it would clearer to have Flow ID, Length and Padding fields in parenthesis next to F[], L[], and Pad[] respectively.

[Page 5], after "FEC Framework Configuration Information" please add "(FFCI)".

[Page 5], section 4.1, "G MUST be equal..", please define G in section "3.2.  Notations".

[Page 9], last sentence, "Each ADUI contributes to exactly one source symbol to the source block.", it is clearer to say "...of the source block."

[Page 15], Section 6.1.1, "(e.g., before versus after FEC protection, and within the end-system versus in a middlebox)", please rephrase if possible, this is not very clear.

[Page 19], reference [SIMPLE_RS] is now at version 03.

[Page 19], reference [RFC5053]: title is missing "for Object Delivery"

-Overall for clarity, please adapt one method for spelling out acronyms (either in one section in intro, or throughout the text as they are first used; but not both).
-Overall for clarity, some line feed would be useful in section 5.  

Best Regards,

Meral Shirazipour
Ericsson Research