Skip to main content

Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)
RFC 8747

Revision differences

Document history

Date By Action
2026-05-20
(System) Changed metadata: changed keywords to '['CBOR Web Token', 'CWT', 'Proof-of-Possession', 'Holder-of-Key']' from '[]'
2026-05-20
(System) Metadata update from RFC Editor
2026-05-20
(System) Changed author "H. Tschofenig": changed name from "Hannes Tschofenig" to "H. Tschofenig", cleared country (was "Austria"), changed order from "4" to "5"
2026-05-20
(System) Changed author "S. Erdtman": changed name from "Samuel Erdtman" to "S. Erdtman", changed order from "3" to "4"
2026-05-20
(System) Changed author "G. Selander": changed name from "Göran Selander" to "G. Selander", cleared country (was "Sweden"), changed order from "2" to "3"
2026-05-20
(System)
Changed author "L. Seitz": changed name from "Ludwig Seitz" to "L. Seitz", changed affiliation from "RISE SICS" to "Combitech", cleared country (was "Sweden"), changed order …
Changed author "L. Seitz": changed name from "Ludwig Seitz" to "L. Seitz", changed affiliation from "RISE SICS" to "Combitech", cleared country (was "Sweden"), changed order from "1" to "2"
2026-05-20
(System) Changed author "M. Jones": changed name from "Michael Jones" to "M. Jones", changed order from "0" to "1"
2026-05-20
(System) Metadata update from RFC Editor
2021-03-29
Francesca Palombini Closed request for Last Call review by ARTART with state 'Overtaken by Events'
2021-02-03
Suhas Nandakumar Assignment of request for Last Call review by ARTART to Peter Saint-Andre was marked no-response
2020-03-10
(System) IANA registries were updated to include RFC8747
2020-03-09
(System)
Received changes through RFC Editor sync (created alias RFC 8747, changed abstract to 'This specification describes how to declare in a CBOR Web Token …
Received changes through RFC Editor sync (created alias RFC 8747, changed abstract to 'This specification describes how to declare in a CBOR Web Token (CWT) (which is defined by RFC 8392) that the presenter of the CWT possesses a particular proof-of-possession key.  Being able to prove possession of a key is also sometimes described as being the holder-of-key.  This specification provides equivalent functionality to "Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)" (RFC 7800) but using Concise Binary Object Representation (CBOR) and CWTs rather than JavaScript Object Notation (JSON) and JSON Web Tokens (JWTs).', changed pages to 14, changed standardization level to Proposed Standard, changed state to RFC, added RFC published event at 2020-03-09, changed IESG state to RFC Published)
2020-03-09
(System) RFC published