## **Document History**
1. Does the working group (WG) consensus represent the strong concurrence of a
few individuals, with others being silent, or did it reach broad agreement?
I would say weak consensus. The idea is straightforward and simple, Aaron is an
expert at RFC-writing, and Let’s Encrypt already has deployment experience, so
I’m not surprised at the low level of discussion. The few respondents were
strongly in favour.
2. Was there controversy about particular points, or were there decisions where
the consensus was particularly rough?
No.
3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
so, please summarize the areas of conflict in separate email messages to the
responsible Area Director. (It should be in a separate email because this
questionnaire is publicly available.)
No
4. For protocol documents, are there existing implementations of the contents of
the document? Have a significant number of potential implementers indicated
plans to implement? Are any existing implementations reported somewhere,
either in the document itself (as [RFC
7942](https://datatracker.ietf.org/doc/rfc7942/) recommends) or elsewhere
(where)?
Let’s Encrypt.
## **Additional Reviews**
5. Do the contents of this document closely interact with technologies in other
IETF working groups or external organizations, and would it therefore
benefit from their review? Have those reviews occurred? If yes, describe
which reviews took place.
No.
6. Describe how the document meets any required formal expert review criteria,
such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.
No formal models. ACME JSON blobs, which seem fine.
7. If the document contains a YANG module, has the final version of the module
been checked with any of the [recommended validation
tools](https://wiki.ietf.org/group/ops/yang-review-tools) for syntax and
formatting validation? If there are any resulting errors or warnings, what
is the justification for not fixing them at this time? Does the YANG module
comply with the Network Management Datastore Architecture (NMDA) as
specified in [RFC 8342](https://datatracker.ietf.org/doc/rfc8342/)?
None
8. Describe reviews and automated checks performed to validate sections of the
final version of the document written in a formal language, such as XML
code, BNF rules, MIB definitions, CBOR's CDDL, etc.
None
## **Document Shepherd Checks**
9. Based on the shepherd's review of the document, is it their opinion that this
document is needed, clearly written, complete, correctly designed, and ready
to be handed off to the responsible Area Director?
Yes.
10. Several IETF Areas have assembled [lists of common issues that
their](https://wiki.ietf.org/group/iesg/ExpertTopics)
[reviewers encounter](https://wiki.ietf.org/group/iesg/ExpertTopics). For
which areas have such issues been identified and addressed? For which does
this still need to happen in subsequent reviews?
Not carefully reviewed, but no open issues that I know about.
11. What type of RFC publication is being requested on the IETF stream
([Best](https://www.rfc-editor.org/rfc/rfc2026.html#section-5)
[Current Practice](https://www.rfc-editor.org/rfc/rfc2026.html#section-5),
[Proposed Standard, Internet
Standard](https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1),
[Informational, Experimental or
Historic](https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2))? Why
is this the proper type of RFC? Do all Datatracker state attributes
correctly reflect this intent?
PS
12. Have reasonable efforts been made to remind all authors of the intellectual
property rights (IPR) disclosure obligations described in [BCP
79](https://datatracker.ietf.org/doc/bcp79/)? To the best of your
knowledge, have all required disclosures been filed? If not, explain why.
If yes, summarize any relevant discussion, including links to
publicly-available messages when applicable.
Yes.
13. Has each author, editor, and contributor shown their willingness to be
listed as such? If the total number of authors and editors on the front
page is greater than five, please provide a justification.
Yes.
14. Document any remaining I-D nits in this document. Simply running the
[idnits](https://www.ietf.org/tools/idnits/)
[tool](https://www.ietf.org/tools/idnits/) is not enough; please review
the ["Content Guidelines"
on](https://authors.ietf.org/en/content-guidelines-overview)
[authors.ietf.org](https://authors.ietf.org/en/content-guidelines-overview).
(Also note that the current idnits tool generates some incorrect warnings;
a rewrite is underway.)
One idnit about referencing BCP14 instead of RFC2119. Otherwise clean.
15. Should any informative references be normative or vice-versa? See the
[IESG](https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/)
[Statement on Normative and Informative
References](https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/).
RFC8555 (ACME) is the only real reference. Good.
16. List any normative references that are not freely available to anyone. Did
the community have sufficient access to review any such normative
references?
None
17. Are there any normative downward references (see [RFC
3967](https://datatracker.ietf.org/doc/rfc3967/) and
[BCP](https://www.rfc-editor.org/info/bcp97)
[97](https://www.rfc-editor.org/info/bcp97)) that are not already listed
in the [DOWNREF registry](https://datatracker.ietf.org/doc/downref/)? If
so, list them.
None; all published RFCS.
18. Are there normative references to documents that are not ready to be
submitted to the IESG for publication or are otherwise in an unclear state?
If so, what is the plan for their completion?
None; all published RFCS.
19. Will publication of this document change the status of any existing RFCs? If
so, does the Datatracker metadata correctly reflect this and are those RFCs
listed on the title page, in the abstract, and discussed in the
introduction? If not, explain why and point to the part of the document
where the relationship of this document to these other RFCs is discussed.
No
20. Describe the document shepherd's review of the IANA considerations section,
especially with regard to its consistency with the body of the document.
Confirm that all aspects of the document requiring IANA assignments are
associated with the appropriate reservations in IANA registries. Confirm
that any referenced IANA registries have been clearly identified. Confirm
that each newly created IANA registry specifies its initial contents,
allocations procedures, and a reasonable name (see [RFC
8126](https://datatracker.ietf.org/doc/rfc8126/)).
Fine.
21. List any new IANA registries that require Designated Expert Review for
future allocations. Are the instructions to the Designated Expert clear?
Please include suggestions of designated experts, if appropriate.
No new registries