# Document Shepherd Write-Up for Group Documents: draft-ietf-cellar-codec-18
(updated after AD Evaluation of -16)
*This version is dated 4 July 2022.*
## Document History
1. Does the working group (WG) consensus represent the strong concurrence of a
few individuals, with others being silent, or did it reach broad agreement?
The WG is small (6-8 active participants), and the authors are the most active
contributors, but the entire active working group was involved in reaching
consensus for this document.
2. Was there controversy about particular points, or were there decisions where
the consensus was particularly rough?
No. This working group is quite calm, and work on draft-ietf-cellar-codec was
no exception.
3. Has anyone threatened an appeal or otherwise indicated extreme discontent?
No.
4. For protocol documents, are there existing implementations of the contents of
the document?
Yes. Notable implementations include vlc, ffmpeg, mkvtoolnix, mediainfo.
## Additional Reviews
5. Do the contents of this document closely interact with technologies in other
IETF working groups or external organizations, and would it therefore benefit
from their review? Have those reviews occurred? If yes, describe which
reviews took place.
Pretty much all the relevant people participate in this IETF WG.
6. Describe how the document meets any required formal expert review criteria,
such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.
The document does not contain any MIB, YANG module, new media type, or URI type.
7. If the document contains a YANG module, has the final version of the module
been checked with any of the recommended validation tools for syntax and
formatting validation? If there are any resulting errors or warnings,
what is
the justification for not fixing them at this time? Does the YANG
module comply with the Network Management Datastore Architecture
(NMDA) as specified
in RFC 8342?
This document does not contain any YANG modules.
8. Describe reviews and automated checks performed to validate sections of the
final version of the document written in a formal language, such as
XML code, BNF rules, MIB definitions, CBOR's CDDL, etc.
N/A
## Document Shepherd Checks
9. Based on the shepherd's review of the document, is it their opinion that this
document is needed, clearly written, complete, correctly designed,
and ready to be handed off to the responsible Area Director?
Yes. The document shepherd did a full top-to-bottom review of
draft-ietf-cellar-tags-14 which resulted in some significant technical changes,
but these changes involved
- tightening BCP 14 language
- providing context for SHOULDs that provide direction for new codec
descriptions while not invalidating existing descriptions - Matroska is
intended for use in archival media storage, so allowing conformant
implementations to process these codec descriptions is critical
- providing explanations for concepts that the working group understands very
well, but new implementers might not understand
10.Several IETF Areas have assembled lists of common issues that their
reviewers encounter. For which areas have such issues been identified
and addressed? For which does this still need to happen in subsequent
reviews?
No issues with common issues have been identified for this document - the
document content is application-level, and provides additional capabilities for
"Matroska Media Container Format Specification", RFC 9559, so no additional
issues with common issues are expected here.
11. What type of RFC publication is being requested on the IETF stream (Best
Current Practice, Proposed Standard, Internet Standard,
Informational, Experimental or Historic)? Why is this the proper type
of RFC? Do all Datatracker state attributes correctly reflect this
intent?
Proposed Standard is appropriate for this document. It provides additional
capabilities for "Matroska Media Container Format Specification", RFC 9559,
which is also published as Proposed Standard. It holds the same position as
"Matroska Media Container Tag Specifications", which is under IESG review as of
this writing, and is also requesting Proposed Standard.
12. Have reasonable efforts been made to remind all authors of the intellectual
property rights (IPR) disclosure obligations described in BCP 79? To
the best of your knowledge, have all required disclosures been
filed? If not, explain why. If yes, summarize any relevant
discussion, including links to publicly-available messages when
applicable.
Yes. Document authors have been surveyed. All have confirmed in email that no
disclosures have been made, and no disclosures are expected..
13. Has each author, editor, and contributor shown their willingness to be
listed as such? If the total number of authors and editors on the
front page is greater than five, please provide a justification.
Yes. Document authors have agreed.
14.Document any remaining I-D nits in this document. Simply running the idnits
tool is not enough; please review the "Content Guidelines" on
authors.ietf.org. (Also note that the current idnits tool generates
some incorrect warnings; a rewrite is underway.)
Beyond the Content Guidelines, idnits 2.17.1 identifies possible downrefs, but
please see below. :
Also - idnits 2.17.1 identifies [Events] as a possible missing reference, but
it's not - it's a string in Section 6.3, and appears twice.
15. Should any informative references be normative or vice-versa? See the IESG
Statement on Normative and Informative References.
The Normative references really are normative. The Informative references are
really informative. The normative/informative split was discussed with both
Orie and Charles.
—------------
16.List any normative references that are not freely available to anyone. Did
the community have sufficient access to review any such normative
references?
-- ref. 'ALAC' is freely available.
-- ref. 'ARIB.STD-B10' is freely available.
-- ref. 'ARIB.STD-B24' is freely available.
-- ref. 'ARIB.TR-B14' is freely available.
-- ref. 'ATSC.A52' is freely available.
-- ref. 'AV1' is freely available.
-- ref. 'AV1-ISOBMFF 'is freely available.
-- ref. 'BITMAPINFOHEADER' is freely available.
-- ref. 'Blu-ray.Part3' is freely available.
-- ref. 'Dirac' is freely available.
-- ref. 'DolbyVision-ISOBMFF' is freely available.
-- ref. 'ETSI.EN300-468' is freely available.
-- ref. 'ETSI.EN300-743' is freely available.
-- ref. 'ETSI.TS102-114' is freely available.
-- ref. 'ETSI.TS102-366' is freely available.
-- ref. 'IEEE.1857-10' is available for purchase from IEEE.
-- ref. 'IEEE.1857-3' is available for purchase from IEEE.
-- ref. 'IEEE.1857-4' is available for purchase from IEEE.
-- ref. 'IEEE.754' is available for purchase from IEEE.
-- ref. 'ISO.11172-3' is available at no charge to reviewers from ISO/IEC JTC
1/SC 29 through the IETF liaison, Stephan Wegner (stewe@stewe.org) on
request, and is available to implementers for purchase from ISO.
-- ref. 'ISO.13818-2' is available at no charge to reviewers from ISO/IEC JTC
1/SC 29 through the IETF liaison, Stephan Wegner (stewe@stewe.org) on
request, and is available to implementers for purchase from ISO.
-- ref. 'ISO.14496-15' is available at no charge to reviewers from ISO/IEC
JTC 1/SC 29 through the IETF liaison, Stephan Wegner (stewe@stewe.org) on
request, and is available to implementers for purchase from ISO.
-- ref. 'ISO.14496-2' is available at no charge to reviewers from ISO/IEC JTC
1/SC 29 through the IETF liaison, Stephan Wegner (stewe@stewe.org) on
request, and is available to implementers for purchase from ISO.
-- ref. 'ISO.14496-3' is available at no charge to reviewers from ISO/IEC JTC
1/SC 29 through the IETF liaison, Stephan Wegner (stewe@stewe.org) on
request, and is available to implementers for purchase from ISO.
-- ref. 'ITU-T.H.262' is freely available. This version of the specification
has been superseded, but is sufficient for Matroska implementations
containing archival media.
-- ref. 'JPEG' is freely available.
-- ref. 'JPEG2000' is available for purchase from ITU-T. This specification
was a normative reference for RFC 9828, published in 2025, so was considered
sufficiently available for implementers.
-- ref. 'OggKate' is freely available.
-- ref. 'QTFF' is freely available.
-- ref. 'SSA' is freely available.
-- ref. 'Theora' is freely available.
-- ref. 'TRUEHD' is freely available.
-- ref. 'TTA' is freely available.
-- ref. 'USF' is freely available.
-- ref. 'VobSub' is freely available.
-- ref. 'VORBIS' is freely available.
-- ref. 'VP9' is freely available.
-- ref. 'WAVEFORMATEX' is freely available.
-- ref. 'WAVPACK' is freely available.
-- ref. 'WebVTT' is freely available.
17. Are there any normative downward references (see RFC 3967 and BCP
97) that are not already listed in the DOWNREF registry? If so,
list them.
-- Possible downref: Non-RFC (?) normative reference: ref. 'ALAC'
-- Possible downref: Non-RFC (?) normative reference: ref. 'AV1'
-- Possible downref: Non-RFC (?) normative reference: ref. 'AV1-ISOBMFF'
-- Possible downref: Non-RFC (?) normative reference: ref.
'BITMAPINFOHEADER'
-- Possible downref: Non-RFC (?) normative reference: ref. 'Dirac'
-- Possible downref: Non-RFC (?) normative reference: ref.
'DolbyVision-ISOBMFF'
-- Possible downref: Non-RFC (?) normative reference: ref. 'IEEE.1857-10'
-- Possible downref: Non-RFC (?) normative reference: ref. 'IEEE.1857-3'
-- Possible downref: Non-RFC (?) normative reference: ref. 'IEEE.1857-4'
-- Possible downref: Non-RFC (?) normative reference: ref. 'IEEE.754'
-- Possible downref: Non-RFC (?) normative reference: ref. 'JPEG'
-- Possible downref: Non-RFC (?) normative reference: ref. 'JPEG2000'
-- Possible downref: Non-RFC (?) normative reference: ref. 'OggKate'
-- Possible downref: Non-RFC (?) normative reference: ref. 'QTFF'
** Downref: Normative reference to an Informational RFC: RFC 9043
** IESG: Please include this note in IETF Last Call announcements, and please
consider adding this (recent CELLAR) specification to the downref registry. **
-- Possible downref: Non-RFC (?) normative reference: ref. 'SSA'
-- Possible downref: Non-RFC (?) normative reference: ref. 'Theora'
-- Possible downref: Non-RFC (?) normative reference: ref. 'TRUEHD'
-- Possible downref: Non-RFC (?) normative reference: ref. 'TTA'
-- Possible downref: Non-RFC (?) normative reference: ref. 'USF'
-- Possible downref: Non-RFC (?) normative reference: ref. 'VobSub'
-- Possible downref: Non-RFC (?) normative reference: ref. 'VORBIS'
-- Possible downref: Non-RFC (?) normative reference: ref. 'VP9'
-- Possible downref: Non-RFC (?) normative reference: ref. 'WAVEFORMATEX'
-- Possible downref: Non-RFC (?) normative reference: ref. 'WAVPACK'
-- Possible downref: Non-RFC (?) normative reference: ref. 'WebVTT'
18. Are there normative references to documents that are not ready to be
submitted to the IESG for publication or are otherwise in an unclear
state? If so, what is the plan for their completion?
No.
19. Will publication of this document change the status of any existing RFCs?
No.
20. Describe the document shepherd's review of the IANA considerations section,
especially with regard to its consistency with the body of the
document.
The shepherd read it, and then suggested revisions which were incorporated.
21. List any new IANA registries that require Designated Expert Review for
future allocations. Are the instructions to the Designated Expert
clear? Please include suggestions of designated experts, if
appropriate.
This document creates two new registries called "Matroska Codec IDs Registry"
and "Matroska BlockAdditional Type IDs Registry".
Both new registries use the "Expert Review" policy [RFC8126].
[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]:
https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/