Skip to main content

Shepherd writeup
draft-ietf-idr-bgpls-inter-as-topology-ext

# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.

Note that some numbered items contain multiple related questions; please be sure
to answer all of them.

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
   few individuals, with others being silent, or did it reach broad agreement?

WG LC occurred on (4/20/2026 to 5/4/2026)
https://mailarchive.ietf.org/arch/msg/idr/oxgyiUFXg5RiMEt0KKzSonuUkqg/
8 individuals on the list plus five authors.
This amount of support is light to medium support for BGP-LS drafts.

Discussion also occurred after the SEC-DIR review
https://mailarchive.ietf.org/arch/msg/idr/g83LwkW6R88bhUNGMEUr43HtTCk/

post-Secdir issue: Most BGP-LS information comes from the IGP (OSPF or ISIS),
but some comes from local information (directly connected interfaces or static
routes) or BGP. Resolution: Section 8 describes this use case. Section 9
describes how a controller glues "half" links together. No one objected to this
addition on the list.

Closed WG LC:
https://mailarchive.ietf.org/arch/msg/idr/CwlPXLGxFxXX0g5iOQtMVmMhmTY/

Queried LSR post-WG review
One good review comment from Les Ginsberg.
Forwarded email to IDR:
https://mailarchive.ietf.org/arch/msg/idr/ZuPPjv7bfWzcLoRGkDctqexRwI8/
https://mailarchive.ietf.org/arch/msg/lsr/Tp0VZGjgIQueTV8amIuwngOqgSs/

Closed with final edits Area Director (Gunter)
Discussion involves: Gunter, Aijun (main author) and Ketan (co-authors), Les
(for lsr issue), and Sue Hares (shepherd)
https://mailarchive.ietf.org/arch/msg/idr/RBuNBBc9RgLVLi38zlOCwZSzfNQ/ Chair
and AD carefully negotiated changes to draft to address directorates without
going into "lsr"

Directorate reviews:
SEC-DIR: David Thaler - Has NITS on version 28
https://mailarchive.ietf.org/arch/msg/secdir/XEi_-Aji-AAKgN0CJggiAcmb3Xw
SEC-DIR: Reviewer: Akira Tsukamoto on -version 36.
Review result: Has Nits
https://mailarchive.ietf.org/arch/msg/idr/h7H9AF8kTytXIDqmhK3vW61AzEI/

OPS-DIR: Tina Tsou - on version 27 - Has NITs
RTG-DIR: (review 1): Michael Richardson on version 23
RTG-DIR: (review 2): Andrew Stone (6/5/2026) on version 32 - Has nits

Gen-DIR:
reviewer: Roni Even  on -35
Status: Ready with NITS
https://mailarchive.ietf.org/arch/msg/idr/8VZZr169cfYRDI4bH4t8N9UwIKY

IANA review:
REviewer: David Dong
status: Ready with IANA
https://mailarchive.ietf.org/arch/msg/idr/9jBOvvjFnwfVD6czUg1qw6RzETQ/

2. Was there controversy about particular points, or were there decisions where
   the consensus was particularly rough?

There was controversy over adding section 8, but the additional time on the
list resolved the issue.
https://mailarchive.ietf.org/arch/msg/idr/g83LwkW6R88bhUNGMEUr43HtTCk/ (see
above discussion).  Please note that this issue was also discussed on the IDR
list during AD Evaluation prior to IESG evaluation.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
   so, please summarize the areas of conflict in separate email messages to the
   responsible Area Director. (It should be in a separate email because this
   questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
   the document? Have a significant number of potential implementers indicated
   plans to implement? Are any existing implementations reported somewhere,
   either in the document itself (as [RFC 7942][3] recommends) or elsewhere
   (where)?

Two implementations:
H3C - based on H3C Comware,V700R001B75D112. Maturity level: Demo
Network controller R&D team(based on FRR, version 7.4) from China Telecom
See the implementation report at:
https://wiki.ietf.org/group/idr/implementations/draft-ietf-idr-bgpls-inter-as-topology-ext
Note: Section 8 has no implementations.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
   IETF working groups or external organizations, and would it therefore benefit
   from their review? Have those reviews occurred? If yes, describe which
   reviews took place.

LSR review comment during the IDR
https://mailarchive.ietf.org/arch/msg/idr/bcBVjMYsQy59uF_AUypf9FgjUcw/
Sent email to LSR asking for comments.

Directorate reviews:
SEC-DIR: David Thaler - Has NITS on version 28
https://mailarchive.ietf.org/arch/msg/secdir/XEi_-Aji-AAKgN0CJggiAcmb3Xw

OPS-DIR: Tina Tsou - on version 27
RTG-DIR: (review 1): Michael Richardson on version 23
RTG-DIR: (review 2): Andrew Stone (6/5/2026) on version 32

for other reviews (see above).

6. Describe how the document meets any required formal expert review criteria,
   such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

No formal review.

7. If the document contains a YANG module, has the final version of the module
   been checked with any of the [recommended validation tools][4] for syntax and
   formatting validation? If there are any resulting errors or warnings, what is
   the justification for not fixing them at this time? Does the YANG module
   comply with the Network Management Datastore Architecture (NMDA) as specified
   in [RFC 8342][5]?

No Yang module. Added to our growing list for BGP moidel.

8. Describe reviews and automated checks performed to validate sections of the
   final version of the document written in a formal language, such as XML code,
   BNF rules, MIB definitions, CBOR's CDDL, etc.

No formal validation on this draft.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
   document is needed, clearly written, complete, correctly designed, and ready
   to be handed off to the responsible Area Director?

Read Text. Discussed portions with Authors. Verify OK with LSR.
Please see lengthy discussions on list.  Negotiated text with author that
does not encroach on lsr view (specification) of BGP-LS data.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

This draft's review covers the BGP-LS features. While the use case in Chapter 8
may have been debated, the base function in (sections 5-7) was generally agreed
upon. All Discussions have occurred on list.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed standard.
  It defines a new type within BGP-LS [RFC9552] Network Layer Reachability
  Information (NLRI) for an
   inter-AS Link, as well as three new type-length-values (TLVs) for the
   BGP-LS inter-AS Link descriptor.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

See the WG LC which occurred on (4/20/2026 to 5/4/2026)
https://mailarchive.ietf.org/arch/msg/idr/oxgyiUFXg5RiMEt0KKzSonuUkqg/
All authors have sent an IPR statement to the IDR list.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Aijun Wang
https://mailarchive.ietf.org/arch/msg/idr/1d3eMpmF4oHtFBv1G9vGNzTieNM/

Huaimo Chen
https://mailarchive.ietf.org/arch/msg/idr/xCNxrSeh6RlKIKfwQp2k8ULIjIY/

Changwang Li
https://mailarchive.ietf.org/arch/msg/idr/zi88uCwnQhiWzL9btDEJ9yP5ek4/

Ketan Talaulikar
https://mailarchive.ietf.org/arch/msg/idr/TgAOjlQaSB_1LAhDIox4A9Q1Qyo/

Shunwan Zhang
https://mailarchive.ietf.org/arch/msg/idr/oFY-Byxnz31O3rbq-bVHr5BYtjc/

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

There is one incorrect warning:
"6 instances of lines with non-ascii characters in the document."

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].
No

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?
No.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

No.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

NO.
19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

No - Additions to BGP-LS [RFC9552]

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

An early allocation (FCFS) for this draft.
The values match the early allocation
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml
(in BGP-LS NLRI Types and BGP-LS NLRI and Attribute TLVs)

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

None.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]:
https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

Back