Skip to main content

References from draft-ietf-lamps-pq-composite-kem

These dependencies are extracted using heuristics looking for strings with particular prefixes. Notably, this means that references to I-Ds by title only are not reflected here. If it's really important, please inspect the documents' references sections directly.

Reference type help

Document Title Status Type Downref
draft-irtf-cfrg-hybrid-kems Hybrid PQ/T Key Encapsulation Mechanisms
References Referenced by
Informational informatively references
RFC 2104 HMAC: Keyed-Hashing for Message Authentication
References Referenced by
Informational normatively references Downref
RFC 2119 Key words for use in RFCs to Indicate Requirement Levels
References Referenced by
Best Current Practice normatively references
RFC 2986 PKCS #10: Certification Request Syntax Specification Version 1.7
References Referenced by
Informational informatively references
RFC 4211 Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)
References Referenced by
Proposed Standard informatively references
RFC 5280 Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile
References Referenced by
Proposed Standard normatively references
RFC 5480 Elliptic Curve Cryptography Subject Public Key Information
References Referenced by
Proposed Standard normatively references
RFC 5639 Elliptic Curve Cryptography (ECC) Brainpool Standard Curves and Curve Generation
References Referenced by
Informational informatively references
RFC 5652 Cryptographic Message Syntax (CMS)
References Referenced by
Internet Standard normatively references
RFC 5869 HMAC-based Extract-and-Expand Key Derivation Function (HKDF)
References Referenced by
Informational normatively references Downref
RFC 5912 New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)
References Referenced by
Informational normatively references Downref
RFC 5914 Trust Anchor Format
References Referenced by
Proposed Standard informatively references
RFC 5915 Elliptic Curve Private Key Structure
References Referenced by
Informational normatively references Downref
RFC 5958 Asymmetric Key Packages
References Referenced by
Proposed Standard normatively references
RFC 6090 Fundamental Elliptic Curve Cryptography Algorithms
References Referenced by
Informational informatively references
RFC 7292 PKCS #12: Personal Information Exchange Syntax v1.1
References Referenced by
Informational informatively references
RFC 7296 Internet Key Exchange Protocol Version 2 (IKEv2)
References Referenced by
Internet Standard informatively references
RFC 7748 Elliptic Curves for Security
References Referenced by
Informational normatively references Downref
RFC 8017 PKCS #1: RSA Cryptography Specifications Version 2.2
References Referenced by
Informational normatively references Downref
RFC 8174 Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words
References Referenced by
Best Current Practice normatively references
RFC 8410 Algorithm Identifiers for Ed25519, Ed448, X25519, and X448 for Use in the Internet X.509 Public Key Infrastructure
References Referenced by
Proposed Standard normatively references
RFC 8411 IANA Registration for the Cryptographic Algorithm Object Identifier Range
References Referenced by
Informational informatively references
RFC 8551 Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message Specification
References Referenced by
Proposed Standard informatively references
RFC 9180 Hybrid Public Key Encryption
References Referenced by
Informational informatively references
RFC 9629 Using Key Encapsulation Mechanism (KEM) Algorithms in the Cryptographic Message Syntax (CMS)
References Referenced by
Proposed Standard normatively references
RFC 9690 Use of the RSA-KEM Algorithm in the Cryptographic Message Syntax (CMS)
References Referenced by
Proposed Standard informatively references
RFC 9794 Terminology for Post-Quantum Traditional Hybrid Schemes
References Referenced by
Informational informatively references
RFC 9810 Internet X.509 Public Key Infrastructure -- Certificate Management Protocol (CMP)
References Referenced by
Proposed Standard informatively references
RFC 9846 The Transport Layer Security (TLS) Protocol Version 1.3
References Referenced by
Proposed Standard informatively references
RFC 9935 Internet X.509 Public Key Infrastructure - Algorithm Identifiers for the Module-Lattice-Based Key-Encapsulation Mechanism (ML-KEM)
References Referenced by
Proposed Standard informatively references
RFC 9958 Post-Quantum Cryptography for Engineers
References Referenced by
Informational informatively references