Skip to main content

Shepherd writeup
draft-ietf-tsvwg-sctp-zero-checksum

Shepherd Review - SCTP Zero Checksum
Document History
Was the document considered in any WG, and if so, why was it not adopted as a
work item there? The document was only considered in TSVWG.

Was there controversy about particular points that caused the WG to not adopt
the document? No.

Has anyone threatened an appeal or otherwise indicated extreme discontent? If
so, please summarize the areas of conflict in separate email messages to the
responsible Area Director. (It should be in a separate email because this
questionnaire is publicly available.) No.

For protocol documents, are there existing implementations of the contents of
the document? Have a significant number of potential implementers indicated
plans to implement? Are any existing implementations reported somewhere, either
in the document itself (as RFC 7942 recommends) or elsewhere (where)? There are
a number of implementations I'm aware of: FreeBSD SCTP kernel stack:
https://cgit.freebsd.org/src/tree/. This shares the SCTP code with (2) usrsctp
userland stack: https://github.com/sctplab/usrsct. This shares the SCTP code
with (1). Userland SCTP implementation of Google:
https://webrtc.googlesource.com/src/+/refs/heads/main/net/dcsctp. Please note
that this is an implementation for
https://www.ietf.org/archive/id/draft-ietf-tsvwg-sctp-zero-checksum-00.html.
Victor is working on updating the code to the latest draft version. Userland
SCTP implementation in go: https://github.com/pion/sctp/pull/284. There needs
to be some changes in the API. Support in Wireshark:
https://gitlab.com/wireshark/wireshark Support in the SCTP capable fork of
packetdrill: https://github.com/nplab/packetdrill Testcases for packetdrill:
https://github.com/tsvwg/zero-checksum/tree/main/zero-checksum-tests Michael is
working on adding support for zero checksum to the SCTP Test Tool:
https://github.com/nplab/stt. He's planning to port of the testcases in (7) to
stt to be able to use the tests for testing (4).

Additional Reviews
Do the contents of this document closely interact with technologies in other
IETF working groups or external organizations, and would it therefore benefit
from their review? Have those reviews occurred? If yes, describe which
reviews took place.
No.

Describe how the document meets any required formal expert review criteria,
such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.
There are no parameters that need review.

If the document contains a YANG module, has the final version of the module
been checked with any of the recommended validation tools for syntax and
formatting validation? If there are any resulting errors or warnings, what is
the justification for not fixing them at this time? Does the YANG module
comply with the Network Management Datastore Architecture (NMDA) as specified
in RFC 8342?
The document doesn't contain a YANG module.

Describe reviews and automated checks performed to validate sections of the
final version of the document written in a formal language, such as XML code,
BNF rules, MIB definitions, CBOR's CDDL, etc.
There are no parameters that need validation.

Document Shepherd Checks
Based on the shepherd's review of the document, is it their opinion that this
document is needed, clearly written, complete, correctly designed, and ready
to be handed off to the responsible Area Director?
Yes, the document is needed, clearly written, complete, correctly designed, and
ready to be handed off to the responsible Area Director. As in other SCTP
specifications in the RFC-series, this document includes a section with
considerations for the SCTP API.

Several IETF Areas have assembled lists of common issues that their
reviewers encounter. For which areas have such issues been identified
and addressed? For which does this still need to happen in subsequent
reviews?
No common issues were identified or need to be addressed.

What type of RFC publication is being requested on the IETF stream (Best
Current Practice, Proposed Standard, Internet Standard,
Informational, Experimental or Historic)? Why is this the proper type
of RFC? Do all Datatracker state attributes correctly reflect this intent?
The document is requested to be published as Proposed Standard. This is the
proper type for this document since it is generally stable, has resolved known
design choices, is believed to be well-understood, has received significant
community review, and appears to enjoy enough community interest to be
considered valuable. The datatracker state correctly reflects this request.

Have reasonable efforts been made to remind all authors of the intellectual
property rights (IPR) disclosure obligations described in BCP 79? To
the best of your knowledge, have all required disclosures been filed? If
not, explain why. If yes, summarize any relevant discussion, including links
to publicly-available messages when applicable.
The authors were emailed in February 2024, and every one of them confirmed that
they're not aware of any IPR.

Has each author, editor, and contributor shown their willingness to be
listed as such? If the total number of authors and editors on the front page
is greater than five, please provide a justification.
All authors have agreed to be listed as such.

Document any remaining I-D nits in this document. Simply running the idnits
tool is not enough; please review the "Content Guidelines" on
authors.ietf.org. (Also note that the current idnits tool generates
some incorrect warnings; a rewrite is underway.)
Document looks good.

Should any informative references be normative or vice-versa? See the IESG
Statement on Normative and Informative References.
Both informative and normative references look correct to me.

List any normative references that are not freely available to anyone. Did
the community have sufficient access to review any such normative
references?
All normative references are freely available.

Are there any normative downward references (see RFC 3967 and BCP
97) that are not already listed in the DOWNREF registry? If so,
list them.
The document doesn't have any downward references.

Are there normative references to documents that are not ready to be
submitted to the IESG for publication or are otherwise in an unclear state?
If so, what is the plan for their completion?
There are only normative references to already published RFCs.

Will publication of this document change the status of any existing RFCs? If
so, does the Datatracker metadata correctly reflect this and are those RFCs
listed on the title page, in the abstract, and discussed in the
introduction? If not, explain why and point to the part of the document
where the relationship of this document to these other RFCs is discussed.
The document doesn't change the status of any existing RFC.

Describe the document shepherd's review of the IANA considerations section,
especially with regard to its consistency with the body of the document.
Confirm that all aspects of the document requiring IANA assignments are
associated with the appropriate reservations in IANA registries. Confirm
that any referenced IANA registries have been clearly identified. Confirm
that each newly created IANA registry specifies its initial contents,
allocations procedures, and a reasonable name (see RFC 8126).
The document defines the Zero Checksum Acceptable Chunk Parameter. The
description of the parameter is consistent with the rest of the document. The
document establishes a new IANA registry for the "Error Correction Method",
including the initial contents. The name seems reasonable.

List any new IANA registries that require Designated Expert Review for
future allocations. Are the instructions to the Designated Expert clear?
Please include suggestions of designated experts, if appropriate.
Designated Expert Review is required for the newly established registry. The
instructions are clear. Suggestion for designated export: Michael Tüxen
Back