Skip to main content

Minutes IETF126: 6lo
minutes-126-6lo-01

Meeting Minutes IPv6 over Networks of Resource-constrained Nodes (6lo) WG
Date and time 2026-07-24 09:30
Title Minutes IETF126: 6lo
State Active
Other versions plain text
Last updated 2026-07-31

minutes-126-6lo-01
6lo Working Group Agenda — IETF 126

Date & Time: Friday, July 24, 2026 | 09:30–10:30 UTC (11:30–12:30 Local)

Chairs: Shwetha Bhandari, Carles Gomez

Delegate: Alexander Pevlov | AD: Éric Vyncke

Full Agenda: agenda-126-6lo
Administrative & Session Notes

    Minute Taker: Christian Amsüss, …
    Jabber Scribe:

Agenda Items

1. 6lo Chairs Introduction

    Presenter: Carles Gomez
    Time: 10 mins
    Materials: Slides
    Notes:
    Agenda bashing, blue sheets, document status updates…

CG does introductions.

(no changes to agenda)

EV: Laurent Toutain will become 3rd chair, thanks for accepting this.

2. Path-Aware Semantic Addressing (PASA) for Low Power and Lossy Networks

    Presenter: Luigi Iannone
    Time: 10 mins
    Draft: draft-ietf-6lo-path-aware-semantic-addressing
    Materials: Slides
    Notes:

LI presenting (see slides)

LI (p6): Questions to group

    Q&A / Discussion:

EV: Nothing bad about being experimental. Think it will go better in IETF LC /
IESG evaluation. WG needs to decide what to do.

CB: That’d also mean you need to describe the experiment.
EV: Usually.
CB: Is also an opportunity to indicate the way forward.

LT: Implementations?
LI: Internally, ongoing.

3. Generic Address Assignment Option for 6LoWPAN Neighbor Discovery

    Presenter: LI
    Draft: draft-ietf-6lo-nd-gaao
    Materials: Slides
    Notes:

LI presenting (see slides)

    Q&A / Discussion:

Lorenzo Colitti: Comparison w/ DHCPv6 doesn’t reflect improvements elsewhere.
“Inefficient” – comparison at the end shows it’s not much more efficient. Shows
that DHCPv6 with rapid commit is about as efficient as this, just about how
many links are traversed by messages. Could be overcome. Maybe “would have been
an alternative” and explain why not taken. LI: Efficiency depends on topology,
can clarify that more. On efficiency, reference is there. Suggestion on
concrete sentence appreciate. LC: Can we make those DHCP packets go where these
packets would go? LI: Multicast is the problem. We’re not excluding use of
DHCPv6. This is for 6LoWPAN deployments that use RFC6775 ND stack. On that
stack, use GAAO. No answer on what is better; depends on context. LC: Concrete
suggestion: Section at end discusses rapid commit. Section at start (“not
efficient”) is not updated (now is “almost as efficient”). Could say “could
have done X and not make DHCP packet go that far”, “but did not why”. LI:
Depending on topology. LC: I think not, maybe understanding …

AP moving discussion off stage.

ED: Working on 6LoWPAN mesh not using 6LoWPAN ND, there defined DHCPv6
operation based on unicast as an option. Configuration tells you DHCPv6 server.
But never was popular or deployed, b/c SLAAC already was there. Might be a good
input point. LI: Please send reference.

LI summarizing: Rework introduction, reference unicast DHCP, work in Eric’s
input.

AP: Who read latest revision? (no hands, but some on chat). Please read this.

4. Transmission of SCHC-Compressed Packets over IEEE 802.15.4 Networks

    Presenter: Carles Gomez
    Time: 10 mins
    Draft: draft-ietf-6lo-schc-15dot4
    Materials: Slides
    Notes:

CG presenting (see slides)

CG (p2): Expecting better compression exploiting additional knowledge.
CG (p5): Residue length is indicated indirectly.

    Q&A / Discussion:

EV (ad p5-7): Suggest normative table into main body; appendices are
non-normative by default.

AP (ad p5-7): Like approach of reducing number of bits.

AP (on p8-9): Your document is top priority for SCHC architecture (as a use
case). We did automated overview: most concepts can be mapped, those who can’t
will. Nothing would radically change, we’d be happy to work with you and Ana to
make this smooth. AP: On WGLC request, please bring this also to SCHC group.

AP: Maybe wiser to do terminology change before WGLC.

5. Transmission of IPv6 Packets over Short-Range OWC (Optical Wireless
Communications)

    Presenter: Younghwan Choi
    Time: 10 mins
    Draft: draft-ietf-6lo-owc
    Materials: Slides
    Notes:

YC presenting (see slides)

    Q&A / Discussion:

AP: Small and straightforward. We have shepherd. Some reviews from WG would be
nice. Good work.

6. RFC 8163 bis

    Presenter: Kerry Lynn
    Time: 5 mins
    Draft: draft-ietf-6lo-rfc8163-bis
    Materials: Slides
    Notes:

CG standing in for KL who could not join (see slides).

CG: Kerry has been updating his port.
CG (p3): Seeking help around SCHC.

    Q&A / Discussion:

AP: Excellent; send mail to SCHC list and say hi. There will be people
interested in jumping in.

LT: Can look for students at IMT Atlantique.

Chat

Christian Amsüss
14:59
Brief note (also mention on list, but now’s a good time to find people to chat
afterwards): ETSI took some of this group’s work into ETSI TS 103 874-3 (DECT
nr+ IPv6 profile); I’ll be working with this, including trying to understand
whether and how it’s really aligned with this group’s work, and what quirks
come up. Éric Vyncke 15:01 Thanks Christian for being the note taker (only on
the Q&A part) Alexander Pelov 15:01 for note taking :
https://notes.ietf.org/notes-ietf-126-6lo?both Carles Gomez 15:10 @Christian
Great, thanks for the information! RFC 8105 is a related 6lo document (IPv6
over DECT-ULE) Christian Amsüss 15:16 The new DECT nr+ ecosystem is almost
completely distinct from the prior work. (But the ETSI authors probably learned
from ETSI-ULA). Alexander Pelov 15:17 DECT nr+ looks quite promising. That’s an
interesting work, thanks Christian Carles Gomez 15:26 I read the latest one
Alexander Pelov 15:29 I think it would be really useful for the WG to read the
GAAO document and provide feedback on the wording / scope one or two reviews
would help the authors, in my opinion Éric Vyncke 15:43 Kerry is not online
Éric Vyncke 15:47 Not a WG document, so, it should rather be the author to send
this email (about getting SCHC assistance) Éric Vyncke 15:48 Oups my bad…