Document Shepherd Write-Up for Individual Documents
This version is dated 9 October 2026.
Thank you for serving as a document shepherd. One of the responsibilities of
the shepherd is to consider and answer the questions in this write-up to
provide helpful context to Last Call and Internet Engineering Steering Group
(IESG) reviewers. Your diligence in completing it is appreciated. The full
role of the shepherd is described in RFC 4858. At a minimum, you will need
the cooperation of the authors and editors to complete these checks.
Note that some numbered items contain multiple, related questions; please be
sure to answer all of them. It is highly appreciated to elaborate your answers
with more contextual information (as appropriate).
When an item does not apply to the document, please indicate "N/A".
NOTE: Please remove the above text when posting your write-up.
Document History & Implementations
-
Was the document considered in any WG, and if so, why was it not adopted as
a work item there? -
Was there controversy about particular points that caused the WG to not
adopt the document? -
If anyone threatened an appeal or otherwise indicated extreme discontent,
please summarize the areas of conflict in separate email messages to the
responsible Area Director.(NOTE: This should be in a separate email because this completed
questionnaire will be publicly available.) -
For protocol documents, indicate whether there are existing (or planned)
implementations and, if so, where they are listed. (RFC 7942
recommends they be reported in the document itself).
Additional Reviews
-
Have reviews for the document happened in other IETF WGs or external
organizations that you are aware of? If so, please provide references to
those reviews (if any). -
Describe the results of formal expert reviews (e.g., media type, URI) that
the document has undergone. Also, indicate whether any of the required
reviews are missing. -
If the document contains a YANG module, does the document’s Datatracker page
indicate that it has no errors and warnings?Has a YANGDOCTOR review been done on a recent version, indicating that it is
ready for publication?Does the document use the various templates in RFC 9907 (mainly, YANG
module, Security, and IANA templates)? -
Describe all reviews and automated checks performed to validate sections of
the document written in a formal language, such as XML, JSON code,
ABNF/RBNF/BNF rules, ASN.1, CBOR CDDL, etc. -
Does the document describe any protocol elements that are intended for human
interpretation and understanding? If so, does the document contain an
Internationalization Considerations section that describes how those
protocol elements are suitable for international use?
Document Shepherd Checks
-
Confirm that (in your opinion) this document is clearly written, complete,
technically accurate, correctly designed, and ready to be handed off to the
responsible Area Director. -
Several IETF Areas have assembled
lists of common issues that their reviewers encounter. Have such
issues been identified and addressed? For which areas are subsequent
reviews believed particularly important to happen? -
What type of RFC publication is being requested
(Best Current Practice, Proposed Standard, Internet Standard,
Informational, Experimental, or Historic)?Why is this the appropriate type of RFC?
-
Will publication of this document change the status of any existing
RFC(s)? If so, does the Datatracker status page for this document correctly
list those RFCs on the Title page, in the Abstract, and in the Introduction
of the document? -
If the document uses BCP 14 key words, does the document follow the
guidance in the
IESG Statement on Clarifying the Use of BCP 14 Key Words?
Is there any use of the BCP 14 key words that could be considered unclear
or inappropriate? Please flag those. -
Confirm that reasonable efforts have been made to remind the document
authors, editors, and contributors about the intellectual property rights
(IPR) disclosure obligations described in BCP 79.Please summarize any relevant discussion, including links to publicly
available messages when applicable. -
Confirm that each author, editor, and contributor has shown their
willingness to be listed as such. If the total number of authors and
editors on the front page is greater than five, please provide a
justification. -
Please list any remaining I-D nits in the version of the document you
reviewed that you feel are actual errors. Simply running the
idnits tool is not enough; please review the
"Content Guidelines" on authors.ietf.org. Idnits may display false
positives; please flag those and please briefly explain as needed.
(NOTE: No need to provide explanation for common false positives that are
self-explanatory such as the existence of a newer version of referenced
I-D)
Document References
-
List any informative references that should be normative or vice-versa?
If so, please list those.See the IESG Statement on Normative and Informative References.
-
List any normative references that are not freely available to anyone.
Does the community have sufficient access to review these references? -
List any normative downward references (see RFC 3967 and
BCP 97) that are not already listed in the DOWNREF registry. -
List any normative references to documents that are not ready to be
submitted to the IESG for publication or are otherwise in an unclear
state. For each, indicate the plan for their completion, if known.
IANA Considerations
-
Describe your review of the IANA considerations section, especially its
consistency with the body of the document.Confirm that all IANA requested actions are associated with the
appropriate reservations in IANA registries.Confirm that any referenced IANA registries have been clearly identified.
Confirm that each newly created IANA registry specifies its initial
contents, allocation procedures, and a reasonable name (see
RFC 8126). -
List any new IANA registries that require Designated Expert Review for
future allocations (Expert Review, Specification Required). If any, please
confirm that the document includes guidelines for Designated Experts. Are
these instructions to the Designated Expert clear?