draft-bcmj-green-power-and-energy-yang-07.txt:
xym 0.9.0:
Extracting 'ietf-power-and-energy'
Getting YANG file name from module name: ietf-power-and-energy.yang
Removed 2 empty lines
Extracting 'iana-ietf-power-and-energy'
Getting YANG file name from module name: iana-ietf-power-and-energy.yang
Removed 0 empty lines
iana-ietf-power-and-energy@2026-02-26.yang:
pyang 2.7.1: pyang --verbose --ietf -p {libs} {model}:
# module search path: a/www/ietf-ftp/yang/rfcmod/:/a/www/ietf-ftp/yang/draftmod/:/a/www/ietf-ftp/yang/ianamod/:/a/www/ietf-ftp/yang/catalogmod/:.:/usr/local/share/yang/modules
# read iana-ietf-power-and-energy@2026-02-26.yang (CL)
iana-ietf-power-and-energy@2026-02-26.yang:38: warning: RFC 8407: 3.1: The IETF Trust Copyright statement seems to be missing or is not correct (see pyang --ietf-help for details).
yanglint 2.1.30: yanglint --verbose -p {tmplib} -p {rfclib} -p {draftlib} -p {ianalib} -p {cataloglib} {model} -i:
libyang verb: Search directory string "/a/www/ietf-ftp/yang/rfcmod/" canonized to "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Search directory string "/a/www/ietf-ftp/yang/draftmod/" canonized to "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Search directory string "/a/www/ietf-ftp/yang/ianamod/" canonized to "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Search directory string "/a/www/ietf-ftp/yang/catalogmod/" canonized to "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "ietf-inet-types" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/ietf-inet-types@2025-12-22.yang" file.
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "ietf-yang-types" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/ietf-yang-types@2025-12-22.yang" file.
ietf-power-and-energy@2026-01-22.yang:
pyang 2.7.1: pyang --verbose --ietf -p {libs} {model}:
# module search path: a/www/ietf-ftp/yang/rfcmod/:/a/www/ietf-ftp/yang/draftmod/:/a/www/ietf-ftp/yang/ianamod/:/a/www/ietf-ftp/yang/catalogmod/:.:/usr/local/share/yang/modules
# read ietf-power-and-energy@2026-01-22.yang (CL)
# read /usr/local/share/yang/modules/ietf/ietf-hardware.yang
# read /a/www/ietf-ftp/yang/rfcmod/ietf-hardware@2018-03-13.yang
# read /usr/local/share/yang/modules/ietf/ietf-inet-types.yang
# read /a/www/ietf-ftp/yang/rfcmod/ietf-inet-types@2025-12-22.yang
# read /usr/local/share/yang/modules/ietf/ietf-yang-types.yang
# read /a/www/ietf-ftp/yang/rfcmod/ietf-yang-types@2025-12-22.yang
# read /usr/local/share/yang/modules/iana/iana-hardware.yang
# read /a/www/ietf-ftp/yang/rfcmod/iana-hardware@2018-03-13.yang
# read /a/www/ietf-ftp/yang/draftmod/iana-ietf-power-and-energy.yang
ietf-power-and-energy@2026-01-22.yang:43: warning: RFC 8407: 3.1: The IETF Trust Copyright statement seems to be missing or is not correct (see pyang --ietf-help for details).
ietf-power-and-energy@2026-01-22.yang:751: warning: the module seems to use RFC 2119 keywords, but the required text from RFC 8174 is not found or is not correct (see pyang --ietf-help for details).
yanglint 2.1.30: yanglint --verbose -p {tmplib} -p {rfclib} -p {draftlib} -p {ianalib} -p {cataloglib} {model} -i:
libyang verb: Search directory string "/a/www/ietf-ftp/yang/rfcmod/" canonized to "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Search directory string "/a/www/ietf-ftp/yang/draftmod/" canonized to "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Search directory string "/a/www/ietf-ftp/yang/ianamod/" canonized to "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Search directory string "/a/www/ietf-ftp/yang/catalogmod/" canonized to "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "ietf-inet-types" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "ietf-inet-types" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/ietf-inet-types@2025-12-22.yang" file.
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "ietf-yang-types" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "ietf-yang-types" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/ietf-yang-types@2025-12-22.yang" file.
libyang verb: Searching for "ietf-hardware" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "ietf-hardware" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "ietf-hardware" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "ietf-hardware" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "ietf-hardware" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/ietf-hardware@2018-03-13.yang" file.
libyang verb: Searching for "iana-hardware" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "iana-hardware" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "iana-hardware" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "iana-hardware" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "iana-hardware" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/iana-hardware@2018-03-13.yang" file.
libyang verb: Searching for "iana-ietf-power-and-energy" in "/a/www/ietf-ftp/yang/catalogmod".
libyang verb: Searching for "iana-ietf-power-and-energy" in "/a/www/ietf-ftp/yang/ianamod".
libyang verb: Searching for "iana-ietf-power-and-energy" in "/a/www/ietf-ftp/yang/draftmod".
libyang verb: Searching for "iana-ietf-power-and-energy" in "/a/www/ietf-ftp/yang/rfcmod".
libyang verb: Searching for "iana-ietf-power-and-energy" in "workspace".
libyang verb: Loading schema from "/a/www/ietf-ftp/yang/catalogmod/iana-ietf-power-and-energy@2026-02-26.yang" file.