Document History
1. Does the working group (WG) consensus represent the strong concurrence of a
few individuals, with others being silent, or did it reach broad agreement?
The working group reached agreement (please see the next response).
2. Was there controversy about particular points, or were there decisions where
the consensus was particularly rough?
There was no controversy. This document has followed a quicker process than
usual, due to its nature of being a short document fixing a mistake in RFC 8928
with the position of one bit (the C-flag) in EARO, which in addition was not
registered with IANA.
The draft received comments during adoption and WGLC, including the shepherd's
comments. The last version of the draft addresses all the comments.
3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
so, please summarize the areas of conflict in separate email messages to the
responsible Area Director. (It should be in a separate email because this
questionnaire is publicly available.)
No.
4. For protocol documents, are there existing implementations of the contents of
the document? Have a significant number of potential implementers indicated
plans to implement? Are any existing implementations reported somewhere,
either in the document itself (as RFC 7942 recommends) or elsewhere
(where)?
At this moment, neither the shepherd nor the authors are aware of existing
implementations or plans to implement the draft. Nevertheless, the draft is
required to fix a mistake in RFC 8928, as described earlier.
Additional Reviews
5. Do the contents of this document closely interact with technologies in other
IETF working groups or external organizations, and would it therefore benefit
from their review? Have those reviews occurred? If yes, describe which
reviews took place.
The draft fixes a mistake in an RFC that belongs to a suite of extensions and
optimizations of IPv6 Neighbor Discovery for 6LoWPAN. However, the fix itself
did not require further review from 6man.
6. Describe how the document meets any required formal expert review criteria,
such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.
Not applicable.
7. If the document contains a YANG module, has the final version of the module
been checked with any of the recommended validation tools for syntax and
formatting validation? If there are any resulting errors or warnings, what is
the justification for not fixing them at this time? Does the YANG module
comply with the Network Management Datastore Architecture (NMDA) as specified
in RFC 8342?
Not applicable.
8. Describe reviews and automated checks performed to validate sections of the
final version of the document written in a formal language, such as XML code,
BNF rules, MIB definitions, CBOR's CDDL, etc.
Not applicable.
Document Shepherd Checks
9. Based on the shepherd's review of the document, is it their opinion that this
document is needed, clearly written, complete, correctly designed, and ready
to be handed off to the responsible Area Director?
This document has been reviewed by the shepherd (the first version reviewed by
the shepherd being -01). The last revision (-03) aims to address WGLC comments
and addresses the shepherd's comments. The document is clearly needed to fix
the aforementioned mistake in RFC 8928 and, in the shepherd's opinion, the
document is ready to be handed off to the responsible Area Director.
10. Several IETF Areas have assembled lists of common issues that their
reviewers encounter. For which areas have such issues been identified
and addressed? For which does this still need to happen in subsequent
reviews?
This specification belongs to the Internet Area. No particular issues have been
identified, from the Internet Area or other areas.
11. What type of RFC publication is being requested on the IETF stream (Best
Current Practice, Proposed Standard, Internet Standard,
Informational, Experimental or Historic)? Why is this the proper type
of RFC? Do all Datatracker state attributes correctly reflect this intent?
The intended status of the document is 'standards track'. This intended status
is indicated in the document header and correctly reflected by Datatracker
state attributes. 'standards track' is the proper type of RFC for the document,
since it is motivated by the need to update RFC 8928, which is another
'standards track' document.
12. Have reasonable efforts been made to remind all authors of the intellectual
property rights (IPR) disclosure obligations described in BCP 79? To
the best of your knowledge, have all required disclosures been filed? If
not, explain why. If yes, summarize any relevant discussion, including links
to publicly-available messages when applicable.
Each author or contributor has confirmed that they are not aware of IPR that
would read on this document, as shown in the responses to this message:
https://mailarchive.ietf.org/arch/msg/6lo/Vag450iUkTxXN_v6je4sKjSW3gc
13. Has each author, editor, and contributor shown their willingness to be
listed as such? If the total number of authors and editors on the front page
is greater than five, please provide a justification.
Yes, each author has shown their willingness to be listed as such.
14. Document any remaining I-D nits in this document. Simply running the idnits
tool is not enough; please review the "Content Guidelines" on
authors.ietf.org. (Also note that the current idnits tool generates
some incorrect warnings; a rewrite is underway.)
The only nit appears to be the following idnits output:
"-(13): Line appears to be too long, but this could be caused by non-ascii
characters in UTF-8 encoding"
I suspect that the quotation marks in the Abstract produce the above idnits
output.
15. Should any informative references be normative or vice-versa? See the IESG
Statement on Normative and Informative References.
References are correctly classified into normative or informative.
16. List any normative references that are not freely available to anyone. Did
the community have sufficient access to review any such normative
references?
All normative references are freely available to anyone.
17. Are there any normative downward references (see RFC 3967 and BCP
97) that are not already listed in the DOWNREF registry? If so,
list them.
There would be, strictly speaking, a normative downward reference:
draft-ietf-6lo-prefix-registration (not listed in the DOWNREF registry).
However, that document (draft-ietf-6lo-prefix-registration) has already been
submitted to the IESG for publication, and its intended status is 'Standards
Track'.
18. Are there normative references to documents that are not ready to be
submitted to the IESG for publication or are otherwise in an unclear state?
If so, what is the plan for their completion?
The document mentioned in the previous answer,
draft-ietf-6lo-prefix-registration, has been submitted to the IESG for
publication. It is currently scheduled to be discussed in the IESG telechat on
2025-06-05.
19. Will publication of this document change the status of any existing RFCs? If
so, does the Datatracker metadata correctly reflect this and are those RFCs
listed on the title page, in the abstract, and discussed in the
introduction? If not, explain why and point to the part of the document
where the relationship of this document to these other RFCs is discussed.
This document updates RFC 8928. This is properly reflected on the title page,
the abstract and the introduction.
20. Describe the document shepherd's review of the IANA considerations section,
especially with regard to its consistency with the body of the document.
Confirm that all aspects of the document requiring IANA assignments are
associated with the appropriate reservations in IANA registries. Confirm
that any referenced IANA registries have been clearly identified. Confirm
that each newly created IANA registry specifies its initial contents,
allocations procedures, and a reasonable name (see RFC 8126).
This document requests IANA to register the C-flag as bit 1 of the "Address
Registration Option Flags" registry, which is part of the ICMPv6 parameters
registry:
https://www.iana.org/assignments/icmpv6-parameters/icmpv6-parameters.xhtml The
request is consistent with the current status of the mentioned registry, and
with the content of the document.
21. List any new IANA registries that require Designated Expert Review for
future allocations. Are the instructions to the Designated Expert clear?
Please include suggestions of designated experts, if appropriate.
This document does not request the creation of any new IANA registry.