Skip to main content

Shepherd writeup
draft-ietf-core-groupcomm-bis

# Document Shepherd Write-Up for Group Documents

*The revision of the template used here is dated 4 July 2022.*

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
   few individuals, with others being silent, or did it reach broad agreement?

This is a substantial document addressing a somewhat specialized topic
(multicast), so there is no surprise that there were only about four
responses (all positive) to the second WGLC, albeit with several
detailed reviews coming in earlier.

2. Was there controversy about particular points, or were there decisions where
   the consensus was particularly rough?

No.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
   so, please summarize the areas of conflict in separate email messages to the
   responsible Area Director. (It should be in a separate email because this
   questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
   the document? Have a significant number of potential implementers indicated
   plans to implement? Are any existing implementations reported somewhere,
   either in the document itself (as [RFC 7942][3] recommends) or elsewhere
   (where)?

Yes.  Multicast CoAP is sufficiently entrenched that we didn't do a
survey of existing implementations.  For these, the document provides
information that will aid in their further development; several
implementers have contributed reviews.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
   IETF working groups or external organizations, and would it therefore benefit
   from their review? Have those reviews occurred? If yes, describe which
   reviews took place.

The main technology outside of the CoRE WG this document interacts is
IP multicast.  As the document is based on extensive implementation
experience, we expect the usual directorate review to be sufficient.
(The document also interacts with LAKE via OSCORE; several main LAKE
contributors have reviewed, one is co-author.)

6. Describe how the document meets any required formal expert review criteria,
   such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

N/A

7. If the document contains a YANG module, has the final version of the module
   been checked with any of the [recommended validation tools][4] for syntax and
   formatting validation? If there are any resulting errors or warnings, what is
   the justification for not fixing them at this time? Does the YANG module
   comply with the Network Management Datastore Architecture (NMDA) as specified
   in [RFC 8342][5]?

N/A

8. Describe reviews and automated checks performed to validate sections of the
   final version of the document written in a formal language, such as XML code,
   BNF rules, MIB definitions, CBOR's CDDL, etc.

N/A

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
   document is needed, clearly written, complete, correctly designed, and ready
   to be handed off to the responsible Area Director?

Yes.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

The document interacts with such common issues mainly in the
applications (ART), Internet (INT) and transport/transfer (WIT) areas.
These issues have been a good part of the discussion in the WG and are
believed to be properly addressed.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed Standard, replacing RFC 7390 which was Experimental.
(Not all proposals in RFC 7390 are part of this draft.)

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

Yes; authors (including a previous co-author) have replied to the IPR
query that was issued with the WGLC.  No disclosures have been filed.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes.  (We reduced the number of co-authors to two in the step from -12
to -13.)

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

The idnits tool has several warnings about artwork being wide enough
to be outdented, which we believe do not need action.

There are two normative references to an Informational RFC: RFC 7967
and RFC 9053.  (see 15, 17.)

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

RFC 9053 is listed as a normative reference although only becomes
normative through its use in normative references of this document.
We believe listing it in the normative references could prevent
surprises by readers that do not follow through on all normative
references.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

(No such normative references.)

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.
Yes.
There are downreferences to:

* RFC 7967, which is an Independent Stream document that exercises an
  extension point of RFC 7252; the new option 258 (No-Response) has
  since turned out to be useful in controlling a potential avalanche
  of responses to a multicast request.  Its use is therefore suggested
  in the passages dealing with amplification attacks.

* draft-ietf-core-oscore-groupcomm, which should be processed in a
  cluster with this document.

* RFC 9053 (COSE algorithms), which is mostly used by
  draft-ietf-core-oscore-groupcomm but is listed as a normative
  reference here as well.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

(draft-ietf-core-oscore-groupcomm is expected to be submitted in close
temporal proximity to this document.)

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

This document obsoletes RFC 7390 (experimental RFC); it also updates RFC 7252
and RFC 7641. This is listed on the title page and further explained in
abstract and intro; Section 1.3 then goes into more details.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

This document has no actions for IANA.
(It suggests making use of a registry established by RFC 6690 in the
"Constrained RESTful Environments (CoRE) Parameters" registry group,
but these would be separate actions.)

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

This document has no actions for IANA.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]:
https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
Back