Key Transparency Architecture
draft-ietf-keytrans-architecture-10
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-14
|
10 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Donald Eastlake |
|
2026-10-12
|
10 | Peter Yee | Request for IETF Last Call review by GENART is assigned to Gyan Mishra |
|
2026-10-12
|
10 | Deb Cooley | Closed request for IETF Last Call review by SECDIR with state 'Withdrawn' |
|
2026-10-12
|
10 | Deb Cooley | Requested IETF Last Call review by SECDIR |
|
2026-10-12
|
10 | Deb Cooley | Requested IETF Last Call review by SECDIR |
|
2026-10-12
|
10 | Jiankang Yao | Request for IETF Last Call review by ARTART Completed: Almost Ready. Reviewer: Jiankang Yao. Sent review to list. |
|
2026-10-10
|
10 | Barry Leiba | Request for IETF Last Call review by ARTART is assigned to Jiankang Yao |
|
2026-10-10
|
10 | Gonzalo Salgueiro | Assignment of request for IETF Last Call review by ARTART to Gonzalo Salgueiro was rejected |
|
2026-10-10
|
10 | Barry Leiba | Request for IETF Last Call review by ARTART is assigned to Gonzalo Salgueiro |
|
2026-10-09
|
10 | Morgan Condie | IANA Review state changed to IANA - Review Needed |
|
2026-10-09
|
10 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-10-23): From: The IESG To: IETF-Announce CC: cfm@acm.org, debcooley1@gmail.com, draft-ietf-keytrans-architecture@ietf.org, keytrans-chairs@ietf.org, keytrans@ietf.org … The following Last Call announcement was sent out (ends 2026-10-23): From: The IESG To: IETF-Announce CC: cfm@acm.org, debcooley1@gmail.com, draft-ietf-keytrans-architecture@ietf.org, keytrans-chairs@ietf.org, keytrans@ietf.org Reply-To: last-call@ietf.org, keytrans@ietf.org Sender: Subject: Last Call: (Key Transparency Architecture) to Informational RFC The IESG has received a request from the Key Transparency WG (keytrans) to consider the following document: 'Key Transparency Architecture' as Informational RFC The IESG plans to make a decision on this document in the coming weeks, and solicits last-call comments. Please send substantive comments to the last-call@ietf.org mailing list, with keytrans@ietf.org copied, no later than 2026-10-23. Please retain the beginning of the Subject line to facilitate automated sorting. Abstract This document defines the terminology and interaction patterns involved in the deployment of Key Transparency in a general secure group messaging infrastructure, and specifies the security properties that the protocol provides. It also gives more general, non- prescriptive guidance on how to securely apply Key Transparency to a number of common applications. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-keytrans-architecture/ No IPR declarations have been submitted directly on this I-D. |
|
2026-10-09
|
10 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-10-09
|
10 | Deb Cooley | Last call was requested |
|
2026-10-09
|
10 | Deb Cooley | Ballot approval text was generated |
|
2026-10-09
|
10 | Deb Cooley | IESG state changed to Last Call Requested from AD Evaluation::AD Followup |
|
2026-10-09
|
10 | Deb Cooley | Last call announcement was generated |
|
2026-10-07
|
10 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-10-07
|
10 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-10-07
|
10 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-10.txt |
|
2026-10-07
|
10 | Brendan McMillion | New version approved |
|
2026-10-07
|
10 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2026-10-07
|
10 | Brendan McMillion | Uploaded new revision |
|
2026-09-28
|
09 | Deb Cooley | Changed consensus to Yes from Unknown |
|
2026-09-28
|
09 | Deb Cooley | AD comments here: https://mailarchive.ietf.org/arch/msg/keytrans/bjNImBi7FOPuDKUeAITiB8CuxxY/ |
|
2026-09-28
|
09 | (System) | Changed action holders to Brendan McMillion (IESG state changed) |
|
2026-09-28
|
09 | Deb Cooley | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2026-09-27
|
09 | Deb Cooley | Ballot writeup was changed |
|
2026-09-24
|
09 | Deb Cooley | IESG state changed to AD Evaluation from Publication Requested |
|
2026-09-24
|
09 | Deb Cooley | Ballot writeup was changed |
|
2026-07-19
|
09 | Prachi Jain | Added to session: IETF-126: keytrans Fri-0930 |
|
2026-07-09
|
09 | Prachi Jain | # Shepherd Review of draft-ietf-keytrans-architecture-09 6 July 2026 — Rev. 3 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence … # Shepherd Review of draft-ietf-keytrans-architecture-09 6 July 2026 — Rev. 3 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This architecture document has consensus, and has seen feedback and contributions, from a relatively small group of people who do research and/or engineering on key-transparency systems. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There have been no significant objections to the working group's process, the adoption of this document, or its substance as of the working group's last call. All feedback from the last call has been addressed. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? *Not applicable.* ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Key transparency is a free-standing building block of a user-level PKI. Although it draws on ideas from certificate transparency (RFC 6962) and makes use of verifiable random functions (RFC 9381), it does not have significant interdependencies with other technologies, standards, or working groups. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. *Not applicable.* 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? *Not applicable.* 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. *Not applicable.* ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? The "Security Considerations" section includes detailed discussion of security and privacy considerations, including its implications for operators under emerging privacy regulations. Indeed, much of the document exists to address the first several "common issues" within the Security Area: - Threat modeling - Trusted and untrusted parties - Terminology relating to security concepts - Matching threats to threat mitigation 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Informational. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. There are no such obligations known to the author as of 29 June 2026. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) There are two warnings still present in `-09`: > There is 1 instance of lines with non-ascii characters in the document. This is the name Velák in the citation for RFC 9381. > Outdated reference: A later version (-05) exists of draft-ietf-keytrans-protocol-04 This can be updated with the latest version of this informational reference immediately prior to publication. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. See #18. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? *Not applicable.* 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. No. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? The intended Informational RFC is the necessary foundation for `draft-ietf-keytrans-protocol` and clearly lays out its architectural needs and goals. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). *Not applicable.* 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. *Not applicable.* |
|
2026-07-09
|
09 | Prachi Jain | IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up |
|
2026-07-09
|
09 | Prachi Jain | IESG state changed to Publication Requested from I-D Exists |
|
2026-07-09
|
09 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-07-09
|
09 | Prachi Jain | Responsible AD changed to Deb Cooley |
|
2026-07-09
|
09 | Prachi Jain | Document is now in IESG state Publication Requested |
|
2026-07-09
|
09 | Prachi Jain | Tag Revised I-D Needed - Issue raised by WGLC cleared. |
|
2026-07-07
|
09 | Cory Myers | # Shepherd Review of draft-ietf-keytrans-architecture-09 6 July 2026 — Rev. 3 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence … # Shepherd Review of draft-ietf-keytrans-architecture-09 6 July 2026 — Rev. 3 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This architecture document has consensus, and has seen feedback and contributions, from a relatively small group of people who do research and/or engineering on key-transparency systems. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There have been no significant objections to the working group's process, the adoption of this document, or its substance as of the working group's last call. All feedback from the last call has been addressed. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? *Not applicable.* ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. Key transparency is a free-standing building block of a user-level PKI. Although it draws on ideas from certificate transparency (RFC 6962) and makes use of verifiable random functions (RFC 9381), it does not have significant interdependencies with other technologies, standards, or working groups. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. *Not applicable.* 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? *Not applicable.* 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. *Not applicable.* ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? The "Security Considerations" section includes detailed discussion of security and privacy considerations, including its implications for operators under emerging privacy regulations. Indeed, much of the document exists to address the first several "common issues" within the Security Area: - Threat modeling - Trusted and untrusted parties - Terminology relating to security concepts - Matching threats to threat mitigation 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Informational. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. There are no such obligations known to the author as of 29 June 2026. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) There are two warnings still present in `-09`: > There is 1 instance of lines with non-ascii characters in the document. This is the name Velák in the citation for RFC 9381. > Outdated reference: A later version (-05) exists of draft-ietf-keytrans-protocol-04 This can be updated with the latest version of this informational reference immediately prior to publication. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. See #18. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? *Not applicable.* 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. No. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? The intended Informational RFC is the necessary foundation for `draft-ietf-keytrans-protocol` and clearly lays out its architectural needs and goals. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). *Not applicable.* 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. *Not applicable.* |
|
2026-06-29
|
09 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-09.txt |
|
2026-06-29
|
09 | Brendan McMillion | New version approved |
|
2026-06-29
|
09 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2026-06-29
|
09 | Brendan McMillion | Uploaded new revision |
|
2026-06-29
|
09 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2026-06-29
|
09 | Brendan McMillion | Uploaded new revision |
|
2026-04-15
|
08 | Prachi Jain | Notification list changed to cfm@acm.org because the document shepherd was set |
|
2026-04-15
|
08 | Prachi Jain | Document shepherd changed to Cory Myers |
|
2026-04-12
|
08 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-08.txt |
|
2026-04-12
|
08 | Brendan McMillion | New version approved |
|
2026-04-12
|
08 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2026-04-12
|
08 | Brendan McMillion | Uploaded new revision |
|
2026-03-09
|
07 | Prachi Jain | Added to session: IETF-125: keytrans Wed-0330 |
|
2026-02-18
|
07 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-07.txt |
|
2026-02-18
|
07 | (System) | New version approved |
|
2026-02-18
|
07 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2026-02-18
|
07 | Brendan McMillion | Uploaded new revision |
|
2026-02-17
|
06 | Shivan Sahib | Tag Revised I-D Needed - Issue raised by WGLC set. |
|
2026-02-17
|
06 | Shivan Sahib | IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call |
|
2026-01-27
|
06 | Prachi Jain | IETF WG state changed to In WG Last Call from WG Document |
|
2026-01-21
|
06 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-06.txt |
|
2026-01-21
|
06 | (System) | New version approved |
|
2026-01-21
|
06 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2026-01-21
|
06 | Brendan McMillion | Uploaded new revision |
|
2025-10-27
|
05 | Prachi Jain | Added to session: IETF-124: keytrans Wed-2100 |
|
2025-10-19
|
05 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-05.txt |
|
2025-10-19
|
05 | (System) | New version approved |
|
2025-10-19
|
05 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2025-10-19
|
05 | Brendan McMillion | Uploaded new revision |
|
2025-07-11
|
04 | Prachi Jain | Added to session: IETF-123: keytrans Wed-1230 |
|
2025-07-06
|
04 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-04.txt |
|
2025-07-06
|
04 | Brendan McMillion | New version approved |
|
2025-07-06
|
04 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2025-07-06
|
04 | Brendan McMillion | Uploaded new revision |
|
2025-02-25
|
03 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-03.txt |
|
2025-02-25
|
03 | Brendan McMillion | New version approved |
|
2025-02-19
|
03 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2025-02-19
|
03 | Brendan McMillion | Uploaded new revision |
|
2024-08-26
|
02 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-02.txt |
|
2024-08-26
|
02 | (System) | New version approved |
|
2024-08-26
|
02 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2024-08-26
|
02 | Brendan McMillion | Uploaded new revision |
|
2024-07-17
|
01 | Prachi Jain | Added to session: IETF-120: keytrans Fri-2230 |
|
2024-03-17
|
01 | Prachi Jain | Added to session: IETF-119: keytrans Wed-0500 |
|
2024-03-04
|
01 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-01.txt |
|
2024-03-04
|
01 | Brendan McMillion | New version approved |
|
2024-03-04
|
01 | (System) | Request for posting confirmation emailed to previous authors: Brendan McMillion |
|
2024-03-04
|
01 | Brendan McMillion | Uploaded new revision |
|
2024-01-22
|
00 | Orie Steele | Changed document external resources from: None to: github_repo https://github.com/ietf-wg-keytrans/draft-arch |
|
2024-01-22
|
00 | Orie Steele | Intended Status changed to Informational from None |
|
2024-01-22
|
00 | Orie Steele | This document now replaces draft-mcmillion-keytrans-architecture instead of None |
|
2024-01-18
|
00 | Brendan McMillion | New version available: draft-ietf-keytrans-architecture-00.txt |
|
2024-01-18
|
00 | Shivan Sahib | WG -00 approved |
|
2024-01-18
|
00 | Brendan McMillion | Set submitter to "Brendan McMillion ", replaces to (none) and sent approval email to group chairs: keytrans-chairs@ietf.org |
|
2024-01-18
|
00 | Brendan McMillion | Uploaded new revision |