Composite ML-KEM for use in X.509 Public Key Infrastructure
draft-ietf-lamps-pq-composite-kem-23
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-28
|
23 | (System) | RPC status changed to Awaiting Editor Assignment from Awaiting Reference Checker, formatting |
|
2026-10-21
|
23 | (System) | IANA Action state changed to RFC-Ed-Ack from Waiting on RFC Editor |
|
2026-10-21
|
23 | (System) | IANA Action state changed to Waiting on RFC Editor from In Progress |
|
2026-10-21
|
23 | (System) | IANA Action state changed to In Progress from Waiting on Authors |
|
2026-10-20
|
23 | (System) | IANA Action state changed to Waiting on Authors from In Progress |
|
2026-10-14
|
23 | (System) | RPC status changed to Awaiting Reference Checker, formatting from blocked: Author Input Required |
|
2026-10-14
|
23 | (System) | RFC Editor state changed to In Progress from Blocked |
|
2026-10-14
|
23 | Jan Klaußner | New version available: draft-ietf-lamps-pq-composite-kem-23.txt |
|
2026-10-14
|
23 | (System) | New version approved |
|
2026-10-14
|
23 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-10-14
|
23 | Jan Klaußner | Uploaded new revision |
|
2026-10-12
|
22 | (System) | RPC status changed to blocked: Author Input Required from Awaiting Formatting, Awaiting Reference Checker |
|
2026-10-12
|
22 | (System) | RFC Editor state changed to Blocked from In Progress |
|
2026-10-12
|
22 | (System) | RPC status changed to Awaiting Formatting, Awaiting Reference Checker from Awaiting Enqueuer |
|
2026-10-12
|
22 | (System) | RPC status changed to Awaiting Enqueuer |
|
2026-10-12
|
22 | (System) | RFC Editor state changed to In Progress |
|
2026-10-12
|
22 | (System) | IESG state changed to RFC Ed Queue from Approved-announcement sent |
|
2026-10-12
|
22 | (System) | Announcement was received by RFC Editor |
|
2026-10-12
|
22 | (System) | IANA Action state changed to In Progress |
|
2026-10-12
|
22 | Morgan Condie | IESG state changed to Approved-announcement sent from Approved-announcement to be sent |
|
2026-10-12
|
22 | Morgan Condie | IESG has approved the document |
|
2026-10-12
|
22 | Morgan Condie | Closed "Approve" ballot |
|
2026-10-12
|
22 | Morgan Condie | Ballot approval text was generated |
|
2026-10-12
|
22 | Morgan Condie | Ballot writeup was changed |
|
2026-10-10
|
22 | (System) | Removed all action holders (IESG state changed) |
|
2026-10-10
|
22 | Deb Cooley | IESG state changed to Approved-announcement to be sent from IESG Evaluation::AD Followup |
|
2026-10-09
|
22 | Éric Vyncke | [Ballot comment] Thanks for the work done in this document and for addressing my previous blocking DISCUSS position at https://mailarchive.ietf.org/arch/msg/spasm/yWZWsdeyVxGEzfcOL4hu8gWxEWY/ as well as for your … [Ballot comment] Thanks for the work done in this document and for addressing my previous blocking DISCUSS position at https://mailarchive.ietf.org/arch/msg/spasm/yWZWsdeyVxGEzfcOL4hu8gWxEWY/ as well as for your patience waiting for my change of ballot (I must admit that I was a long break when you replied to my ballot :-O ). |
|
2026-10-09
|
22 | Éric Vyncke | [Ballot Position Update] Position for Éric Vyncke has been changed to No Objection from Discuss |
|
2026-10-06
|
22 | Roman Danyliw | [Ballot comment] Thank you to Behcet Sarikaya for the GENART review. Thank you for addressing my DISCUSS feedback. |
|
2026-10-06
|
22 | Roman Danyliw | [Ballot Position Update] Position for Roman Danyliw has been changed to No Objection from Discuss |
|
2026-10-06
|
22 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-10-06
|
22 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-10-06
|
22 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed |
|
2026-10-06
|
22 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-22.txt |
|
2026-10-06
|
22 | (System) | New version approved |
|
2026-10-06
|
22 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-10-06
|
22 | Mike Ounsworth | Uploaded new revision |
|
2026-10-01
|
21 | Roman Danyliw | [Ballot discuss] (revised for -21) ** Section 7. This section provides an ASN.1 module without citing a normative reference to the formal syntax. Please provide … [Ballot discuss] (revised for -21) ** Section 7. This section provides an ASN.1 module without citing a normative reference to the formal syntax. Please provide a normative reference to [X680]. Yes, [X690] is already a referenced but that only covers the DER (and other encodings). Looking at other LAMPS documents with ASN.1 modules, I believe the convention is: Section 7. This appendix includes the ASN.1 module [X680] for … … Section 11.1 Normative References [X680] ITU-T, "Information technology - Abstract Syntax Notation One (ASN.1): Specification of basic notation", ITU-T Recommendation X.680, ISO/IEC 8824-1:2021, February 2021, . The PR mentioned in https://mailarchive.ietf.org/arch/msg/spasm/j-kmIoxm5K1VREujKoF1HLa5Knc/ would address this feedback. |
|
2026-10-01
|
21 | Roman Danyliw | Ballot discuss text updated for Roman Danyliw |
|
2026-09-03
|
21 | (System) | Changed action holders to Mike Ounsworth, John Gray, Massimiliano Pala, Jan Klaußner, Scott Fluhrer (IESG state changed) |
|
2026-09-03
|
21 | Cindy Morgan | IESG state changed to IESG Evaluation::Revised I-D Needed from IESG Evaluation |
|
2026-09-02
|
21 | Tommy Jensen | [Ballot Position Update] New position, No Objection, has been recorded for Tommy Jensen |
|
2026-09-02
|
21 | Amanda Baber | IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed |
|
2026-09-02
|
21 | Mike Bishop | [Ballot comment] # IESG review of draft-ietf-lamps-pq-composite-kem-21 CC @MikeBishop ## Comments ### Use of first-person First person is rarely correct in a specification. It occurs … [Ballot comment] # IESG review of draft-ietf-lamps-pq-composite-kem-21 CC @MikeBishop ## Comments ### Use of first-person First person is rarely correct in a specification. It occurs in several places throughout Section 9. "Let's explore, "We need", "We note", "We must", etc. It's okay in the Acknowledgments, but even there you could as easily say "the authors". ### Section 9.1, paragraph 2 Consider being specific about which following sections. ## Nits All comments below are about very minor potential issues that you may choose to address in some way - or ignore - as you see fit. Some were flagged by automated tools (via https://github.com/larseggert/ietf-reviewtool), so there will likely be some false positives. There is no need to let me know what you did with these suggestions. ### Typos #### Section 10.1, paragraph 8 ``` - [SP.800-56Cr2] section 4 "One-Step Key Derivation" requires a counter - ^ + [SP.800-56Cr2] Section 4 "One-Step Key Derivation" requires a counter + ^ ``` ### Uncited outdated reference You updated from RFC8446 to RFC9846, but never removed `[RFC8446]` from the references. (This may be on purpose.) ### Grammar/style #### Section 1, paragraph 5 ``` ingle composite algorithm, or a small number of composite algorithms, that me ^^^^^^^^^^^^^^^^^ ``` Specify a number, remove phrase, use "a few", or use "some". #### Section 1.1, paragraphs 6, 12 and 15 ``` such as adding new identifiers). Typically this means that the new feature f ^^^^^^^^^ ``` ``` esents a pair of values a and b. Typically this indicates that a function re ^^^^^^^^^ ``` ``` epending on the underlying TYPE. Typically this means that a function will n ^^^^^^^^^ ``` A comma may be missing after the conjunctive/linking adverb "Typically". #### Section 1.1, paragraph 12 ``` -- tuple, struct, output parameters, etc --is left to the implementer. * (a, ^^^ ``` In American English, abbreviations like "etc." require a period. #### Section 2.2, paragraph 14 ``` nent algorithms independently. Multi-threaded, multi-process, or multi-modul ^^^^^^^^^^^^^^ ``` This word is normally spelled as one. #### Section 3.1.1, paragraph 1 ``` ollowing describes how to instantiate a Encaps(pk) function for a given compo ^ ``` Use "an" instead of "a" if the following word starts with a vowel sound, e.g. "an article", "an hour". #### Section 3.3, paragraph 10 ``` ely that the input is injective). However some implementations may choose to ^^^^^^^ ``` A comma may be missing after the conjunctive/linking adverb "However". #### Section 6, paragraph 1 ``` e the same for the 2048, 3072 and 4096 bit key sizes since the objective is ^^^^^^^^ ``` When "4096-bit" is used as a modifier, it is usually spelled with a hyphen. The other numbers would get corresponding hyphens: "2048-, 3072-, and 4096-bit" #### Section 7, paragraph 26 ``` ompromise the data. As with most of cryptography, this property is easy to st ^^^^^^^^^^^^^^^^^^^^ ``` Consider using "most cryptography" or "most of the cryptography". #### Section 8.1.2, paragraph 18 ``` place of DH. Informally we note that that RSA-OAEP is IND-CCA2 secure [RFC8 ^^^^^^^^^ ``` Possible typo: you repeated a word. #### Section 9.2, paragraph 4 ``` ty and therefore often tolerated. However this reasoning does not hold in th ^^^^^^^ ``` A comma may be missing after the conjunctive/linking adverb "However". #### Section 9.3, paragraph 1 ``` ecosystem into non-interoperable sub-groups when different communities choos ^^^^^^^^^^ ``` This word is normally spelled as one. #### Section 9.3, paragraph 3 ``` o define profiles that select a small number of composites appropriate for th ^^^^^^^^^^^^^^^^^ ``` Specify a number, remove phrase, use "a few", or use "some". ## Notes This review is in the ["IETF Comments" Markdown format][ICMF]. You can use the [`ietf-comments` tool][ICT] to automatically convert this review into individual GitHub issues. Review generated by the [`ietf-reviewtool`][IRT]. [ICMF]: https://github.com/mnot/ietf-comments/blob/main/format.md [ICT]: https://github.com/mnot/ietf-comments [IRT]: https://github.com/larseggert/ietf-reviewtool |
|
2026-09-02
|
21 | Mike Bishop | [Ballot Position Update] New position, No Objection, has been recorded for Mike Bishop |
|
2026-09-02
|
21 | Christopher Inacio | [Ballot comment] Thanks to Russ for the useful shepherds write up and thanks to Linda D. for the SECDIR review. |
|
2026-09-02
|
21 | Christopher Inacio | Ballot comment text updated for Christopher Inacio |
|
2026-09-02
|
21 | Christopher Inacio | [Ballot Position Update] New position, No Objection, has been recorded for Christopher Inacio |
|
2026-09-01
|
21 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed |
|
2026-09-01
|
21 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-21.txt |
|
2026-09-01
|
21 | (System) | New version approved |
|
2026-09-01
|
21 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-09-01
|
21 | Mike Ounsworth | Uploaded new revision |
|
2026-08-31
|
20 | (System) | IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed |
|
2026-08-31
|
20 | Roman Danyliw | [Ballot discuss] ** Section 7. This section provides an ASN.1 module without citing a normative reference to the formal syntax. Please provide a normative reference … [Ballot discuss] ** Section 7. This section provides an ASN.1 module without citing a normative reference to the formal syntax. Please provide a normative reference to [X680]. Yes, [X690] is already a referenced but that only covers the DER (and other encodings). Looking at other LAMPS documents with ASN.1 modules, I believe the convention is: Section 7. This appendix includes the ASN.1 module [X680] for … … Section 11.1 Normative References [X680] ITU-T, "Information technology - Abstract Syntax Notation One (ASN.1): Specification of basic notation", ITU-T Recommendation X.680, ISO/IEC 8824-1:2021, February 2021, . |
|
2026-08-31
|
20 | Roman Danyliw | [Ballot comment] Thank you to Behcet Sarikaya for the GENART review. |
|
2026-08-31
|
20 | Roman Danyliw | [Ballot Position Update] New position, Discuss, has been recorded for Roman Danyliw |
|
2026-08-30
|
20 | Andy Newton | [Ballot comment] Many thanks for the work put into this document. I support Éric's DISCUSS on normative language in an appendix. |
|
2026-08-30
|
20 | Andy Newton | [Ballot Position Update] New position, No Objection, has been recorded for Andy Newton |
|
2026-08-28
|
20 | Charles Eckel | [Ballot comment] # Charles Eckel, ART AD, IESG ballot: draft-ietf-lamps-pq-composite-kem-20 CC @eckelcu * line numbers: - https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-lamps-pq-composite-kem-20.txt&submitcheck=True * comment syntax: - https://github.com/mnot/ietf-comments/blob/main/format.md * … [Ballot comment] # Charles Eckel, ART AD, IESG ballot: draft-ietf-lamps-pq-composite-kem-20 CC @eckelcu * line numbers: - https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-lamps-pq-composite-kem-20.txt&submitcheck=True * comment syntax: - https://github.com/mnot/ietf-comments/blob/main/format.md * "Handling Ballot Positions": - https://ietf.org/about/groups/iesg/statements/handling-ballot-positions/ Thanks to Russ Housley for the helpful shepherd write and to the authors and working group for a well-written and important document. ## Comments ### shared secret vs. shared secret key ``` 357 * Encaps(pk) -> (ss, ct): A probabilistic encapsulation algorithm, 358 which takes as input a public key pk and outputs a ciphertext ct 359 and shared secret key ss. Note: this specification uses Encaps() 360 to conform to [FIPS.203], while [RFC9180] uses Encap(). 362 * Decaps(sk, ct) -> ss: A decapsulation algorithm, which takes as 363 input a secret key sk and ciphertext ct and outputs a shared 364 secret ss. Different KEM algorithms differ in how they handle ``` I suspect "shared secret key ss" in line 360 should be changed to "shared secret ss" to align with lines 363-364. ### References +1 to Ketan Talaulikar's point that RFC 5912 is used normatively in the ASN.1 module but is absent from the reference sections, as is [X509ASN1]. ## Nits ### Expand KDF on first use ``` 1554 SHA3-256 is used as the KDF for all Composite ML-KEM algorithms. ``` I believe this the first use of KDF in this draft. It would be helpful to the reader to expand it, or add it to section 1.1. |
|
2026-08-28
|
20 | Charles Eckel | [Ballot Position Update] New position, No Objection, has been recorded for Charles Eckel |
|
2026-08-28
|
20 | Mohamed Boucadair | [Ballot comment] Hi Mike, John, Massimiliano, Jan, and Scott, Thank you for the effort put into this document. I appreciate that several comments that were … [Ballot comment] Hi Mike, John, Massimiliano, Jan, and Scott, Thank you for the effort put into this document. I appreciate that several comments that were raised for draft-ietf-lamps-pq-composite-sigs have been also mirrored here ;-) I only have nits that I sent in a PR [1], for authors convenience. Feel free to grab whatever useful for you. Cheers, Med [1] https://github.com/lamps-wg/draft-composite-kem/pull/272 |
|
2026-08-28
|
20 | Mohamed Boucadair | [Ballot Position Update] New position, No Objection, has been recorded for Mohamed Boucadair |
|
2026-08-27
|
20 | Éric Vyncke | [Ballot discuss] # Éric Vyncke INT AD comments for draft-ietf-lamps-pq-composite-kem-20 CC @evyncke Thank you for the work put into this document. The depth of crypto … [Ballot discuss] # Éric Vyncke INT AD comments for draft-ietf-lamps-pq-composite-kem-20 CC @evyncke Thank you for the work put into this document. The depth of crypto was obviously above my head. Please find below one blocking DISCUSS points (easy to address), some non-blocking COMMENT points/nits (replies would be appreciated even if only for my own education). I hope that this review helps to improve the document, Regards, -éric Note: this ballot comments follow the Markdown syntax of https://github.com/mnot/ietf-comments/tree/main, i.e., they can be processed by a tool to create github issues. ## DISCUSS (blocking) As noted in https://datatracker.ietf.org/doc/statement-iesg-handling-ballot-positions-20220121/, a DISCUSS ballot is a request to have a discussion on the points below; I really think that the document would be improved with a change here, but can be convinced otherwise. ### Appendix A Usually appendixes are not normative, so, I wonder whether they are in this document when I read BCP14 term in `Implementations MUST NOT perform strict length checking based on such values.`. If they are normative, then simply mention it in the beginning of the appendix, else use a lower case "must not". I guess they are normative, but readers should not "guess", they must be sure. |
|
2026-08-27
|
20 | Éric Vyncke | [Ballot comment] ## COMMENTS (non-blocking) ### Avoid personal tone Who are the "us" and "we" in several places (see partial list below) ? The authors … [Ballot comment] ## COMMENTS (non-blocking) ### Avoid personal tone Who are the "us" and "we" in several places (see partial list below) ? The authors ? The WG ? The IETF ? Rephrase is usually easy and efficient: - section 1 `this migration gives us` - section 2.2 `we consider only the elliptic curve` - section 9.2 `we also need to consider the case` - and probably others ### Section 2 I find *very* weird to prefer a US FIPS notation rather than the IETF one in `Note: this specification uses Encaps() to conform to [FIPS.203], while [RFC9180] uses Encap()`. ### Appendix G s/to the NIST ACVP/to the *US* NIST ACVP/ as there could be other NIST than in the USA. ### Appendix H Usually Contributors and Acknowledgement sections are not in the appendix. |
|
2026-08-27
|
20 | Éric Vyncke | [Ballot Position Update] New position, Discuss, has been recorded for Éric Vyncke |
|
2026-08-26
|
20 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-20.txt |
|
2026-08-26
|
20 | (System) | New version approved |
|
2026-08-26
|
20 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-08-26
|
20 | Mike Ounsworth | Uploaded new revision |
|
2026-08-25
|
19 | Gunter Van de Velde | [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde |
|
2026-08-25
|
19 | Jim Guichard | [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard |
|
2026-08-24
|
19 | Ketan Talaulikar | [Ballot comment] Thanks to the authors and the WG for their work on this document. I have only a couple of questions/comments to offer. I … [Ballot comment] Thanks to the authors and the WG for their work on this document. I have only a couple of questions/comments to offer. I see RFC5912 being referenced in the ASN.1 in what seems to me like a normative manner but it is not included in the document references. Can you please check this out? On the other hand, [X509ASN1] seems to also have a reference in the ASN.1 but I don't quite know if that was intentional; it is also not covered in the references. |
|
2026-08-24
|
19 | Ketan Talaulikar | [Ballot Position Update] New position, No Objection, has been recorded for Ketan Talaulikar |
|
2026-08-14
|
19 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-19.txt |
|
2026-08-14
|
19 | (System) | New version approved |
|
2026-08-14
|
19 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-08-14
|
19 | Mike Ounsworth | Uploaded new revision |
|
2026-08-13
|
18 | Linda Dunbar | Request for IETF Last Call review by SECDIR Completed: Has Nits. Reviewer: Linda Dunbar. Sent review to list. Submission of review completed at an earlier … Request for IETF Last Call review by SECDIR Completed: Has Nits. Reviewer: Linda Dunbar. Sent review to list. Submission of review completed at an earlier date. |
|
2026-08-13
|
18 | Linda Dunbar | Request for IETF Last Call review by SECDIR Completed: Has Nits. Reviewer: Linda Dunbar. |
|
2026-08-13
|
18 | Deb Cooley | Placed on agenda for telechat - 2026-09-03 |
|
2026-08-13
|
18 | Deb Cooley | Ballot has been issued |
|
2026-08-13
|
18 | Deb Cooley | [Ballot Position Update] New position, Yes, has been recorded for Deb Cooley |
|
2026-08-13
|
18 | Deb Cooley | Created "Approve" ballot |
|
2026-08-13
|
18 | Deb Cooley | IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead |
|
2026-07-27
|
18 | Behcet Sarikaya | Request for IETF Last Call review by GENART Completed: Almost Ready. Reviewer: Behcet Sarikaya. Sent review to list. |
|
2026-07-27
|
18 | (System) | IESG state changed to Waiting for AD Go-Ahead from In Last Call |
|
2026-07-23
|
18 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed |
|
2026-07-23
|
18 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-18.txt |
|
2026-07-23
|
18 | John Gray | New version approved |
|
2026-07-23
|
18 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-07-23
|
18 | Mike Ounsworth | Uploaded new revision |
|
2026-07-22
|
17 | David Dong | IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-lamps-pq-composite-kem-17. If any part of this review is inaccurate, please let us know. IANA understands that, upon … IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-lamps-pq-composite-kem-17. If any part of this review is inaccurate, please let us know. IANA understands that, upon approval of this document, there are two actions that we must complete. First, in the SMI Security for PKIX Module Identifier registry in the Structure of Management Information (SMI) Numbers (MIB Module Registrations) registry group located at: https://www.iana.org/assignments/smi-numbers/ a single new registration will be made as follows: Decimal: [ TBD-at-registration ] Description: Composite-MLKEM-2025 - id-mod-composite-mlkem-2025 Reference: [ RFC-to-be ] As this document requests a registration in an Expert Review or Specification Required (see RFC 8126) registry, we have completed the required Expert Review via a separate request. Second, in the SMI Security for PKIX Algorithms also in the Structure of Management Information (SMI) Numbers (MIB Module Registrations) registry group located at: https://www.iana.org/assignments/smi-numbers/ the following twelve existing registrations will have their references changed to [ RFC-to-be ]: Decimal: 1.3.6.1.5.5.7.6.55 Description: id-MLKEM768-RSA2048-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.56 Description: id-MLKEM768-RSA3072-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.57 Description: id-MLKEM768-RSA4096-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.58 Description: id-MLKEM768-X25519-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.59 Description: id-MLKEM768-ECDH-P256-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.60 Description: id-MLKEM768-ECDH-P384-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.61 Description: id-MLKEM768-ECDH-brainpoolP256r1-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.62 Description: id-MLKEM1024-RSA3072-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.63 Description: id-MLKEM1024-ECDH-P384-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.64 Description: id-MLKEM1024-ECDH-brainpoolP384r1-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.65 Description: id-MLKEM1024-X448-SHA3-256 References: [ RFC-to-be ] Decimal: 1.3.6.1.5.5.7.6.66 Description: id-MLKEM1024-ECDH-P521-SHA3-256 References: [ RFC-to-be ] We understand that these are the only actions required to be completed upon†approval of this document. NOTE: The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed. For definitions of IANA review states, please see: https://datatracker.ietf.org/help/state/draft/iana-review Thank you, David Dong IANA Services Sr. Specialist |
|
2026-07-22
|
17 | (System) | IANA Review state changed to IANA OK - Actions Needed from IANA - Review Needed |
|
2026-07-13
|
17 | David Dong | IANA Experts State changed to Expert Reviews OK from Reviews assigned |
|
2026-07-10
|
17 | David Dong | IANA Experts State changed to Reviews assigned |
|
2026-07-09
|
17 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Linda Dunbar |
|
2026-07-07
|
17 | Jean Mahoney | Request for IETF Last Call review by GENART is assigned to Behcet Sarikaya |
|
2026-07-06
|
17 | Morgan Condie | IANA Review state changed to IANA - Review Needed |
|
2026-07-06
|
17 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-07-27): From: The IESG To: IETF-Announce CC: debcooley1@gmail.com, draft-ietf-lamps-pq-composite-kem@ietf.org, housley@vigilsec.com, lamps-chairs@ietf.org, spasm@ietf.org … The following Last Call announcement was sent out (ends 2026-07-27): From: The IESG To: IETF-Announce CC: debcooley1@gmail.com, draft-ietf-lamps-pq-composite-kem@ietf.org, housley@vigilsec.com, lamps-chairs@ietf.org, spasm@ietf.org Reply-To: last-call@ietf.org Sender: Subject: Last Call: (Composite ML-KEM for use in X.509 Public Key Infrastructure) to Proposed Standard The IESG has received a request from the Limited Additional Mechanisms for PKIX and SMIME WG (lamps) to consider the following document: - 'Composite ML-KEM for use in X.509 Public Key Infrastructure' as Proposed Standard The IESG plans to make a decision in the next few weeks, and solicits final comments on this action. Please send substantive comments to the last-call@ietf.org mailing lists by 2026-07-27. Exceptionally, comments may be sent to iesg@ietf.org instead. In either case, please retain the beginning of the Subject line to allow automated sorting. Abstract This document defines combinations of US NIST ML-KEM in hybrid with traditional algorithms RSA-OAEP, ECDH, X25519, and X448. These combinations are tailored to meet security best practices and regulatory guidelines. Composite ML-KEM is applicable in any application that uses X.509 or PKIX data structures that accept ML- KEM, but where the operator wants extra protection against breaks or catastrophic bugs in ML-KEM. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-lamps-pq-composite-kem/ No IPR declarations have been submitted directly on this I-D. |
|
2026-07-06
|
17 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-07-06
|
17 | Morgan Condie | Last call announcement was changed |
|
2026-07-06
|
17 | Morgan Condie | Last call announcement was generated |
|
2026-07-05
|
17 | Deb Cooley | Last call was requested |
|
2026-07-05
|
17 | Deb Cooley | Last call announcement was generated |
|
2026-07-05
|
17 | Deb Cooley | Ballot approval text was generated |
|
2026-07-05
|
17 | Deb Cooley | IESG state changed to Last Call Requested from AD Evaluation::AD Followup |
|
2026-06-28
|
17 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-06-28
|
17 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-06-28
|
17 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-17.txt |
|
2026-06-28
|
17 | (System) | New version approved |
|
2026-06-28
|
17 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2026-06-28
|
17 | Mike Ounsworth | Uploaded new revision |
|
2026-06-22
|
16 | Deb Cooley | Comments available here: https://mailarchive.ietf.org/arch/msg/spasm/PzP1VjvupkY7FB0oL4SB4N24jQM/ |
|
2026-06-22
|
16 | (System) | Changed action holders to Scott Fluhrer, Massimiliano Pala, Mike Ounsworth, John Gray, Jan Klaußner (IESG state changed) |
|
2026-06-22
|
16 | Deb Cooley | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2026-06-15
|
16 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-16.txt |
|
2026-06-15
|
16 | Mike Ounsworth | New version accepted (logged-in submitter: Mike Ounsworth) |
|
2026-06-15
|
16 | Mike Ounsworth | Uploaded new revision |
|
2026-06-15
|
15 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-15.txt |
|
2026-06-15
|
15 | Mike Ounsworth | New version accepted (logged-in submitter: Mike Ounsworth) |
|
2026-06-15
|
15 | Mike Ounsworth | Uploaded new revision |
|
2026-06-15
|
14 | Deb Cooley | IESG state changed to AD Evaluation from Publication Requested |
|
2026-06-15
|
14 | Deb Cooley | Ballot writeup was changed |
|
2026-03-31
|
14 | Russ Housley | # Shepherd Write-up for draft-ietf-lamps-pq-composite-kem-14 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with … # Shepherd Write-up for draft-ietf-lamps-pq-composite-kem-14 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? There is support in the LAMPS WG for this document. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a lot of debate, and many people asked for fewer combinations, but in the end there were people that want each of the combinations that are specified. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No one has threatened an appeal or otherwise expressed disagreemnt. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? Some code written, and a lot of time was spent at the hackathon to make sure that various implementation are interoperable. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. No concerns about interaction with other technologies. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. ASN.1 is used. Once a placeholder values are inserted for the module identifier and the algorithm identifiers that will be assigned by IANA, the ASN.1 module compiles without error. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This document does not include a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. ASN.1 is used. Once a placeholder values are inserted for the module identifier and the algorithm identifiers that will be assigned by IANA, the ASN.1 module compiles without error. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? No concerns were noticed. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? As reflected in the Datatracker: Proposed Standard on the IETF Stream. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No IPR declarations have been filed. The authors have explicitly stated that they are unaware of any other IPR that needs to be declared. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) IDnits complains about ASN.1 tags; IDnits thinks the tags are references. IDnits complains about a missing reference to [X509ASN1], but it is referenced in a comment in the ASN.1 module. IDnits complains about a downref to [RFC2104], [RFC5869], [RFC7748], and [RFC8017], but all of these documents are already in the downref registry. IDnits complains about a downref to [RFC5915]. The IESG is asked to call out this downref in the IETF Last Call, and then add it to the downref registry. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. No concerns. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? Some of the informative references are behind a paywall. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. Yes, there is a downref to [RFC5915]. The IESG is asked to call out this downref in the IETF Last Call, and then add it to the downref registry. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? All normative references have already been published. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). IANA is requested to assign one object identifier (OID). for the ASN.1 module identifier. The rest of the OIDs under the control of IANA have already been assigned. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No. |
|
2026-03-31
|
14 | Russ Housley | IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up |
|
2026-03-31
|
14 | Russ Housley | IESG state changed to Publication Requested from I-D Exists |
|
2026-03-31
|
14 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-03-31
|
14 | Russ Housley | Responsible AD changed to Deb Cooley |
|
2026-03-31
|
14 | Russ Housley | Document is now in IESG state Publication Requested |
|
2026-03-31
|
14 | Russ Housley | Changed consensus to Yes from Unknown |
|
2026-03-31
|
14 | Russ Housley | Intended Status changed to Proposed Standard from None |
|
2026-03-31
|
14 | Russ Housley | # Shepherd Write-up for draft-ietf-lamps-pq-composite-kem-14 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with … # Shepherd Write-up for draft-ietf-lamps-pq-composite-kem-14 ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? There is support in the LAMPS WG for this document. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a lot of debate, and many people asked for fewer combinations, but in the end there were people that want each of the combinations that are specified. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No one has threatened an appeal or otherwise expressed disagreemnt. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? Some code written, and a lot of time was spent at the hackathon to make sure that various implementation are interoperable. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. No concerns about interaction with other technologies. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. ASN.1 is used. Once a placeholder values are inserted for the module identifier and the algorithm identifiers that will be assigned by IANA, the ASN.1 module compiles without error. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This document does not include a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. ASN.1 is used. Once a placeholder values are inserted for the module identifier and the algorithm identifiers that will be assigned by IANA, the ASN.1 module compiles without error. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? No concerns were noticed. 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? As reflected in the Datatracker: Proposed Standard on the IETF Stream. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. No IPR declarations have been filed. The authors have explicitly stated that they are unaware of any other IPR that needs to be declared. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) IDnits complains about ASN.1 tags; IDnits thinks the tags are references. IDnits complains about a missing reference to [X509ASN1], but it is referenced in a comment in the ASN.1 module. IDnits complains about a downref to [RFC2104], [RFC5869], [RFC7748], and [RFC8017], but all of these documents are already in the downref registry. IDnits complains about a downref to [RFC5915]. The IESG is asked to call out this downref in the IETF Last Call, and then add it to the downref registry. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. No concerns. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? Some of the informative references are behind a paywall. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. Yes, there is a downref to [RFC5915]. The IESG is asked to call out this downref in the IETF Last Call, and then add it to the downref registry. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? All normative references have already been published. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). IANA is requested to assign one object identifier (OID). for the ASN.1 module identifier. The rest of the OIDs under the control of IANA have already been assigned. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No. |
|
2026-03-31
|
14 | Russ Housley | Notification list changed to housley@vigilsec.com because the document shepherd was set |
|
2026-03-31
|
14 | Russ Housley | Document shepherd changed to Russ Housley |
|
2026-03-31
|
14 | Russ Housley | IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call |
|
2026-03-27
|
14 | John Gray | New version available: draft-ietf-lamps-pq-composite-kem-14.txt |
|
2026-03-27
|
14 | Mike Ounsworth | New version accepted (logged-in submitter: Mike Ounsworth) |
|
2026-03-27
|
14 | Mike Ounsworth | Uploaded new revision |
|
2026-03-27
|
13 | John Gray | New version available: draft-ietf-lamps-pq-composite-kem-13.txt |
|
2026-03-27
|
13 | Mike Ounsworth | New version accepted (logged-in submitter: Mike Ounsworth) |
|
2026-03-27
|
13 | Mike Ounsworth | Uploaded new revision |
|
2026-01-07
|
12 | John Gray | New version available: draft-ietf-lamps-pq-composite-kem-12.txt |
|
2026-01-07
|
12 | John Gray | New version accepted (logged-in submitter: John Gray) |
|
2026-01-07
|
12 | John Gray | Uploaded new revision |
|
2025-12-03
|
11 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-11.txt |
|
2025-12-03
|
11 | John Gray | New version approved |
|
2025-12-03
|
11 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-12-03
|
11 | Mike Ounsworth | Uploaded new revision |
|
2025-12-03
|
11 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-12-03
|
11 | Mike Ounsworth | Uploaded new revision |
|
2025-11-24
|
10 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-10.txt |
|
2025-11-24
|
10 | John Gray | New version approved |
|
2025-11-24
|
10 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-11-24
|
10 | Mike Ounsworth | Uploaded new revision |
|
2025-11-03
|
09 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-09.txt |
|
2025-11-03
|
09 | John Gray | New version approved |
|
2025-11-03
|
09 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-11-03
|
09 | Mike Ounsworth | Uploaded new revision |
|
2025-10-17
|
08 | Russ Housley | IETF WG state changed to In WG Last Call from WG Document |
|
2025-10-15
|
08 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-08.txt |
|
2025-10-15
|
08 | Mike Ounsworth | New version approved |
|
2025-10-15
|
08 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-10-15
|
08 | Mike Ounsworth | Uploaded new revision |
|
2025-06-16
|
07 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-07.txt |
|
2025-06-16
|
07 | John Gray | New version approved |
|
2025-06-16
|
07 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-06-16
|
07 | Mike Ounsworth | Uploaded new revision |
|
2025-03-17
|
06 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-06.txt |
|
2025-03-17
|
06 | Mike Ounsworth | New version approved |
|
2025-03-17
|
06 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-03-17
|
06 | Mike Ounsworth | Uploaded new revision |
|
2025-03-03
|
06 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2025-03-03
|
06 | Mike Ounsworth | Uploaded new revision |
|
2024-10-21
|
05 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-05.txt |
|
2024-10-21
|
05 | Mike Ounsworth | New version approved |
|
2024-10-21
|
05 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer |
|
2024-10-21
|
05 | Mike Ounsworth | Uploaded new revision |
|
2024-07-08
|
04 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-04.txt |
|
2024-07-08
|
04 | John Gray | New version approved |
|
2024-07-08
|
04 | (System) | Request for posting confirmation emailed to previous authors: Jan Klaussner , John Gray , Massimiliano Pala , Mike Ounsworth , Scott Fluhrer , lamps-chairs@ietf.org |
|
2024-07-08
|
04 | Mike Ounsworth | Uploaded new revision |
|
2024-03-02
|
03 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-03.txt |
|
2024-03-02
|
03 | (System) | New version approved |
|
2024-03-02
|
03 | (System) | Request for posting confirmation emailed to previous authors: John Gray , Mike Ounsworth , lamps-chairs@ietf.org |
|
2024-03-02
|
03 | Mike Ounsworth | Uploaded new revision |
|
2023-10-23
|
02 | John Gray | New version available: draft-ietf-lamps-pq-composite-kem-02.txt |
|
2023-10-23
|
02 | John Gray | New version accepted (logged-in submitter: John Gray) |
|
2023-10-23
|
02 | John Gray | Uploaded new revision |
|
2023-10-23
|
01 | John Gray | New version available: draft-ietf-lamps-pq-composite-kem-01.txt |
|
2023-10-23
|
01 | John Gray | New version accepted (logged-in submitter: John Gray) |
|
2023-10-23
|
01 | John Gray | Uploaded new revision |
|
2023-08-23
|
00 | Russ Housley | Changed document external resources from: None to: github_repo https://github.com/lamps-wg/draft-composite-kem |
|
2023-08-23
|
00 | Russ Housley | This document now replaces draft-ounsworth-pq-composite-kem instead of None |
|
2023-08-23
|
00 | Mike Ounsworth | New version available: draft-ietf-lamps-pq-composite-kem-00.txt |
|
2023-08-23
|
00 | Russ Housley | WG -00 approved |
|
2023-08-23
|
00 | Mike Ounsworth | Set submitter to "Mike Ounsworth ", replaces to draft-ounsworth-pq-composite-kem and sent approval email to group chairs: lamps-chairs@ietf.org |
|
2023-08-23
|
00 | Mike Ounsworth | Uploaded new revision |