UDP-based Transport for Configured Subscriptions
draft-ietf-netconf-udp-notif-26
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-07
|
26 | Per Andersson | # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes, this work has benefited from the discussion of UDP transport notification over years and is a replacement draft for both draft-zheng-netconf-udp-pub-channel and draft-unyte-netconf-udp-notif and represents a broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No controversy. The need of congestion control was brought up during TSVART review and discussed in IETF 119 NETCONF session and rough consensus had been reached on detailed level of congestion control. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There are 4 known open source implementations and 3 implementations from network vendors, which have been documented in section 9 of rev-22 of this document. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document uses transport technology in WIT area and has been reviewed by TSVART https://mailarchive.ietf.org/arch/msg/netconf/J8YeAHqnqIiyj-QqXdBx4nToXUw/ The comments from TSVART have been addressed in v-24 and confirmed on the NETCONF ML https://mailarchive.ietf.org/arch/msg/netconf/0FwQWSxxi64r-i5AyqjskRvXC0M/. Additional comments from WIT Area AD Gorry have been addressed in v-25 and confirmed on the NETCONF ML: https://mailarchive.ietf.org/arch/msg/netconf/KbOfowwjF3kgQPMtPwQAZiQYukY/. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. This document has been reviewed by YANG Doctor, the review result is available at: https://datatracker.ietf.org/doc/review-ietf-netconf-udp-notif-20-yangdoctors-early-schoenwaelder-2025-04-16/ No message states that the YANG Doctors review is cleared. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? 3 pyang command tools "pyang --ietf ","pyang --lint" and "yanglint" have been used to validate v-25 of YANG module included in this document, there are no errors or warnings to be found. Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? Yes 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. Manual review of the XML examples in Appendix A. There are no errors or warnings to be found. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? N/A 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because Capabilities for high frequency UDP based Data Collection are needed by both NETCONF clients and RESTCONF client. The "Intended RFC Status" in Datatracker has to be set to reflect this intent. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. All authors have responded not being aware of any IPR: https://mailarchive.ietf.org/arch/msg/netconf/VQUz-x7mEWVmdxwG_ZZAbN-mlUk/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. The document has 5 authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Checking nits according to https://www.ietf.org/id-info/checklist : ---------------------------------------------------------------------------- Miscellaneous warnings: ---------------------------------------------------------------------------- -- The document date (3 July 2025) is 70 days in the past. Is this intentional? Checking references for intended status: Proposed Standard ---------------------------------------------------------------------------- (See RFCs 3967 and 4897 for information about using normative references to lower-maturity documents in RFCs) -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP195' -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP230' == Outdated reference: A later version (-15) exists of draft-ietf-netconf-distributed-notif-14 ** Obsolete normative reference: RFC 6347 (Obsoleted by RFC 9147) Summary: 1 error (**), 0 flaws (~~), 1 warning (==), 3 comments (--). Run idnits with the --verbose option for more detailed information about the items above. I think Outdated reference draft-ietf-netconf-distributed-notif needs to be changed into v-15. For Obsolete normative reference RFC6347, I believe it is intentional to reference both TLS1.2 and TLS1.3 therefore this error is innocuous and can be ignored. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. References are cited properly. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. None. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? None. This document adds dependency to two other documents: [I-D.ietf-netconf-distributed-notif] and [I-D.ietf-netconf-udp-client-server]. Both documents will be submitted to the IESG in parallel for publication. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No change. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document shepherd has reviewed IANA considerations section and confirm three new registries are correctly defined and consistent with the body of this document. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. N/A [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-10-07
|
26 | Per Andersson | IETF WG state changed to Submitted to IESG for Publication from Waiting for WG Chair Go-Ahead |
|
2026-10-07
|
26 | Per Andersson | IESG state changed to Publication Requested from I-D Exists |
|
2026-10-07
|
26 | (System) | Changed action holders to Mahesh Jethanandani (IESG state changed) |
|
2026-10-07
|
26 | Per Andersson | Responsible AD changed to Mahesh Jethanandani |
|
2026-10-07
|
26 | Per Andersson | Document is now in IESG state Publication Requested |
|
2026-10-07
|
26 | Per Andersson | Tag Awaiting Expert Review/Resolution of Issues Raised cleared. |
|
2026-07-29
|
26 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-26.txt |
|
2026-07-29
|
26 | Thomas Graf | New version accepted (logged-in submitter: Thomas Graf) |
|
2026-07-29
|
26 | Thomas Graf | Uploaded new revision |
|
2026-07-21
|
25 | Kent Watsen | Waiting for TSVART requested early-review to clear. |
|
2026-07-21
|
25 | Kent Watsen | IETF WG state changed to Waiting for WG Chair Go-Ahead from WG Consensus: Waiting for Write-Up |
|
2026-04-14
|
25 | Qin Wu | # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes, this work has benefited from the discussion of UDP transport notification over years and is a replacement draft for both draft-zheng-netconf-udp-pub-channel and draft-unyte-netconf-udp-notif and represents a broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No controversy. The need of congestion control was brought up during TSVART review and discussed in IETF 119 NETCONF session and rough consensus had been reached on detailed level of congestion control. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There are 4 known open source implementations and 3 implementations from network vendors, which have been documented in section 9 of rev-22 of this document. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document uses transport technology in WIT area and has been reviewed by TSVART https://mailarchive.ietf.org/arch/msg/netconf/J8YeAHqnqIiyj-QqXdBx4nToXUw/ The comments from TSVART have been addressed in v-24 and confirmed on the NETCONF ML https://mailarchive.ietf.org/arch/msg/netconf/0FwQWSxxi64r-i5AyqjskRvXC0M/. Additional comments from WIT Area AD Gorry have been addressed in v-25 and confirmed on the NETCONF ML: https://mailarchive.ietf.org/arch/msg/netconf/KbOfowwjF3kgQPMtPwQAZiQYukY/. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. This document has been reviewed by YANG Doctor, the review result is available at: https://datatracker.ietf.org/doc/review-ietf-netconf-udp-notif-20-yangdoctors-early-schoenwaelder-2025-04-16/ No message states that the YANG Doctors review is cleared. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? 3 pyang command tools "pyang --ietf ","pyang --lint" and "yanglint" have been used to validate v-25 of YANG module included in this document, there are no errors or warnings to be found. Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? Yes 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. Manual review of the XML examples in Appendix A. There are no errors or warnings to be found. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? N/A 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because Capabilities for high frequency UDP based Data Collection are needed by both NETCONF clients and RESTCONF client. The "Intended RFC Status" in Datatracker has to be set to reflect this intent. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. All authors have responded not being aware of any IPR: https://mailarchive.ietf.org/arch/msg/netconf/VQUz-x7mEWVmdxwG_ZZAbN-mlUk/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. The document has 5 authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Checking nits according to https://www.ietf.org/id-info/checklist : ---------------------------------------------------------------------------- Miscellaneous warnings: ---------------------------------------------------------------------------- -- The document date (3 July 2025) is 70 days in the past. Is this intentional? Checking references for intended status: Proposed Standard ---------------------------------------------------------------------------- (See RFCs 3967 and 4897 for information about using normative references to lower-maturity documents in RFCs) -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP195' -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP230' == Outdated reference: A later version (-15) exists of draft-ietf-netconf-distributed-notif-14 ** Obsolete normative reference: RFC 6347 (Obsoleted by RFC 9147) Summary: 1 error (**), 0 flaws (~~), 1 warning (==), 3 comments (--). Run idnits with the --verbose option for more detailed information about the items above. I think Outdated reference draft-ietf-netconf-distributed-notif needs to be changed into v-15. For Obsolete normative reference RFC6347, I believe it is intentional to reference both TLS1.2 and TLS1.3 therefore this error is innocuous and can be ignored. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. References are cited properly. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. None. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? None. This document adds dependency to two other documents: [I-D.ietf-netconf-distributed-notif] and [I-D.ietf-netconf-udp-client-server]. Both documents will be submitted to the IESG in parallel for publication. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No change. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document shepherd has reviewed IANA considerations section and confirm three new registries are correctly defined and consistent with the body of this document. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. N/A [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2026-01-28
|
25 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-25.txt |
|
2026-01-28
|
25 | Thomas Graf | New version accepted (logged-in submitter: Thomas Graf) |
|
2026-01-28
|
25 | Thomas Graf | Uploaded new revision |
|
2026-01-03
|
24 | Qin Wu | # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes, this work has benefited from the discussion of UDP transport notification over years and is a replacement draft for both draft-zheng-netconf-udp-pub-channel and draft-unyte-netconf-udp-notif and represents a broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No controversy. The need of congestion control was brought up during TSVART review and discussed in IETF 119 NETCONF session and rough consensus had been reached on detailed level of congestion control. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There are 4 known open source implementations and 3 implementations from network vendors, which have been documented in section 9 of rev-22 of this document. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document uses transport technology in WIT area and has been reviewed by TSVART https://mailarchive.ietf.org/arch/msg/netconf/J8YeAHqnqIiyj-QqXdBx4nToXUw/ The comments from TSVART have been addressed in v-24 and confirmed on the NETCONF ML https://mailarchive.ietf.org/arch/msg/netconf/0FwQWSxxi64r-i5AyqjskRvXC0M/. Additional comments from WIT Area AD Gorry needs to be revolved https://mailarchive.ietf.org/arch/msg/netconf/n9TyQPxx6gJS0m67Yxh_futATT0/. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. This document has been reviewed by YANG Doctor, the review result is available at: https://datatracker.ietf.org/doc/review-ietf-netconf-udp-notif-20-yangdoctors-early-schoenwaelder-2025-04-16/ No message states that the YANG Doctors review is cleared. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? 3 pyang command tools "pyang --ietf ","pyang --lint" and "yanglint" have been used to validate v-22 of YANG module included in this document, there are no errors or warnings to be found. But there appears to be a author list mismatch by checking YANG module, i.e., Authors list embedded in the YANG Data Model in section 7.2 is not consistent with author list in the front page for this document. Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? Yes 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. Manual review of the XML examples in Appendix A. There are no errors or warnings to be found. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? N/A 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because Capabilities for high frequency UDP based Data Collection are needed by both NETCONF clients and RESTCONF client. The "Intended RFC Status" in Datatracker has to be set to reflect this intent. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. All authors have responded not being aware of any IPR: https://mailarchive.ietf.org/arch/msg/netconf/VQUz-x7mEWVmdxwG_ZZAbN-mlUk/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. The document has 5 authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Checking nits according to https://www.ietf.org/id-info/checklist : ---------------------------------------------------------------------------- Miscellaneous warnings: ---------------------------------------------------------------------------- -- The document date (3 July 2025) is 70 days in the past. Is this intentional? Checking references for intended status: Proposed Standard ---------------------------------------------------------------------------- (See RFCs 3967 and 4897 for information about using normative references to lower-maturity documents in RFCs) -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP195' -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP230' == Outdated reference: A later version (-15) exists of draft-ietf-netconf-distributed-notif-14 ** Obsolete normative reference: RFC 6347 (Obsoleted by RFC 9147) Summary: 1 error (**), 0 flaws (~~), 1 warning (==), 3 comments (--). Run idnits with the --verbose option for more detailed information about the items above. I think Outdated reference draft-ietf-netconf-distributed-notif needs to be changed into v-15. For Obsolete normative reference RFC6347, I believe it is intentional to reference both TLS1.2 and TLS1.3 therefore this error is innocuous and can be ignored. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. References are cited properly. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. None. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? None. This document adds dependency to two other documents: [I-D.ietf-netconf-distributed-notif] and [I-D.ietf-netconf-udp-client-server]. Both documents will be submitted to the IESG in parallel for publication. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No change. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document shepherd has reviewed IANA considerations section and confirm three new registries are correctly defined and consistent with the body of this document. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. N/A [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2025-12-03
|
24 | Kent Watsen | Also, Mahesh asked NETCONF chairs to wait for another/new TSVART review to resolve. |
|
2025-12-03
|
24 | Kent Watsen | Tag Awaiting Expert Review/Resolution of Issues Raised set. |
|
2025-12-03
|
24 | Kent Watsen | Shepherd writeup needs to be updated to reflect lastest TSVART review |
|
2025-11-20
|
24 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-24.txt |
|
2025-11-20
|
24 | Thomas Graf | New version accepted (logged-in submitter: Thomas Graf) |
|
2025-11-20
|
24 | Thomas Graf | Uploaded new revision |
|
2025-11-04
|
23 | Michael Tüxen | Request for Early review by TSVART Completed: Ready with Nits. Reviewer: Michael Tüxen. Sent review to list. |
|
2025-10-14
|
23 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-23.txt |
|
2025-10-14
|
23 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2025-10-14
|
23 | Alex Huang Feng | Uploaded new revision |
|
2025-10-03
|
22 | Qin Wu | # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes, this work has benefited from the discussion of UDP transport notification over years and is a replacement draft for both draft-zheng-netconf-udp-pub-channel and draft-unyte-netconf-udp-notif and represents a broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No controversy. The need of congestion control was brought up during TSVART review and discussed in IETF 119 NETCONF session and rough consensus had been reached on detailed level of congestion control. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There are 4 known open source implementations and 3 implementations from network vendors, which have been documented in section 9 of rev-22 of this document. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document uses transport technology in WIT area and has been reviewed by TSVART https://mailarchive.ietf.org/arch/msg/netconf/J8YeAHqnqIiyj-QqXdBx4nToXUw/ The comments from TSVART have been addressed in v-12. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. This document has been reviewed by YANG Doctor, the review result is available at: https://datatracker.ietf.org/doc/review-ietf-netconf-udp-notif-20-yangdoctors-early-schoenwaelder-2025-04-16/ No message states that the YANG Doctors review is cleared. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? 3 pyang command tools "pyang --ietf ","pyang --lint" and "yanglint" have been used to validate v-22 of YANG module included in this document, there are no errors or warnings to be found. But there appears to be a author list mismatch by checking YANG module, i.e., Authors list embedded in the YANG Data Model in section 7.2 is not consistent with author list in the front page for this document. Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? Yes 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. Manual review of the XML examples in Appendix A. There are no errors or warnings to be found. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? N/A 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because Capabilities for high frequency UDP based Data Collection are needed by both NETCONF clients and RESTCONF client. The "Intended RFC Status" in Datatracker has to be set to reflect this intent. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. All authors have responded not being aware of any IPR: https://mailarchive.ietf.org/arch/msg/netconf/VQUz-x7mEWVmdxwG_ZZAbN-mlUk/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. The document has 5 authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Checking nits according to https://www.ietf.org/id-info/checklist : ---------------------------------------------------------------------------- Miscellaneous warnings: ---------------------------------------------------------------------------- -- The document date (3 July 2025) is 70 days in the past. Is this intentional? Checking references for intended status: Proposed Standard ---------------------------------------------------------------------------- (See RFCs 3967 and 4897 for information about using normative references to lower-maturity documents in RFCs) -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP195' -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP230' == Outdated reference: A later version (-15) exists of draft-ietf-netconf-distributed-notif-14 ** Obsolete normative reference: RFC 6347 (Obsoleted by RFC 9147) Summary: 1 error (**), 0 flaws (~~), 1 warning (==), 3 comments (--). Run idnits with the --verbose option for more detailed information about the items above. I think Outdated reference draft-ietf-netconf-distributed-notif needs to be changed into v-15. For Obsolete normative reference RFC6347, I believe it is intentional to reference both TLS1.2 and TLS1.3 therefore this error is innocuous and can be ignored. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. References are cited properly. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. None. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? None. This document adds dependency to two other documents: [I-D.ietf-netconf-distributed-notif] and [I-D.ietf-netconf-udp-client-server]. Both documents will be submitted to the IESG in parallel for publication. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No change. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document shepherd has reviewed IANA considerations section and confirm three new registries are correctly defined and consistent with the body of this document. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. N/A [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2025-10-03
|
22 | Magnus Westerlund | Request for Early review by TSVART is assigned to Michael Tüxen |
|
2025-10-02
|
22 | Kent Watsen | Requested Early review by TSVART |
|
2025-09-18
|
22 | Qin Wu | # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the … # Document Shepherd Write-Up for Group Documents *This version is dated 12 September 2025.* Thank you for your service as a document shepherd. Among the responsibilities is answering the questions in this write-up to give helpful context to Last Call and Internet Engineering Steering Group ([IESG][1]) reviewers, and your diligence in completing it is appreciated. The full role of the shepherd is further described in [RFC 4858][2]. You will need the cooperation of the authors and editors to complete these checks. Note that some numbered items contain multiple related questions; please be sure to answer all of them. ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? Yes, this work has benefited from the discussion of UDP transport notification over years and is a replacement draft for both draft-zheng-netconf-udp-pub-channel and draft-unyte-netconf-udp-notif and represents a broad agreement. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? No controversy. The need of congestion control was brought up during TSVART review and discussed in IETF 119 NETCONF session and rough consensus had been reached on detailed level of congestion control. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? There are 4 known open source implementations and 3 implementations from network vendors, which have been documented in section 9 of rev-22 of this document. ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. This document uses transport technology in WIT area and has been reviewed by TSVART https://mailarchive.ietf.org/arch/msg/netconf/J8YeAHqnqIiyj-QqXdBx4nToXUw/ The comments from TSVART have been addressed in v-12. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. This document has been reviewed by YANG Doctor, the review result is available at: https://datatracker.ietf.org/doc/review-ietf-netconf-udp-notif-20-yangdoctors-early-schoenwaelder-2025-04-16/ Resolution of the comments was satisfactory to the YANG Doctor. 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? 3 pyang command tools "pyang --ietf ","pyang --lint" and "yanglint" have been used to validate v-22 of YANG module included in this document, there are no errors or warnings to be found. But there appears to be a author list mismatch by checking YANG module, i.e., Authors list embedded in the YANG Data Model in section 7.2 is not consistent with author list in the front page for this document. Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? Yes 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. Manual review of the XML examples in Appendix A. There are no errors or warnings to be found. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? N/A 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? Proposed Standard. Because Capabilities for high frequency UDP based Data Collection are needed by both NETCONF clients and RESTCONF client. The "Intended RFC Status" in Datatracker has to be set to reflect this intent. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. All authors have responded not being aware of any IPR: https://mailarchive.ietf.org/arch/msg/netconf/VQUz-x7mEWVmdxwG_ZZAbN-mlUk/ 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. The document has 5 authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Checking nits according to https://www.ietf.org/id-info/checklist : ---------------------------------------------------------------------------- Miscellaneous warnings: ---------------------------------------------------------------------------- -- The document date (3 July 2025) is 70 days in the past. Is this intentional? Checking references for intended status: Proposed Standard ---------------------------------------------------------------------------- (See RFCs 3967 and 4897 for information about using normative references to lower-maturity documents in RFCs) -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP195' -- Possible downref: Non-RFC (?) normative reference: ref. 'BCP230' == Outdated reference: A later version (-15) exists of draft-ietf-netconf-distributed-notif-14 ** Obsolete normative reference: RFC 6347 (Obsoleted by RFC 9147) Summary: 1 error (**), 0 flaws (~~), 1 warning (==), 3 comments (--). Run idnits with the --verbose option for more detailed information about the items above. I think Outdated reference draft-ietf-netconf-distributed-notif needs to be changed into v-15. For Obsolete normative reference RFC6347, I believe it is intentional to reference both TLS1.2 and TLS1.3 therefore this error is innocuous and can be ignored. 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. References are cited properly. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. None. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? None. This document adds dependency to two other documents: [I-D.ietf-netconf-distributed-notif] and [I-D.ietf-netconf-udp-client-server]. Both documents will be submitted to the IESG in parallel for publication. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No change. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document shepherd has reviewed IANA considerations section and confirm two existing registries (one is the "IETF XML" registry and the otheris the "YANG Module Names" registry) are updated and correctly specified and consistent with the body of this document.The referenced IANA registries have been clearly identified. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. N/A [1]: https://www.ietf.org/about/groups/iesg/ [2]: https://www.rfc-editor.org/rfc/rfc4858.html [3]: https://www.rfc-editor.org/rfc/rfc7942.html [4]: https://wiki.ietf.org/group/ops/yang-review-tools [5]: https://www.rfc-editor.org/rfc/rfc8342.html [6]: https://wiki.ietf.org/group/iesg/ExpertTopics [7]: https://www.rfc-editor.org/info/bcp79 [8]: https://www.ietf.org/tools/idnits/ [9]: https://www.rfc-editor.org/rfc/rfc3967.html [10]: https://www.rfc-editor.org/info/bcp97 [11]: https://www.rfc-editor.org/rfc/rfc8126.html [12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5 [13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1 [14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2 [15]: https://authors.ietf.org/en/content-guidelines-overview [16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/ [17]: https://datatracker.ietf.org/doc/downref/ |
|
2025-09-11
|
22 | Kent Watsen | Notification list changed to bill.wu@huawei.com from maqiufang1@huawei.com, bill.wu@huawei.com |
|
2025-09-11
|
22 | Kent Watsen | Notification list changed to maqiufang1@huawei.com, bill.wu@huawei.com from maqiufang1@huawei.com because the document shepherd was set |
|
2025-09-11
|
22 | Kent Watsen | Document shepherd changed to Qin Wu |
|
2025-07-03
|
22 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-22.txt |
|
2025-07-03
|
22 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2025-07-03
|
22 | Alex Huang Feng | Uploaded new revision |
|
2025-06-02
|
21 | Tina Tsou | Request for Early review by OPSDIR Completed: Has Issues. Reviewer: Tina Tsou. Sent review to list. |
|
2025-05-28
|
21 | Bo Wu | Request for Early review by OPSDIR is assigned to Tina Tsou |
|
2025-05-26
|
21 | Bo Wu | Assignment of request for Early review by OPSDIR to Jan Lindblad was withdrawn |
|
2025-05-25
|
21 | Bo Wu | Assignment of request for Early review by OPSDIR to Ron Bonica was withdrawn |
|
2025-05-25
|
21 | Bo Wu | Request for Early review by OPSDIR is assigned to Jan Lindblad |
|
2025-05-14
|
21 | Per Andersson | Changed document external resources from: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif-transport@2025-04-27.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-udp-notif-transport@2025-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) to: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif-transport.yang (Yang catalog … Changed document external resources from: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif-transport@2025-04-27.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-udp-notif-transport@2025-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) to: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif-transport.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-udp-notif-transport.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) |
|
2025-05-14
|
21 | Per Andersson | Changed document external resources from: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module= (ietf-udp-notif-transport@2025-04-27.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]= (ietf-udp-notif-transport@2025-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) to: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif-transport@2025-04-27.yang … Changed document external resources from: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module= (ietf-udp-notif-transport@2025-04-27.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]= (ietf-udp-notif-transport@2025-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) to: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif-transport@2025-04-27.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-udp-notif-transport@2025-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) |
|
2025-05-14
|
21 | Per Andersson | Changed document external resources from: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif@2020-04-27.yang (Yang catalog entry for ietf-udp-notif@2020-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-udp-notif@2020-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) to: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module= (ietf-udp-notif-transport@2025-04-27.yang (Yang … Changed document external resources from: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-udp-notif@2020-04-27.yang (Yang catalog entry for ietf-udp-notif@2020-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-udp-notif@2020-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) to: yc_entry https://www.yangcatalog.org/yang-search/module_details.php?module= (ietf-udp-notif-transport@2025-04-27.yang (Yang catalog entry for ietf-udp-notif-transport@2025-04-27.yang) yc_impact https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]= (ietf-udp-notif-transport@2025-04-27.yang&recurse=0&rfcs=1&show_subm=1&show_dir=both (Yang impact analysis for draft-ietf-netconf-udp-notif) |
|
2025-05-14
|
21 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-21.txt |
|
2025-05-14
|
21 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2025-05-14
|
21 | Alex Huang Feng | Uploaded new revision |
|
2025-04-24
|
20 | Per Andersson | Changed consensus to Yes from Unknown |
|
2025-04-24
|
20 | Per Andersson | Intended Status changed to Proposed Standard from None |
|
2025-04-16
|
20 | Jürgen Schönwälder | Request for Early review by YANGDOCTORS Completed: On the Right Track. Reviewer: Jürgen Schönwälder. Sent review to list. |
|
2025-04-13
|
20 | Bo Wu | Request for Early review by OPSDIR is assigned to Ron Bonica |
|
2025-04-08
|
20 | Mehmet Ersue | Request for Early review by YANGDOCTORS is assigned to Jürgen Schönwälder |
|
2025-04-08
|
20 | Per Andersson | Requested Early review by YANGDOCTORS |
|
2025-04-08
|
20 | Per Andersson | Requested Early review by OPSDIR |
|
2025-04-03
|
20 | Per Andersson | Notification list changed to maqiufang1@huawei.com because the document shepherd was set |
|
2025-04-03
|
20 | Per Andersson | Document shepherd changed to Qiufang Ma |
|
2025-03-06
|
20 | Per Andersson | IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call |
|
2025-03-03
|
20 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-20.txt |
|
2025-03-03
|
20 | (System) | New version approved |
|
2025-03-03
|
20 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2025-03-03
|
20 | Alex Huang Feng | Uploaded new revision |
|
2025-02-21
|
19 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-19.txt |
|
2025-02-21
|
19 | (System) | New version approved |
|
2025-02-21
|
19 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2025-02-21
|
19 | Alex Huang Feng | Uploaded new revision |
|
2025-02-06
|
18 | Per Andersson | IETF WG state changed to In WG Last Call from WG Document |
|
2025-01-13
|
18 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-18.txt |
|
2025-01-13
|
18 | Thomas Graf | New version accepted (logged-in submitter: Thomas Graf) |
|
2025-01-13
|
18 | Thomas Graf | Uploaded new revision |
|
2024-12-01
|
17 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-17.txt |
|
2024-12-01
|
17 | Thomas Graf | New version accepted (logged-in submitter: Thomas Graf) |
|
2024-12-01
|
17 | Thomas Graf | Uploaded new revision |
|
2024-10-21
|
16 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-16.txt |
|
2024-10-21
|
16 | (System) | New version approved |
|
2024-10-21
|
16 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2024-10-21
|
16 | Alex Huang Feng | Uploaded new revision |
|
2024-10-17
|
15 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-15.txt |
|
2024-10-17
|
15 | (System) | New version approved |
|
2024-10-17
|
15 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2024-10-17
|
15 | Alex Huang Feng | Uploaded new revision |
|
2024-07-04
|
14 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-14.txt |
|
2024-07-04
|
14 | (System) | New version approved |
|
2024-07-04
|
14 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2024-07-04
|
14 | Alex Huang Feng | Uploaded new revision |
|
2024-06-27
|
13 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-13.txt |
|
2024-06-27
|
13 | (System) | New version approved |
|
2024-06-27
|
13 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2024-06-27
|
13 | Alex Huang Feng | Uploaded new revision |
|
2024-01-21
|
12 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-12.txt |
|
2024-01-21
|
12 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2024-01-21
|
12 | Alex Huang Feng | Uploaded new revision |
|
2023-11-17
|
11 | Michael Tüxen | Request for Early review by TSVART Completed: Not Ready. Reviewer: Michael Tüxen. Review has been revised by Michael Tüxen. |
|
2023-11-15
|
11 | Michael Tüxen | Request for Early review by TSVART Completed: Not Ready. Reviewer: Michael Tüxen. Sent review to list. |
|
2023-10-20
|
11 | Magnus Westerlund | Request for Early review by TSVART is assigned to Michael Tüxen |
|
2023-10-19
|
11 | Mahesh Jethanandani | Requested Early review by TSVART |
|
2023-10-11
|
11 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-11.txt |
|
2023-10-11
|
11 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2023-10-11
|
11 | Alex Huang Feng | Uploaded new revision |
|
2023-07-07
|
10 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-10.txt |
|
2023-07-07
|
10 | Thomas Graf | New version accepted (logged-in submitter: Thomas Graf) |
|
2023-07-07
|
10 | Thomas Graf | Uploaded new revision |
|
2023-03-17
|
09 | Mahesh Jethanandani | Added to session: IETF-116: netconf Mon-0400 |
|
2023-03-10
|
09 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-09.txt |
|
2023-03-10
|
09 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2023-03-10
|
09 | Alex Huang Feng | Uploaded new revision |
|
2022-09-12
|
08 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-08.txt |
|
2022-09-12
|
08 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2022-09-12
|
08 | Alex Huang Feng | Uploaded new revision |
|
2022-07-11
|
07 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-07.txt |
|
2022-07-11
|
07 | Alex Huang Feng | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2022-07-11
|
07 | Alex Huang Feng | Uploaded new revision |
|
2022-06-29
|
06 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-06.txt |
|
2022-06-29
|
06 | (System) | New version approved |
|
2022-06-29
|
06 | (System) | Request for posting confirmation emailed to previous authors: Alex Feng , Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2022-06-29
|
06 | Alex Huang Feng | Uploaded new revision |
|
2022-03-04
|
05 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-05.txt |
|
2022-03-04
|
05 | (System) | New version accepted (logged-in submitter: Alex Huang Feng) |
|
2022-03-04
|
05 | Alex Huang Feng | Uploaded new revision |
|
2021-10-21
|
04 | Alex Huang Feng | New version available: draft-ietf-netconf-udp-notif-04.txt |
|
2021-10-21
|
04 | (System) | New version approved |
|
2021-10-21
|
04 | (System) | Request for posting confirmation emailed to previous authors: Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou , netconf-chairs@ietf.org |
|
2021-10-21
|
04 | Alex Huang Feng | Uploaded new revision |
|
2021-07-12
|
03 | Pierre Francois | New version available: draft-ietf-netconf-udp-notif-03.txt |
|
2021-07-12
|
03 | (System) | New version approved |
|
2021-07-12
|
03 | (System) | Request for posting confirmation emailed to previous authors: Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2021-07-12
|
03 | Pierre Francois | Uploaded new revision |
|
2021-05-25
|
02 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-02.txt |
|
2021-05-25
|
02 | (System) | New version approved |
|
2021-05-25
|
02 | (System) | Request for posting confirmation emailed to previous authors: Guangying Zheng , Paolo Lucente , Pierre Francois , Thomas Graf , Tianran Zhou |
|
2021-05-25
|
02 | Thomas Graf | Uploaded new revision |
|
2021-05-06
|
01 | (System) | Document has expired |
|
2020-11-02
|
01 | Pierre Francois | New version available: draft-ietf-netconf-udp-notif-01.txt |
|
2020-11-02
|
01 | (System) | New version approved |
|
2020-11-02
|
01 | (System) | Request for posting confirmation emailed to previous authors: Pierre Francois , Thomas Graf , Tianran Zhou , Paolo Lucente , Guangying Zheng |
|
2020-11-02
|
01 | Pierre Francois | Uploaded new revision |
|
2020-10-02
|
00 | Mahesh Jethanandani | This document now replaces draft-unyte-netconf-udp-notif instead of None |
|
2020-10-02
|
00 | Thomas Graf | New version available: draft-ietf-netconf-udp-notif-00.txt |
|
2020-10-02
|
00 | (System) | WG -00 approved |
|
2020-10-02
|
00 | Thomas Graf | Set submitter to "Thomas Graf ", replaces to draft-unyte-netconf-udp-notif and sent approval email to group chairs: netconf-chairs@ietf.org |
|
2020-10-02
|
00 | Thomas Graf | Uploaded new revision |