Skip to main content

Support of Versioning in YANG Notifications Subscription
draft-ietf-netconf-yang-notifications-versioning-16

Revision differences

Document history

Date Rev. By Action
2026-09-29
16 (System) IESG state changed to Waiting for AD Go-Ahead from In Last Call
2026-09-28
16 Sabrina Tanamal IANA Experts State changed to Reviews assigned
2026-09-28
16 Sabrina Tanamal
IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-netconf-yang-notifications-versioning-16. If any part of this review is inaccurate, please let us know.

IANA understands that, upon …
IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-netconf-yang-notifications-versioning-16. If any part of this review is inaccurate, please let us know.

IANA understands that, upon approval of this document, there are two actions which we must complete.

First, in the ns registry on the IETF XML Registry page located at:

https://www.iana.org/assignments/xml-registry/

a new namespace will be registered as follows:

ID: yang:ietf-yang-push-revision
URI: urn:ietf:params:xml:ns:yang:ietf-yang-push-revision
Filename: [ TBD-at-Registration ]
Reference: [ RFC-to-be ]

As this document requests registrations in a Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. Expert review will need to be completed before your document can be approved for publication as an RFC.

Second, in the YANG Module Names registry on the YANG Parameters registry page located at:

https://www.iana.org/assignments/yang-parameters/

a new YANG module will be registered as follows:

Name: ietf-yang-push-revision
File: [ TBD-at-Registration ]
Maintained by IANA? N
Namespace: urn:ietf:params:xml:ns:yang:ietf-yang-push-revision
Prefix: ypr
Module:
Reference: [ RFC-to-be ]

While the YANG module name will be registered after the IESG approves the document, the YANG module file will be posted after the RFC Editor notifies us that the document has been published.

We understand that these are the only actions required to be completed upon approval of this document.

NOTE: The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed.

For definitions of IANA review states, please see:

https://datatracker.ietf.org/help/state/draft/iana-review

Thank you,

Sabrina Tanamal
IANA
2026-09-28
16 (System) IANA Review state changed to IANA - Not OK from IANA - Review Needed
2026-09-25
16 Barry Leiba Closed request for IETF Last Call review by ARTART with state 'Team Will not Review Document'
2026-09-24
16 Dave Thaler Request for IETF Last Call review by SECDIR Completed: Has Nits. Reviewer: Dave Thaler. Sent review to list.
2026-09-21
16 Christer Holmberg Request for IETF Last Call review by GENART Completed: Ready with Issues. Reviewer: Christer Holmberg. Sent review to list.
2026-09-18
16 Tero Kivinen Request for IETF Last Call review by SECDIR is assigned to Dave Thaler
2026-09-17
16 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-16.txt
2026-09-17
16 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2026-09-17
16 Thomas Graf Uploaded new revision
2026-09-16
15 Jean Mahoney Request for IETF Last Call review by GENART is assigned to Christer Holmberg
2026-09-16
15 Per Andersson Request for IETF Last Call review by YANGDOCTORS is assigned to Robert Wills
2026-09-16
15 Per Andersson Assignment of request for IETF Last Call review by YANGDOCTORS to Italo Busi was rejected
2026-09-16
15 Per Andersson Request for IETF Last Call review by YANGDOCTORS is assigned to Italo Busi
2026-09-15
15 Morgan Condie IANA Review state changed to IANA - Review Needed
2026-09-15
15 Morgan Condie
The following Last Call announcement was sent out (ends 2026-09-29):

From: The IESG
To: IETF-Announce
CC: draft-ietf-netconf-yang-notifications-versioning@ietf.org, mjethanandani@gmail.com, netconf-chairs@ietf.org, netconf@ietf.org, tahiliani.ietf@gmail.com …
The following Last Call announcement was sent out (ends 2026-09-29):

From: The IESG
To: IETF-Announce
CC: draft-ietf-netconf-yang-notifications-versioning@ietf.org, mjethanandani@gmail.com, netconf-chairs@ietf.org, netconf@ietf.org, tahiliani.ietf@gmail.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  (Support of Versioning in YANG Notifications Subscription) to Proposed Standard


The IESG has received a request from the Network Configuration WG (netconf)
to consider the following document: - 'Support of Versioning in YANG
Notifications Subscription'
  as Proposed
  Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
last-call@ietf.org mailing lists by 2026-09-29. Exceptionally, comments may
be sent to iesg@ietf.org instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract


  This document defines a YANG module which extends the YANG-Push
  Subscription mechanism to enforce that particular revisions or
  semantic versions are used when configuring or establishing a
  Subscription.  It also extends the YANG-Push Subscription state
  change Notifications to include additional context about the YANG
  schema associated with the Subscription.




The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-notifications-versioning/



No IPR declarations have been submitted directly on this I-D.




2026-09-15
15 Morgan Condie IESG state changed to In Last Call from Last Call Requested
2026-09-15
15 Mahesh Jethanandani Last call was requested
2026-09-15
15 Mahesh Jethanandani Last call announcement was generated
2026-09-15
15 Mahesh Jethanandani Ballot approval text was generated
2026-09-15
15 Mahesh Jethanandani Ballot writeup was generated
2026-09-15
15 Mahesh Jethanandani IESG state changed to Last Call Requested from AD Evaluation::AD Followup
2026-09-15
15 Mahesh Jethanandani Requested IETF Last Call review by ARTART
2026-09-15
15 Mahesh Jethanandani Requested IETF Last Call review by GENART
2026-09-15
15 Mahesh Jethanandani Requested IETF Last Call review by YANGDOCTORS
2026-09-15
15 Mahesh Jethanandani Requested IETF Last Call review by SECDIR
2026-09-14
15 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-09-14
15 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-09-14
15 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-15.txt
2026-09-14
15 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2026-09-14
15 Thomas Graf Uploaded new revision
2026-08-08
14 Mahesh Jethanandani Please see AD review comments at https://mailarchive.ietf.org/arch/msg/netconf/zFSKfUy1VFuu3zbsubgfqOjh0x8/. I anticipate that the document will require a revision.
2026-08-08
14 (System) Changed action holders to Mahesh Jethanandani, Thomas Graf, Benoît Claise, Alex Huang Feng (IESG state changed)
2026-08-08
14 Mahesh Jethanandani IESG state changed to AD Evaluation::Revised I-D Needed from Publication Requested
2026-07-03
14 Per Andersson
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.


Note that some numbered items contain multiple related questions; please be sure
to answer all of them.


## Document History


1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?


Shepherd:
The WG consensus represents strong concurrence from many individuals, with additional comments received during the review process. The WGLC resulted in a few minor reviews and comments, and the document was revised accordingly. No objections to publication were raised. As such, the document has achieved broad agreement within the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?


Shepherd:
There was no controversy about particular points, or decisions where the consensus was rough.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)


Shepherd:
No one threatened an appeal or indicated extreme discontent.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

Shepherd:
Yes. The draft includes an Implementation Status section (Section 8) in accordance with RFC 7942. It reports independent implementations in Huawei VRP, 6WIND Virtual Service Router (VSR), and Cisco IOS XR, demonstrating that the YANG notification versioning extensions have been implemented by multiple vendors


## Additional Reviews


5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.


Shepherd:
Reviews have been conducted within the NETCONF Working Group. No additional cross-WG or external reviews were deemed necessary.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.


Shepherd:
The YANG module in the document has undergone an early YANG Doctor review during the NETCONF Working Group process, with feedback incorporated into subsequent revisions.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?


Shepherd:
Yes. The final version of the module has been checked for syntax and formatting validation. There are no errors, no warnings.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.


Shepherd:
The XML and JSON examples were manually reviewed by the shepherd. No issues affecting the technical correctness of the document were found.

Chair:

Some of the XML and JSON snippets had issues that needed to be addressed.
The issues raised have been addressed.


## Document Shepherd Checks


9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?


Shepherd:
Yes. Based on the shepherd’s review, the document is needed, clearly written, and complete, and it is ready to be forwarded to the responsible Area Director.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?


Shepherd:
The shepherd reviewed the document and the feedback received on the mailing list of NETCONF, and did not identify any concerns requiring further review.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?


Shepherd:
Proposed Standard. This is appropriate because it extends the standardized NETCONF/YANG-Push ecosystem with additional protocol mechanisms for subscription-level YANG module versioning, and is intended for interoperable implementation across multiple vendors. The functionality is protocol-facing and normatively specifies extensions to existing standardized behaviors, rather than being purely informational or experimental. The Datatracker state attributes correctly reflect this intent.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.


Shepherd:
Yes. The authors have confirmed that they are not aware of any IPR that applies to this document (https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/).


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.


Shepherd:
Yes. The authors have confirmed their willingness to be listed in the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)


Shepherd:
The shepherd reviewed the document and did not find any issues beyond those reported by the idnits tool.


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].


Shepherd:
All references seem appropriate.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?


Shepherd:
All normative references are freely available.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.


Shepherd:
Not applicable to this document.


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?


Shepherd:
Not applicable to this document.


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.


Shepherd:
No. Publication of this document will not change the status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).


Shepherd:
The IANA Considerations section is consistent with the document and specifies two registrations: a new XML namespace URI in the IETF XML Registry and a new YANG module entry in the YANG Module Names registry for ietf-yang-push-revision. The requested actions are correctly specified and aligned with the module definition.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.


Shepherd:
All IANA actions are limited to registering an XML namespace URI and a YANG module entry in existing registries, both of which follow established registration procedures. This document does not create any new IANA registries and therefore does not require Designated Expert Review.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-07-03
14 Per Andersson IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up
2026-07-03
14 Per Andersson IESG state changed to Publication Requested from I-D Exists
2026-07-03
14 (System) Changed action holders to Mahesh Jethanandani (IESG state changed)
2026-07-03
14 Per Andersson Responsible AD changed to Mahesh Jethanandani
2026-07-03
14 Per Andersson Document is now in IESG state Publication Requested
2026-07-02
14 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-14.txt
2026-07-02
14 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2026-07-02
14 Thomas Graf Uploaded new revision
2026-07-02
13 Per Andersson
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.


Note that some numbered items contain multiple related questions; please be sure
to answer all of them.


## Document History


1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?


Shepherd:
The WG consensus represents strong concurrence from many individuals, with additional comments received during the review process. The WGLC resulted in a few minor reviews and comments, and the document was revised accordingly. No objections to publication were raised. As such, the document has achieved broad agreement within the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?


Shepherd:
There was no controversy about particular points, or decisions where the consensus was rough.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)


Shepherd:
No one threatened an appeal or indicated extreme discontent.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

Shepherd:
Yes. The draft includes an Implementation Status section (Section 8) in accordance with RFC 7942. It reports independent implementations in Huawei VRP, 6WIND Virtual Service Router (VSR), and Cisco IOS XR, demonstrating that the YANG notification versioning extensions have been implemented by multiple vendors


## Additional Reviews


5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.


Shepherd:
Reviews have been conducted within the NETCONF Working Group. No additional cross-WG or external reviews were deemed necessary.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.


Shepherd:
The YANG module in the document has undergone an early YANG Doctor review during the NETCONF Working Group process, with feedback incorporated into subsequent revisions.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?


Shepherd:
Yes. The final version of the module has been checked for syntax and formatting validation. There are no errors, no warnings.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.


Shepherd:
The XML and JSON examples were manually reviewed by the shepherd. No issues affecting the technical correctness of the document were found.

Chair:

Some of the XML and JSON snippets had issues that needed to be addressed.
The issues raised have been addressed.


## Document Shepherd Checks


9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?


Shepherd:
Yes. Based on the shepherd’s review, the document is needed, clearly written, and complete, and it is ready to be forwarded to the responsible Area Director.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?


Shepherd:
The shepherd reviewed the document and the feedback received on the mailing list of NETCONF, and did not identify any concerns requiring further review.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?


Shepherd:
Proposed Standard. This is appropriate because it extends the standardized NETCONF/YANG-Push ecosystem with additional protocol mechanisms for subscription-level YANG module versioning, and is intended for interoperable implementation across multiple vendors. The functionality is protocol-facing and normatively specifies extensions to existing standardized behaviors, rather than being purely informational or experimental. The Datatracker state attributes correctly reflect this intent.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.


Shepherd:
Yes. The authors have confirmed that they are not aware of any IPR that applies to this document (https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/).


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.


Shepherd:
Yes. The authors have confirmed their willingness to be listed in the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)


Shepherd:
The shepherd reviewed the document and did not find any issues beyond those reported by the idnits tool.


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].


Shepherd:
All references seem appropriate.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?


Shepherd:
All normative references are freely available.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.


Shepherd:
Not applicable to this document.


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?


Shepherd:
Not applicable to this document.


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.


Shepherd:
No. Publication of this document will not change the status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).


Shepherd:
The IANA Considerations section is consistent with the document and specifies two registrations: a new XML namespace URI in the IETF XML Registry and a new YANG module entry in the YANG Module Names registry for ietf-yang-push-revision. The requested actions are correctly specified and aligned with the module definition.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.


Shepherd:
All IANA actions are limited to registering an XML namespace URI and a YANG module entry in existing registries, both of which follow established registration procedures. This document does not create any new IANA registries and therefore does not require Designated Expert Review.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-07-02
13 Per Andersson
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.


Note that some numbered items contain multiple related questions; please be sure
to answer all of them.


## Document History


1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?


Shepherd:
The WG consensus represents strong concurrence from many individuals, with additional comments received during the review process. The WGLC resulted in a few minor reviews and comments, and the document was revised accordingly. No objections to publication were raised. As such, the document has achieved broad agreement within the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?


Shepherd:
There was no controversy about particular points, or decisions where the consensus was rough.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)


Shepherd:
No one threatened an appeal or indicated extreme discontent.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

Shepherd:
Yes. The draft includes an Implementation Status section (Section 8) in accordance with RFC 7942. It reports independent implementations in Huawei VRP, 6WIND Virtual Service Router (VSR), and Cisco IOS XR, demonstrating that the YANG notification versioning extensions have been implemented by multiple vendors


## Additional Reviews


5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.


Shepherd:
Reviews have been conducted within the NETCONF Working Group. No additional cross-WG or external reviews were deemed necessary.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.


Shepherd:
The YANG module in the document has undergone an early YANG Doctor review during the NETCONF Working Group process, with feedback incorporated into subsequent revisions.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?


Shepherd:
Yes. The final version of the module has been checked for syntax and formatting validation. There are no errors, no warnings.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.


Shepherd:
The XML and JSON examples were manually reviewed by the shepherd. No issues affecting the technical correctness of the document were found.

Chair:

Some of the XML and JSON snippets had issues that needed to be addressed.
The issues raised have been addressed.


## Document Shepherd Checks


9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?


Shepherd:
Yes. Based on the shepherd’s review, the document is needed, clearly written, and complete, and it is ready to be forwarded to the responsible Area Director.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?


Shepherd:
The shepherd reviewed the document and the feedback received on the mailing list of NETCONF, and did not identify any concerns requiring further review.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?


Shepherd:
Proposed Standard. This is appropriate because it extends the standardized NETCONF/YANG-Push ecosystem with additional protocol mechanisms for subscription-level YANG module versioning, and is intended for interoperable implementation across multiple vendors. The functionality is protocol-facing and normatively specifies extensions to existing standardized behaviors, rather than being purely informational or experimental. The Datatracker state attributes correctly reflect this intent.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.


Shepherd:
Yes. The authors have confirmed that they are not aware of any IPR that applies to this document (https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/).

Chair:
Link to IPR thread.

https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.


Shepherd:
Yes. The authors have confirmed their willingness to be listed in the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)


Shepherd:
The shepherd reviewed the document and did not find any issues beyond those reported by the idnits tool.


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].


Shepherd:
All references seem appropriate.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?


Shepherd:
All normative references are freely available.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.


Shepherd:
Not applicable to this document.


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?


Shepherd:
Not applicable to this document.


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.


Shepherd:
No. Publication of this document will not change the status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).


Shepherd:
The IANA Considerations section is consistent with the document and specifies two registrations: a new XML namespace URI in the IETF XML Registry and a new YANG module entry in the YANG Module Names registry for ietf-yang-push-revision. The requested actions are correctly specified and aligned with the module definition.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.


Shepherd:
All IANA actions are limited to registering an XML namespace URI and a YANG module entry in existing registries, both of which follow established registration procedures. This document does not create any new IANA registries and therefore does not require Designated Expert Review.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-07-02
13 Mohit Tahiliani
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.


Note that some numbered items contain multiple related questions; please be sure
to answer all of them.


## Document History


1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?


Shepherd:
The WG consensus represents strong concurrence from many individuals, with additional comments received during the review process. The WGLC resulted in a few minor reviews and comments, and the document was revised accordingly. No objections to publication were raised. As such, the document has achieved broad agreement within the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?


Shepherd:
There was no controversy about particular points, or decisions where the consensus was rough.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)


Shepherd:
No one threatened an appeal or indicated extreme discontent.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

Shepherd:
Yes. The draft includes an Implementation Status section (Section 8) in accordance with RFC 7942. It reports independent implementations in Huawei VRP, 6WIND Virtual Service Router (VSR), and Cisco IOS XR, demonstrating that the YANG notification versioning extensions have been implemented by multiple vendors


## Additional Reviews


5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.


Shepherd:
Reviews have been conducted within the NETCONF Working Group. No additional cross-WG or external reviews were deemed necessary.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.


Shepherd:
The YANG module in the document has undergone an early YANG Doctor review during the NETCONF Working Group process, with feedback incorporated into subsequent revisions.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?


Shepherd:
Yes. The final version of the module has been checked for syntax and formatting validation. There are no errors, no warnings.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.


Shepherd:
The XML and JSON examples were manually reviewed by the shepherd. No issues affecting the technical correctness of the document were found.

Chair:

Some of the XML and JSON snippets have issues than need to be addressed.


## Document Shepherd Checks


9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?


Shepherd:
Yes. Based on the shepherd’s review, the document is needed, clearly written, and complete, and it is ready to be forwarded to the responsible Area Director.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?


Shepherd:
The shepherd reviewed the document and the feedback received on the mailing list of NETCONF, and did not identify any concerns requiring further review.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?


Shepherd:
Proposed Standard. This is appropriate because it extends the standardized NETCONF/YANG-Push ecosystem with additional protocol mechanisms for subscription-level YANG module versioning, and is intended for interoperable implementation across multiple vendors. The functionality is protocol-facing and normatively specifies extensions to existing standardized behaviors, rather than being purely informational or experimental. The Datatracker state attributes correctly reflect this intent.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.


Shepherd:
Yes. The authors have confirmed that they are not aware of any IPR that applies to this document (https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/).

Chair:
Link to IPR thread.

https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.


Shepherd:
Yes. The authors have confirmed their willingness to be listed in the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)


Shepherd:
The shepherd reviewed the document and did not find any issues beyond those reported by the idnits tool.


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].


Shepherd:
All references seem appropriate.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?


Shepherd:
All normative references are freely available.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.


Shepherd:
Not applicable to this document.


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?


Shepherd:
Not applicable to this document.


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.


Shepherd:
No. Publication of this document will not change the status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).


Shepherd:
The IANA Considerations section is consistent with the document and specifies two registrations: a new XML namespace URI in the IETF XML Registry and a new YANG module entry in the YANG Module Names registry for ietf-yang-push-revision. The requested actions are correctly specified and aligned with the module definition.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.


Shepherd:
All IANA actions are limited to registering an XML namespace URI and a YANG module entry in existing registries, both of which follow established registration procedures. This document does not create any new IANA registries and therefore does not require Designated Expert Review.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-07-01
13 Alex Huang Feng New version available: draft-ietf-netconf-yang-notifications-versioning-13.txt
2026-07-01
13 Alex Huang Feng New version accepted (logged-in submitter: Alex Huang Feng)
2026-07-01
13 Alex Huang Feng Uploaded new revision
2026-06-25
12 Per Andersson
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.


Note that some numbered items contain multiple related questions; please be sure
to answer all of them.


## Document History


1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?


Shepherd:
The WG consensus represents strong concurrence from many individuals, with additional comments received during the review process. The WGLC resulted in a few minor reviews and comments, and the document was revised accordingly. No objections to publication were raised. As such, the document has achieved broad agreement within the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?


Shepherd:
There was no controversy about particular points, or decisions where the consensus was rough.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)


Shepherd:
No one threatened an appeal or indicated extreme discontent.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

Shepherd:
Yes. The draft includes an Implementation Status section (Section 8) in accordance with RFC 7942. It reports independent implementations in Huawei VRP, 6WIND Virtual Service Router (VSR), and Cisco IOS XR, demonstrating that the YANG notification versioning extensions have been implemented by multiple vendors


## Additional Reviews


5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.


Shepherd:
Reviews have been conducted within the NETCONF Working Group. No additional cross-WG or external reviews were deemed necessary.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.


Shepherd:
The YANG module in the document has undergone an early YANG Doctor review during the NETCONF Working Group process, with feedback incorporated into subsequent revisions.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?


Shepherd:
Yes. The final version of the module has been checked for syntax and formatting validation. There are no errors, no warnings.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.


Shepherd:
Not applicable to this document.

Chair:

Some of the XML and JSON snippets have issues than need to be addressed.


## Document Shepherd Checks


9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?


Shepherd:
Yes. Based on the shepherd’s review, the document is needed, clearly written, and complete, and it is ready to be forwarded to the responsible Area Director.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?


Shepherd:
The shepherd reviewed the document and the feedback received on the mailing list of NETCONF, and did not identify any concerns requiring further review.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?


Shepherd:
Proposed Standard. This is appropriate because it extends the standardized NETCONF/YANG-Push ecosystem with additional protocol mechanisms for subscription-level YANG module versioning, and is intended for interoperable implementation across multiple vendors. The functionality is protocol-facing and normatively specifies extensions to existing standardized behaviors, rather than being purely informational or experimental. The Datatracker state attributes correctly reflect this intent.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.


Shepherd:
Yes. The authors have confirmed that they are not aware of any IPR that applies to this document.

Chair:
Link to IPR thread.

https://mailarchive.ietf.org/arch/msg/netconf/DNcmMc91u8JcQvDzGEpc7cnIFbo/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.


Shepherd:
Yes. The authors have confirmed their willingness to be listed in the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)


Shepherd:
The shepherd reviewed the document and did not find any issues beyond those reported by the idnits tool.


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].


Shepherd:
All references seem appropriate.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?


Shepherd:
All normative references are freely available.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.


Shepherd:
Not applicable to this document.


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?


Shepherd:
Not applicable to this document.


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.


Shepherd:
No. Publication of this document will not change the status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).


Shepherd:
The IANA Considerations section is consistent with the document and specifies two registrations: a new XML namespace URI in the IETF XML Registry and a new YANG module entry in the YANG Module Names registry for ietf-yang-push-revision. The requested actions are correctly specified and aligned with the module definition.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.


Shepherd:
All IANA actions are limited to registering an XML namespace URI and a YANG module entry in existing registries, both of which follow established registration procedures. This document does not create any new IANA registries and therefore does not require Designated Expert Review.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-06-23
12 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-12.txt
2026-06-23
12 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2026-06-23
12 Thomas Graf Uploaded new revision
2026-06-18
11 Mohit Tahiliani
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents


*This version is dated 4 July 2022.*


Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.


Note that some numbered items contain multiple related questions; please be sure
to answer all of them.


## Document History


1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?


Shepherd:
The WG consensus represents strong concurrence from many individuals, with additional comments received during the review process. The WGLC resulted in a few minor reviews and comments, and the document was revised accordingly. No objections to publication were raised. As such, the document has achieved broad agreement within the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?


Shepherd:
There was no controversy about particular points, or decisions where the consensus was rough.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)


Shepherd:
No one threatened an appeal or indicated extreme discontent.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?
Shepherd:
Yes. The draft includes an Implementation Status section (Section 8) in accordance with RFC 7942. It reports independent implementations in Huawei VRP, 6WIND Virtual Service Router (VSR), and Cisco IOS XR, demonstrating that the YANG notification versioning extensions have been implemented by multiple vendors


## Additional Reviews


5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.


Shepherd:
Reviews have been conducted within the NETCONF Working Group. No additional cross-WG or external reviews were deemed necessary.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.


Shepherd:
The YANG module in the document has undergone an early YANG Doctor review during the NETCONF Working Group process, with feedback incorporated into subsequent revisions.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?


Shepherd:
Yes. The final version of the module has been checked for syntax and formatting validation. There are no errors, no warnings.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.


Shepherd:
Not applicable to this document.


## Document Shepherd Checks


9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?


Shepherd:
Yes. Based on the shepherd’s review, the document is needed, clearly written, and complete, and it is ready to be forwarded to the responsible Area Director.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?


Shepherd:
The shepherd reviewed the document and the feedback received on the mailing list of NETCONF, and did not identify any concerns requiring further review.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?


Shepherd:
Proposed Standard. This is appropriate because it extends the standardized NETCONF/YANG-Push ecosystem with additional protocol mechanisms for subscription-level YANG module versioning, and is intended for interoperable implementation across multiple vendors. The functionality is protocol-facing and normatively specifies extensions to existing standardized behaviors, rather than being purely informational or experimental. The Datatracker state attributes correctly reflect this intent.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.


Shepherd:
Yes. The authors have confirmed that they are not aware of any IPR that applies to this document.


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.


Shepherd:
Yes. The authors have confirmed their willingness to be listed in the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)


Shepherd:
The shepherd reviewed the document and did not find any issues beyond those reported by the idnits tool.


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].


Shepherd:
All references seem appropriate.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?


Shepherd:
All normative references are freely available.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.


Shepherd:
Not applicable to this document.


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?


Shepherd:
Not applicable to this document.


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.


Shepherd:
No. Publication of this document will not change the status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).


Shepherd:
The IANA Considerations section is consistent with the document and specifies two registrations: a new XML namespace URI in the IETF XML Registry and a new YANG module entry in the YANG Module Names registry for ietf-yang-push-revision. The requested actions are correctly specified and aligned with the module definition.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.


Shepherd:
All IANA actions are limited to registering an XML namespace URI and a YANG module entry in existing registries, both of which follow established registration procedures. This document does not create any new IANA registries and therefore does not require Designated Expert Review.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-02-12
11 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-11.txt
2026-02-12
11 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2026-02-12
11 Thomas Graf Uploaded new revision
2026-02-04
10 Kent Watsen Notification list changed to tahiliani.ietf@gmail.com because the document shepherd was set
2026-02-04
10 Kent Watsen Document shepherd changed to Mohit P. Tahiliani
2025-12-18
10 Mithun Valaphil IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call
2025-12-10
10 Gabriele Galimberti Request for Early review by OPSDIR Completed: Ready. Reviewer: Gabriele Galimberti. Sent review to list.
2025-11-23
10 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-10.txt
2025-11-23
10 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2025-11-23
10 Thomas Graf Uploaded new revision
2025-11-19
09 Bo Wu Request for Early review by OPSDIR is assigned to Gabriele Galimberti
2025-11-19
09 Mithun Valaphil IETF WG state changed to In WG Last Call from WG Document
2025-11-19
09 Per Andersson Requested Early review by OPSDIR
2025-11-19
09 Robert Wills Request for Early review by YANGDOCTORS Completed: Ready with Nits. Reviewer: Robert Wills. Sent review to list.
2025-10-08
09 Per Andersson Request for Early review by YANGDOCTORS is assigned to Robert Wills
2025-10-08
09 Kent Watsen Requested Early review by YANGDOCTORS
2025-09-05
09 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-09.txt
2025-09-05
09 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2025-09-05
09 Thomas Graf Uploaded new revision
2025-04-24
08 Per Andersson Changed consensus to Yes from Unknown
2025-04-24
08 Per Andersson Intended Status changed to Proposed Standard from None
2025-04-05
08 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-08.txt
2025-04-05
08 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2025-04-05
08 Thomas Graf Uploaded new revision
2025-01-17
07 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-07.txt
2025-01-17
07 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2025-01-17
07 Thomas Graf Uploaded new revision
2024-12-12
06 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-06.txt
2024-12-12
06 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2024-12-12
06 Thomas Graf Uploaded new revision
2024-06-16
05 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-05.txt
2024-06-16
05 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2024-06-16
05 Thomas Graf Uploaded new revision
2024-04-14
04 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-04.txt
2024-04-14
04 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2024-04-14
04 Thomas Graf Uploaded new revision
2023-10-20
03 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-03.txt
2023-10-20
03 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2023-10-20
03 Thomas Graf Uploaded new revision
2023-10-06
02 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-02.txt
2023-10-06
02 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2023-10-06
02 Thomas Graf Uploaded new revision
2023-07-06
01 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-01.txt
2023-07-06
01 Thomas Graf New version accepted (logged-in submitter: Thomas Graf)
2023-07-06
01 Thomas Graf Uploaded new revision
2023-06-19
00 Mahesh Jethanandani This document now replaces draft-tgraf-netconf-yang-notifications-versioning instead of draft-netconf-yang-notifications-versioning
2023-06-19
00 Mahesh Jethanandani This document now replaces draft-netconf-yang-notifications-versioning instead of None
2023-06-19
00 Thomas Graf New version available: draft-ietf-netconf-yang-notifications-versioning-00.txt
2023-06-19
00 Mahesh Jethanandani WG -00 approved
2023-06-18
00 Thomas Graf Set submitter to "Thomas Graf ", replaces to draft-netconf-yang-notifications-versioning and sent approval email to group chairs: netconf-chairs@ietf.org
2023-06-18
00 Thomas Graf Uploaded new revision