Skip to main content

OAuth Identity and Authorization Chaining Across Domains
draft-ietf-oauth-identity-chaining-17

Revision differences

Document history

Date Rev. By Action
2026-08-21
17 (System) RPC status changed to Awaiting First editor from Awaiting Editor Assignment
2026-08-19
17 (System) RPC status changed to Awaiting Editor Assignment from Awaiting First editor
2026-08-13
17 (System) RPC status changed to Awaiting First editor from ref_checker
2026-07-22
17 (System) RPC status changed to ref_checker from formatting
2026-07-19
17 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-17.txt
2026-07-19
17 Brian Campbell New version approved
2026-07-19
17 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-07-19
17 Arndt Schwenkschuster Uploaded new revision
2026-07-10
16 (System) RPC status changed to formatting from blocked: Author Input Required
2026-07-10
16 (System) RFC Editor state changed to In Progress from Blocked
2026-07-09
16 (System) IANA Action state changed to RFC-Ed-Ack from Waiting on RFC Editor
2026-07-08
16 (System) IANA Action state changed to Waiting on RFC Editor from In Progress
2026-07-08
16 (System) IANA Action state changed to In Progress from Waiting on Authors
2026-06-30
16 (System) IANA Action state changed to Waiting on Authors from In Progress
2026-06-26
16 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-16.txt
2026-06-26
16 (System) New version approved
2026-06-26
16 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-06-26
16 Arndt Schwenkschuster Uploaded new revision
2026-06-24
15 Phillip Hallam-Baker Request for IETF Last Call review by SECDIR Completed: Has Issues. Reviewer: Phillip Hallam-Baker. Sent review to list.
2026-06-22
15 (System) RPC status changed to blocked: Author Input Required from Awaiting Editor Assignment
2026-06-22
15 (System) RFC Editor state changed to Blocked from In Progress
2026-06-22
15 (System) RPC status changed to Awaiting Editor Assignment
2026-06-22
15 (System) RFC Editor state changed to In Progress
2026-06-22
15 (System) IESG state changed to RFC Ed Queue from Approved-announcement sent
2026-06-22
15 (System) Announcement was received by RFC Editor
2026-06-22
15 (System) IANA Action state changed to In Progress
2026-06-22
15 (System) Removed all action holders (IESG state changed)
2026-06-22
15 Morgan Condie IESG state changed to Approved-announcement sent from Approved-announcement to be sent
2026-06-22
15 Morgan Condie IESG has approved the document
2026-06-22
15 Morgan Condie Closed "Approve" ballot
2026-06-22
15 Morgan Condie Ballot approval text was generated
2026-06-22
15 Morgan Condie Ballot writeup was changed
2026-06-19
15 Deb Cooley IESG state changed to Approved-announcement to be sent from Approved-announcement to be sent::AD Followup
2026-06-19
15 (System) Changed action holders to Deb Cooley (IESG state changed)
2026-06-19
15 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-06-19
15 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-15.txt
2026-06-19
15 (System) New version approved
2026-06-19
15 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-06-19
15 Arndt Schwenkschuster Uploaded new revision
2026-06-04
14 (System) Changed action holders to Arndt Schwenkschuster, Pieter Kasselman, Kelley Burgin, Michael Jenkins, Brian Campbell, Aaron Parecki (IESG state changed)
2026-06-04
14 Cindy Morgan IESG state changed to Approved-announcement to be sent::Revised I-D Needed from IESG Evaluation
2026-06-03
14 Tommy Jensen [Ballot Position Update] New position, No Objection, has been recorded for Tommy Jensen
2026-06-03
14 Christopher Inacio
[Ballot comment]
Thanks to Russ H. for the review.  Thanks to Rifat for the shepherd write up, nice to see the implementations.

Thanks to the …
[Ballot comment]
Thanks to Russ H. for the review.  Thanks to Rifat for the shepherd write up, nice to see the implementations.

Thanks to the authors for a very concise document.
2026-06-03
14 Christopher Inacio [Ballot Position Update] New position, No Objection, has been recorded for Christopher Inacio
2026-06-03
14 Mike Bishop [Ballot Position Update] New position, No Objection, has been recorded for Mike Bishop
2026-06-03
14 Amanda Baber IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed
2026-06-03
14 Roman Danyliw
[Ballot comment]
Thank you to Lars Eggert for the GENART review.

To the responsible AD
-- does the >5 author count make sense for this …
[Ballot comment]
Thank you to Lars Eggert for the GENART review.

To the responsible AD
-- does the >5 author count make sense for this document?
-- as this document scope is covered in the new 05-05 charter up for approval, could it be ensured that they see approval concurrently?
2026-06-03
14 Roman Danyliw [Ballot Position Update] New position, No Objection, has been recorded for Roman Danyliw
2026-06-03
14 Mohamed Boucadair
[Ballot comment]
Hi Arndt, Pieter, Kelley, Michael, Brian, and Aaron,

Thank you for the effort put into this document.

Thanks to Bing Liu for the …
[Ballot comment]
Hi Arndt, Pieter, Kelley, Michael, Brian, and Aaron,

Thank you for the effort put into this document.

Thanks to Bing Liu for the OPSDIR review and the authors for engaging.

Please find below some few minor comments:

# It is not clear at this stage how a client knows that server in that other domain:

CURRENT:
  The client in trust domain A then presents
  the received grant as an assertion to the authorization server in
  trust domain B, using the JWT authorization grant feature of ..

An easy fix is s/trust domain B/trust domain B (Section 2.2)

# Mysterious use cases

CURRENT:
  The identity and authorization chaining flow outlined below describes
  how a combination of OAuth 2.0 Token Exchange [RFC8693] and JWT
  Profile for OAuth 2.0 Client Authentication and Authorization Grants
  [RFC7523] are used to address the use cases identified.

Which use cases are we referring to here? Those in the appendix? Else? Please clarify in the text.

# Figure 1

How a client knows its trust domain and what triggers discovery of a server in another domain?

# Discovery

CURRENT:
  This specification does not define authorization server discovery.  A
  client may use the authorization_servers property as defined in OAuth
  2.0 Protected Resource Metadata [RFC9728], maintain a static mapping
  or use other means to identify the authorization server.

The second sentence lists discovery examples which may be interpreted as contradicting with “not define”.

I think “s/does not define/does not mandate any” or similar would be better.

# I suggest to add a mention in the main body to introduce the appendixes.

# A PR with some nits and minor edits [1]. Feel free to grab whatever useful for you.

Cheers,
Med

[1] https://github.com/oauth-wg/oauth-identity-chaining/pull/193
2026-06-03
14 Mohamed Boucadair [Ballot Position Update] New position, No Objection, has been recorded for Mohamed Boucadair
2026-06-02
14 Éric Vyncke
[Ballot comment]
Thanks for the work done in this document. I regret that the shepherd's write-up does not have real justifications for the intended publication …
[Ballot comment]
Thanks for the work done in this document. I regret that the shepherd's write-up does not have real justifications for the intended publication status or for the number of authors.

In section 2.5, should this rather be a "MUST" in `Authorization Servers SHOULD verify that the requested scopes are not higher privileged than the scopes of the presented subject_token` ? If "SHOULD" is kept, then please provide the additional guidance per https://datatracker.ietf.org/doc/statement-iesg-statement-on-clarifying-the-use-of-bcp-14-key-words/

The same issue in section 5.4, i.e., why not a "MUST NOT" in `The authorization server in trust domain B SHOULD NOT issue refresh tokens ` ?

The same IESG statement also considers that BCP14 terms should not be used in appendix.

Final regret for not using SVG graphics, but this is cosmetic.
2026-06-02
14 Éric Vyncke [Ballot Position Update] New position, No Objection, has been recorded for Éric Vyncke
2026-06-02
14 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-14.txt
2026-06-02
14 (System) New version approved
2026-06-02
14 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-06-02
14 Arndt Schwenkschuster Uploaded new revision
2026-06-02
13 Andy Newton
[Ballot comment]
Many thanks to Russ Housely for the ARTART review.

I have no objections to this document. Thanks to the authors and the working …
[Ballot comment]
Many thanks to Russ Housely for the ARTART review.

I have no objections to this document. Thanks to the authors and the working group for producing this document, and thanks for including a privacy considerations section.
2026-06-02
13 Andy Newton [Ballot Position Update] New position, No Objection, has been recorded for Andy Newton
2026-06-02
13 Ketan Talaulikar
[Ballot comment]
Thanks to the authors and the WG for their work on this document.

I would like to point out that there is some …
[Ballot comment]
Thanks to the authors and the WG for their work on this document.

I would like to point out that there is some text in the IANA Considerations that does not belong there (i.e., it does not have any instructions for IANA) per RFC8126.

"The parameter indicates the supported token types that can be requested in an [RFC8693] Token Exchange."
This seems like a repeat of the Metadata Description and can be deleted?

And then the section 4.2 below is more for information of readers and not something for IANA team to act on. This is better moved somewhere else in the document, I don't have a good suggestion as to where that might be.

4.2. Media Types
This specification does not define any new media types.

Profiles or deployment-specific implementations can adopt explicit typing as defined in JSON Web Token Best Current Practices [RFC8725] and define a new media type [RFC2046] in the "Media Types" registry [IANA.media-types] in the manner described in [RFC6838].
2026-06-02
13 Ketan Talaulikar [Ballot Position Update] New position, No Objection, has been recorded for Ketan Talaulikar
2026-06-02
13 Gunter Van de Velde [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde
2026-06-01
13 (System) IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed
2026-06-01
13 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-13.txt
2026-06-01
13 (System) New version approved
2026-06-01
13 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-06-01
13 Arndt Schwenkschuster Uploaded new revision
2026-05-29
12 (System) IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed
2026-05-27
12 Jim Guichard [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard
2026-05-26
12 David Dong IANA Experts State changed to Expert Reviews OK from Reviews assigned
2026-05-25
12 Gorry Fairhurst [Ballot Position Update] Position for Gorry Fairhurst has been changed to No Objection from No Record
2026-05-25
12 Gorry Fairhurst
[Ballot comment]
Thank you for the work that has been put into this document. I do not see any transport-protocol related concerns.

However, I would …
[Ballot comment]
Thank you for the work that has been put into this document. I do not see any transport-protocol related concerns.

However, I would have found it helpful to have read a more informative abstract.

I would  expect this to explain that request information needs to be preserved when a request crosses one or more trust domains, known as "chaining", and to mention the combination of OAuth 2.0 Token Exchange and the JWT Profile for OAuth 2.0 Client Authentication and Authorization Grants. Please consider adding one or two more lines of text.

Gorry
2026-05-25
12 Gorry Fairhurst Ballot comment text updated for Gorry Fairhurst
2026-05-23
12 Deb Cooley Placed on agenda for telechat - 2026-06-04
2026-05-23
12 Deb Cooley Ballot has been issued
2026-05-23
12 Deb Cooley [Ballot Position Update] New position, Yes, has been recorded for Deb Cooley
2026-05-23
12 Deb Cooley Created "Approve" ballot
2026-05-23
12 Deb Cooley IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead
2026-05-23
12 Deb Cooley Ballot writeup was changed
2026-05-12
12 Bing Liu Request for IETF Last Call review by OPSDIR Completed: Not Ready. Reviewer: Bing Liu. Sent review to list.
2026-05-11
12 (System) IANA Review state changed to Version Changed - Review Needed from IANA - Not OK
2026-05-11
12 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-12.txt
2026-05-11
12 Brian Campbell New version approved
2026-05-11
12 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-05-11
12 Arndt Schwenkschuster Uploaded new revision
2026-05-11
11 (System) IESG state changed to Waiting for AD Go-Ahead from In Last Call
2026-05-07
11 David Dong
IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-oauth-identity-chaining-11. If any part of this review is inaccurate, please let us know.

IANA understands that, upon …
IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-oauth-identity-chaining-11. If any part of this review is inaccurate, please let us know.

IANA understands that, upon approval of this document, there is a single action which we must complete.

In the OAuth Authorization Server Metadata registry in the OAuth Parameters registry group located at:

https://www.iana.org/assignments/oauth-parameters/

a single new registration will be made as follows:

Metadata Name: identity_chaining_requested_token_types_supported
Metadata Description: JSON array containing a list of Token Type Identifiers supported as a requested_token_type in an Identity and Authorization Chaining Token Exchange ([RFC8693]) request.
Change Controller: IETF
Reference: [ RFC-to-be; Section 3 ]

As this section requests a registration in a Specification Required (see RFC 8126) registry, we have initiated the required expert review in a separate ticket. This expert review will need to be completed before your document can be approved for publication as an RFC.

We understand that this is the only action required to be completed upon approval of this document.

NOTE: The action requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the action that will be performed.

For definitions of IANA review states, please see:

https://datatracker.ietf.org/help/state/draft/iana-review

Thank you,

David Dong
IANA Services Sr. Specialist
2026-05-07
11 (System) IANA Review state changed to IANA - Not OK from IANA - Review Needed
2026-05-07
11 David Dong IANA Experts State changed to Reviews assigned
2026-05-04
11 Lars Eggert
Request for IETF Last Call review by GENART Completed: Ready with Nits. Reviewer: Lars Eggert. Sent review to list. Submission of review completed at an …
Request for IETF Last Call review by GENART Completed: Ready with Nits. Reviewer: Lars Eggert. Sent review to list. Submission of review completed at an earlier date.
2026-05-04
11 Lars Eggert Request for IETF Last Call review by GENART Completed: Ready with Nits. Reviewer: Lars Eggert.
2026-05-03
11 Tero Kivinen Request for IETF Last Call review by SECDIR is assigned to Phillip Hallam-Baker
2026-05-01
11 Deb Cooley Requested IETF Last Call review by SECDIR
2026-05-01
11 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-11.txt
2026-05-01
11 Brian Campbell New version approved
2026-05-01
11 (System) Request for posting confirmation emailed to previous authors: Aaron Parecki , Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-05-01
11 Arndt Schwenkschuster Uploaded new revision
2026-04-30
10 Bo Wu Request for IETF Last Call review by OPSDIR is assigned to Bing Liu
2026-04-29
10 Russ Housley Request for IETF Last Call review by ARTART Completed: Ready. Reviewer: Russ Housley. Sent review to list.
2026-04-29
10 Barry Leiba Request for IETF Last Call review by ARTART is assigned to Russ Housley
2026-04-28
10 Jean Mahoney Request for IETF Last Call review by GENART is assigned to Lars Eggert
2026-04-27
10 Mohamed Boucadair Requested IETF Last Call review by OPSDIR
2026-04-27
10 Morgan Condie IANA Review state changed to IANA - Review Needed
2026-04-27
10 Morgan Condie
The following Last Call announcement was sent out (ends 2026-05-11):

From: The IESG
To: IETF-Announce
CC: debcooley1@gmail.com, draft-ietf-oauth-identity-chaining@ietf.org, oauth-chairs@ietf.org, oauth@ietf.org, rifaat.s.ietf@gmail.com …
The following Last Call announcement was sent out (ends 2026-05-11):

From: The IESG
To: IETF-Announce
CC: debcooley1@gmail.com, draft-ietf-oauth-identity-chaining@ietf.org, oauth-chairs@ietf.org, oauth@ietf.org, rifaat.s.ietf@gmail.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  (OAuth Identity and Authorization Chaining Across Domains) to Proposed Standard


The IESG has received a request from the Web Authorization Protocol WG
(oauth) to consider the following document: - 'OAuth Identity and
Authorization Chaining Across Domains'
  as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
last-call@ietf.org mailing lists by 2026-05-11. Exceptionally, comments may
be sent to iesg@ietf.org instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract


  This specification defines a mechanism to preserve identity and
  authorization information across trust domains that use the OAuth 2.0
  Framework.

Discussion Venues

  This note is to be removed before publishing as an RFC.

  Discussion of this document takes place on the Web Authorization
  Protocol Working Group mailing list (oauth@ietf.org), which is
  archived at https://mailarchive.ietf.org/arch/browse/oauth/.

  Source for this draft and an issue tracker can be found at
  https://github.com/oauth-wg/oauth-identity-chaining.




The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-oauth-identity-chaining/



No IPR declarations have been submitted directly on this I-D.




2026-04-27
10 Morgan Condie IESG state changed to In Last Call from Last Call Requested
2026-04-27
10 Morgan Condie Last call announcement was generated
2026-04-25
10 Rifaat Shekh-Yusef
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

  Yes, there was strong support for this document from the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

  No such points or decisions.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

  No such threats.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

  KeyCloak 26.5
  https://www.keycloak.org/2026/01/jwt-authorization-grant

  Ping Identity has implementations based on existing functionality supporting
  those specs.

  Okta
  https://developer.okta.com/blog/2025/09/03/cross-app-access

  Auth0
  https://auth0.com/docs/secure/call-apis-on-users-behalf/xaa

  Okta Open Source
  https://github.com/oktadev/okta-cross-app-access-mcp

  Okta Standalone implementation
  https://xaa.dev/

  Basic testing implementation
  https://motd.xaa.rocks/

  WSO2 Identity Server has some basic building blocks
  https://is.docs.wso2.com/en/latest/references/grant-types/#jwt-bearer-grant
  https://is.docs.wso2.com/en/latest/references/grant-types/#token-exchange-grant

 

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

  Yes, it is related to the work of the WIMSE WG. Many of the people active at
  the WIMSE WG are also active at the OAuth WG.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

  Not applicable.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

  Not applicable.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

  JSONLint was used to validate the JSON examples.


## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

  Yes, the document is well written and defines the OAuth interaction between
  different trust domains.

  I reviewed v06 and v07 of the document and the authors addressed the issues
  I raised in v07 and v08.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

    Not needed.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

    Proposed Standard.

    The draft defines a new mechanism that preserves identity and authorization
    information across trust domains that use OAuth.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

    Brian
    https://mailarchive.ietf.org/arch/msg/oauth/kTvSouMzS8Gws4t9JLstwmxWpcs/

    Pieter
    https://mailarchive.ietf.org/arch/msg/oauth/-24Nfmg3k-s-cpC9rD2BHCu6m-k/

    Arndt
    https://mailarchive.ietf.org/arch/msg/oauth/vqPIS_j_AUiFYztC7hnBhu4LI0k/

    Mike
    https://mailarchive.ietf.org/arch/msg/oauth/TZkod7RgLJZVgV4XY7Z5CbtHges/

    George
    https://mailarchive.ietf.org/arch/msg/oauth/MHaSQwTsb5ug_rnK8A3Lgqb3IBU/

    Kelley
    https://mailarchive.ietf.org/arch/msg/oauth/2zdY2k-VZXzLiPLzVGYYTyy4E7Y/

    Aaron
    https://mailarchive.ietf.org/arch/msg/oauth/jt3set63DlDOHZEsPoBtk91xIFU/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

    Aaron was added recently to the list of authors based on his significant
    contribution to the document that improved the quality of the document.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

    None


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

    These were fixed in v08.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

    No such references.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

    None


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

    None


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

    No change of status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

    The IANA section looks good to me.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

    Not applicable.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-04-25
10 Deb Cooley Last call was requested
2026-04-25
10 Deb Cooley Last call announcement was generated
2026-04-25
10 Deb Cooley Ballot approval text was generated
2026-04-25
10 Deb Cooley IESG state changed to Last Call Requested from AD Evaluation::AD Followup
2026-04-24
10 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-10.txt
2026-04-24
10 Brian Campbell New version approved
2026-04-24
10 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman , oauth-chairs@ietf.org
2026-04-24
10 Arndt Schwenkschuster Uploaded new revision
2026-04-24
09 (System) Changed action holders to Deb Cooley (IESG state changed)
2026-04-24
09 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2026-04-24
09 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-09.txt
2026-04-24
09 Brian Campbell New version approved
2026-04-24
09 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-04-24
09 Arndt Schwenkschuster Uploaded new revision
2026-04-08
08 Deb Cooley comments are available here:  https://mailarchive.ietf.org/arch/msg/oauth/_ujmJ_Gdl0kCmQzau4fskRwT3B4/
2026-04-08
08 (System) Changed action holders to Arndt Schwenkschuster, Pieter Kasselman, Kelley Burgin, Michael Jenkins, Brian Campbell (IESG state changed)
2026-04-08
08 Deb Cooley IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation
2026-04-06
08 Deb Cooley Ballot writeup was changed
2026-03-13
08 Deb Cooley Ballot writeup was changed
2026-03-12
08 Deb Cooley IESG state changed to AD Evaluation from Publication Requested
2026-02-09
08 Rifaat Shekh-Yusef
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

  Yes, there was strong support for this document from the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

  No such points or decisions.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

  No such threats.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

  KeyCloak 26.5
  https://www.keycloak.org/2026/01/jwt-authorization-grant

  Ping Identity has implementations based on existing functionality supporting
  those specs.

  Okta
  https://developer.okta.com/blog/2025/09/03/cross-app-access

  Auth0
  https://auth0.com/docs/secure/call-apis-on-users-behalf/xaa

  Okta Open Source
  https://github.com/oktadev/okta-cross-app-access-mcp

  Okta Standalone implementation
  https://xaa.dev/

  Basic testing implementation
  https://motd.xaa.rocks/

  WSO2 Identity Server has some basic building blocks
  https://is.docs.wso2.com/en/latest/references/grant-types/#jwt-bearer-grant
  https://is.docs.wso2.com/en/latest/references/grant-types/#token-exchange-grant

 

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

  Yes, it is related to the work of the WIMSE WG. Many of the people active at
  the WIMSE WG are also active at the OAuth WG.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

  Not applicable.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

  Not applicable.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

  JSONLint was used to validate the JSON examples.


## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

  Yes, the document is well written and defines the OAuth interaction between
  different trust domains.

  I reviewed v06 and v07 of the document and the authors addressed the issues
  I raised in v07 and v08.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

    Not needed.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

    Proposed Standard.

    The draft defines a new mechanism that preserves identity and authorization
    information across trust domains that use OAuth.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

    Brian
    https://mailarchive.ietf.org/arch/msg/oauth/kTvSouMzS8Gws4t9JLstwmxWpcs/

    Pieter
    https://mailarchive.ietf.org/arch/msg/oauth/-24Nfmg3k-s-cpC9rD2BHCu6m-k/

    Arndt
    https://mailarchive.ietf.org/arch/msg/oauth/vqPIS_j_AUiFYztC7hnBhu4LI0k/

    Mike
    https://mailarchive.ietf.org/arch/msg/oauth/TZkod7RgLJZVgV4XY7Z5CbtHges/

    George
    https://mailarchive.ietf.org/arch/msg/oauth/MHaSQwTsb5ug_rnK8A3Lgqb3IBU/

    Kelley
    https://mailarchive.ietf.org/arch/msg/oauth/2zdY2k-VZXzLiPLzVGYYTyy4E7Y/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

    Yes.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

    None


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

    These were fixed in v08.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

    No such references.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

    None


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

    None


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

    No change of status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

    The IANA section looks good to me.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

    Not applicable.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-02-09
08 Rifaat Shekh-Yusef IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up
2026-02-09
08 Rifaat Shekh-Yusef IESG state changed to Publication Requested from I-D Exists
2026-02-09
08 (System) Changed action holders to Deb Cooley (IESG state changed)
2026-02-09
08 Rifaat Shekh-Yusef Responsible AD changed to Deb Cooley
2026-02-09
08 Rifaat Shekh-Yusef Document is now in IESG state Publication Requested
2026-02-09
08 Rifaat Shekh-Yusef
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

  Yes, there was strong support for this document from the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

  No such points or decisions.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

  No such threats.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

  KeyCloak 26.5
  https://www.keycloak.org/2026/01/jwt-authorization-grant

  Ping Identity has implementations based on existing functionality supporting
  those specs.

  Okta
  https://developer.okta.com/blog/2025/09/03/cross-app-access

  Auth0
  https://auth0.com/docs/secure/call-apis-on-users-behalf/xaa

  Okta Open Source
  https://github.com/oktadev/okta-cross-app-access-mcp

  Okta Standalone implementation
  https://xaa.dev/

  Basic testing implementation
  https://motd.xaa.rocks/

  WSO2 Identity Server has some basic building blocks
  https://is.docs.wso2.com/en/latest/references/grant-types/#jwt-bearer-grant
  https://is.docs.wso2.com/en/latest/references/grant-types/#token-exchange-grant

 

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

  Yes, it is related to the work of the WIMSE WG. Many of the people active at
  the WIMSE WG are also active at the OAuth WG.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

  Not applicable.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

  Not applicable.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

  JSONLint was used to validate the JSON examples.


## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

  Yes, the document is well written and defines the OAuth interaction between
  different trust domains.

  I reviewed v06 and v07 of the document and the authors addressed the issues
  I raised in v07 and v08.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

    Not needed.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

    Proposed Standard.

    The draft defines a new mechanism that preserves identity and authorization
    information across trust domains that use OAuth.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

    Brian
    https://mailarchive.ietf.org/arch/msg/oauth/kTvSouMzS8Gws4t9JLstwmxWpcs/

    Pieter
    https://mailarchive.ietf.org/arch/msg/oauth/-24Nfmg3k-s-cpC9rD2BHCu6m-k/

    Arndt
    https://mailarchive.ietf.org/arch/msg/oauth/vqPIS_j_AUiFYztC7hnBhu4LI0k/

    Mike
    https://mailarchive.ietf.org/arch/msg/oauth/TZkod7RgLJZVgV4XY7Z5CbtHges/

    George
    https://mailarchive.ietf.org/arch/msg/oauth/MHaSQwTsb5ug_rnK8A3Lgqb3IBU/

    Kelley
    https://mailarchive.ietf.org/arch/msg/oauth/2zdY2k-VZXzLiPLzVGYYTyy4E7Y/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

    Yes.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

    None


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

    These were fixed in v08.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

    No such references.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

    None


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

    None


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

    No change of status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

    The IANA section looks good to me.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

    Not applicable.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-02-09
08 Rifaat Shekh-Yusef Changed consensus to Yes from Unknown
2026-02-09
08 Rifaat Shekh-Yusef Intended Status changed to Proposed Standard from Informational
2026-02-09
08 Rifaat Shekh-Yusef Intended Status changed to Informational from None
2026-02-09
08 Rifaat Shekh-Yusef
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few …
# Document Shepherd Write-Up for Group Documents

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

  Yes, there was strong support for this document from the WG.


2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

  No such points or decisions.


3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

  No such threats.


4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

  KeyCloak 26.5
  https://www.keycloak.org/2026/01/jwt-authorization-grant

  Ping Identity has implementations based on existing functionality supporting
  those specs.

  Okta
  https://developer.okta.com/blog/2025/09/03/cross-app-access

  Auth0
  https://auth0.com/docs/secure/call-apis-on-users-behalf/xaa

  Okta Open Source
  https://github.com/oktadev/okta-cross-app-access-mcp

  Okta Standalone implementation
  https://xaa.dev/

  Basic testing implementation
  https://motd.xaa.rocks/

  WSO2 Identity Server has some basic building blocks
  https://is.docs.wso2.com/en/latest/references/grant-types/#jwt-bearer-grant
  https://is.docs.wso2.com/en/latest/references/grant-types/#token-exchange-grant

 

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

  Yes, it is related to the work of the WIMSE WG. Many of the people active at
  the WIMSE WG are also active at the OAuth WG.


6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

  Not applicable.


7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

  Not applicable.


8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

  JSONLint was used to validate the JSON examples.


## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

  Yes, the document is well written and defines the OAuth interaction between
  different trust domains.

  I reviewed v06 and v07 of the document and the authors addressed the issues
  I raised in v07 and v08.


10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

    Not needed.


11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

    Informational.

    This document does not define any new OAuth functionalities, and instead
    describes the interaction between different trust domains using existing
    OAuth capabilities.


12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

    Brian
    https://mailarchive.ietf.org/arch/msg/oauth/kTvSouMzS8Gws4t9JLstwmxWpcs/

    Pieter
    https://mailarchive.ietf.org/arch/msg/oauth/-24Nfmg3k-s-cpC9rD2BHCu6m-k/

    Arndt
    https://mailarchive.ietf.org/arch/msg/oauth/vqPIS_j_AUiFYztC7hnBhu4LI0k/

    Mike
    https://mailarchive.ietf.org/arch/msg/oauth/TZkod7RgLJZVgV4XY7Z5CbtHges/

    George
    https://mailarchive.ietf.org/arch/msg/oauth/MHaSQwTsb5ug_rnK8A3Lgqb3IBU/

    Kelley
    https://mailarchive.ietf.org/arch/msg/oauth/2zdY2k-VZXzLiPLzVGYYTyy4E7Y/


13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

    Yes.


14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

    None


15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

    These were fixed in v08.


16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

    No such references.


17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

    None


18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

    None


19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

    No change of status of any existing RFCs.


20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

    The IANA section looks good to me.


21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

    Not applicable.


[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/
2026-02-09
08 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-08.txt
2026-02-09
08 (System) New version approved
2026-02-09
08 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2026-02-09
08 Arndt Schwenkschuster Uploaded new revision
2026-02-06
07 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-07.txt
2026-02-06
07 (System) New version approved
2026-02-06
07 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman , oauth-chairs@ietf.org
2026-02-06
07 Arndt Schwenkschuster Uploaded new revision
2026-01-27
06 Rifaat Shekh-Yusef Notification list changed to rifaat.s.ietf@gmail.com because the document shepherd was set
2026-01-27
06 Rifaat Shekh-Yusef Document shepherd changed to Rifaat Shekh-Yusef
2026-01-26
06 Rifaat Shekh-Yusef IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call
2025-09-12
06 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-06.txt
2025-09-12
06 (System) New version approved
2025-09-12
06 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2025-09-12
06 Arndt Schwenkschuster Uploaded new revision
2025-08-25
05 Rifaat Shekh-Yusef IETF WG state changed to In WG Last Call from WG Document
2025-07-03
05 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-05.txt
2025-07-03
05 (System) New version approved
2025-07-03
05 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2025-07-03
05 Arndt Schwenkschuster Uploaded new revision
2025-03-10
04 Rifaat Shekh-Yusef Added to session: IETF-122: oauth  Fri-0230
2025-02-27
04 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-04.txt
2025-02-27
04 (System) New version approved
2025-02-27
04 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2025-02-27
04 Arndt Schwenkschuster Uploaded new revision
2024-12-21
03 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-03.txt
2024-12-21
03 Kelley Burgin New version approved
2024-12-20
03 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman , oauth-chairs@ietf.org
2024-12-20
03 Arndt Schwenkschuster Uploaded new revision
2024-10-31
02 Justin Richer Added to session: IETF-121: wimse  Thu-1300
2024-07-08
02 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-02.txt
2024-07-08
02 (System) New version approved
2024-07-08
02 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2024-07-08
02 Arndt Schwenkschuster Uploaded new revision
2024-03-17
01 Justin Richer Added to session: IETF-119: wimse  Mon-0300
2024-03-15
01 Rifaat Shekh-Yusef Added to session: IETF-119: oauth  Tue-2330
2024-02-19
01 Arndt Schwenkschuster New version available: draft-ietf-oauth-identity-chaining-01.txt
2024-02-19
01 Brian Campbell New version approved
2024-02-19
01 (System) Request for posting confirmation emailed to previous authors: Arndt Schwenkschuster , Brian Campbell , Kelley Burgin , Michael Jenkins , Pieter Kasselman
2024-02-19
01 Arndt Schwenkschuster Uploaded new revision
2023-12-01
00 Rifaat Shekh-Yusef This document now replaces draft-oauth-identity-chaining instead of None
2023-12-01
00 Brian Campbell New version available: draft-ietf-oauth-identity-chaining-00.txt
2023-12-01
00 Rifaat Shekh-Yusef WG -00 approved
2023-12-01
00 Brian Campbell Set submitter to "Brian Campbell ", replaces to draft-oauth-identity-chaining and sent approval email to group chairs: oauth-chairs@ietf.org
2023-12-01
00 Brian Campbell Uploaded new revision