Skip to main content

The EAP-TLS Authentication Protocol
RFC 5216

Revision differences

Document history

Date By Action
2026-05-20
(System) Changed metadata: changed keywords to '['extensible authentication protocol', 'point-to-point', 'link control compression', 'extensible', 'transport level security']' from '[]'
2026-05-20
(System) Metadata update from RFC Editor
2026-05-20
(System) Changed author "R. Hurst": changed name from "Ryan Hurst" to "R. Hurst", cleared country (was "Redmond, WA 98052-6399"), changed order from "0" to "3"
2026-05-20
(System) Changed author "B. Aboba": changed name from "Bernard Aboba" to "B. Aboba", cleared country (was "Redmond, WA 98052-6399"), changed order from "1" to "2"
2026-05-20
(System) Changed author "D. Simon": changed name from "Daniel Simon" to "D. Simon", cleared country (was "Redmond, WA 98052-6399"), changed order from "-1" to "1"
2026-05-20
(System) Metadata update from RFC Editor
2020-01-21
(System) Received changes through RFC Editor sync (added Verified Errata tag)
2018-12-20
(System)
Received changes through RFC Editor sync (changed abstract to 'The Extensible Authentication Protocol (EAP), defined in RFC 3748, provides support for multiple authentication methods. …
Received changes through RFC Editor sync (changed abstract to 'The Extensible Authentication Protocol (EAP), defined in RFC 3748, provides support for multiple authentication methods. Transport Layer Security (TLS) provides for mutual authentication, integrity-protected ciphersuite negotiation, and key exchange between two endpoints. This document defines EAP-TLS, which includes support for certificate-based mutual authentication and key derivation.

This document obsoletes RFC 2716. A summary of the changes between this document and RFC 2716 is available in Appendix A. [STANDARDS-TRACK]')
2017-05-16
(System) Changed document authors from "Ryan Hurst, Bernard Aboba" to "Ryan Hurst, Bernard Aboba, Daniel Simon"
2015-10-14
(System) Notify list changed from emu-chairs@ietf.org to (None)
2008-03-24
Amy Vezza [Note]: 'RFC 5216' added by Amy Vezza
2008-03-24
Amy Vezza State Changes to RFC Published from RFC Ed Queue by Amy Vezza
2008-03-24
Amy Vezza [Note]: 'RFC 2716' added by Amy Vezza
2008-03-21
(System) RFC published