Automatic Certificate Management Environment (ACME) Device Attestation Extension
draft-ietf-acme-device-attest-10
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-09-09
|
10 | (System) | RPC status changed to Awaiting First editor from Awaiting Editor Assignment |
|
2026-08-19
|
10 | (System) | RPC status changed to Awaiting Editor Assignment from Awaiting First editor |
|
2026-08-13
|
10 | (System) | IANA Action state changed to RFC-Ed-Ack from Waiting on RFC Editor |
|
2026-08-13
|
10 | (System) | RPC status changed to Awaiting First editor from ref_checker |
|
2026-08-11
|
10 | Tero Kivinen | Closed request for IETF Last Call review by SECDIR with state 'Overtaken by Events' |
|
2026-08-11
|
10 | Tero Kivinen | Assignment of request for IETF Last Call review by SECDIR to Barry Leiba was marked no-response |
|
2026-08-10
|
10 | (System) | RPC status changed to ref_checker from formatting |
|
2026-08-10
|
10 | (System) | RPC status changed to formatting from blocked: Author Input Required |
|
2026-08-10
|
10 | (System) | RFC Editor state changed to In Progress from Blocked |
|
2026-08-09
|
10 | Ganesh Mallaya | New version available: draft-ietf-acme-device-attest-10.txt |
|
2026-08-09
|
10 | (System) | New version approved |
|
2026-08-09
|
10 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala |
|
2026-08-09
|
10 | Ganesh Mallaya | Uploaded new revision |
|
2026-08-06
|
09 | (System) | IANA Action state changed to Waiting on RFC Editor from Waiting on Authors |
|
2026-08-04
|
09 | (System) | IANA Action state changed to Waiting on Authors from In Progress |
|
2026-07-31
|
09 | (System) | RPC status changed to blocked: Author Input Required from Awaiting Editor Assignment |
|
2026-07-31
|
09 | (System) | RFC Editor state changed to Blocked from In Progress |
|
2026-07-31
|
09 | (System) | RPC status changed to Awaiting Editor Assignment |
|
2026-07-31
|
09 | (System) | RFC Editor state changed to In Progress |
|
2026-07-31
|
09 | (System) | IESG state changed to RFC Ed Queue from Approved-announcement sent |
|
2026-07-31
|
09 | (System) | Announcement was received by RFC Editor |
|
2026-07-30
|
09 | (System) | IANA Action state changed to In Progress |
|
2026-07-30
|
09 | Cindy Morgan | IESG state changed to Approved-announcement sent from Approved-announcement to be sent |
|
2026-07-30
|
09 | Cindy Morgan | IESG has approved the document |
|
2026-07-30
|
09 | Cindy Morgan | Closed "Approve" ballot |
|
2026-07-30
|
09 | Cindy Morgan | Ballot approval text was generated |
|
2026-07-30
|
09 | Cindy Morgan | Ballot writeup was changed |
|
2026-07-30
|
09 | (System) | Removed all action holders (IESG state changed) |
|
2026-07-30
|
09 | Deb Cooley | IESG state changed to Approved-announcement to be sent from IESG Evaluation::AD Followup |
|
2026-07-30
|
09 | Mike Bishop | [Ballot comment] Thank you for your updates, which address my DISCUSS and COMMENT points. |
|
2026-07-30
|
09 | Mike Bishop | [Ballot Position Update] Position for Mike Bishop has been changed to No Objection from Discuss |
|
2026-07-23
|
09 | Corey Bonnell | New version available: draft-ietf-acme-device-attest-09.txt |
|
2026-07-23
|
09 | Corey Bonnell | New version approved |
|
2026-07-23
|
09 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala |
|
2026-07-23
|
09 | Corey Bonnell | Uploaded new revision |
|
2026-07-16
|
08 | Mohamed Boucadair | [Ballot comment] Hi Brandon, Ganesh, Sven, Corey, and Ryan, The changes [1] address almost all the comments [2]. I ACK that the authors will remove … [Ballot comment] Hi Brandon, Ganesh, Sven, Corey, and Ryan, The changes [1] address almost all the comments [2]. I ACK that the authors will remove RFC8809 from the normative references. I still think a change is needed for this one: # Display format: mismatch type vs. payload CURRENT: Content-Type: application/jose+json { "protected": base64url({ "alg": "ES256", "kid": "https://example.com/acme/acct/evOfKhNU60wg", "nonce": "SS2sSl1PtspvFZ08kNtzKd", "url": "https://example.com/acme/chall/Rg5dV14Gh1Q" }), "payload": base64url({ "attObj": base64url(/* WebAuthn attestation object */), }), "signature": "Q1bURgJoEslbD1c5...3pYdSMLio57mQNN4" } Can we please add some text to explain how the displayed payload should be interpreted. Better, maybe update the example to follow the convention used in the examples in RFC7515. Cheers, Med [1] https://author-tools.ietf.org/iddiff?url1=draft-ietf-acme-device-attest-07&url2=draft-ietf-acme-device-attest-08&difftype=--html [2] https://mailarchive.ietf.org/arch/msg/acme/0O-8TlKh0j3hRw-JLBOWyXCF-Aw/ |
|
2026-07-16
|
08 | Mohamed Boucadair | [Ballot Position Update] Position for Mohamed Boucadair has been changed to No Objection from Discuss |
|
2026-07-15
|
08 | Mahesh Jethanandani | [Ballot comment] Thanks for addressing my DISCUSS and COMMENTs. |
|
2026-07-15
|
08 | Mahesh Jethanandani | [Ballot Position Update] Position for Mahesh Jethanandani has been changed to No Objection from Discuss |
|
2026-07-14
|
08 | Andy Newton | [Ballot comment] Thanks for addressing my discuss issues. |
|
2026-07-14
|
08 | Andy Newton | [Ballot Position Update] Position for Andy Newton has been changed to No Objection from Discuss |
|
2026-07-07
|
08 | Mike Bishop | [Ballot discuss] # IESG review of draft-ietf-acme-device-attest-08 Thank you for your update, which addresses a number of my DISCUSS and COMMENT points. I've updated this … [Ballot discuss] # IESG review of draft-ietf-acme-device-attest-08 Thank you for your update, which addresses a number of my DISCUSS and COMMENT points. I've updated this ballot to focus on the remaining issues. CC @MikeBishop ## Discuss In Sections 3.2 and 4.2, clients and servers MAY violate a MUST in RFC8555. Section 7.4 reiterates this permission again and recommends the new, noncompliant behavior. Although -08 now does explicitly update RFC8555, it doesn't state what the change is. I would presume that the MUST has become either a "SHOULD" or a "MUST ... unless..." to permit this new path. |
|
2026-07-07
|
08 | Mike Bishop | [Ballot comment] ## Comments ### Section 2, paragraph 2 You use a number of terms from other RFCs without direct pointers; I'd encourage you to … [Ballot comment] ## Comments ### Section 2, paragraph 2 You use a number of terms from other RFCs without direct pointers; I'd encourage you to add a Terminology section here for things like Assigner Authority (RFC4043). ### Section 6.1.1, paragraph 1 A reference to Section 7.3.4 of RFC8555 would be useful here. ### Section 6.1.3, paragraph 1 What is the difference between 6.1.2 and 6.1.3? They appear to say the same thing, that multiple challenge types MAY be deployed in parallel. ### Section 7.4, paragraph 1 ``` Implementers should treat this privacy-preserving mode as the default posture unless there is a specific operational requirement for the ``` This is probably a SHOULD. ### Section 9, paragraph 1 Please include links to the IANA registries. ## Nits All comments below are about very minor potential issues that you may choose to address in some way - or ignore - as you see fit. Some were flagged by automated tools (via https://github.com/larseggert/ietf-reviewtool), so there will likely be some false positives. There is no need to let me know what you did with these suggestions. ### Typos #### Section 3.2, paragraph 6 ``` - PermanentIdentifier in the subjectAltName extension. See the - ---- ``` ### Section 4.2 ``` - Section 7 section for more information. - -------- ``` |
|
2026-07-07
|
08 | Mike Bishop | Ballot comment and discuss text updated for Mike Bishop |
|
2026-07-07
|
08 | Roman Danyliw | [Ballot comment] Thank you to Roni Even for the GENART review. Thank you for addressing my DISCUSS and COMMENT feedback. |
|
2026-07-07
|
08 | Roman Danyliw | [Ballot Position Update] Position for Roman Danyliw has been changed to No Objection from Discuss |
|
2026-07-06
|
08 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-07-06
|
08 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-07-06
|
08 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed |
|
2026-07-06
|
08 | Corey Bonnell | New version available: draft-ietf-acme-device-attest-08.txt |
|
2026-07-06
|
08 | Corey Bonnell | New version approved |
|
2026-07-06
|
08 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala |
|
2026-07-06
|
08 | Corey Bonnell | Uploaded new revision |
|
2026-06-18
|
07 | (System) | Changed action holders to Brandon Weeks, Ganesh Mallaya, Sven Rajala, Corey Bonnell, Ryan Hurst (IESG state changed) |
|
2026-06-18
|
07 | Cindy Morgan | IESG state changed to IESG Evaluation::Revised I-D Needed from IESG Evaluation |
|
2026-06-17
|
07 | Tommy Jensen | [Ballot comment] I support all outstanding DISCUSS ballots and will avoid repeating their concerns. In the mean time, I would suggest adding some consideration text … [Ballot comment] I support all outstanding DISCUSS ballots and will avoid repeating their concerns. In the mean time, I would suggest adding some consideration text regarding the use of the "detail" field in the problem document, as referenced in Section 5: > If any of the steps fail, then the Server MUST respond to the Client > with a "badAttestationStatement" error and set the status of the > challenge object to "invalid". The Server SHOULD provide the reason > for rejecting the challenge in the "detail" field of the problem document. Various DNS WGs discussed at length the implications of different data formats provided in DNS error responses, namely the risks of placing URLs there. While this situation is clearly different, I still imagine there are wise and less-wise things for implementations to expose to potentially malicious peers about the nature of the failure. In addition, the use of SHOULD implies there are situations where it is acceptable for the Server to not explain itself. What are those situations? I imagine the answer overlaps with any reason any subset of potential explanations for a failure should not be revealed. |
|
2026-06-17
|
07 | Tommy Jensen | [Ballot Position Update] New position, No Objection, has been recorded for Tommy Jensen |
|
2026-06-17
|
07 | Christopher Inacio | [Ballot comment] Thanks for the text and attestation based extension. Especially thanks for the extensive privacy considerations. And thanks to Mike O. for the shepherd … [Ballot comment] Thanks for the text and attestation based extension. Especially thanks for the extensive privacy considerations. And thanks to Mike O. for the shepherd write up; and even adding another paragraph on top after last call edits. I am not blocking on any of my comments, because most of them are already noted and DISCUSSed by other ADs; so everything in here is really just foot stomping issues already raised. * 3.1 - yes as noted, the ABNF needs to be fixed. I think it has more issues than just the parenthesis mismatch; the `device-identifier-value `does not start with a bunch of control sequences, (the %x00-2E), but I’m not really sure what was intended. * 3.2 ¶2 “ Subject Alternative Name” should become “Subject Alternative Name (SAN)” so that the use of “SAN” in ¶4 is explained. * 4.1 - as noted in other reviews, the ABNF needs to be fixed. * 7.4 - As others noted, “MUST consider” is not a protcol mandate. * 7.6 - ditto on the use of “SHOULD work through…” and “SHOULD treat the attestation…” * As others noted, this draft does update RFC8555 and should be marked as such |
|
2026-06-17
|
07 | Christopher Inacio | Ballot comment text updated for Christopher Inacio |
|
2026-06-17
|
07 | Christopher Inacio | [Ballot comment] Thanks for the text and attestation based extension. Especially thanks for the extensive privacy considerations. I am not blocking on any of my … [Ballot comment] Thanks for the text and attestation based extension. Especially thanks for the extensive privacy considerations. I am not blocking on any of my comments, because most of them are already noted and DISCUSSed by other ADs; so everything in here is really just foot stomping issues already raised. * 3.1 - yes as noted, the ABNF needs to be fixed. I think it has more issues than just the parenthesis mismatch; the `device-identifier-value `does not start with a bunch of control sequences, (the %x00-2E), but I’m not really sure what was intended. * 3.2 ¶2 “ Subject Alternative Name” should become “Subject Alternative Name (SAN)” so that the use of “SAN” in ¶4 is explained. * 4.1 - as noted in other reviews, the ABNF needs to be fixed. * 7.4 - As others noted, “MUST consider” is not a protcol mandate. * 7.6 - ditto on the use of “SHOULD work through…” and “SHOULD treat the attestation…” * As others noted, this draft does update RFC8555 and should be marked as such |
|
2026-06-17
|
07 | Christopher Inacio | [Ballot Position Update] New position, No Objection, has been recorded for Christopher Inacio |
|
2026-06-17
|
07 | Mike Bishop | [Ballot discuss] # IESG review of draft-ietf-acme-device-attest-07 CC @MikeBishop ## Discuss ### Updates RFC 8555 In Section 1, paragraph 6, "Variances" is not a defined … [Ballot discuss] # IESG review of draft-ietf-acme-device-attest-07 CC @MikeBishop ## Discuss ### Updates RFC 8555 In Section 1, paragraph 6, "Variances" is not a defined term in RFC terminology that I'm aware of. Are these modifications to RFC8555? Are these new object types being defined for its extension points? I suspect the latter for the first two; it defines two new identifier types and one new challenge type. However, the third appears to be a change to the requirements of RFC8555, which would necessitate an Updates: tag. In Sections 3.2 and 4.2, clients and servers MAY violate a MUST in RFC8555, which is a fairly explicit sign that this document Updates RFC8555. Section 7.4 reiterates this permission again and recommends the new, noncompliant behavior. ### Section 6, paragraph 1 ``` Although this document focuses guidance on implementing new identifier types and a challenge for certificate issuance using ACME, it does not define a new protocol, a protocol extension, or an architecture. ``` Defining new identifier and challenge types for ACME certainly smells like a protocol extension. How is it not? ### Section 7.1, paragraph 4 ``` Implementers SHOULD assess whether the operational benefit of unchanging device identification outweighs this correlation exposure. In deployments where device anonymity or pseudonymity is a requirement, such as systems handling sensitive workloads on behalf of individuals, implementers SHOULD consider whether alternative validation mechanisms that do not bind the certificate to a permanent hardware identifier are more appropriate. ``` How does an implementation follow the SHOULDs when the guidance is on the deployment? "SHOULD consider" is straight from Section 2 of RFC 6919. (Please do not normatively reference RFC 6919.) ### Section 7.2, paragraph 3 ``` Implementers operating ACME Clients SHOULD be aware that the attestation format selected may expose more device state than is necessary to satisfy the server's authorization policy. Where ``` How does one implement this SHOULD? I suspect it should be "should" instead. |
|
2026-06-17
|
07 | Mike Bishop | [Ballot comment] ## Comments ### Section 1, paragraph 7 ``` Using ACME and device attestation to issue client certificates for enterprise … [Ballot comment] ## Comments ### Section 1, paragraph 7 ``` Using ACME and device attestation to issue client certificates for enterprise PKI will be a common use case. The following variances to ``` This is speculative. Perhaps this could be phrased as enabling this use-case? ### Section 2, paragraph 2 You use a number of terms from other RFCs without direct pointers; I'd encourage you to add a Terminology section here for things like Assigner Authority (RFC4043). ### Section 6.1.1, paragraph 1 A reference to Section 7.3.4 of RFC8555 would be useful here. ### Section 6.1.3, paragraph 1 What is the difference between 6.1.2 and 6.1.3? They appear to say the same thing, that multiple challenge types MAY be deployed in parallel. ### Section 7.4, paragraph 1 ``` Implementers should treat this privacy-preserving mode as the default posture unless there is a specific operational requirement for the ``` Contrary to the DISCUSS above, this is probably a SHOULD. ### Section 9, paragraph 1 Please include links to the IANA registries. ## Nits All comments below are about very minor potential issues that you may choose to address in some way - or ignore - as you see fit. Some were flagged by automated tools (via https://github.com/larseggert/ietf-reviewtool), so there will likely be some false positives. There is no need to let me know what you did with these suggestions. ### Typos #### Section 3.2, paragraph 6 ``` - PermanentIdentifier in the subjectAltName extension. See the - ---- ``` ### Section 3, paragraph 1 ``` typically a serial number. Additionally, the assigner of the identifier MAY also be specified. The name of this identifier type ``` Use only one of "Additionally" or "also". ### Section 3.1, paragraph 2 ``` first-and-second-components = (("0" / "1") "." (*1(%x31-33) %x30-39))) / ("2" "." component) ``` Unbalanced ')' in this production and similar |
|
2026-06-17
|
07 | Mike Bishop | [Ballot Position Update] New position, Discuss, has been recorded for Mike Bishop |
|
2026-06-16
|
07 | Andy Newton | [Ballot discuss] # Andy Newton, ART AD, comments for draft-ietf-acme-device-attest-07 CC @anewton1998 * line numbers: - https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-acme-device-attest-07.txt&submitcheck=True * comment syntax: - https://github.com/mnot/ietf-comments/blob/main/format.md * … [Ballot discuss] # Andy Newton, ART AD, comments for draft-ietf-acme-device-attest-07 CC @anewton1998 * line numbers: - https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-acme-device-attest-07.txt&submitcheck=True * comment syntax: - https://github.com/mnot/ietf-comments/blob/main/format.md * "Handling Ballot Positions": - https://ietf.org/about/groups/iesg/statements/handling-ballot-positions/ ## Discuss As noted in https://www.ietf.org/blog/handling-iesg-ballot-positions/, a DISCUSS ballot is just a request to have a discussion on the following topics. My DISCUSSes all center on BCP14 language. I also support Roman's DISUCSS. ### MUST consult 420 specific account key. The Server MUST consult format-specific 421 documentation to determine which construction applies and MUST 422 verify accordingly. Attestation formats whose signing procedure How does a server consult documentation? If this is about conforming to another specification, maybe: The server MUST conform to the specification of a given format and MUST verify the attestation accordingly. Hopefully I got the gist of that correct. ### SHOULD be aware 635 Implementers operating ACME Clients SHOULD be aware that the 636 attestation format selected may expose more device state than is 637 necessary to satisfy the server's authorization policy. Where 638 multiple attestation formats are available, Clients SHOULD prefer 639 formats that minimize the set of disclosed attributes. I am not sure the SHOULD on line 635 is normative and to be uppercase. For the SHOULD on line 638, is there a realistic reason a client would not prefer these formats? If not, can this be a MUST? ### Implementers operating 718 Implementers operating servers SHOULD store account-to-device 719 bindings using the minimum fidelity necessary for authorization 720 decisions. Where the operational requirement is only to confirm that 721 a given device is authorized to request certificates, it may be 722 sufficient to store a hash or other one-way transformation of the 723 device identifier rather than the identifier itself. Implementers 724 should also define and enforce retention limits on historical 725 account-to-certificate linkage records. This advice appears to be addressing operators and not implementations. Would it be better to say "Implementations SHOULD store"? Also, why isn't this a MUST? Is there a realistic reason for not doing this? And if so, can it be stated? ### SHOULD work through 729 Implementers considering whether to include permanent-identifier or 730 hardware-module in CSRs and issued certificates SHOULD work through 731 the following questions before enabling these identifiers: Can this be a MUST as well? What reason would somebody have for not following these best practices? |
|
2026-06-16
|
07 | Andy Newton | [Ballot Position Update] New position, Discuss, has been recorded for Andy Newton |
|
2026-06-16
|
07 | Mahesh Jethanandani | [Ballot discuss] Section 3.2, paragraph 5 > [RFC8555] section 7.4 mandates that "The CSR MUST indicate the exact > same set … [Ballot discuss] Section 3.2, paragraph 5 > [RFC8555] section 7.4 mandates that "The CSR MUST indicate the exact > same set of requested identifiers as the initial newOrder request". > However, there are some environments where the Server requires > validation of the identifier but does not include the identifier in > certificates due to privacy concerns. To support privacy-preserving > certificates, Clients MAY omit this identifier in the certificate > signing request (CSR). Similarly, if the Server wishes to issue > privacy-preserving certificates, it MAY reject CSRs containing a > PermanentIdentifier in the subjectAltName extension. See the > Section 7 for more information. If this document is deviating from RFC8555 on how the Clients "MAY omit this identifier" and the Server "MAY reject CSRs containing a PermenantIdentifier", is that not updating RFC8555? Please either (a) add a "Updates RFC8555 (b) provide a clear technical argument for why these deviations fall within RFC 8555's extensibility provisions (and hence do not constitute a modification of its normative requirements). Section 4.1, paragraph 14 > The value of the hwSerialNum field of the HardwareModuleName MUST be > an octet-for-octet match of the hw-serial-num-value value as encoded > in the Order resource. If the hw-type-value value is included in the > identifier as encoded in the Order resource, then the hwType field of > the HardwareModuleName MUST be the encoding of the "dotted-decimal" > object identifier encoded as the hw-type-value value. RFC 4108 defines HardwareModuleName with hwType as a required OBJECT IDENTIFIER (it is not marked OPTIONAL in the ASN.1). When hw-type-value is absent from the Order, this section is silent on what OID to use for hwType in the certificate. This is a protocol gap: there is no interoperable basis for constructing the HardwareModuleName SAN when hw-type-value is absent. The document must specify one of: (a) the OID to use in hwType in this case, (b) that the identifier may only appear in an issued certificate when hw-type-value was specified, or (c) that a hardware-module Order without hw-type-value can only be satisfied in privacy-preserving (identifier-omitted) mode. |
|
2026-06-16
|
07 | Mahesh Jethanandani | [Ballot comment] Section 3.1, paragraph 1 > assigner-value = first-and-second-components *("." component) > first-and-second-components = (("0" / "1") "." (*1(%x31-33) %x30-39))) / ("2" "." component) … [Ballot comment] Section 3.1, paragraph 1 > assigner-value = first-and-second-components *("." component) > first-and-second-components = (("0" / "1") "." (*1(%x31-33) %x30-39))) / ("2" "." component) > component = "0" / (%x31-39 *%x30-39) > device-identifier-value = 1*(%x00-2E / %x30-FF) I believe the first-and-second-components statement here and all subsequent such statements have a spurious closing brace (as highlighted by my editor). Section 5, paragraph 13 > 1. Perform the verification procedures described in Section 6 of > [WebAuthn]. Please check if you have the correct Section here. I believe it should be Section 7.1 (for WebAuthn Level 2) and Section 8 as applicable. |
|
2026-06-16
|
07 | Mahesh Jethanandani | Ballot comment and discuss text updated for Mahesh Jethanandani |
|
2026-06-15
|
07 | (System) | IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed |
|
2026-06-15
|
07 | Mahesh Jethanandani | [Ballot discuss] Section 3.1, paragraph 1 > assigner-value = first-and-second-components *("." component) > first-and-second-components = (("0" / "1") "." (*1(%x31-33) %x30-39))) / ("2" "." component) … [Ballot discuss] Section 3.1, paragraph 1 > assigner-value = first-and-second-components *("." component) > first-and-second-components = (("0" / "1") "." (*1(%x31-33) %x30-39))) / ("2" "." component) > component = "0" / (%x31-39 *%x30-39) > device-identifier-value = 1*(%x00-2E / %x30-FF) I believe the first-and-second-components statement here and all subsequent such statements have a spurious closing brace (as highlighted by my editor). Section 3.2, paragraph 5 > [RFC8555] section 7.4 mandates that "The CSR MUST indicate the exact > same set of requested identifiers as the initial newOrder request". > However, there are some environments where the Server requires > validation of the identifier but does not include the identifier in > certificates due to privacy concerns. To support privacy-preserving > certificates, Clients MAY omit this identifier in the certificate > signing request (CSR). Similarly, if the Server wishes to issue > privacy-preserving certificates, it MAY reject CSRs containing a > PermanentIdentifier in the subjectAltName extension. See the > Section 7 for more information. If this document is deviating from RFC8555 on how the Clients "MAY omit this identifier" and the Server "MAY reject CSRs containing a PermenantIdentifier", is that not updating RFC8555? Please either (a) add a "Updates RFC8555 (b) provide a clear technical argument for why these deviations fall within RFC 8555's extensibility provisions (and hence do not constitute a modification of its normative requirements). Section 4.1, paragraph 14 > The value of the hwSerialNum field of the HardwareModuleName MUST be > an octet-for-octet match of the hw-serial-num-value value as encoded > in the Order resource. If the hw-type-value value is included in the > identifier as encoded in the Order resource, then the hwType field of > the HardwareModuleName MUST be the encoding of the "dotted-decimal" > object identifier encoded as the hw-type-value value. RFC 4108 defines HardwareModuleName with hwType as a required OBJECT IDENTIFIER (it is not marked OPTIONAL in the ASN.1). When hw-type-value is absent from the Order, this section is silent on what OID to use for hwType in the certificate. This is a protocol gap: there is no interoperable basis for constructing the HardwareModuleName SAN when hw-type-value is absent. The document must specify one of: (a) the OID to use in hwType in this case, (b) that the identifier may only appear in an issued certificate when hw-type-value was specified, or (c) that a hardware-module Order without hw-type-value can only be satisfied in privacy-preserving (identifier-omitted) mode. |
|
2026-06-15
|
07 | Mahesh Jethanandani | [Ballot comment] Section 5, paragraph 13 > 1. Perform the verification procedures described in Section 6 of > [WebAuthn]. Please check … [Ballot comment] Section 5, paragraph 13 > 1. Perform the verification procedures described in Section 6 of > [WebAuthn]. Please check if you have the correct Section here. I believe it should be Section 7.1 (for WebAuthn Level 2) and Section 8 as applicable. |
|
2026-06-15
|
07 | Mahesh Jethanandani | [Ballot Position Update] New position, Discuss, has been recorded for Mahesh Jethanandani |
|
2026-06-15
|
07 | Roman Danyliw | [Ballot discuss] ** Use of BCP14 key words for underspecified behavior -- Section 7.4 * If the certificate is intended for use in certificate … [Ballot discuss] ** Use of BCP14 key words for underspecified behavior -- Section 7.4 * If the certificate is intended for use in certificate transparency logs, implementers MUST consider that embedding a permanent- identifier or hardware-module value will make that identifier permanently and publicly discoverable, indexed by issuance time, issuer, and subject. Consider using non-BCP14 language. What is the interoperable definition of “MUST consider”? -- Section 7.6 7.6. Implementer Decision Guidance Implementers considering whether to include permanent-identifier or hardware-module in CSRs and issued certificates SHOULD work through the following questions before enabling these identifiers: Thank you for this thoughtful list of implementation considerations. Please remove the BCP14 key words from this section. There is no mechanism to “work though” this list in an interoperable fashion. |
|
2026-06-15
|
07 | Roman Danyliw | [Ballot comment] Thank you to Roni Even for the GENART review. ** Section 6.1. Editorial. 6.1. Enterprise PKI ACME was originally envisioned for issuing … [Ballot comment] Thank you to Roni Even for the GENART review. ** Section 6.1. Editorial. 6.1. Enterprise PKI ACME was originally envisioned for issuing certificates in the Web PKI, however this extension will primarily be useful in enterprise PKI. The purpose of this text is not clear. ** Section 6.2 Servers SHOULD consider the trust properties of each attestation format when establishing issuance policy, including the nature of the authority making the attestation and the key protection guarantees it can assert. When should servers ignore the trust properties of each attestation format (i.e., why is this a BCP14 SHOULD? Shouldn’t this be mandatory?) ** Section 7.3 Implementers integrating ACME device attestation into enterprise PKI platforms should publish a clear attestation data handling policy that specifies what attributes are evaluated, how long they are retained, and whether they are shared with other systems. Why would an enterprise PKI have to explain policy choices? ** Section 7.5 Implementers operating servers SHOULD store account-to-device bindings using the minimum fidelity necessary for authorization decisions. When is it acceptable for implementations to over-collect these bindings? Perhaps avoid using “SHOULD”? ** Section 8 See [I-D.ietf-tls-rfc8446bis], Appendix C.1 for additional information on randomness requirements. It wasn’t clear which exact “requirements” were to be extracted from Appendix C.1? Is it that it is “RECOMMENDED to use an existing CSPRNG implementation in preference to crafting a new one”? |
|
2026-06-15
|
07 | Roman Danyliw | [Ballot Position Update] New position, Discuss, has been recorded for Roman Danyliw |
|
2026-06-15
|
07 | Gunter Van de Velde | [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde |
|
2026-06-15
|
07 | Mohamed Boucadair | [Ballot discuss] Hi Brandon, Ganesh, Sven, Corey, and Ryan, Thank you for the effort put into this document. Appreciate, in particular, the detailed operational guidance … [Ballot discuss] Hi Brandon, Ganesh, Sven, Corey, and Ryan, Thank you for the effort put into this document. Appreciate, in particular, the detailed operational guidance in the document. Please find below some points for discussion: # IANA registry CURRENT: The webauthn payload MAY contain any identifiers registered in "WebAuthn Attestation Statement Format Identifiers" and any extensions registered in "WebAuthn Extension Identifiers" [IANA-Webauthn], [RFC8809]. Although this is an optional feature, [IANA-Webauthn] is normative as the values are taken from that registry. As I’m there, I don’t think [RFC8809] citation is needed here (that would also remove the downref). # I don’t understand the practicalities of the following. What does that concretely mean? CURRENT: The Server MUST consult format-specific documentation to determine which construction applies and MUST verify accordingly. # Strengthen the guidance CURRENT: Implementers operating ACME Clients SHOULD be aware that the attestation format selected may expose more device state than is necessary to satisfy the server's authorization policy. Given the risk to reveal more information that needed, the requirement should be stronger here. s/SHOULD/MUST or “must” or “have to” would be more appropriate here. |
|
2026-06-15
|
07 | Mohamed Boucadair | [Ballot comment] # Speculative? CURRENT: Using ACME and device attestation to issue client certificates for enterprise PKI will be a common use case. … [Ballot comment] # Speculative? CURRENT: Using ACME and device attestation to issue client certificates for enterprise PKI will be a common use case. Do we really need to include this in an a RFC? # Redundant behavior The exclusion of of “/” is covered twice. Section 3: Although [RFC4043] permits any valid UTF-8 string to be used as the identifier, this specification mandates that identifiers MUST NOT contain the forward-slash "/" (UTF-8: U+002F) character. Vs. Section 3.1 In addition to the value being a valid UTF-8 string, the value MUST match the permanent-identifier- value production rule as defined in this ABNF [RFC5234] syntax: assigner-value = first-and-second-components *("." component) first-and-second-components = (("0" / "1") "." (*1(%x31-33) %x30-39))) / ("2" "." component) component = "0" / (%x31-39 *%x30-39) device-identifier-value = 1*(%x00-2E / %x30-FF) The MUST for the ABNF is sufficient in my opinion and would change “MUST NOT” to “must not” in the first excerpt. The same comment apply for a similar construct in Section 4. # Valid examples I suggest to make these changes: OLD: Example identifier without an assigner: … Example identifier with an assigner: NEW: Example of a valid identifier without an assigner: … Example of a valid identifier with an assigner: and OLD: Example identifier with the type of the hardware module represented … Example of identifier with no type specified and a serial number of NEW: Example of a valid identifier with the type of the hardware module represented …. Example of a valid identifier with no type specified and a serial number of # Valid JSON Example OLD: "type": `hardware-module`, NEW: "type": “hardware-module”, # Section 5: Clients vs The client OLD: The Client can prove control over a permanent identifier of a device I suggest to change that to NEW: A Client can prove control over a permanent identifier of a device Or NEW2: Clients can prove control over a permanent identifier of a device # Missing narrative text OLD: The device-attest-01 ACME challenge object has the following format: type (required, string): The string "device-attest-01". token (required, string): A random value that uniquely identifies the challenge. { "type": "device-attest-01", "url": "https://example.com/acme/chall/Rg5dV14Gh1Q", "status": "pending", "token": "evaGxfADs6pSRb2LAv9IZf17Dt3juxGJ-PCt92wr-oA" } NEW: The device-attest-01 ACME challenge object has the following format: type (required, string): The string "device-attest-01". token (required, string): A random value that uniquely identifies the challenge. An example message with a device-attest-01 challenge is provided below: { "type": "device-attest-01", "url": "https://example.com/acme/chall/Rg5dV14Gh1Q", "status": "pending", "token": "evaGxfADs6pSRb2LAv9IZf17Dt3juxGJ-PCt92wr-oA" } # Display format: mismatch type vs. payload CURRENT: Content-Type: application/jose+json { "protected": base64url({ "alg": "ES256", "kid": "https://example.com/acme/acct/evOfKhNU60wg", "nonce": "SS2sSl1PtspvFZ08kNtzKd", "url": "https://example.com/acme/chall/Rg5dV14Gh1Q" }), "payload": base64url({ "attObj": base64url(/* WebAuthn attestation object */), }), "signature": "Q1bURgJoEslbD1c5...3pYdSMLio57mQNN4" } Can we please add some text to explain how the displayed payload should be interpreted. Better, maybe update the example to follow the convention used in the examples in RFC7515. # Rationale It is not clear to me the rationale followed in Section 7 for the use of normative language. That section uses key words to call out some guidance to implementers/operators, but there are some aspects that seem (at least to me) to be important as well but for which key words are not used such as the following: CURRENT: Implementers operating servers must clearly define and document the purposes for which attestation data is processed and must not process attestation data for purposes materially different from authorization of the certificate request without explicit policy disclosure to the device owner or operator. Or Implementers should treat this privacy-preserving mode as the default posture unless there is a specific operational requirement for the identifier to appear in the certificate. Or Implementers should also define and enforce retention limits on historical account-to-certificate linkage records. Cheers, Med |
|
2026-06-15
|
07 | Mohamed Boucadair | [Ballot Position Update] New position, Discuss, has been recorded for Mohamed Boucadair |
|
2026-06-14
|
07 | Éric Vyncke | [Ballot Position Update] Position for Éric Vyncke has been changed to No Objection from No Record |
|
2026-06-14
|
07 | Éric Vyncke | [Ballot comment] Thanks for the work done in this document. I have nevertheless a non-blocking comment about the use of "SHOULD" in the operational/privacy/security sections, … [Ballot comment] Thanks for the work done in this document. I have nevertheless a non-blocking comment about the use of "SHOULD" in the operational/privacy/security sections, I note that the protocol specification does not contain such "SHOULD". Per https://datatracker.ietf.org/doc/statement-iesg-statement-on-clarifying-the-use-of-bcp-14-key-words/, lower case "should" is probably more appropriate per `They shouldn’t be used merely to express a preference. If there are no interoperability implications to the choice being presented, using “MAY” or “OPTIONAL”, or omitting key words entirely, is likely more appropriate.` |
|
2026-06-14
|
07 | Éric Vyncke | Ballot comment text updated for Éric Vyncke |
|
2026-06-13
|
07 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed |
|
2026-06-13
|
07 | Corey Bonnell | New version available: draft-ietf-acme-device-attest-07.txt |
|
2026-06-13
|
07 | (System) | New version approved |
|
2026-06-13
|
07 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala , acme-chairs@ietf.org |
|
2026-06-13
|
07 | Corey Bonnell | Uploaded new revision |
|
2026-06-11
|
06 | Ketan Talaulikar | [Ballot Position Update] New position, No Objection, has been recorded for Ketan Talaulikar |
|
2026-06-11
|
06 | Jim Guichard | [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard |
|
2026-06-11
|
06 | Gorry Fairhurst | [Ballot comment] Thanks for providing this document. I do not see any transport-protocol related concerns. |
|
2026-06-11
|
06 | Gorry Fairhurst | [Ballot Position Update] New position, No Objection, has been recorded for Gorry Fairhurst |
|
2026-06-02
|
06 | David Dong | IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed |
|
2026-06-02
|
06 | David Dong | IANA Experts State changed to Expert Reviews OK from Reviews assigned |
|
2026-06-02
|
06 | Deb Cooley | Tag Revised I-D Needed - Issue raised by WGLC cleared. |
|
2026-06-02
|
06 | Mike Ounsworth | UPDATE June 2, 2026: During the WGLC period between January and May, two additional authors (Corey Bonnell and Ryan Hurst) were added to help address … UPDATE June 2, 2026: During the WGLC period between January and May, two additional authors (Corey Bonnell and Ryan Hurst) were added to help address technical feedback that required design work outside the depth of the original authors. Additionally, a new Contributors section was added to recognize the design and implementation contributions of Mariano Cano and Herman Slatman during the early phase of this draft's development. # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document, as a whole, has been non-contentious since it is documenting a technology already in wide adoption. There has not been much debate, but mainly because I think its usefulness as an RFC is obvious. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There has been spirited debate about how this document interacts with the RATS WG, draft-liu-acme-rats, and draft-ietf-acme-client; but the debate has been about what content should be in the other drafts; this document is a well-scoped, self-contained, and broadly-deployed technology, so nobody suggested changing it. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? The protocol described in this document is implemented in Android, among others. https://developer.android.com/privacy-and-security/security-key-attestation We know that several public and private CAs support or intend to support carrying this data over ACME once an RFC exists. I have heard through the grapevine that CA/B Forum is waiting for an RFC and then will adopt this. Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. It interacts with IETF RATS WG, and W3C WebAuthn, but it is merely providing a way to transport those things over ACME, so I do not believe it requires review from those experts. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. I don’t know. I don’t believe that any of this applies. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? It does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. None, as far as I know. Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This document would benefit from an HTTP dir review. 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? This document should be Proposed Standard. I believe it is correctly tagged in Datatracker. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. To my knowledge, there is no IPR relating to the new ACME mechanism defined in this document; I have no idea if the same statement is true of the re-packaged W3C WebAuthn payload which is a mandatory-to-implement part of this document. Sven and Ganesh confirm as much. Brandon is unreachable. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Since the content is specific to WebAuthn, the authors received a WGLC comment to add the word “WebAuthn” somehow to the in-document title. I am not aware of any other violations of the content guidelines, but I also have not looked super carefully. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. All Normative references look reasonable to me to be Normative, except that maybe [RFC8809] could be moved to Informative? 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. [RFC8809] is Informational. This should be moved to Informative. [RFC2985] is Information, but already in DownRef registry. Everything else looks fine. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). This document has a fairly complex IANA Considerations, but it seems reasonable to create these registries in order to track which W3C-defined things are allowed in X.509 certificate requests. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No new registries. |
|
2026-06-01
|
06 | Morgan Condie | Placed on agenda for telechat - 2026-06-18 |
|
2026-06-01
|
06 | Deb Cooley | Ballot has been issued |
|
2026-06-01
|
06 | Deb Cooley | [Ballot Position Update] New position, Yes, has been recorded for Deb Cooley |
|
2026-06-01
|
06 | Deb Cooley | Created "Approve" ballot |
|
2026-06-01
|
06 | Deb Cooley | IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead |
|
2026-06-01
|
06 | Corey Bonnell | New version available: draft-ietf-acme-device-attest-06.txt |
|
2026-06-01
|
06 | (System) | New version approved |
|
2026-06-01
|
06 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala |
|
2026-06-01
|
06 | Corey Bonnell | Uploaded new revision |
|
2026-05-19
|
05 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA - Not OK |
|
2026-05-19
|
05 | Corey Bonnell | New version available: draft-ietf-acme-device-attest-05.txt |
|
2026-05-19
|
05 | (System) | New version approved |
|
2026-05-19
|
05 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala |
|
2026-05-19
|
05 | Corey Bonnell | Uploaded new revision |
|
2026-05-18
|
04 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Barry Leiba |
|
2026-05-18
|
04 | (System) | IESG state changed to Waiting for AD Go-Ahead from In Last Call |
|
2026-05-16
|
04 | Deb Cooley | Request closed, assignment withdrawn: Klaas Wierenga IETF Last Call SECDIR review |
|
2026-05-16
|
04 | Deb Cooley | Closed request for IETF Last Call review by SECDIR with state 'Withdrawn' |
|
2026-05-16
|
04 | Deb Cooley | Requested IETF Last Call review by SECDIR |
|
2026-05-13
|
04 | David Dong | IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-acme-device-attest-04. If any part of this review is inaccurate, please let us know. IANA understands that, upon … IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-acme-device-attest-04. If any part of this review is inaccurate, please let us know. IANA understands that, upon approval of this document, there are three actions that we must complete. First, in the ACME Identifier Types registry in the Automated Certificate Management Environment (ACME) Protocol registry group located at: https://www.iana.org/assignments/acme/ two new registrations are to be made as follows: Label: permanent-identifier Reference: [ RFC-to-be ] Label: hardware-module Reference: [ RFC-to-be ] As this document requests registrations in an Expert Review or Specification Required (see RFC 8126) registry, we have initiated the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK." Second, in the ACME Validation Methods registry also in the Automated Certificate Management Environment (ACME) Protocol registry group located at: https://www.iana.org/assignments/acme/ two new registrations are to be made as follows: Label: device-attest-01 Identifier Type: permanent-identifier ACME: Y Reference: [ RFC-to-be ] Label: device-attest-01 Identifier Type: hardware-module ACME: Y Reference: [ RFC-to-be ] As this also requests registrations in an Expert Review or Specification Required (see RFC 8126) registry, we have initiated the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK.” Third, in the ACME Error Type registry also in the Automated Certificate Management Environment (ACME) Protocol registry group located at: https://www.iana.org/assignments/acme/ a single new registration will be made as follows: Type: badAttestationStatement Description: The attestation statement is unacceptable (e.g. not signed by an attestation authority trusted by the CA) Reference: [ RFC-to-be ] As this also requests a registration in an Expert Review or Specification Required (see RFC 8126) registry, we have initiated the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK.” We understand that these are the only actions required to be completed upon approval of this document. NOTE: The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed. For definitions of IANA review states, please see: https://datatracker.ietf.org/help/state/draft/iana-review Thank you, David Dong IANA Services Sr. Specialist |
|
2026-05-13
|
04 | (System) | IANA Review state changed to IANA - Not OK from Version Changed - Review Needed |
|
2026-05-13
|
04 | Roni Even | Request for IETF Last Call review by GENART Completed: Ready. Reviewer: Roni Even. Sent review to list. |
|
2026-05-07
|
04 | Peter Yee | Request for IETF Last Call review by GENART is assigned to Roni Even |
|
2026-05-05
|
04 | Ganesh Mallaya | New version available: draft-ietf-acme-device-attest-04.txt |
|
2026-05-05
|
04 | (System) | New version approved |
|
2026-05-05
|
04 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Ryan Hurst , Sven Rajala |
|
2026-05-05
|
04 | Ganesh Mallaya | Uploaded new revision |
|
2026-05-04
|
03 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-05-18): From: The IESG To: IETF-Announce CC: acme-chairs@ietf.org, acme@ietf.org, debcooley1@gmail.com, draft-ietf-acme-device-attest@ietf.org, mike@ounsworth.ca … The following Last Call announcement was sent out (ends 2026-05-18): From: The IESG To: IETF-Announce CC: acme-chairs@ietf.org, acme@ietf.org, debcooley1@gmail.com, draft-ietf-acme-device-attest@ietf.org, mike@ounsworth.ca Reply-To: last-call@ietf.org Sender: Subject: Last Call: (Automated Certificate Management Environment (ACME) Device Attestation Extension) to Proposed Standard The IESG has received a request from the Automated Certificate Management Environment WG (acme) to consider the following document: - 'Automated Certificate Management Environment (ACME) Device Attestation Extension' as Proposed Standard The IESG plans to make a decision in the next few weeks, and solicits final comments on this action. Please send substantive comments to the last-call@ietf.org mailing lists by 2026-05-18. Exceptionally, comments may be sent to iesg@ietf.org instead. In either case, please retain the beginning of the Subject line to allow automated sorting. Abstract This document specifies new identifiers and a challenge for the Automated Certificate Management Environment (ACME) protocol which allows validating the identity of a device using attestation. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-acme-device-attest/ No IPR declarations have been submitted directly on this I-D. The document contains these normative downward references. See RFC 3967 for additional information: rfc8809: Registries for Web Authentication (WebAuthn) (Informational - Internet Engineering Task Force (IETF) stream) |
|
2026-05-04
|
03 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-05-04
|
03 | Morgan Condie | Last call announcement was generated |
|
2026-05-04
|
03 | Deb Cooley | Last call was requested |
|
2026-05-04
|
03 | Deb Cooley | IESG state changed to Last Call Requested from AD Evaluation |
|
2026-05-04
|
03 | Deb Cooley | Round 2 AD comments: https://mailarchive.ietf.org/arch/msg/acme/ygjL82y-ebI7svpjL-AzDYj9DsY/ |
|
2026-05-03
|
03 | Deb Cooley | IESG state changed to AD Evaluation from Publication Requested |
|
2026-05-03
|
03 | Deb Cooley | Ballot writeup was changed |
|
2026-04-28
|
03 | Mike Ounsworth | # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the … # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document, as a whole, has been non-contentious since it is documenting a technology already in wide adoption. There has not been much debate, but mainly because I think its usefulness as an RFC is obvious. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There has been spirited debate about how this document interacts with the RATS WG, draft-liu-acme-rats, and draft-ietf-acme-client; but the debate has been about what content should be in the other drafts; this document is a well-scoped, self-contained, and broadly-deployed technology, so nobody suggested changing it. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? The protocol described in this document is implemented in Android, among others. https://developer.android.com/privacy-and-security/security-key-attestation We know that several public and private CAs support or intend to support carrying this data over ACME once an RFC exists. I have heard through the grapevine that CA/B Forum is waiting for an RFC and then will adopt this. Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. It interacts with IETF RATS WG, and W3C WebAuthn, but it is merely providing a way to transport those things over ACME, so I do not believe it requires review from those experts. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. I don’t know. I don’t believe that any of this applies. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? It does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. None, as far as I know. Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This document would benefit from an HTTP dir review. 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? This document should be Proposed Standard. I believe it is correctly tagged in Datatracker. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. To my knowledge, there is no IPR relating to the new ACME mechanism defined in this document; I have no idea if the same statement is true of the re-packaged W3C WebAuthn payload which is a mandatory-to-implement part of this document. Sven and Ganesh confirm as much. Brandon is unreachable. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Since the content is specific to WebAuthn, the authors received a WGLC comment to add the word “WebAuthn” somehow to the in-document title. I am not aware of any other violations of the content guidelines, but I also have not looked super carefully. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. All Normative references look reasonable to me to be Normative, except that maybe [RFC8809] could be moved to Informative? 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. [RFC8809] is Informational. This should be moved to Informative. [RFC2985] is Information, but already in DownRef registry. Everything else looks fine. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). This document has a fairly complex IANA Considerations, but it seems reasonable to create these registries in order to track which W3C-defined things are allowed in X.509 certificate requests. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No new registries. |
|
2026-04-28
|
03 | Mike Ounsworth | IETF WG state changed to Submitted to IESG for Publication from In WG Last Call |
|
2026-04-28
|
03 | Mike Ounsworth | IESG state changed to Publication Requested from I-D Exists |
|
2026-04-28
|
03 | Mike Ounsworth | Document is now in IESG state Publication Requested |
|
2026-04-22
|
03 | Brandon Weeks | New version available: draft-ietf-acme-device-attest-03.txt |
|
2026-04-22
|
03 | (System) | New version approved |
|
2026-04-22
|
03 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Corey Bonnell , Ganesh Mallaya , Sven Rajala , acme-chairs@ietf.org |
|
2026-04-22
|
03 | Brandon Weeks | Uploaded new revision |
|
2026-04-10
|
02 | Mike Ounsworth | Extending WGLC, pending a new version that addresses Aaron's comments. |
|
2026-04-10
|
02 | Mike Ounsworth | Tag Revised I-D Needed - Issue raised by WGLC set. |
|
2026-03-26
|
02 | Mike Ounsworth | IETF WG state changed to In WG Last Call from WG Document |
|
2026-03-26
|
02 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA - Not OK |
|
2026-03-26
|
02 | Brandon Weeks | New version available: draft-ietf-acme-device-attest-02.txt |
|
2026-03-26
|
02 | (System) | New version approved |
|
2026-03-26
|
02 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Ganesh Mallaya , Sven Rajala , acme-chairs@ietf.org |
|
2026-03-26
|
02 | Brandon Weeks | Uploaded new revision |
|
2026-03-25
|
01 | Cindy Morgan | Returned to the WG from the IESG |
|
2026-03-25
|
01 | Cindy Morgan | IETF WG state changed to WG Document from Submitted to IESG for Publication |
|
2026-03-25
|
01 | Cindy Morgan | IESG state changed to I-D Exists from Waiting for AD Go-Ahead |
|
2026-02-12
|
01 | (System) | IESG state changed to Waiting for AD Go-Ahead from In Last Call |
|
2026-02-12
|
01 | Nabeel Cocker | Request for IETF Last Call review by OPSDIR Completed: Ready. Reviewer: Nabeel Cocker. Sent review to list. Submission of review completed at an earlier date. |
|
2026-02-12
|
01 | Nabeel Cocker | Request for IETF Last Call review by OPSDIR Completed: Ready. Reviewer: Nabeel Cocker. |
|
2026-02-10
|
01 | David Dong | IANA Experts State changed to Reviews assigned |
|
2026-02-10
|
01 | David Dong | IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-acme-device-attest-01. If any part of this review is inaccurate, please let us know. IANA understands that, upon … IESG/Authors/WG Chairs: IANA has completed its review of draft-ietf-acme-device-attest-01. If any part of this review is inaccurate, please let us know. IANA understands that, upon approval of this document, there are three actions which we must complete. First, in the ACME Identifier Types registry in the Automated Certificate Management Environment (ACME) Protocol registry group located at: https://www.iana.org/assignments/acme/ two new registrations will be made as follows: Label: permanent-identifier Reference: [ RFC-to-be ] Label: hardware-module Reference: [ RFC-to-be ] As this document requests registrations in an Expert Review or Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK." Second, in the ACME Validation Methods registry also in the Automated Certificate Management Environment (ACME) Protocol registry group located at: a single new registration will be made as follows: Label: device-attest-01 Identifier Type: permanent-identifier ACME: Y Reference: [ RFC-to-be ] https://www.iana.org/assignments/acme/ As this also requests a registration in an Expert Review or Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK." Third, in the ACME Error Types registry also in the Automated Certificate Management Environment (ACME) Protocol registry group located at: a single new registration will be made as follows: Type: badAttestationStatement Description: The attestation statement is unacceptable (e.g. not signed by an attestation authority trusted by the CA) Reference: [ RFC-to-be ] As this also requests a registration in an Expert Review or Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. This review must be completed before the document's IANA state can be changed to "IANA OK." We understand that these are the only actions required to be completed upon approval of this document. NOTE: The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed. For definitions of IANA review states, please see: https://datatracker.ietf.org/help/state/draft/iana-review Thank you, David Dong IANA Services Sr. Specialist |
|
2026-02-10
|
01 | (System) | IANA Review state changed to IANA - Not OK from IANA - Review Needed |
|
2026-02-10
|
01 | Roni Even | Request for IETF Last Call review by GENART Completed: Ready. Reviewer: Roni Even. Sent review to list. |
|
2026-02-04
|
01 | Bo Wu | Request for IETF Last Call review by OPSDIR is assigned to Nabeel Cocker |
|
2026-02-04
|
01 | Carlos Pignataro | Assignment of request for IETF Last Call review by OPSDIR to Carlos Pignataro was rejected |
|
2026-02-03
|
01 | Bo Wu | Assignment of request for IETF Last Call review by OPSDIR to Yingzhen Qu was withdrawn |
|
2026-02-03
|
01 | Bo Wu | Request for IETF Last Call review by OPSDIR is assigned to Carlos Pignataro |
|
2026-01-31
|
01 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Klaas Wierenga |
|
2026-01-31
|
01 | Bo Wu | Request for IETF Last Call review by OPSDIR is assigned to Yingzhen Qu |
|
2026-01-30
|
01 | Jean Mahoney | Request for IETF Last Call review by GENART is assigned to Roni Even |
|
2026-01-30
|
01 | Mohamed Boucadair | Requested IETF Last Call review by OPSDIR |
|
2026-01-29
|
01 | Morgan Condie | IANA Review state changed to IANA - Review Needed |
|
2026-01-29
|
01 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-02-12): From: The IESG To: IETF-Announce CC: acme-chairs@ietf.org, acme@ietf.org, debcooley1@gmail.com, draft-ietf-acme-device-attest@ietf.org, mike@ounsworth.ca … The following Last Call announcement was sent out (ends 2026-02-12): From: The IESG To: IETF-Announce CC: acme-chairs@ietf.org, acme@ietf.org, debcooley1@gmail.com, draft-ietf-acme-device-attest@ietf.org, mike@ounsworth.ca Reply-To: last-call@ietf.org Sender: Subject: Last Call: (Automated Certificate Management Environment (ACME) Device Attestation Extension) to Proposed Standard The IESG has received a request from the Automated Certificate Management Environment WG (acme) to consider the following document: - 'Automated Certificate Management Environment (ACME) Device Attestation Extension' as Proposed Standard The IESG plans to make a decision in the next few weeks, and solicits final comments on this action. Please send substantive comments to the last-call@ietf.org mailing lists by 2026-02-12. Exceptionally, comments may be sent to iesg@ietf.org instead. In either case, please retain the beginning of the Subject line to allow automated sorting. Abstract This document specifies new identifiers and a challenge for the Automated Certificate Management Environment (ACME) protocol which allows validating the identity of a device using attestation. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-acme-device-attest/ No IPR declarations have been submitted directly on this I-D. The document contains these normative downward references. See RFC 3967 for additional information: rfc8809: Registries for Web Authentication (WebAuthn) (Informational - Internet Engineering Task Force (IETF) stream) |
|
2026-01-29
|
01 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-01-29
|
01 | Deb Cooley | Last call was requested |
|
2026-01-29
|
01 | Deb Cooley | Last call announcement was generated |
|
2026-01-29
|
01 | Deb Cooley | Ballot approval text was generated |
|
2026-01-29
|
01 | Deb Cooley | IESG state changed to Last Call Requested from AD Evaluation::AD Followup |
|
2026-01-29
|
01 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-01-29
|
01 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-01-29
|
01 | Brandon Weeks | New version available: draft-ietf-acme-device-attest-01.txt |
|
2026-01-29
|
01 | (System) | New version approved |
|
2026-01-29
|
01 | (System) | Request for posting confirmation emailed to previous authors: Brandon Weeks , Ganesh Mallaya , Sven Rajala |
|
2026-01-29
|
01 | Brandon Weeks | Uploaded new revision |
|
2025-12-27
|
00 | Deb Cooley | Comments can be found here: https://mailarchive.ietf.org/arch/msg/acme/ItDd0-aCM2ELwCfSpMQt37LzesM/ |
|
2025-12-27
|
00 | (System) | Changed action holders to Brandon Weeks, Ganesh Mallaya, Sven Rajala (IESG state changed) |
|
2025-12-27
|
00 | Deb Cooley | IESG state changed to AD Evaluation::Revised I-D Needed from AD Evaluation |
|
2025-12-27
|
00 | Deb Cooley | IESG state changed to AD Evaluation from Publication Requested |
|
2025-12-24
|
00 | Deb Cooley | Ballot writeup was changed |
|
2025-12-08
|
00 | Mike Ounsworth | # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the … # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document, as a whole, has been non-contentious since it is documenting a technology already in wide adoption. There has not been much debate, but mainly because I think its usefulness as an RFC is obvious. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There has been spirited debate about how this document interacts with the RATS WG, draft-liu-acme-rats, and draft-ietf-acme-client; but the debate has been about what content should be in the other drafts; this document is a well-scoped, self-contained, and broadly-deployed technology, so nobody suggested changing it. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? The protocol described in this document is implemented in Android, among others. https://developer.android.com/privacy-and-security/security-key-attestation We know that several public and private CAs support or intend to support carrying this data over ACME once an RFC exists. I have heard through the grapevine that CA/B Forum is waiting for an RFC and then will adopt this. Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. It interacts with IETF RATS WG, and W3C WebAuthn, but it is merely providing a way to transport those things over ACME, so I do not believe it requires review from those experts. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. I don’t know. I don’t believe that any of this applies. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? It does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. None, as far as I know. Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This document would benefit from an HTTP dir review. 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? This document should be Proposed Standard. I believe it is correctly tagged in Datatracker. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. To my knowledge, there is no IPR relating to the new ACME mechanism defined in this document; I have no idea if the same statement is true of the re-packaged W3C WebAuthn payload which is a mandatory-to-implement part of this document. Sven and Ganesh confirm as much. Brandon is unreachable. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Since the content is specific to WebAuthn, the authors received a WGLC comment to add the word “WebAuthn” somehow to the in-document title. I am not aware of any other violations of the content guidelines, but I also have not looked super carefully. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. All Normative references look reasonable to me to be Normative, except that maybe [RFC8809] could be moved to Informative? 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. [RFC8809] is Informational. This should be moved to Informative. [RFC2985] is Information, but already in DownRef registry. Everything else looks fine. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). This document has a fairly complex IANA Considerations, but it seems reasonable to create these registries in order to track which W3C-defined things are allowed in X.509 certificate requests. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No new registries. |
|
2025-12-08
|
00 | Mike Ounsworth | IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up |
|
2025-12-08
|
00 | Mike Ounsworth | IESG state changed to Publication Requested from I-D Exists |
|
2025-12-08
|
00 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2025-12-08
|
00 | Mike Ounsworth | Responsible AD changed to Deb Cooley |
|
2025-12-08
|
00 | Mike Ounsworth | Document is now in IESG state Publication Requested |
|
2025-12-08
|
00 | Mike Ounsworth | # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the … # Document Shepherd Write-Up for Group Documents *This version is dated 8 December 2025.* Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? This document, as a whole, has been non-contentious since it is documenting a technology already in wide adoption. There has not been much debate, but mainly because I think its usefulness as an RFC is obvious. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There has been spirited debate about how this document interacts with the RATS WG, draft-liu-acme-rats, and draft-ietf-acme-client; but the debate has been about what content should be in the other drafts; this document is a well-scoped, self-contained, and broadly-deployed technology, so nobody suggested changing it. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) No. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as RFC 7942 recommends) or elsewhere (where)? The protocol described in this document is implemented in Android, among others. https://developer.android.com/privacy-and-security/security-key-attestation We know that several public and private CAs support or intend to support carrying this data over ACME once an RFC exists. I have heard through the grapevine that CA/B Forum is waiting for an RFC and then will adopt this. Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. It interacts with IETF RATS WG, and W3C WebAuthn, but it is merely providing a way to transport those things over ACME, so I do not believe it requires review from those experts. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. I don’t know. I don’t believe that any of this applies. 7. If the document contains a YANG module, has the final version of the module been checked with any of the recommended validation tools for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342? It does not contain a YANG module. 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. None, as far as I know. Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? Yes. 10. Several IETF Areas have assembled lists of common issues that their reviewers encounter. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? This document would benefit from an HTTP dir review. 11. What type of RFC publication is being requested on the IETF stream (Best Current Practice, Proposed Standard, Internet Standard, Informational, Experimental or Historic)? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? This document should be Proposed Standard. I believe it is correctly tagged in Datatracker. 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in BCP 79? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. To my knowledge, there is no IPR relating to the new ACME mechanism defined in this document; I have no idea if the same statement is true of the re-packaged W3C WebAuthn payload which is a mandatory-to-implement part of this document. Sven and Ganesh confirm as much. Brandon is unreachable. 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes. 14. Document any remaining I-D nits in this document. Simply running the idnits tool is not enough; please review the "Content Guidelines" on authors.ietf.org. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) Since the content is specific to WebAuthn, the authors received a WGLC comment to add the word “WebAuthn” somehow to the in-document title. I am not aware of any other violations of the content guidelines, but I also have not looked super carefully. 15. Should any informative references be normative or vice-versa? See the IESG Statement on Normative and Informative References. All Normative references look reasonable to me to be Normative, except that maybe [RFC8809] could be moved to Informative? 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None. 17. Are there any normative downward references (see RFC 3967 and BCP 97) that are not already listed in the DOWNREF registry? If so, list them. [RFC8809] is Informational. This should be moved to Informative. [RFC2985] is Information, but already in DownRef registry. Everything else looks fine. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? No. 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. No. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see RFC 8126). This document has a fairly complex IANA Considerations, but it seems reasonable to create these registries in order to track which W3C-defined things are allowed in X.509 certificate requests. 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. No new registries. |
|
2025-12-08
|
00 | Mike Ounsworth | Changed consensus to Yes from Unknown |
|
2025-12-08
|
00 | Mike Ounsworth | Intended Status changed to Proposed Standard from None |
|
2025-12-08
|
00 | Mike Ounsworth | Notification list changed to mike@ounsworth.ca because the document shepherd was set |
|
2025-12-08
|
00 | Mike Ounsworth | Document shepherd changed to Mike Ounsworth |
|
2025-12-08
|
00 | Mike Ounsworth | I have done a shepherd writeup, currently waiting for authors to review and approve before posting. |
|
2025-12-08
|
00 | Mike Ounsworth | IETF WG state changed to WG Consensus: Waiting for Write-Up from WG Document |
|
2025-12-08
|
00 | Mike Ounsworth | This document now replaces draft-acme-device-attest instead of None |
|
2025-12-08
|
00 | Ganesh Mallaya | New version available: draft-ietf-acme-device-attest-00.txt |
|
2025-12-08
|
00 | Mike Ounsworth | WG -00 approved |
|
2025-12-08
|
00 | Ganesh Mallaya | Set submitter to "Ganesh ", replaces to (none) and sent approval email to group chairs: acme-chairs@ietf.org |
|
2025-12-08
|
00 | Ganesh Mallaya | Uploaded new revision |