Skip to main content

Use of the RSA-KEM Algorithm in the Cryptographic Message Syntax (CMS)
draft-ietf-lamps-rfc5990bis-10

Revision differences

Document history

Date Rev. By Action
2025-02-10
(System)
Received changes through RFC Editor sync (changed state to RFC, created became rfc relationship between draft-ietf-lamps-rfc5990bis and RFC 9690, changed IESG state to RFC …
Received changes through RFC Editor sync (changed state to RFC, created became rfc relationship between draft-ietf-lamps-rfc5990bis and RFC 9690, changed IESG state to RFC Published)
2025-02-04
10 (System) RFC Editor state changed to AUTH48-DONE from AUTH48
2025-01-22
10 (System) RFC Editor state changed to AUTH48
2025-01-16
10 (System) RFC Editor state changed to RFC-EDITOR from EDIT
2025-01-16
10 (System) RFC Editor state changed to EDIT from RFC-EDITOR
2025-01-16
10 (System) RFC Editor state changed to RFC-EDITOR from EDIT
2024-10-10
10 (System) RFC Editor state changed to EDIT from AUTH
2024-08-02
10 (System) RFC Editor state changed to AUTH from EDIT
2024-07-30
10 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-10.txt
2024-07-30
10 Sean Turner New version approved
2024-07-30
10 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2024-07-30
10 Russ Housley Uploaded new revision
2024-07-24
09 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-09.txt
2024-07-24
09 Sean Turner New version approved
2024-07-24
09 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2024-07-24
09 Russ Housley Uploaded new revision
2024-06-13
08 (System) IANA Action state changed to RFC-Ed-Ack from Waiting on RFC Editor
2024-06-12
08 (System) IANA Action state changed to Waiting on RFC Editor from In Progress
2024-06-12
08 (System) IANA Action state changed to In Progress from Waiting on Authors
2024-06-12
08 (System) IANA Action state changed to Waiting on Authors from In Progress
2024-06-06
08 (System) RFC Editor state changed to EDIT
2024-06-06
08 (System) IESG state changed to RFC Ed Queue from Approved-announcement sent
2024-06-06
08 (System) Announcement was received by RFC Editor
2024-06-06
08 (System) IANA Action state changed to In Progress
2024-06-06
08 Jenny Bui IESG state changed to Approved-announcement sent from Approved-announcement to be sent
2024-06-06
08 Jenny Bui IESG has approved the document
2024-06-06
08 Jenny Bui Closed "Approve" ballot
2024-06-06
08 Jenny Bui Ballot approval text was generated
2024-06-06
08 (System) Removed all action holders (IESG state changed)
2024-06-06
08 Deb Cooley IESG state changed to Approved-announcement to be sent from IESG Evaluation::AD Followup
2024-06-05
08 Paul Wouters [Ballot comment]
Thanks for addressing my concerns. I've updated my ballot to Yes
2024-06-05
08 Paul Wouters [Ballot Position Update] Position for Paul Wouters has been changed to Yes from Discuss
2024-06-05
08 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-08.txt
2024-06-05
08 Sean Turner New version approved
2024-06-05
08 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2024-06-05
08 Russ Housley Uploaded new revision
2024-05-17
07 (System) Changed action holders to Deb Cooley (IESG state changed)
2024-05-17
07 (System) Sub state has been changed to AD Followup from Revised I-D Needed
2024-05-17
07 (System) IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed
2024-05-17
07 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-07.txt
2024-05-17
07 Sean Turner New version approved
2024-05-17
07 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2024-05-17
07 Russ Housley Uploaded new revision
2024-05-16
06 (System) Changed action holders to Russ Housley, Sean Turner (IESG state changed)
2024-05-16
06 Jenny Bui IESG state changed to IESG Evaluation::Revised I-D Needed from IESG Evaluation
2024-05-15
06 Murray Kucherawy [Ballot comment]
I support Paul's DISCUSS position.
2024-05-15
06 Murray Kucherawy [Ballot Position Update] New position, No Objection, has been recorded for Murray Kucherawy
2024-05-15
06 Sabrina Tanamal IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed
2024-05-15
06 John Scudder [Ballot Position Update] New position, No Objection, has been recorded for John Scudder
2024-05-15
06 Zaheduzzaman Sarker [Ballot Position Update] New position, No Objection, has been recorded for Zaheduzzaman Sarker
2024-05-15
06 Francesca Palombini [Ballot Position Update] New position, No Objection, has been recorded for Francesca Palombini
2024-05-13
06 Paul Wouters
[Ballot discuss]
I have a few issues, mostly related to SHOULD vs MUST, that I'd like to discuss.



      then the key usage …
[Ballot discuss]
I have a few issues, mostly related to SHOULD vs MUST, that I'd like to discuss.



      then the key usage extension MUST contain only the following
        value:

        keyEncipherment

        The digitalSignature and dataEncipherment values SHOULD NOT
        be present.

This MUST and SHOULD NOT do not match up. Same for the following sentence:

        That is, a public key intended to be employed only with the
        RSA-KEM Algorithm SHOULD NOT also be employed for data encryption
        or for digital signatures.


Section 2.4 describes its use with SMIME where GenericHybridParameters are
        mandatory, but within that section it states:

        If the GenericHybridParameters are present, then ....

But in this context, it MUST always be present. I would remove the above
start of the sentence to avoid confusion.


        To achieve 128-bit security, the RSA key size SHOULD be at least
        3072 bits, the key-derivation function SHOULD make use of SHA-256,
        and the symmetric key-encryption algorithm SHOULD be AES Key
        Wrap with a 128-bit key.

I think at least the first and third SHOULD should be a MUST. The second
one is a bit more open not because of the sizes involved with SHA-256,
but because it could use another hash algo (eg SHA-3)


      Implementations SHOULD NOT use z directly for any purpose.

Why not MUST NOT ?


      for increased security assurance,

I'd like to see this part removed, as I think the minimum bar includes
this advise. It is not "increased security" but for "minimum requirements".
2024-05-13
06 Paul Wouters
[Ballot comment]
Maybe rename section 2.1 to "Mandatory To Implement" ?

      version is the syntax version number; it MUST be 0.

Maybe …
[Ballot comment]
Maybe rename section 2.1 to "Mandatory To Implement" ?

      version is the syntax version number; it MUST be 0.

Maybe start at 1, and leave 0 for "undefined" or "auto"
cases for software implementations? 0 can often not be
distinguished for "unset".

Section 3:

        The RSA-KEM Algorithm should be considered as a replacement for
        the widely implemented PKCS #1 v1.5

Should this statement be narrowed down? You are not talking about
RSA PKCS #1 v1.5 for Digitial Signatures here, are you? Just about
keyEncipherment ?

      Disclosure of the RSA private key could result in the compromise
        of all messages protected with that key.

I find this lowercase should a bit odd. How about:

        Disclosure of the RSA private key results in the compromise of
        all messages protected with that key.

(compromise as a word is already dependent on circumstance and not a
guarantee of attacker)
Same for the next sentence and its "could".

        Parties MAY gain assurance that implementations

I would lowercase the MAY, it is directed at implementers
2024-05-13
06 Paul Wouters [Ballot Position Update] New position, Discuss, has been recorded for Paul Wouters
2024-05-12
06 Roman Danyliw [Ballot comment]
Thank you to Christer Holmberg for the GENART review.
2024-05-12
06 Roman Danyliw [Ballot Position Update] New position, No Objection, has been recorded for Roman Danyliw
2024-05-11
06 Erik Kline [Ballot Position Update] New position, No Objection, has been recorded for Erik Kline
2024-05-10
06 Éric Vyncke
[Ballot comment]
Thanks for the work done in this document, it seems indeed that a refresh was needed.

Just 2 comments

`First, the input to …
[Ballot comment]
Thanks for the work done in this document, it seems indeed that a refresh was needed.

Just 2 comments

`First, the input to the underlying RSA operation is a string-encoded random integer between 0 and n-1, where n is the RSA modulus, so it does not have any structure that could be exploited by an adversary.` does the length of this random number give some clue to the attacker ?

3rd paragraph of the security considerations have several SHOULD without any indication when those SHOULD can be bypassed.
2024-05-10
06 Éric Vyncke [Ballot Position Update] New position, No Objection, has been recorded for Éric Vyncke
2024-05-08
06 Jim Guichard [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard
2024-05-07
06 Gunter Van de Velde [Ballot comment]
# Gunter Van de Velde, RTG AD, comments for draft-ietf-lamps-rfc5990bis-06

idnits spits up normative references to informational rfc
2024-05-07
06 Gunter Van de Velde [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde
2024-05-03
06 Deb Cooley Ballot writeup was changed
2024-04-30
06 (System) IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions Needed
2024-04-30
06 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-06.txt
2024-04-30
06 (System) New version approved
2024-04-30
06 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2024-04-30
06 Russ Housley Uploaded new revision
2024-04-29
06 (System) IANA Review state changed to IANA OK - Actions Needed from Version Changed - Review Needed
2024-04-29
05 Orie Steele
[Ballot comment]

# Orie Steele, ART AD, comments for draft-ietf-lamps-rfc5990bis-05
CC @OR13

This review is in the ["IETF Comments" Markdown format][ICMF].
You can use the …
[Ballot comment]

# Orie Steele, ART AD, comments for draft-ietf-lamps-rfc5990bis-05
CC @OR13

This review is in the ["IETF Comments" Markdown format][ICMF].
You can use the [`ietf-comments` tool][ICT] to automatically convert this review into
individual GitHub issues, or using this [online validator](https://mnot.github.io/ietf-comments/).

Line numbers are generated with this:
https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-lamps-rfc5990bis-05.txt&submitcheck=True

## Comments

### key pair reuse with other algorithms

```
563   Accordingly, an RSA key pair used for the RSA-KEM Algorithm SHOULD
564   NOT also be used for digital signatures.  Indeed, the Accredited
565   Standards Committee X9 (ASC X9) requires such a separation between
566   key pairs used for key establishment and key pairs used for digital
567   signature [ANS-X9.44].  Continuing this principle of key separation,
568   a key pair used for the RSA-KEM Algorithm SHOULD NOT be used with
569   other key establishment schemes, or for data encryption, or with more
570   than one set of underlying algorithm components.
```

Since separation is mentioned here, there does not appear to be any context binding in Encap / Decap via the KDF at that layer, or in Derive KEK after.

I wonder if there was discussion of binding the kem algorithm id into KDF(ss).

Is there a scenario where a key pair used for the RSA-KEM Algorithm SHOULD / MUST be used with other key establishment schemes, or for data encryption, or with more than one set of underlying algorithm components?

Why not MUST NOT?

## Nits

### digitalSignatrure

```
424   The digitalSignatrure and dataEncipherment values SHOULD NOT be
```

Spelling.
2024-04-29
05 Orie Steele [Ballot Position Update] New position, No Objection, has been recorded for Orie Steele
2024-04-23
05 Dhruv Dhody Request for Last Call review by OPSDIR Completed: Has Nits. Reviewer: Dhruv Dhody. Sent review to list. Submission of review completed at an earlier date.
2024-04-23
05 Dhruv Dhody Request for Last Call review by OPSDIR Completed: Has Nits. Reviewer: Dhruv Dhody.
2024-04-23
05 Jenny Bui IESG state changed to IESG Evaluation from Last Call Requested
2024-04-23
05 Jenny Bui Last call was requested
2024-04-23
05 Jenny Bui IESG state changed to Last Call Requested from IESG Evaluation
2024-04-23
05 Deb Cooley Placed on agenda for telechat - 2024-05-16
2024-04-23
05 Deb Cooley Ballot has been issued
2024-04-23
05 Deb Cooley [Ballot Position Update] New position, Yes, has been recorded for Deb Cooley
2024-04-23
05 Deb Cooley Created "Approve" ballot
2024-04-23
05 Deb Cooley IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead
2024-04-23
05 (System) IESG state changed to Waiting for AD Go-Ahead from In Last Call
2024-04-22
05 Donald Eastlake Request for Last Call review by SECDIR Completed: Has Nits. Reviewer: Donald Eastlake.
2024-04-19
05 Carlos Pignataro Request for Last Call review by OPSDIR is assigned to Dhruv Dhody
2024-04-18
05 (System) IANA Review state changed to IANA OK - Actions Needed from IANA - Review Needed
2024-04-18
05 David Dong
(Via drafts-lastcall@iana.org): IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-lamps-rfc5990bis-05. If any part of this review is inaccurate, please let us know.

IANA …
(Via drafts-lastcall@iana.org): IESG/Authors/WG Chairs:

IANA has completed its review of draft-ietf-lamps-rfc5990bis-05. If any part of this review is inaccurate, please let us know.

IANA has a question about the action requested in the IANA Considerations section of this document.

IANA understands that, upon approval of this document, there is a single action which we must complete.

In the SMI Security for S/MIME Module Identifier (1.2.840.113549.1.9.16.0) registry in the Structure of Management Information (SMI) Numbers (MIB Module Registrations) registry group located at:

https://www.iana.org/assignments/smi-numbers/

a single new registration will be made as follows:

Decimal: [ TBD-at-Registration ]
Description: id-mod-cms-rsa-kem-2023
Reference: [ RFC-to-be ]

As this document requests a registration in an Expert Review or Specification Required (see RFC 8126) registry, we have initiated and completed the required Expert Review via a separate request.

IANA Question --> As this document is intended to obsolete RFC5990, should the reference for Decimal: 14 in the SMI Security for S/MIME Algorithms (1.2.840.113549.1.9.16.3) with Description: id-alg-rsa-kem be changed to [ RFC-to-be ]?

We understand that this is the only action required to be completed upon approval of this document.

NOTE: The action requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the action that will be performed.

For definitions of IANA review states, please see:

https://datatracker.ietf.org/help/state/draft/iana-review

Thank you,

David Dong
IANA Services Sr. Specialist
2024-04-18
05 Tero Kivinen Request for Last Call review by SECDIR is assigned to Donald Eastlake
2024-04-18
05 Christer Holmberg Request for Last Call review by GENART Completed: Almost Ready. Reviewer: Christer Holmberg. Sent review to list.
2024-04-12
05 Jean Mahoney Request for Last Call review by GENART is assigned to Christer Holmberg
2024-04-11
05 David Dong IANA Experts State changed to Expert Reviews OK from Reviews assigned
2024-04-09
05 David Dong IANA Experts State changed to Reviews assigned
2024-04-09
05 Cindy Morgan IANA Review state changed to IANA - Review Needed
2024-04-09
05 Cindy Morgan
The following Last Call announcement was sent out (ends 2024-04-23):

From: The IESG
To: IETF-Announce
CC: debcooley1@gmail.com, draft-ietf-lamps-rfc5990bis@ietf.org, lamps-chairs@ietf.org, spasm@ietf.org, tim.hollebeek@digicert.com …
The following Last Call announcement was sent out (ends 2024-04-23):

From: The IESG
To: IETF-Announce
CC: debcooley1@gmail.com, draft-ietf-lamps-rfc5990bis@ietf.org, lamps-chairs@ietf.org, spasm@ietf.org, tim.hollebeek@digicert.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  (Use of the RSA-KEM Algorithm in the Cryptographic Message Syntax (CMS)) to Proposed Standard


The IESG has received a request from the Limited Additional Mechanisms for
PKIX and SMIME WG (lamps) to consider the following document: - 'Use of the
RSA-KEM Algorithm in the Cryptographic Message Syntax (CMS)'
  as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
last-call@ietf.org mailing lists by 2024-04-23. Exceptionally, comments may
be sent to iesg@ietf.org instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract


  The RSA Key Encapsulation Mechanism (RSA-KEM) Algorithm is a one-pass
  (store-and-forward) cryptographic mechanism for an originator to
  securely send keying material to a recipient using the recipient's
  RSA public key.  The RSA-KEM Algorithm is specified in Clause 11.5 of
  ISO/IEC: 18033-2:2006.  This document specifies the conventions for
  using the RSA-KEM Algorithm as a standalone KEM algorithm and the
  conventions for using the RSA-KEM Algorithm with the Cryptographic
  Message Syntax (CMS) using KEMRecipientInfo as specified in draft-
  ietf-lamps-cms-kemri.




The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc5990bis/



No IPR declarations have been submitted directly on this I-D.




2024-04-09
05 Cindy Morgan IESG state changed to In Last Call from Last Call Requested
2024-04-09
05 Deb Cooley Last call was requested
2024-04-09
05 Deb Cooley Last call announcement was generated
2024-04-09
05 Deb Cooley IESG state changed to Last Call Requested from Publication Requested
2024-04-09
05 Deb Cooley Removed from agenda for telechat
2024-04-09
05 Deb Cooley Telechat date has been changed to 2024-05-02 from 2024-04-18
2024-04-09
05 Deb Cooley Ballot writeup was changed
2024-04-09
05 Deb Cooley Ballot approval text was generated
2024-04-09
05 Deb Cooley Placed on agenda for telechat - 2024-04-18
2024-04-05
05 Tim Hollebeek
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.

Note that some numbered items contain multiple related questions; please be sure
to answer all of them.

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

The draft has broad support within the WG.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No, this draft was non-controversial.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

This draft supports the use of the ISO RSA-KEM algorithm as a KEM in CMS, which
several implementers have indicated is desirable.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No additional reviews necessary.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

No such reviews needed.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

No YANG module.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

WARNING: THIS DOCUMENTS CONTAINS ASN.1.  Thankfully, it has been reviewed by
several experts fluent in ASN.1 and wearing appropriate protective equipment,
and has been verified to compile correctly.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is ready.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

The usual security area checks have been made.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed standard, which aligns with RFC 5990, which this replaces.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

All authors have stated they have no knowledge of any IPR related to this draft.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

* The abstract needs to be updated to explicitly state this document replaces RFC 5990.

* Several normative references to informative RFCs that should be resolved in some manner:

- RFC 3394, 5911, 5912, 6268, 8017

most of these RFCs are "informational" only because they describe things that are
normatively specified elsewhere, and the draft doesn't appear to normatively rely
on them anyway (the references tend to be in ASN.1 comments or referenced as
inspiration, not for their normative value).  I'd recommend just moving these
references to the informational section, unless the authors believe they need to
be normative references.

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

See 14.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

ANS-X9.44 and ISO 18033-2.  The shepherd has copies and was able to review them. 
They were the basis for RFC 5990 as well, and those references are largely
irrelevant to the updates being made here.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

Yes, but they will likely go away as part of resolving the issues noted in 14.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

No.  ietf-lamps-cms-kemri is referenced, but that's already in the RFC editor's queue.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

The abstract and introduction need to be updated to clearly state that this
document obsoletes RFC 5990.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

The IANA considerations request one module identifier.  The request looks reasonable.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No new registries.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2024-04-05
05 Tim Hollebeek IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up
2024-04-05
05 Tim Hollebeek IESG state changed to Publication Requested from I-D Exists
2024-04-05
05 (System) Changed action holders to Deb Cooley (IESG state changed)
2024-04-05
05 Tim Hollebeek Responsible AD changed to Deb Cooley
2024-04-05
05 Tim Hollebeek Document is now in IESG state Publication Requested
2024-04-05
05 Tim Hollebeek
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the …
# Document Shepherd Write-Up for Group Documents

*This version is dated 4 July 2022.*

Thank you for your service as a document shepherd. Among the responsibilities is
answering the questions in this write-up to give helpful context to Last Call
and Internet Engineering Steering Group ([IESG][1]) reviewers, and your
diligence in completing it is appreciated. The full role of the shepherd is
further described in [RFC 4858][2]. You will need the cooperation of the authors
and editors to complete these checks.

Note that some numbered items contain multiple related questions; please be sure
to answer all of them.

## Document History

1. Does the working group (WG) consensus represent the strong concurrence of a
  few individuals, with others being silent, or did it reach broad agreement?

The draft has broad support within the WG.

2. Was there controversy about particular points, or were there decisions where
  the consensus was particularly rough?

No, this draft was non-controversial.

3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If
  so, please summarize the areas of conflict in separate email messages to the
  responsible Area Director. (It should be in a separate email because this
  questionnaire is publicly available.)

No.

4. For protocol documents, are there existing implementations of the contents of
  the document? Have a significant number of potential implementers indicated
  plans to implement? Are any existing implementations reported somewhere,
  either in the document itself (as [RFC 7942][3] recommends) or elsewhere
  (where)?

This draft supports the use of the ISO RSA-KEM algorithm as a KEM in CMS, which
several implementers have indicated is desirable.

## Additional Reviews

5. Do the contents of this document closely interact with technologies in other
  IETF working groups or external organizations, and would it therefore benefit
  from their review? Have those reviews occurred? If yes, describe which
  reviews took place.

No additional reviews necessary.

6. Describe how the document meets any required formal expert review criteria,
  such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

No such reviews needed.

7. If the document contains a YANG module, has the final version of the module
  been checked with any of the [recommended validation tools][4] for syntax and
  formatting validation? If there are any resulting errors or warnings, what is
  the justification for not fixing them at this time? Does the YANG module
  comply with the Network Management Datastore Architecture (NMDA) as specified
  in [RFC 8342][5]?

No YANG module.

8. Describe reviews and automated checks performed to validate sections of the
  final version of the document written in a formal language, such as XML code,
  BNF rules, MIB definitions, CBOR's CDDL, etc.

WARNING: THIS DOCUMENTS CONTAINS ASN.1.  Thankfully, it has been reviewed by
several experts fluent in ASN.1 and wearing appropriate protective equipment,
and has been verified to compile correctly.

## Document Shepherd Checks

9. Based on the shepherd's review of the document, is it their opinion that this
  document is needed, clearly written, complete, correctly designed, and ready
  to be handed off to the responsible Area Director?

The document is ready.

10. Several IETF Areas have assembled [lists of common issues that their
    reviewers encounter][6]. For which areas have such issues been identified
    and addressed? For which does this still need to happen in subsequent
    reviews?

The usual security area checks have been made.

11. What type of RFC publication is being requested on the IETF stream ([Best
    Current Practice][12], [Proposed Standard, Internet Standard][13],
    [Informational, Experimental or Historic][14])? Why is this the proper type
    of RFC? Do all Datatracker state attributes correctly reflect this intent?

Proposed standard, which aligns with RFC 5990, which this replaces.

12. Have reasonable efforts been made to remind all authors of the intellectual
    property rights (IPR) disclosure obligations described in [BCP 79][7]? To
    the best of your knowledge, have all required disclosures been filed? If
    not, explain why. If yes, summarize any relevant discussion, including links
    to publicly-available messages when applicable.

All authors have stated they have no knowledge of any IPR related to this draft.

13. Has each author, editor, and contributor shown their willingness to be
    listed as such? If the total number of authors and editors on the front page
    is greater than five, please provide a justification.

Yes.

14. Document any remaining I-D nits in this document. Simply running the [idnits
    tool][8] is not enough; please review the ["Content Guidelines" on
    authors.ietf.org][15]. (Also note that the current idnits tool generates
    some incorrect warnings; a rewrite is underway.)

* The abstract needs to be updated to explicitly state this document replaces RFC 5990.

* Several normative references to informative RFCs that should be resolved in some manner:

- RFC 3394, 5911, 5912, 6268, 8017

most of these RFCs are "informational" only because they describe things that are
normatively specified elsewhere, and the draft doesn't appear to normatively rely
on them anyway (the references tend to be in ASN.1 comments or referenced as
inspiration, not for their normative value).  I'd recommend just moving these
references to the informational section, unless the authors believe they need to
be normative references.

15. Should any informative references be normative or vice-versa? See the [IESG
    Statement on Normative and Informative References][16].

See 14.

16. List any normative references that are not freely available to anyone. Did
    the community have sufficient access to review any such normative
    references?

ANS-X9.44 and ISO 18033-2.  The shepherd has copies and was able to review them. 
They were the basis for RFC 5990 as well, and those references are largely
irrelevant to the updates being made here.

17. Are there any normative downward references (see [RFC 3967][9] and [BCP
    97
][10]) that are not already listed in the [DOWNREF registry][17]? If so,
    list them.

Yes, but they will likely go away as part of resolving the issues noted in 14.

18. Are there normative references to documents that are not ready to be
    submitted to the IESG for publication or are otherwise in an unclear state?
    If so, what is the plan for their completion?

No.  ietf-lamps-cms-kemri is referenced, but that's already in the RFC editor's queue.

19. Will publication of this document change the status of any existing RFCs? If
    so, does the Datatracker metadata correctly reflect this and are those RFCs
    listed on the title page, in the abstract, and discussed in the
    introduction? If not, explain why and point to the part of the document
    where the relationship of this document to these other RFCs is discussed.

The abstract and introduction need to be updated to clearly state that this
document obsoletes RFC 5990.

20. Describe the document shepherd's review of the IANA considerations section,
    especially with regard to its consistency with the body of the document.
    Confirm that all aspects of the document requiring IANA assignments are
    associated with the appropriate reservations in IANA registries. Confirm
    that any referenced IANA registries have been clearly identified. Confirm
    that each newly created IANA registry specifies its initial contents,
    allocations procedures, and a reasonable name (see [RFC 8126][11]).

The IANA considerations request one module identifier.  The request looks reasonable.

21. List any new IANA registries that require Designated Expert Review for
    future allocations. Are the instructions to the Designated Expert clear?
    Please include suggestions of designated experts, if appropriate.

No new registries.

[1]: https://www.ietf.org/about/groups/iesg/
[2]: https://www.rfc-editor.org/rfc/rfc4858.html
[3]: https://www.rfc-editor.org/rfc/rfc7942.html
[4]: https://wiki.ietf.org/group/ops/yang-review-tools
[5]: https://www.rfc-editor.org/rfc/rfc8342.html
[6]: https://wiki.ietf.org/group/iesg/ExpertTopics
[7]: https://www.rfc-editor.org/info/bcp79
[8]: https://www.ietf.org/tools/idnits/
[9]: https://www.rfc-editor.org/rfc/rfc3967.html
[10]: https://www.rfc-editor.org/info/bcp97
[11]: https://www.rfc-editor.org/rfc/rfc8126.html
[12]: https://www.rfc-editor.org/rfc/rfc2026.html#section-5
[13]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.1
[14]: https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2
[15]: https://authors.ietf.org/en/content-guidelines-overview
[16]: https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
[17]: https://datatracker.ietf.org/doc/downref/

2024-04-05
05 Tim Hollebeek Changed consensus to Yes from Unknown
2024-04-05
05 Tim Hollebeek Intended Status changed to Proposed Standard from None
2024-04-05
05 Tim Hollebeek Notification list changed to tim.hollebeek@digicert.com because the document shepherd was set
2024-04-05
05 Tim Hollebeek Document shepherd changed to Tim Hollebeek
2024-04-05
05 Tim Hollebeek IETF WG state changed to WG Consensus: Waiting for Write-Up from WG Document
2024-03-04
05 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-05.txt
2024-03-04
05 Sean Turner New version approved
2024-03-04
05 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2024-03-04
05 Russ Housley Uploaded new revision
2023-10-19
04 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-04.txt
2023-10-19
04 Sean Turner New version approved
2023-10-19
04 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2023-10-19
04 Russ Housley Uploaded new revision
2023-10-18
03 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-03.txt
2023-10-18
03 Sean Turner New version approved
2023-10-18
03 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2023-10-18
03 Russ Housley Uploaded new revision
2023-10-13
02 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-02.txt
2023-10-13
02 Sean Turner New version approved
2023-10-13
02 (System) Request for posting confirmation emailed to previous authors: Russ Housley , Sean Turner
2023-10-13
02 Russ Housley Uploaded new revision
2023-09-12
01 Sean Turner New version available: draft-ietf-lamps-rfc5990bis-01.txt
2023-09-12
01 Sean Turner New version accepted (logged-in submitter: Sean Turner)
2023-09-12
01 Sean Turner Uploaded new revision
2023-04-19
00 Russ Housley This document now replaces draft-housley-lamps-rfc5990bis instead of None
2023-04-19
00 Russ Housley New version available: draft-ietf-lamps-rfc5990bis-00.txt
2023-04-19
00 Russ Housley WG -00 approved
2023-04-18
00 Russ Housley Set submitter to "Russ Housley ", replaces to (none) and sent approval email to group chairs: lamps-chairs@ietf.org
2023-04-18
00 Russ Housley Uploaded new revision