Remote Attestation Procedures (RATS) Endorsements
draft-ietf-rats-endorsements-13
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2026-10-14
|
13 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-13.txt |
|
2026-10-14
|
13 | Thomas Fossati | New version approved |
|
2026-10-14
|
13 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati |
|
2026-10-14
|
13 | Thomas Fossati | Uploaded new revision |
|
2026-10-12
|
12 | (System) | Changed action holders to Christopher Inacio (IESG state changed) |
|
2026-10-12
|
12 | (System) | Sub state has been changed to AD Followup from Revised I-D Needed |
|
2026-10-12
|
12 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-12.txt |
|
2026-10-12
|
12 | Thomas Fossati | New version approved |
|
2026-10-12
|
12 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati |
|
2026-10-12
|
12 | Thomas Fossati | Uploaded new revision |
|
2026-10-08
|
11 | (System) | Changed action holders to Dave Thaler, Thomas Fossati, Henk Birkholz (IESG state changed) |
|
2026-10-08
|
11 | Morgan Condie | IESG state changed to Approved-announcement to be sent::Revised I-D Needed from IESG Evaluation |
|
2026-10-08
|
11 | Jim Guichard | [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard |
|
2026-10-07
|
11 | Deb Cooley | [Ballot comment] Thanks to Vincent Roca for their secdir review. Abstract, second para, second sentence: Consider changing 'extends' to 'updates near the beginning of the … [Ballot comment] Thanks to Vincent Roca for their secdir review. Abstract, second para, second sentence: Consider changing 'extends' to 'updates near the beginning of the sentence. Also consider removing the phrase, 'as these topics were outside the scope of the rats charter when RFC 9334 was developed'. Introduction, second para: Again, I'm not sure whether the information about the charter update is useful, I would consider removing it here too. Introduction: What would be useful is a list of changes/additions that this specification provides as an update to RFC 9334. Introduction, or Sec 2: Consider adding the definition of 'conceptual messages', since RFC 9334 does not actually define them. Or reference RFC 9999 (Section 1) where they are defined. |
|
2026-10-07
|
11 | Deb Cooley | [Ballot Position Update] New position, No Objection, has been recorded for Deb Cooley |
|
2026-10-07
|
11 | Mike Bishop | [Ballot comment] # IESG review of draft-ietf-rats-endorsements-11 CC @MikeBishop ## Comments ### Section 5, paragraph 4 In addition to the Verifier needing to consider conflicting … [Ballot comment] # IESG review of draft-ietf-rats-endorsements-11 CC @MikeBishop ## Comments ### Section 5, paragraph 4 In addition to the Verifier needing to consider conflicting Endorsements, isn't there a risk that someone selectively presents only the older Endorsement? ### Inclusive language #### Section 8, paragraph 3 ``` terminating within the appraisal session context, to avoid man-in- the-middle attacks. Minimizing the use of intermediaries is also ``` RFC Editor style prefers "on-path attacker"; see https://www.rfc-editor.org/part2/#inclusive_language for background and more guidance. ## Nits All comments below are about very minor potential issues that you may choose to address in some way - or ignore - as you see fit. Some were flagged by automated tools (via https://github.com/larseggert/ietf-reviewtool), so there will likely be some false positives. There is no need to let me know what you did with these suggestions. ### Typos #### "Abstract", paragraph 2 ``` - Endorsements and Reference Values. Instead, it extends RFC9334 to + Endorsements and Reference Values. Instead, it extends RFC 9334 to + + ``` #### "Abstract", paragraph 2 ``` - these topics were outside the scope of the RATS charter when RFC9334 + these topics were outside the scope of the RATS charter when RFC 9334 + + ``` ### Section 2, paragraph 1 ``` state of an Attester includes its "shape", i.e., the structural ``` This is the only use of "shape" in this document; maybe just "includes the structural..."? ### Section 8, paragraph 1 ``` The binding from an Endorsement to a given Target Environment is done as discussed in Section 4 of this document. ``` This seems more like Section 6. Is this correct? ### Grammar/style #### Section 2, paragraph 1 ``` deployed software, firmware, and micro-code), static and dynamic configurati ^^^^^^^^^^ ``` This word is normally spelled as one. #### Section 5, paragraph 5 ``` aims about that Target Environment. Thus each Target Environment (application ^^^^ ``` A comma may be missing after the conjunctive/linking adverb "Thus". ## Notes This review is in the ["IETF Comments" Markdown format][ICMF]. You can use the [`ietf-comments` tool][ICT] to automatically convert this review into individual GitHub issues. Review generated by the [`ietf-reviewtool`][IRT]. [ICMF]: https://github.com/mnot/ietf-comments/blob/main/format.md [ICT]: https://github.com/mnot/ietf-comments [IRT]: https://github.com/larseggert/ietf-reviewtool |
|
2026-10-07
|
11 | Mike Bishop | [Ballot Position Update] New position, No Objection, has been recorded for Mike Bishop |
|
2026-10-07
|
11 | Mohamed Boucadair | [Ballot comment] Hi Dave, Henk, and Thomas, Thank you for the effort put into this document. Thanks also to Jen for the OPSDIR review. Please … [Ballot comment] Hi Dave, Henk, and Thomas, Thank you for the effort put into this document. Thanks also to Jen for the OPSDIR review. Please find below some few comments: # Suggest to delete process/charter details from the document # Make it clear the update does not change any part of the arch document; it is more a zoom on some aspects. # For authors convenience, I sent a PR with few suggestions: https://github.com/ietf-rats-wg/rats-endorsements/pull/94. Feel free to grab whatever useful. Cheers, Med |
|
2026-10-07
|
11 | Mohamed Boucadair | [Ballot Position Update] New position, No Objection, has been recorded for Mohamed Boucadair |
|
2026-10-07
|
11 | Charles Eckel | [Ballot comment] Thanks to Jim Fenton for the ARTART review, and thanks to the authors for addressing the concerns he raised. |
|
2026-10-07
|
11 | Charles Eckel | [Ballot Position Update] New position, No Objection, has been recorded for Charles Eckel |
|
2026-10-06
|
11 | Roman Danyliw | [Ballot comment] ** Ketan raises a good point about the use of the updates tag, and subsequent use of "extends". ** Section 6 When … [Ballot comment] ** Ketan raises a good point about the use of the updates tag, and subsequent use of "extends". ** Section 6 When Target Environments from different vendors each have their own Endorser, a Verifier must be able to distinguish which Endorser is allowed to provide an Endorsement about which Target Environment. … The binding between Target Environment and Endorser might be part of the Appraisal Policy for Evidence, or might be specified as part of the Evidence itself (e.g., claims from a Target Environment might include an identifier of what Endorser can provide additional claims about it), or some combination of the two. Considering this caution that Verifiers need to be able to distinguish which Endorser is applicable for a given Target Environment, how can the Evidence carry the binding between the Target Environment/Endorser? This would imply that the Verifier would already have to trust the Endorser. It seems like this binding could only come from the Appraisal Policy which is independent of the Endorser/TE/Evidence. |
|
2026-10-06
|
11 | Roman Danyliw | [Ballot Position Update] New position, No Objection, has been recorded for Roman Danyliw |
|
2026-10-06
|
11 | Andy Newton | [Ballot comment] I have no objection to this document being published as an RFC. Many thanks to Jim Fenton for the ARTART review, and thanks … [Ballot comment] I have no objection to this document being published as an RFC. Many thanks to Jim Fenton for the ARTART review, and thanks to the authors for engaging with him to address his concerns. |
|
2026-10-06
|
11 | Andy Newton | [Ballot Position Update] New position, No Objection, has been recorded for Andy Newton |
|
2026-10-06
|
11 | Gunter Van de Velde | [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde |
|
2026-10-06
|
11 | Ketan Talaulikar | [Ballot comment] Thanks to the authors and the WG for their work on this document. Please find below a couple of comments/suggestions inline in the … [Ballot comment] Thanks to the authors and the WG for their work on this document. Please find below a couple of comments/suggestions inline in the idnits output of v11 of this document. The end of the review is marked by the tag 24 This document does not aim to define a conceptual message format for 25 Endorsements and Reference Values. Instead, it extends RFC9334 to 26 provide further details on Reference Values and Endorsements, as 27 these topics were outside the scope of the RATS charter when RFC9334 28 was developed. Suggest dropping the charter history from the Abstract; it dates quickly there, and the Introduction already carries it. 24 This document does not aim to define a conceptual message format for 25 Endorsements and Reference Values. Instead, it extends RFC9334 to 26 provide further details on Reference Values and Endorsements, as 27 these topics were outside the scope of the RATS charter when RFC9334 28 was developed. The document carries "Updates: 9334", but neither the Abstract nor the Introduction says what in RFC 9334 is changed; both describe it as extending RFC 9334 with further detail. If the relationship is intended, suggest saying in each what a reader of RFC 9334 now reads alongside it; if the document only adds detail that Section 8 of RFC 9334 leaves to other specifications, perhaps the header is not needed. Please correct me if I am reading this wrong. |
|
2026-10-06
|
11 | Ketan Talaulikar | [Ballot Position Update] New position, No Objection, has been recorded for Ketan Talaulikar |
|
2026-10-02
|
11 | (System) | IANA Review state changed to IANA OK - No Actions Needed from Version Changed - Review Needed |
|
2026-10-01
|
11 | Gorry Fairhurst | [Ballot comment] Thanks for providing this document. I do not see any transport-protocol related concerns. Best wishes, Gorry |
|
2026-10-01
|
11 | Gorry Fairhurst | [Ballot Position Update] New position, No Objection, has been recorded for Gorry Fairhurst |
|
2026-09-22
|
11 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-11.txt |
|
2026-09-22
|
11 | (System) | New version approved |
|
2026-09-22
|
11 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati |
|
2026-09-22
|
11 | Thomas Fossati | Uploaded new revision |
|
2026-09-20
|
10 | Cindy Morgan | Placed on agenda for telechat - 2026-10-08 |
|
2026-09-19
|
10 | Christopher Inacio | Ballot has been issued |
|
2026-09-19
|
10 | Christopher Inacio | [Ballot Position Update] New position, Yes, has been recorded for Christopher Inacio |
|
2026-09-19
|
10 | Christopher Inacio | Created "Approve" ballot |
|
2026-09-19
|
10 | Christopher Inacio | IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead |
|
2026-09-19
|
10 | Christopher Inacio | Ballot writeup was changed |
|
2026-09-16
|
10 | (System) | IANA Review state changed to Version Changed - Review Needed from IANA OK - No Actions Needed |
|
2026-09-16
|
10 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-10.txt |
|
2026-09-16
|
10 | (System) | New version approved |
|
2026-09-16
|
10 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2026-09-16
|
10 | Thomas Fossati | Uploaded new revision |
|
2026-09-11
|
09 | Vincent Roca | Request for IETF Last Call review by SECDIR Completed: Ready. Reviewer: Vincent Roca. Sent review to list. |
|
2026-09-07
|
09 | (System) | IESG state changed to Waiting for AD Go-Ahead from In Last Call |
|
2026-09-06
|
09 | Jen Linkova | Request for IETF Last Call review by OPSDIR Completed: Has Nits. Reviewer: Jen Linkova. Sent review to list. |
|
2026-09-04
|
09 | (System) | IANA Review state changed to IANA OK - No Actions Needed from IANA - Review Needed |
|
2026-09-03
|
09 | Jim Fenton | Request for IETF Last Call review by ARTART Completed: Ready with Nits. Reviewer: Jim Fenton. Sent review to list. |
|
2026-08-28
|
09 | Bo Wu | Request for IETF Last Call review by OPSDIR is assigned to Jen Linkova |
|
2026-08-28
|
09 | Mohamed Boucadair | Requested IETF Last Call review by OPSDIR |
|
2026-08-27
|
09 | Tero Kivinen | Request for IETF Last Call review by SECDIR is assigned to Vincent Roca |
|
2026-08-27
|
09 | Jean Mahoney | Request for IETF Last Call review by GENART is assigned to Lucas Pardue |
|
2026-08-24
|
09 | Barry Leiba | Request for IETF Last Call review by ARTART is assigned to Jim Fenton |
|
2026-08-24
|
09 | Morgan Condie | IANA Review state changed to IANA - Review Needed |
|
2026-08-24
|
09 | Morgan Condie | The following Last Call announcement was sent out (ends 2026-09-07): From: The IESG To: IETF-Announce CC: draft-ietf-rats-endorsements@ietf.org, ned.smith.ietf@outlook.com, rats-chairs@ietf.org, rats@ietf.org, stndrds-inacio@andrew.cmu.edu … The following Last Call announcement was sent out (ends 2026-09-07): From: The IESG To: IETF-Announce CC: draft-ietf-rats-endorsements@ietf.org, ned.smith.ietf@outlook.com, rats-chairs@ietf.org, rats@ietf.org, stndrds-inacio@andrew.cmu.edu, yogesh.deshpande@arm.com Reply-To: last-call@ietf.org Sender: Subject: Last Call: (RATS Endorsements) to Informational RFC The IESG has received a request from the Remote ATtestation ProcedureS WG (rats) to consider the following document: - 'RATS Endorsements' as Informational RFC The IESG plans to make a decision in the next few weeks, and solicits final comments on this action. Please send substantive comments to the last-call@ietf.org mailing lists by 2026-09-07. Exceptionally, comments may be sent to iesg@ietf.org instead. In either case, please retain the beginning of the Subject line to allow automated sorting. Abstract In the IETF Remote Attestation Procedures (RATS) architecture, a Verifier accepts Evidence and uses Appraisal Policy for Evidence, typically with additional input from Endorsements and Reference Values, to generate Attestation Results in formats that are useful for Relying Parties. This document illustrates the purpose and role of Endorsements and discusses some considerations in the choice of message format for Endorsements in the scope of the RATS architecture. This document does not aim to define a conceptual message format for Endorsements and Reference Values. Instead, it extends RFC9334 to provide further details on Reference Values and Endorsements, as these topics were outside the scope of the RATS charter when RFC9334 was developed. The file can be obtained via https://datatracker.ietf.org/doc/draft-ietf-rats-endorsements/ No IPR declarations have been submitted directly on this I-D. |
|
2026-08-24
|
09 | Morgan Condie | IESG state changed to In Last Call from Last Call Requested |
|
2026-08-24
|
09 | Morgan Condie | Last call announcement was generated |
|
2026-08-24
|
09 | Morgan Condie | Last call announcement was generated |
|
2026-08-23
|
09 | Christopher Inacio | Last call was requested |
|
2026-08-23
|
09 | Christopher Inacio | Last call announcement was generated |
|
2026-08-23
|
09 | Christopher Inacio | Ballot approval text was generated |
|
2026-08-23
|
09 | Christopher Inacio | IESG state changed to Last Call Requested from AD Evaluation |
|
2026-08-23
|
09 | Christopher Inacio | Ballot writeup was changed |
|
2026-06-27
|
09 | Christopher Inacio | IESG state changed to AD Evaluation from Publication Requested |
|
2026-06-27
|
09 | Christopher Inacio | Changed action holders to Christopher Inacio (moving to responsible AD after previous AD transition) |
|
2026-03-18
|
09 | Liz Flynn | Shepherding AD changed to Christopher Inacio |
|
2026-03-14
|
09 | Ned Smith | Notification list changed to ned.smith.ietf@outlook.com, yogesh.deshpande@arm.com from ned.smith@intel.com, yogesh.deshpande@arm.com |
|
2026-03-13
|
09 | Kathleen Moriarty | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? The WG reached a broad agreement, as the subject is valuable to the RATS WG now that RATS Reference Values and Endorsements are within the charter. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a total concensus on the technical aspects present in the document. Though there was a rough concensus on where the material presented in the document should reside. Few experts suggested it to be part of RFC9334-bis but this idea was turned down eventually. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available) None to the knowledge of the Shepherd. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? The Rats Endorsement document is an Informational RFC, so there is not a direct implementation applicable to this standard. However matching of Evidence to Reference Values can be seen in open source project Veraison - https://github.com:veraison ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. ONLY Shepherd Review has been undertaken so far. The document is applicable to Security Feature Remote Attestation. Security Considerations: It is important that the Security Considerations section adequately reflects any security impacts associated with endorsement formats and interpretation, especially how endorsement claim semantics impact verifier trust decisions. This review area has been conducted by WG reviews. Protocol Interaction: While the draft is informational and does not specify protocols directly, it interacts with other RATS documents (e.g., evidence formats, appraisal policies). The Shepherd has reviewed for high-level consistency. The Shepherd is not aware of any required formal outside expert reviews (e.g., AAA, DNS) necessary for this informational document. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. Not Applicable 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This aspect is not applicable 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The Datatracker page links an ID Nits check; ID-Nits tool was run post publication of the 09 revision. It shows no major error or flaws in the document. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd had a detailed review of the version 08 document on 06th February 2026. The details of the Review were tracked via issue: https://github.com/ietf-rats-wg/rats-endorsements/issues/67 and comments emailed to RATS mailing list. Major comments on Document Clarity and Security and Privacy Considerations were raised by the Shepherd review. The Authors worked upon the Review Comments and a new Draft Version 09 with all comments incorporated have now been published. As a document Shepherd, I have personally verified that the comments during the review have been addressed. The document is clearly needed, it is clearly written, complete and ready to handed off to next stage of reviews. Given the security relevant nature of RATS Reference Values and Endorsements, a , secdir review is recommended; iotdir and opsdir may also be useful for deployment aspects. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The document is an Extension of RFC 9334, and hence on an Informational Track 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The draft includes the standard BCP 78/79 notices. The Shepherd has obtained via email to Authors Mailing list explicit IPR confirmation from all authors. Each author has confirmed NO Knowledge of any IPR for this document. T he Datatracker page for this draft does not list an AD or IESG state yet; the page includes the IPR link (no disclosures are visible there at the time of this write up). 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, individual explicit email approval of been listed as authors been sought with individual authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) This will be completed during the subsequent review phase 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None exist at the moment. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. The RATS endorsements draft is informational and the referenced documents are also informational, and are referenced as information, so there is no downref (e.g. an informative document referenced as normative). 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document has no IANA request to be made 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. The document has no IANA request to be made |
|
2026-03-13
|
09 | Kathleen Moriarty | IETF WG state changed to Submitted to IESG for Publication from WG Consensus: Waiting for Write-Up |
|
2026-03-13
|
09 | Kathleen Moriarty | IESG state changed to Publication Requested from I-D Exists |
|
2026-03-13
|
09 | (System) | Changed action holders to Deb Cooley (IESG state changed) |
|
2026-03-13
|
09 | Kathleen Moriarty | Responsible AD changed to Deb Cooley |
|
2026-03-13
|
09 | Kathleen Moriarty | Document is now in IESG state Publication Requested |
|
2026-03-13
|
09 | Kathleen Moriarty | Intended Status changed to Informational from None |
|
2026-03-13
|
09 | Kathleen Moriarty | Changed consensus to Yes from Unknown |
|
2026-03-13
|
09 | Yogesh Deshpande | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? The WG reached a broad agreement, as the subject is valuable to the RATS WG now that RATS Reference Values and Endorsements are within the charter. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a total concensus on the technical aspects present in the document. Though there was a rough concensus on where the material presented in the document should reside. Few experts suggested it to be part of RFC9334-bis but this idea was turned down eventually. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available) None to the knowledge of the Shepherd. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? The Rats Endorsement document is an Informational RFC, so there is not a direct implementation applicable to this standard. However matching of Evidence to Reference Values can be seen in open source project Veraison - https://github.com:veraison ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. ONLY Shepherd Review has been undertaken so far. The document is applicable to Security Feature Remote Attestation. Security Considerations: It is important that the Security Considerations section adequately reflects any security impacts associated with endorsement formats and interpretation, especially how endorsement claim semantics impact verifier trust decisions. This review area has been conducted by WG reviews. Protocol Interaction: While the draft is informational and does not specify protocols directly, it interacts with other RATS documents (e.g., evidence formats, appraisal policies). The Shepherd has reviewed for high-level consistency. The Shepherd is not aware of any required formal outside expert reviews (e.g., AAA, DNS) necessary for this informational document. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. Not Applicable 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This aspect is not applicable 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The Datatracker page links an ID Nits check; ID-Nits tool was run post publication of the 09 revision. It shows no major error or flaws in the document. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd had a detailed review of the version 08 document on 06th February 2026. The details of the Review were tracked via issue: https://github.com/ietf-rats-wg/rats-endorsements/issues/67 and comments emailed to RATS mailing list. Major comments on Document Clarity and Security and Privacy Considerations were raised by the Shepherd review. The Authors worked upon the Review Comments and a new Draft Version 09 with all comments incorporated have now been published. As a document Shepherd, I have personally verified that the comments during the review have been addressed. The document is clearly needed, it is clearly written, complete and ready to handed off to next stage of reviews. Given the security relevant nature of RATS Reference Values and Endorsements, a , secdir review is recommended; iotdir and opsdir may also be useful for deployment aspects. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The document is an Extension of RFC 9334, and hence on an Informational Track 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The draft includes the standard BCP 78/79 notices. The Shepherd has obtained via email to Authors Mailing list explicit IPR confirmation from all authors. Each author has confirmed NO Knowledge of any IPR for this document. T he Datatracker page for this draft does not list an AD or IESG state yet; the page includes the IPR link (no disclosures are visible there at the time of this write up). 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, individual explicit email approval of been listed as authors been sought with individual authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) This will be completed during the subsequent review phase 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None exist at the moment. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. The RATS endorsements draft is informational and the referenced documents are also informational, and are referenced as information, so there is no downref (e.g. an informative document referenced as normative). 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document has no IANA request to be made 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. The document has no IANA request to be made |
|
2026-03-13
|
09 | Yogesh Deshpande | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? The WG reached a broad agreement, as the subject is valuable to the RATS WG now that RATS Reference Values and Endorsements are within the charter. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a total concensus on the technical aspects present in the document. Though there was a rough concensus on where the material presented in the document should reside. Few experts suggested it to be part of RFC9334-bis but this idea was turned down eventually. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available) None to the knowledge of the Shepherd. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? The Rats Endorsement document is an Informational RFC, so there is not a direct implementation applicable to this standard. However matching of Evidence to Reference Values can be seen in open source project Veraison - https://github.com:veraison ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. ONLY Shepherd Review has been undertaken so far. The document is applicable to Security Feature Remote Attestation. Security Considerations: It is important that the Security Considerations section adequately reflects any security impacts associated with endorsement formats and interpretation, especially how endorsement claim semantics impact verifier trust decisions. This review area has been conducted by WG reviews. Protocol Interaction: While the draft is informational and does not specify protocols directly, it interacts with other RATS documents (e.g., evidence formats, appraisal policies). The Shepherd has reviewed for high-level consistency. The Shepherd is not aware of any required formal outside expert reviews (e.g., AAA, DNS) necessary for this informational document. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. Not Applicable 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This aspect is not applicable 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The Datatracker page links an ID Nits check; ID-Nits tool was run post publication of the 09 revision. It shows no major error or flaws in the document. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd had a detailed review of the version 08 document on 06th February 2026. The details of the Review were tracked via issue: https://github.com/ietf-rats-wg/rats-endorsements/issues/67 and comments emailed to RATS mailing list. Major comments on Document Clarity and Security and Privacy Considerations were raised by the Shepherd review. The Authors worked upon the Review Comments and a new Draft Version 09 with all comments incorporated have now been published. As a document Shepherd, I have personally verified that the comments during the review have been addressed. The document is clearly needed, it is clearly written, complete and ready to handed off to next stage of reviews. Given the security relevant nature of RATS Reference Values and Endorsements, a , secdir review is recommended; iotdir and opsdir may also be useful for deployment aspects. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The document is an Extension of RFC 9334, and hence on an Informational Track 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The draft includes the standard BCP 78/79 notices. The Shepherd has obtained via email to Authors Mailing list explicit IPR confirmation from all authors. Each author has confirmed NO Knowledge of any IPR for this document. T he Datatracker page for this draft does not list an AD or IESG state yet; the page includes the IPR link (no disclosures are visible there at the time of this write up). 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, individual explicit email approval of been listed as authors been sought with individual authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) This will be completed during the subsequent review phase 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None exist at the moment. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. The RATS endorsements draft is informational and the referenced documents are also informational, and are referenced as information, so there is no downref (e.g. an informative document referenced as normative). 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document has no IANA request to be made 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. The document has no IANA request to be made Shepherd’s Concerns (if any) Note there is ONE Concern that needs to be resolved before this document becoming an RFC. RFC 9334 is added to the downref list, which implies that it can be referenced Normatively. RATS Endorsement Document is an extension of RFC 9334 and this document refers to RFC9334. Hence RATS Endorsement Document MUST be added to Downref List. Or otherwise, it cannot be refereced Normatively (as it is an extension of RFC9334). |
|
2026-03-13
|
09 | Kathleen Moriarty | The draft is ready to progress and just needs the shepherd report to be updated to reflect that there are no downrefs to avoid any … The draft is ready to progress and just needs the shepherd report to be updated to reflect that there are no downrefs to avoid any confusion. |
|
2026-03-13
|
09 | Kathleen Moriarty | IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call |
|
2026-03-10
|
09 | Yogesh Deshpande | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? The WG reached a broad agreement, as the subject is valuable to the RATS WG now that RATS Reference Values and Endorsements are within the charter. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a total concensus on the technical aspects present in the document. Though there was a rough concensus on where the material presented in the document should reside. Few experts suggested it to be part of RFC9334-bis but this idea was turned down eventually. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available) None to the knowledge of the Shepherd. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? The Rats Endorsement document is an Informational RFC, so there is not a direct implementation applicable to this standard. However matching of Evidence to Reference Values can be seen in open source project Veraison - https://github.com:veraison ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. ONLY Shepherd Review has been undertaken so far. The document is applicable to Security Feature Remote Attestation. Security Considerations: It is important that the Security Considerations section adequately reflects any security impacts associated with endorsement formats and interpretation, especially how endorsement claim semantics impact verifier trust decisions. This review area has been conducted by WG reviews. Protocol Interaction: While the draft is informational and does not specify protocols directly, it interacts with other RATS documents (e.g., evidence formats, appraisal policies). The Shepherd has reviewed for high-level consistency. The Shepherd is not aware of any required formal outside expert reviews (e.g., AAA, DNS) necessary for this informational document. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. Not Applicable 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This aspect is not applicable 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The Datatracker page links an ID Nits check; ID-Nits tool was run post publication of the 09 revision. It shows no major error or flaws in the document. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd had a detailed review of the version 08 document on 06th February 2026. The details of the Review were tracked via issue: https://github.com/ietf-rats-wg/rats-endorsements/issues/67 and comments emailed to RATS mailing list. Major comments on Document Clarity and Security and Privacy Considerations were raised by the Shepherd review. The Authors worked upon the Review Comments and a new Draft Version 09 with all comments incorporated have now been published. As a document Shepherd, I have personally verified that the comments during the review have been addressed. The document is clearly needed, it is clearly written, complete and ready to handed off to next stage of reviews. Given the security relevant nature of RATS Reference Values and Endorsements, a , secdir review is recommended; iotdir and opsdir may also be useful for deployment aspects. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The document is an Extension of RFC 9334, and hence on an Informational Track 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The draft includes the standard BCP 78/79 notices. The Shepherd has obtained via email to Authors Mailing list explicit IPR confirmation from all authors. Each author has confirmed NO Knowledge of any IPR for this document. T he Datatracker page for this draft does not list an AD or IESG state yet; the page includes the IPR link (no disclosures are visible there at the time of this write up). 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, individual explicit email approval of been listed as authors been sought with individual authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) This will be completed during the subsequent review phase 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None exist at the moment. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. A final downref check will be performed when references are finalized; no specific downrefs have been flagged in WG discussion to date. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document has no IANA request to be made 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. The document has no IANA request to be made Shepherd’s Concerns (if any) Note there is ONE Concern that needs to be resolved before this document becoming an RFC. RFC 9334 is added to the downref list, which implies that it can be referenced Normatively. RATS Endorsement Document is an extension of RFC 9334 and this document refers to RFC9334. Hence RATS Endorsement Document MUST be added to Downref List. Or otherwise, it cannot be refereced Normatively (as it is an extension of RFC9334). |
|
2026-03-10
|
09 | Yogesh Deshpande | # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent … # Document Shepherd Write-Up for Group Documents *This version is dated 4 July 2022.* ## Document History 1. Does the working group (WG) consensus represent the strong concurrence of a few individuals, with others being silent, or did it reach broad agreement? The WG reached a broad agreement, as the subject is valuable to the RATS WG now that RATS Reference Values and Endorsements are within the charter. 2. Was there controversy about particular points, or were there decisions where the consensus was particularly rough? There was a total concensus on the technical aspects present in the document. Though there was a rough concensus on where the material presented in the document should reside. Few experts suggested it to be part of RFC9334-bis but this idea was turned down eventually. 3. Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this questionnaire is publicly available.) None to the knowledge of the Shepherd. 4. For protocol documents, are there existing implementations of the contents of the document? Have a significant number of potential implementers indicated plans to implement? Are any existing implementations reported somewhere, either in the document itself (as [RFC 7942][3] recommends) or elsewhere (where)? The Rats Endorsement document is an Informational RFC, so there is not a direct implementation applicable to this standard. However matching of Evidence to Reference Values can be seen in open source project Veraison - https://github.com:veraison ## Additional Reviews 5. Do the contents of this document closely interact with technologies in other IETF working groups or external organizations, and would it therefore benefit from their review? Have those reviews occurred? If yes, describe which reviews took place. ONLY Shepherd Review has been undertaken so far. The document is applicable to Security Feature Remote Attestation. Security Considerations: It is important that the Security Considerations section adequately reflects any security impacts associated with endorsement formats and interpretation, especially how endorsement claim semantics impact verifier trust decisions. This review area has been conducted by WG reviews. Protocol Interaction: While the draft is informational and does not specify protocols directly, it interacts with other RATS documents (e.g., evidence formats, appraisal policies). The Shepherd has reviewed for high-level consistency. The Shepherd is not aware of any required formal outside expert reviews (e.g., AAA, DNS) necessary for this informational document. 6. Describe how the document meets any required formal expert review criteria, such as the MIB Doctor, YANG Doctor, media type, and URI type reviews. Not Applicable 7. If the document contains a YANG module, has the final version of the module been checked with any of the [recommended validation tools][4] for syntax and formatting validation? If there are any resulting errors or warnings, what is the justification for not fixing them at this time? Does the YANG module comply with the Network Management Datastore Architecture (NMDA) as specified in [RFC 8342][5]? This aspect is not applicable 8. Describe reviews and automated checks performed to validate sections of the final version of the document written in a formal language, such as XML code, BNF rules, MIB definitions, CBOR's CDDL, etc. The Datatracker page links an ID Nits check; ID-Nits tool was run post publication of the 09 revision. It shows no major error or flaws in the document. ## Document Shepherd Checks 9. Based on the shepherd's review of the document, is it their opinion that this document is needed, clearly written, complete, correctly designed, and ready to be handed off to the responsible Area Director? The shepherd had a detailed review of the version 08 document on 06th February 2026. The details of the Review were tracked via issue: https://github.com/ietf-rats-wg/rats-endorsements/issues/67 and comments emailed to RATS mailing list. Major comments on Document Clarity and Security and Privacy Considerations were raised by the Shepherd review. The Authors worked upon the Review Comments and a new Draft Version 09 with all comments incorporated have now been published. As a document Shepherd, I have personally verified that the comments during the review have been addressed. The document is clearly needed, it is clearly written, complete and ready to handed off to next stage of reviews. Given the security relevant nature of RATS Reference Values and Endorsements, a , secdir review is recommended; iotdir and opsdir may also be useful for deployment aspects. 10. Several IETF Areas have assembled [lists of common issues that their reviewers encounter][6]. For which areas have such issues been identified and addressed? For which does this still need to happen in subsequent reviews? 11. What type of RFC publication is being requested on the IETF stream ([Best Current Practice][12], [Proposed Standard, Internet Standard][13], [Informational, Experimental or Historic][14])? Why is this the proper type of RFC? Do all Datatracker state attributes correctly reflect this intent? The document is an Extension of RFC 9334, and hence on an Informational Track 12. Have reasonable efforts been made to remind all authors of the intellectual property rights (IPR) disclosure obligations described in [BCP 79][7]? To the best of your knowledge, have all required disclosures been filed? If not, explain why. If yes, summarize any relevant discussion, including links to publicly-available messages when applicable. The draft includes the standard BCP 78/79 notices. The Shepherd has obtained via email to Authors Mailing list explicit IPR confirmation from all authors. Each author has confirmed NO Knowledge of any IPR for this document. T he Datatracker page for this draft does not list an AD or IESG state yet; the page includes the IPR link (no disclosures are visible there at the time of this write up). 13. Has each author, editor, and contributor shown their willingness to be listed as such? If the total number of authors and editors on the front page is greater than five, please provide a justification. Yes, individual explicit email approval of been listed as authors been sought with individual authors. 14. Document any remaining I-D nits in this document. Simply running the [idnits tool][8] is not enough; please review the ["Content Guidelines" on authors.ietf.org][15]. (Also note that the current idnits tool generates some incorrect warnings; a rewrite is underway.) This will be completed during the subsequent review phase 15. Should any informative references be normative or vice-versa? See the [IESG Statement on Normative and Informative References][16]. 16. List any normative references that are not freely available to anyone. Did the community have sufficient access to review any such normative references? None exist at the moment. 17. Are there any normative downward references (see [RFC 3967][9] and [BCP 97][10]) that are not already listed in the [DOWNREF registry][17]? If so, list them. A final downref check will be performed when references are finalized; no specific downrefs have been flagged in WG discussion to date. 18. Are there normative references to documents that are not ready to be submitted to the IESG for publication or are otherwise in an unclear state? If so, what is the plan for their completion? 19. Will publication of this document change the status of any existing RFCs? If so, does the Datatracker metadata correctly reflect this and are those RFCs listed on the title page, in the abstract, and discussed in the introduction? If not, explain why and point to the part of the document where the relationship of this document to these other RFCs is discussed. 20. Describe the document shepherd's review of the IANA considerations section, especially with regard to its consistency with the body of the document. Confirm that all aspects of the document requiring IANA assignments are associated with the appropriate reservations in IANA registries. Confirm that any referenced IANA registries have been clearly identified. Confirm that each newly created IANA registry specifies its initial contents, allocations procedures, and a reasonable name (see [RFC 8126][11]). The document has no IANA request to be made 21. List any new IANA registries that require Designated Expert Review for future allocations. Are the instructions to the Designated Expert clear? Please include suggestions of designated experts, if appropriate. The document has no IANA request to be made Shepherd’s Concerns (if any) Note there is ONE Concern that needs to be resolved before this document becoming an RFC. RFC 9334 is added to the downref list, which implies that it can be referenced Normatively. RATS Endorsement Document is an extension of RFC 9334 and this document refers to RFC9334. Hence RATS Endorsement Document MUST be added to Downref List. Or otherwise, it cannot be refereced Normatively (as it is an extension of RFC9334). |
|
2026-03-03
|
09 | Ned Smith | Document: draft-ietf-rats-endorsements Intended Status: Informational Working Group: RATS (Remote ATtestation ProcedureS) Current Version at time of write‑up: -09 (published 2026‑03‑02) (A) Document Announcement Write‑Up Technical … Document: draft-ietf-rats-endorsements Intended Status: Informational Working Group: RATS (Remote ATtestation ProcedureS) Current Version at time of write‑up: -09 (published 2026‑03‑02) (A) Document Announcement Write‑Up Technical Summary: The purpose of this document is to extend RFC9334 to provide further details on Reference Values and Endorsements. Working Group Summary: The work originated in RATS as a concrete realization presentation and discussion starting at IETF 116 (March 2023) , with an email from RATS Chairs on Mon, 26 June 2023 18:21 UTC requesting call for adoption. Document was adopted in RATS WG on: 2023-12-01 Document Quality: The specification has been discussed in multiple WG meetings and has an open GitHub repository referenced from the Datatracker page. Personnel Document Shepherd: Yogesh Deshpande Responsible Area Director: (TBD at time of write‑up; not yet assigned in Datatracker) (B) Shepherd’s Detailed Write‑Up (RFC 4858) 1. Summary of the Document See the Technical Summary above. The intended status is Informational 2. Document History Individual Versions exists since March 2023, while the WG adopted the work on 2023-12-01 and the first version draft-ietf-rats-endorsements-00 Was published around the same time frame. Subsequent Versions are Published with Revision 01 – Dated 2024-06-12 To latest Revision 09 – Dated 2026-03-02 3. Working Group Summary (Degree of Consensus / Controversy) The topic has received repeated presentations and discussion. The Datatracker entry links to a GitHub repo; The document gained relevance because of RATS Charter been modified to widen the scope to include Reference Values and Endorsements to be included in the charter. There were initial discussions about whether an RFC9334-bis would have been appropriate for this? Though the WG concluded the timeline for a RFC9334-bis was not appropriate as a result, this document, stayed as a separate Informational draft. 4. Document Quality (Reviews / Implementations) Over the last two years since the document was originally adopted (revision 00) to revision 09, the document has made significant clarity, and 21 issues are resolved via 50 Pull Requests to the document. The Shepherd recommends secdir and iotdir reviews now that the Shepherd Review has been completed. Shepherd’s Review of the Document: The shepherd had a detailed review of the version 08 document on 06th February 2026. The details of the Review were tracked via issue: https://github.com/ietf-rats-wg/rats-endorsements/issues/67 and comments emailed to RATS mailing list. Major comments on Document Clarity and Security and Privacy Considerations were raised by the Shepherd review. The Authors worked upon the Review Comments and a new Draft Version 09 with all comments incorporated have now been published. As a document Shepherd, I have personally verified that the comments during the review have been addressed. 6. Shepherd’s Concerns (if any) No concerns. Shepherd believes that the further reviews like SecDir and OPSDir or iotDir once complete, review comments MUST be addressed with one more revision cycle post focused reviews. 7. IPR Compliance The draft includes the standard BCP 78/79 notices. The Shepherd has obtained via email to Authors Mailing list explicit IPR confirmation from all authors . Each author has confirmed NO Knowledge of any IPR for this document. The Datatracker page for this draft does not list an AD or IESG state yet; the page includes the IPR link (no disclosures are visible there at the time of this write‑up). 8. Has anyone threatened an appeal or otherwise indicated extreme discontent? None to the knowledge of Shepherd 9. How solid is the WG consensus behind the document? The details of the document are enhancement relevant to the concepts given in RFC9334 and there were email discussions indicating rough consensus to advance the document further. 10. ID‑Nits The Datatracker page links an ID‑Nits check; ID-Nits tool was run post publication of the 09 revision. It shows no major error or flaws in the document. 11. Formal/Directorate Review Needs Given the security‑relevant nature of RATS Reference Values and Endorsements, a , secdir review is recommended; iotdir may also be useful for deployment aspects. 12. References (Normative/Informative) The draft has no Normative References (as it’s an Informational RFC) and has a clear reference to Informative References 13. IANA Considerations The document has no IANA request to be made 14. New Registries The document does not create new registries 15. Impact on Existing Registries Not Applicable 16. Intended Status Justification The document extends the RFC9334 as an Informational RFC, which is justified 17. Downward References A final downref check will be performed when references are finalized; no specific downrefs have been flagged in WG discussion to date. 18. Reviews & Shepherd’s Summary of Significant Issues Significant Issues reported so far have been addressed in revision 09 of the draft. 19. Document Shepherd / Responsible AD Shepherd: Yogesh Deshpande Responsible AD: TBC. 20. Additional Notes for the IESG None at this point in time |
|
2026-03-02
|
09 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-09.txt |
|
2026-03-02
|
09 | Thomas Fossati | New version approved |
|
2026-03-02
|
09 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2026-03-02
|
09 | Thomas Fossati | Uploaded new revision |
|
2026-02-25
|
08 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-08.txt |
|
2026-02-25
|
08 | Thomas Fossati | New version approved |
|
2026-02-25
|
08 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2026-02-25
|
08 | Thomas Fossati | Uploaded new revision |
|
2025-12-09
|
07 | Ned Smith | Notification list changed to ned.smith@intel.com, yogesh.deshpande@arm.com from ned.smith@intel.com because the document shepherd was set |
|
2025-12-09
|
07 | Ned Smith | Document shepherd changed to Yogesh Deshpande |
|
2025-08-25
|
07 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-07.txt |
|
2025-08-25
|
07 | Henk Birkholz | New version approved |
|
2025-08-25
|
07 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2025-08-25
|
07 | Thomas Fossati | Uploaded new revision |
|
2025-03-03
|
06 | Thomas Fossati | New version available: draft-ietf-rats-endorsements-06.txt |
|
2025-03-03
|
06 | Thomas Fossati | New version approved |
|
2025-03-03
|
06 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2025-03-03
|
06 | Thomas Fossati | Uploaded new revision |
|
2024-12-03
|
05 | Ned Smith | Notification list changed to ned.smith@intel.com because the document shepherd was set |
|
2024-12-03
|
05 | Ned Smith | Document shepherd changed to Ned Smith |
|
2024-12-02
|
05 | Ned Smith | Completes December 10 |
|
2024-12-02
|
05 | Ned Smith | IETF WG state changed to In WG Last Call from WG Document |
|
2024-11-08
|
05 | Dave Thaler | New version available: draft-ietf-rats-endorsements-05.txt |
|
2024-11-08
|
05 | Dave Thaler | New version approved |
|
2024-11-08
|
05 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2024-11-08
|
05 | Dave Thaler | Uploaded new revision |
|
2024-11-08
|
04 | Dave Thaler | New version available: draft-ietf-rats-endorsements-04.txt |
|
2024-11-08
|
04 | Dave Thaler | New version approved |
|
2024-11-08
|
04 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2024-11-08
|
04 | Dave Thaler | Uploaded new revision |
|
2024-11-08
|
03 | Ned Smith | Added to session: IETF-121: rats Fri-1530 |
|
2024-10-08
|
03 | Ned Smith | Tag Polled for WG adoption but not adopted cleared. |
|
2024-10-08
|
03 | Ned Smith | IETF WG state changed to WG Document from Call For Adoption By WG Issued |
|
2024-10-08
|
03 | Ned Smith | Tag Polled for WG adoption but not adopted set. |
|
2024-10-08
|
03 | Ned Smith | IETF WG state changed to Call For Adoption By WG Issued from WG Document |
|
2024-07-23
|
03 | Dave Thaler | New version available: draft-ietf-rats-endorsements-03.txt |
|
2024-07-23
|
03 | Dave Thaler | New version approved |
|
2024-07-23
|
03 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2024-07-23
|
03 | Dave Thaler | Uploaded new revision |
|
2024-07-08
|
02 | Dave Thaler | New version available: draft-ietf-rats-endorsements-02.txt |
|
2024-07-08
|
02 | Dave Thaler | New version approved |
|
2024-07-08
|
02 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2024-07-08
|
02 | Dave Thaler | Uploaded new revision |
|
2024-07-08
|
01 | Ned Smith | Added to session: IETF-120: rats Tue-2000 |
|
2024-06-12
|
01 | Dave Thaler | New version available: draft-ietf-rats-endorsements-01.txt |
|
2024-06-12
|
01 | Dave Thaler | New version approved |
|
2024-06-12
|
01 | (System) | Request for posting confirmation emailed to previous authors: Dave Thaler , Henk Birkholz , Thomas Fossati , rats-chairs@ietf.org |
|
2024-06-12
|
01 | Dave Thaler | Uploaded new revision |
|
2024-06-03
|
00 | (System) | Document has expired |
|
2023-12-01
|
00 | Nancy Cam-Winget | Changed document external resources from: None to: github_repo https://github.com/dthaler/rats-endorsements |
|
2023-12-01
|
00 | Nancy Cam-Winget | This document now replaces draft-dthaler-rats-endorsements instead of None |
|
2023-12-01
|
00 | Dave Thaler | New version available: draft-ietf-rats-endorsements-00.txt |
|
2023-12-01
|
00 | Nancy Cam-Winget | WG -00 approved |
|
2023-11-29
|
00 | Dave Thaler | Set submitter to "Dave Thaler ", replaces to draft-dthaler-rats-endorsements and sent approval email to group chairs: rats-chairs@ietf.org |
|
2023-11-29
|
00 | Dave Thaler | Uploaded new revision |