References from draft-mcguinness-oauth-client-ip-ranges
These dependencies are extracted using heuristics looking for strings with particular prefixes. Notably, this means that references to I-Ds by title only are not reflected here. If it's really important, please inspect the documents' references sections directly.
| Document | Title | Status | Type | Downref |
|---|---|---|---|---|
| draft-ietf-oauth-client-id-metadata-document |
OAuth Client ID Metadata Document
References Referenced by |
informatively references | ||
| draft-illyes-webbotauth-jafar |
A JSON-Based Format for Publishing IP Ranges of Automated HTTP Clients
References Referenced by |
informatively references | ||
| RFC 2119 |
Key words for use in RFCs to Indicate Requirement Levels
References Referenced by |
Best Current Practice | normatively references | |
| RFC 3986 |
Uniform Resource Identifier (URI): Generic Syntax
References Referenced by |
Internet Standard | normatively references | |
| RFC 4291 |
IP Version 6 Addressing Architecture
References Referenced by |
Draft Standard | normatively references | |
| RFC 5952 |
A Recommendation for IPv6 Address Text Representation
References Referenced by |
Proposed Standard | normatively references | |
| RFC 6454 |
The Web Origin Concept
References Referenced by |
Proposed Standard | informatively references | |
| RFC 6749 |
The OAuth 2.0 Authorization Framework
References Referenced by |
Proposed Standard | normatively references | |
| RFC 6890 |
Special-Purpose IP Address Registries
References Referenced by |
Best Current Practice | normatively references | |
| RFC 7239 |
Forwarded HTTP Extension
References Referenced by |
Proposed Standard | informatively references | |
| RFC 7591 |
OAuth 2.0 Dynamic Client Registration Protocol
References Referenced by |
Proposed Standard | normatively references | |
| RFC 7592 |
OAuth 2.0 Dynamic Client Registration Management Protocol
References Referenced by |
Experimental | informatively references | |
| RFC 8174 |
Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words
References Referenced by |
Best Current Practice | normatively references | |
| RFC 8190 |
Updates to the Special-Purpose IP Address Registries
References Referenced by |
Best Current Practice | normatively references | |
| RFC 8259 |
The JavaScript Object Notation (JSON) Data Interchange Format
References Referenced by |
Internet Standard | normatively references | |
| RFC 8628 |
OAuth 2.0 Device Authorization Grant
References Referenced by |
Proposed Standard | informatively references | |
| RFC 8705 |
OAuth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access Tokens
References Referenced by |
Proposed Standard | informatively references | |
| RFC 9110 |
HTTP Semantics
References Referenced by |
Internet Standard | normatively references | |
| RFC 9111 |
HTTP Caching
References Referenced by |
Internet Standard | normatively references | |
| RFC 9449 |
OAuth 2.0 Demonstrating Proof of Possession (DPoP)
References Referenced by |
Proposed Standard | informatively references | |
| RFC 9911 |
Common YANG Data Types
References Referenced by |
Proposed Standard | normatively references |