Skip to main content

Transferring Opportunistic Wireless Encryption to the IEEE 802.11 Working Group
draft-wkumari-rfc8110-to-ieee-02

Revision differences

Document history

Date Rev. By Action
2024-12-28
(System)
Received changes through RFC Editor sync (changed state to RFC, created became rfc relationship between draft-wkumari-rfc8110-to-ieee and RFC 9672, changed IESG state to RFC …
Received changes through RFC Editor sync (changed state to RFC, created became rfc relationship between draft-wkumari-rfc8110-to-ieee and RFC 9672, changed IESG state to RFC Published)
2024-12-23
02 (System) RFC Editor state changed to AUTH48-DONE from AUTH48
2024-10-18
02 Carlos Pignataro Closed request for Last Call review by OPSDIR with state 'Overtaken by Events'
2024-10-18
02 Carlos Pignataro Assignment of request for Last Call review by OPSDIR to Wilman Lee was marked no-response
2024-10-11
02 (System) RFC Editor state changed to AUTH48
2024-09-05
02 (System) RFC Editor state changed to EDIT
2024-09-05
02 (System) IESG state changed to RFC Ed Queue from Approved-announcement sent
2024-09-05
02 (System) Announcement was received by RFC Editor
2024-09-05
02 (System) IANA Action state changed to No IANA Actions from In Progress
2024-09-05
02 (System) IANA Action state changed to In Progress
2024-09-05
02 Liz Flynn IESG state changed to Approved-announcement sent from Approved-announcement to be sent
2024-09-05
02 Liz Flynn IESG has approved the document
2024-09-05
02 Liz Flynn Closed "Approve" ballot
2024-09-05
02 Liz Flynn Ballot approval text was generated
2024-09-05
02 (System) Removed all action holders (IESG state changed)
2024-09-05
02 Cindy Morgan IESG state changed to Approved-announcement to be sent from IESG Evaluation
2024-09-05
02 Murray Kucherawy [Ballot Position Update] New position, No Objection, has been recorded for Murray Kucherawy
2024-09-04
02 Francesca Palombini [Ballot Position Update] New position, No Objection, has been recorded for Francesca Palombini
2024-09-04
02 Éric Vyncke IESG state changed to IESG Evaluation from Waiting for AD Go-Ahead
2024-09-04
02 Zaheduzzaman Sarker [Ballot Position Update] New position, No Objection, has been recorded for Zaheduzzaman Sarker
2024-09-04
02 (System) IESG state changed to Waiting for AD Go-Ahead from In Last Call
2024-09-03
02 Deb Cooley [Ballot Position Update] New position, Yes, has been recorded for Deb Cooley
2024-09-03
02 John Scudder
[Ballot comment]
I assume the question of moving RFC 8110 to some appropriate “don’t use this, use that” status (Obsolete I guess) upon publication of …
[Ballot comment]
I assume the question of moving RFC 8110 to some appropriate “don’t use this, use that” status (Obsolete I guess) upon publication of the relevant IEEE spec has been considered by some combination of the authors, sponsoring AD, and extensive Last Call email discussion. In any case I don’t see why it would need to hold up publication of this document.
2024-09-03
02 John Scudder [Ballot Position Update] New position, No Objection, has been recorded for John Scudder
2024-09-03
02 Jim Guichard [Ballot Position Update] New position, No Objection, has been recorded for Jim Guichard
2024-09-03
02 Roman Danyliw [Ballot comment]
Thank you to Christer Holmberg for the GENART review.
2024-09-03
02 Roman Danyliw [Ballot Position Update] New position, No Objection, has been recorded for Roman Danyliw
2024-09-02
02 Paul Wouters
[Ballot comment]
I am always happy when opportunistic encryption is used instead of plaintext. I am glad the IEEE was convinced eventually to do this …
[Ballot comment]
I am always happy when opportunistic encryption is used instead of plaintext. I am glad the IEEE was convinced eventually to do this as well.
2024-09-02
02 Paul Wouters [Ballot Position Update] New position, Yes, has been recorded for Paul Wouters
2024-09-02
02 Juan-Carlos Zúñiga Request for Last Call review by INTDIR Completed: Ready. Reviewer: Juan-Carlos Zúñiga. Sent review to list.
2024-08-29
02 Gunter Van de Velde [Ballot comment]
short and nicely written document. Thank you
2024-08-29
02 Gunter Van de Velde [Ballot Position Update] New position, No Objection, has been recorded for Gunter Van de Velde
2024-08-26
02 Samita Chakrabarti Request for Last Call review by IOTDIR Completed: Ready with Nits. Reviewer: Samita Chakrabarti. Sent review to list.
2024-08-23
02 Erik Kline [Ballot Position Update] New position, Yes, has been recorded for Erik Kline
2024-08-22
02 Warren Kumari [Ballot comment]
'manorther...
2024-08-22
02 Warren Kumari [Ballot Position Update] New position, Recuse, has been recorded for Warren Kumari
2024-08-22
02 Éric Vyncke
[Ballot comment]
To add to the ballot text: this draft is short but unusual as it transfers maintenance of an IETF protocol from IETF to …
[Ballot comment]
To add to the ballot text: this draft is short but unusual as it transfers maintenance of an IETF protocol from IETF to IEEE. There are liaison statements in all directions and all parties (authors, IEEE 802.11, IETF trust, and probably the IETF community after the IETF Last Call) agree with the move.

This is somehow urgent as the IEEE is waiting for the IETF, hence the ballot on the day after the IETF Last Call. If there are critical Last Call comments, I am postponing the ballot.

Special note from the IETF Trust: "The authors of RFC8110 are Dan Harkins and Warren Kumari and are also involved in moving the maintenance of this protocol to the IEEE. As authors they hold a shared copyright with the IETF Trust and they both have the ability to give the IEEE the needed rights to use the RFC8110 material in future IEEE works without any approval from the IETF Trust." and later "The IETF Trust will continue in perpetuity to hold its currently held shared rights with the authors on RFC8110 which means that RFC8110 will remain available to the IETF to use and to create derivative works from along with everything else permitted by the TLP licensing terms."
2024-08-22
02 Éric Vyncke Ballot comment text updated for Éric Vyncke
2024-08-22
02 Éric Vyncke Ballot has been issued
2024-08-22
02 Éric Vyncke [Ballot Position Update] New position, Yes, has been recorded for Éric Vyncke
2024-08-22
02 Éric Vyncke Created "Approve" ballot
2024-08-22
02 Éric Vyncke Ballot writeup was changed
2024-08-19
02 Mark Nottingham Closed request for Last Call review by HTTPDIR with state 'Team Will not Review Document'
2024-08-19
02 Jim Reid Request for Last Call review by DNSDIR Completed: Ready. Reviewer: Jim Reid. Sent review to list.
2024-08-19
02 Jim Reid Request for Last Call review by DNSDIR is assigned to Jim Reid
2024-08-19
02 Éric Vyncke Requested Last Call review by HTTPDIR
2024-08-19
02 Éric Vyncke Requested Last Call review by DNSDIR
2024-08-15
02 (System) IANA Review state changed to IANA OK - No Actions Needed from IANA - Review Needed
2024-08-15
02 David Dong
(Via drafts-lastcall@iana.org): IESG/Authors/WG Chairs:

IANA has completed its review of draft-wkumari-rfc8110-to-ieee-02, which is currently in Last Call, and has the following comments:

We …
(Via drafts-lastcall@iana.org): IESG/Authors/WG Chairs:

IANA has completed its review of draft-wkumari-rfc8110-to-ieee-02, which is currently in Last Call, and has the following comments:

We understand that this document doesn't require any registry actions.

While it's often helpful for a document's IANA Considerations section to remain in place upon publication even if there are no actions, if the authors strongly prefer to remove it, we do not object.

If this assessment is not accurate, please respond as soon as possible.

For definitions of IANA review states, please see:

https://datatracker.ietf.org/help/state/draft/iana-review

Thank you,

David Dong
IANA Services Sr. Specialist
2024-08-13
02 Barry Leiba Request for Telechat review by ARTART Completed: Ready. Reviewer: Barry Leiba. Sent review to list.
2024-08-13
02 Barry Leiba Request for Telechat review by ARTART is assigned to Barry Leiba
2024-08-10
02 Christian Huitema Request for Last Call review by SECDIR Completed: Ready. Reviewer: Christian Huitema. Sent review to list.
2024-08-10
02 Carlos Pignataro Request for Last Call review by OPSDIR is assigned to Wilman Lee
2024-08-09
02 Tero Kivinen Request for Last Call review by SECDIR is assigned to Christian Huitema
2024-08-08
02 Juan-Carlos Zúñiga Request for Last Call review by INTDIR is assigned to Juan-Carlos Zúñiga
2024-08-08
02 Christer Holmberg Request for Last Call review by GENART Completed: Ready with Nits. Reviewer: Christer Holmberg. Sent review to list.
2024-08-07
02 Jean Mahoney Request for Last Call review by GENART is assigned to Christer Holmberg
2024-08-07
02 Samita Chakrabarti Request for Last Call review by IOTDIR is assigned to Samita Chakrabarti
2024-08-07
02 Éric Vyncke Changed consensus to Yes from Unknown
2024-08-07
02 Éric Vyncke Requested Last Call review by IOTDIR
2024-08-07
02 Éric Vyncke Requested Last Call review by INTDIR
2024-08-07
02 Éric Vyncke Requested Last Call review by GENART
2024-08-07
02 Éric Vyncke Requested Last Call review by SECDIR
2024-08-07
02 Cindy Morgan IANA Review state changed to IANA - Review Needed
2024-08-07
02 Cindy Morgan
The following Last Call announcement was sent out (ends 2024-09-04):

From: The IESG
To: IETF-Announce
CC: draft-wkumari-rfc8110-to-ieee@ietf.org, evyncke@cisco.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  …
The following Last Call announcement was sent out (ends 2024-09-04):

From: The IESG
To: IETF-Announce
CC: draft-wkumari-rfc8110-to-ieee@ietf.org, evyncke@cisco.com
Reply-To: last-call@ietf.org
Sender:
Subject: Last Call:  (Transferring Opportunistic Wireless Encryption to the IEEE 802.11 Working Group) to Informational RFC


The IESG has received a request from an individual submitter to consider the
following document: - 'Transferring Opportunistic Wireless Encryption to the
IEEE 802.11
  Working Group'
  as Informational RFC

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
last-call@ietf.org mailing lists by 2024-09-04. Exceptionally, comments may
be sent to iesg@ietf.org instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract


  RFC8110 describes Opportunistic Wireless Encryption (OWE), a mode
  that allows unauthenticated clients to connect to a network using
  encrypted traffic.  This document transfers the ongoing maintenance
  and further development of the protocol to the IEEE 802.11 Working
  Group.

  This document updates RFC8110 by noting that future work on the
  protocol described in RFC8110 will occur in the IEEE 802.11 Working
  Group.




The file can be obtained via
https://datatracker.ietf.org/doc/draft-wkumari-rfc8110-to-ieee/



No IPR declarations have been submitted directly on this I-D.




2024-08-07
02 Cindy Morgan IESG state changed to In Last Call from Last Call Requested
2024-08-07
02 Éric Vyncke Last call was requested
2024-08-07
02 Éric Vyncke Ballot approval text was generated
2024-08-07
02 Éric Vyncke IESG state changed to Last Call Requested from Publication Requested
2024-08-07
02 Éric Vyncke Last call announcement was generated
2024-08-07
02 Éric Vyncke Notification list changed to evyncke@cisco.com because the document shepherd was set
2024-08-07
02 Éric Vyncke Document shepherd changed to Éric Vyncke
2024-08-07
02 Warren Kumari New version available: draft-wkumari-rfc8110-to-ieee-02.txt
2024-08-07
02 Warren Kumari New version approved
2024-08-07
02 (System) Request for posting confirmation emailed to previous authors: Dan Harkins , Warren Kumari
2024-08-07
02 Warren Kumari Uploaded new revision
2024-08-07
01 Éric Vyncke Ballot writeup was changed
2024-08-07
01 (System) Changed action holders to Éric Vyncke (IESG state changed)
2024-08-07
01 Éric Vyncke Placed on agenda for telechat - 2024-09-05
2024-08-07
01 Éric Vyncke Document is now in IESG state Publication Requested
2024-08-07
01 Éric Vyncke
Document History
Was the document considered in any WG, and if so, why was it not adopted as a work item there?

This document updates …
Document History
Was the document considered in any WG, and if so, why was it not adopted as a work item there?

This document updates RFC 8110, which was an individual submission, i.e., not a WG document.


Was there controversy about particular points that caused the WG to not adopt the document?

No, it is basically orthogonal to any existing WG.


Has anyone threatened an appeal or otherwise indicated extreme discontent? If so, please summarize the areas of conflict in separate email messages to the responsible Area Director. (It should be in a separate email because this
questionnaire is publicly available.)

No


For protocol documents, are there existing implementations of the contents of
the document? Have a significant number of potential implementers indicated
plans to implement? Are any existing implementations reported somewhere,
either in the document itself (as RFC 7942 recommends) or elsewhere
(where)?

This document does not specify any protocol. But, it refers to RFC 8110, which has been implemented notably in wpa_supplicant and hostapd (with some modifications of the HKDF).
Additional Reviews
Do the contents of this document closely interact with technologies in other
IETF working groups or external organizations, and would it therefore benefit
from their review? Have those reviews occurred? If yes, describe which
reviews took place.

Reviews will be done during the IETF Last Call in some WGs and directorates.
The IEEE has sent a Liaison Statement about this I-D:
https://datatracker.ietf.org/liaison/1929/


Describe how the document meets any required formal expert review criteria,
such as the MIB Doctor, YANG Doctor, media type, and URI type reviews.

Not applicable.


If the document contains a YANG module, has the final version of the module
been checked with any of the recommended validation tools for syntax and
formatting validation? If there are any resulting errors or warnings, what is
the justification for not fixing them at this time? Does the YANG module
comply with the Network Management Datastore Architecture (NMDA) as specified in RFC 8342?

Not applicable.


Describe reviews and automated checks performed to validate sections of the
final version of the document written in a formal language, such as XML code,
BNF rules, MIB definitions, CBOR's CDDL, etc.

Not applicable.
Document Shepherd Checks
Based on the shepherd's review of the document, is it their opinion that this
document is needed, clearly written, complete, correctly designed, and ready
to be handed off to the responsible Area Director?

Yes (notably as the shepherd is the AD ;-) ).


Several IETF Areas have assembled lists of common issues that their
reviewers encounter. For which areas have such issues been identified
and addressed? For which does this still need to happen in subsequent
reviews?

Not applicable as this is not a specification.


What type of RFC publication is being requested on the IETF stream (Best
Current Practice, Proposed Standard, Internet Standard,
Informational, Experimental or Historic)? Why is this the proper type
of RFC? Do all Datatracker state attributes correctly reflect this intent?

Informational, meta data is correct, it updates an  informational I-D and does not contain any specification.


Have reasonable efforts been made to remind all authors of the intellectual
property rights (IPR) disclosure obligations described in BCP 79? To
the best of your knowledge, have all required disclosures been filed? If
not, explain why. If yes, summarize any relevant discussion, including links
to publicly-available messages when applicable.

Yes, the shepherd has checked for IPR with the authors.


Has each author, editor, and contributor shown their willingness to be
listed as such? If the total number of authors and editors on the front page
is greater than five, please provide a justification.

Yes, the shepherd has checked with the authors.


Document any remaining I-D nits in this document. Simply running the idnits
tool is not enough; please review the "Content Guidelines" on
authors.ietf.org. (Also note that the current idnits tool generates
some incorrect warnings; a rewrite is underway.)

No more remaining nits.


Should any informative references be normative or vice-versa? See the IESG
Statement on Normative and Informative References.

References have been checked.


List any normative references that are not freely available to anyone. Did
the community have sufficient access to review any such normative references?

The normative reference is a freely available RFC.


Are there any normative downward references (see RFC 3967 and BCP
97
) that are not already listed in the DOWNREF registry? If so,
list them.

No


Are there normative references to documents that are not ready to be
submitted to the IESG for publication or are otherwise in an unclear state?
If so, what is the plan for their completion?

No such references.


Will publication of this document change the status of any existing RFCs? If
so, does the Datatracker metadata correctly reflect this and are those RFCs
listed on the title page, in the abstract, and discussed in the
introduction? If not, explain why and point to the part of the document
where the relationship of this document to these other RFCs is discussed.

No changes (even if this was contemplated).


Describe the document shepherd's review of the IANA considerations section,
especially with regard to its consistency with the body of the document.
Confirm that all aspects of the document requiring IANA assignments are
associated with the appropriate reservations in IANA registries. Confirm
that any referenced IANA registries have been clearly identified. Confirm
that each newly created IANA registry specifies its initial contents,
allocations procedures, and a reasonable name (see RFC 8126).

Not applicable.


List any new IANA registries that require Designated Expert Review for
future allocations. Are the instructions to the Designated Expert clear?
Please include suggestions of designated experts, if appropriate.

Not applicable

2024-08-07
01 Éric Vyncke Intended Status changed to Informational from None
2024-08-07
01 Éric Vyncke Stream changed to IETF from None
2024-08-07
01 Éric Vyncke Shepherding AD changed to Éric Vyncke
2024-07-08
01 Warren Kumari New version available: draft-wkumari-rfc8110-to-ieee-01.txt
2024-07-08
01 Warren Kumari New version accepted (logged-in submitter: Warren Kumari)
2024-07-08
01 Warren Kumari Uploaded new revision
2024-04-27
00 Warren Kumari New version available: draft-wkumari-rfc8110-to-ieee-00.txt
2024-04-27
00 (System) New version approved
2024-04-27
00 Warren Kumari Request for posting confirmation emailed  to submitter and authors: Dan Harkins , Warren Kumari
2024-04-27
00 Warren Kumari Uploaded new revision