Skip to main content

Early Review of draft-ietf-netconf-udp-client-server-06
review-ietf-netconf-udp-client-server-06-yangdoctors-early-schoenwaelder-2025-04-16-00

Request Review of draft-ietf-netconf-udp-client-server
Requested revision No specific revision (document currently at 10)
Type Early Review
Team YANG Doctors (yangdoctors)
Deadline 2025-04-29
Requested 2025-04-08
Requested by Per Andersson
Authors Alex Huang Feng , Pierre Francois , Kent Watsen
I-D last updated 2026-06-15 (Latest revision 2025-12-16)
Completed reviews Yangdoctors Early review of -06 by Jürgen Schönwälder (diff)
Opsdir Early review of -07 by Ran Chen (diff)
Tsvart Early review of -06 by Joerg Ott (diff)
Genart IETF Last Call review of -09 by Elwyn B. Davies (diff)
Dnsdir IETF Last Call review of -09 by Peter van Dijk (diff)
Assignment Reviewer Jürgen Schönwälder
State Completed
Request Early review on draft-ietf-netconf-udp-client-server by YANG Doctors Assigned
Posted at https://mailarchive.ietf.org/arch/msg/yang-doctors/a4aRXpyoJN8irlsWh4b5_MdzPRo
Reviewed revision 06 (document currently at 10)
Result On the right track
Completed 2025-04-16
review-ietf-netconf-udp-client-server-06-yangdoctors-early-schoenwaelder-2025-04-16-00
- The definitions may not be sufficient for UDP multicast clients and
  servers. I am not sure whether anything needs to be said about this.

- The udp-client description points to section 5 of RFC6724. I did not
  understand how this section relates to the text in the description.

- The remote-address description says 'name resolution should happen
  on each connection attempt'. Given that UDP is connection-less, I am
  unsure what is meant with this.

- There are unused references, like RFC 9110. I also wonder why the
  security template refers to QUIC RFC 9000 as a secure transport for
  NETCONF. I think NETCONF over QUIC is still in the making (and this
  document would once approve perhaps be a relevant reference, right
  now this makes no sense to me).