Skip to main content

Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)
RFC 8656

Revision differences

Document history

Date By Action
2026-05-20
(System) Changed metadata: changed keywords to '['NAT', 'TURN', 'STUN', 'ICE']' from '[]'
2026-05-20
(System) Metadata update from RFC Editor
2026-05-20
(System) Changed author "J. Rosenberg": changed name from "Jonathan Rosenberg" to "J. Rosenberg", cleared country (was "USA"), changed order from "3" to "4"
2026-05-20
(System) Changed author "P. Matthews": changed name from "Philip Matthews" to "P. Matthews", cleared country (was "Canada"), changed order from "2" to "3"
2026-05-20
(System)
Changed author "A. Johnston": changed name from "Alan Johnston" to "A. Johnston", changed is_editor from "False" to "True", cleared country (was "USA"), changed order from …
Changed author "A. Johnston": changed name from "Alan Johnston" to "A. Johnston", changed is_editor from "False" to "True", cleared country (was "USA"), changed order from "1" to "2"
2026-05-20
(System)
Changed author "T. Reddy": changed name from "Tirumaleswar Reddy.K" to "T. Reddy", changed is_editor from "False" to "True", changed affiliation from "McAfee, Inc." to "McAfee", …
Changed author "T. Reddy": changed name from "Tirumaleswar Reddy.K" to "T. Reddy", changed is_editor from "False" to "True", changed affiliation from "McAfee, Inc." to "McAfee", cleared country (was "India"), changed order from "0" to "1"
2026-05-20
(System) Metadata update from RFC Editor
2026-05-06
(System) Received changes through RFC Editor sync (added Errata tag)
2020-02-24
(System) IANA registries were updated to include RFC8656
2020-02-21
(System)
Received changes through RFC Editor sync (created alias RFC 8656, changed abstract to 'If a host is located behind a NAT, it can be …
Received changes through RFC Editor sync (created alias RFC 8656, changed abstract to 'If a host is located behind a NAT, it can be impossible for that host to communicate directly with other hosts (peers) in certain situations. In these situations, it is necessary for the host to use the services of an intermediate node that acts as a communication relay. This specification defines a protocol, called "Traversal Using Relays around NAT" (TURN), that allows the host to control the operation of the relay and to exchange packets with its peers using the relay. TURN differs from other relay control protocols in that it allows a client to communicate with multiple peers using a single relay address.

The TURN protocol was designed to be used as part of the Interactive Connectivity Establishment (ICE) approach to NAT traversal, though it can also be used without ICE.

This document obsoletes RFCs 5766 and 6156.', changed pages to 79, changed standardization level to Proposed Standard, changed state to RFC, added RFC published event at 2020-02-21, changed IESG state to RFC Published, created obsoletes relation between draft-ietf-tram-turnbis and RFC 5766, created obsoletes relation between draft-ietf-tram-turnbis and RFC 6156)
2020-02-21
(System) RFC published