Skip to main content

IAB, IESG, IETF Trust, and IETF LLC Selection, Confirmation, and Recall Process: Operation of the IETF Nominating and Recall Committees
RFC 8713 part of BCP 10

Revision differences

Document history

Date By Action
2026-05-20
(System) Changed metadata: changed keywords to '['IASA', 'IASA 2.0', 'IASA2']' from '[]'
2026-05-20
(System) Metadata update from RFC Editor
2026-05-20
(System)
Changed author "J. Livingood": changed name from "Jason Livingood" to "J. Livingood", changed is_editor from "False" to "True", cleared country (was "USA"), changed order from …
Changed author "J. Livingood": changed name from "Jason Livingood" to "J. Livingood", changed is_editor from "False" to "True", cleared country (was "USA"), changed order from "2" to "3"
2026-05-20
(System)
Changed author "R. Hinden": changed name from "Bob Hinden" to "R. Hinden", changed is_editor from "False" to "True", cleared country (was "USA"), changed order from …
Changed author "R. Hinden": changed name from "Bob Hinden" to "R. Hinden", changed is_editor from "False" to "True", cleared country (was "USA"), changed order from "1" to "2"
2026-05-20
(System)
Changed author "M. Kucherawy": changed name from "Murray Kucherawy" to "M. Kucherawy", changed is_editor from "False" to "True", cleared country (was "United States"), changed order …
Changed author "M. Kucherawy": changed name from "Murray Kucherawy" to "M. Kucherawy", changed is_editor from "False" to "True", cleared country (was "United States"), changed order from "0" to "1"
2026-05-20
(System) Metadata update from RFC Editor
2023-12-12
(System) Imported membership of rfc8713 in bcp10 via sync to the rfc-index
2023-12-12
(System) No history of BCP10 is currently available in the datatracker before this point
2022-08-18
(System) Received changes through RFC Editor sync (added Errata tag)
2020-02-27
(System)
Received changes through RFC Editor sync (created alias RFC 8713, changed title to 'IAB, IESG, IETF Trust, and IETF LLC Selection, Confirmation, and Recall …
Received changes through RFC Editor sync (created alias RFC 8713, changed title to 'IAB, IESG, IETF Trust, and IETF LLC Selection, Confirmation, and Recall Process: Operation of the IETF Nominating and Recall Committees', changed abstract to 'The process by which the members of the IAB and IESG, some Trustees of the IETF Trust, and some Directors of the IETF Administration LLC (IETF LLC) are selected, confirmed, and recalled is specified in this document. This document is based on RFC 7437. Only those updates required to reflect the changes introduced by IETF Administrative Support Activity (IASA) 2.0 have been included. Any other changes will be addressed in future documents.

This document obsoletes RFC 7437 and RFC 8318.', changed pages to 33, changed standardization level to Best Current Practice, changed state to RFC, added RFC published event at 2020-02-27, changed IESG state to RFC Published, created obsoletes relation between draft-ietf-iasa2-rfc7437bis and RFC 7437, created obsoletes relation between draft-ietf-iasa2-rfc7437bis and RFC 8318)
2020-02-27
(System) RFC published